Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    GuyDviri
    @GuyDviri
    Hello
    Orhan Obut
    @orhanobut
    hey
    GuyDviri
    @GuyDviri
    what up dude , i check yours dialog plus , and it's seems great
    Orhan Obut
    @orhanobut
    doing fine and thanks :)
    GuyDviri
    @GuyDviri
    i try it last night ...and have some issues with it , hoping you can clarify some stuff for me
    Orhan Obut
    @orhanobut
    sure
    GuyDviri
    @GuyDviri
    1) what is the adapter?
    i try to create new SimpleAdapter ,false for the grid and it's crash
    Orhan Obut
    @orhanobut
    ohh what is the exact error?
    GuyDviri
    @GuyDviri
    SimpleAdapter simpleAdapter = new SimpleAdapter( MyApplication.getAppContext(),false);
    DialogPlus dialog = new DialogPlus.Builder(MyApplication.getAppContext())
    .setAdapter(adapter)
    .setOnItemClickListener(new OnItemClickListener() {
    @Override
    public void onItemClick(DialogPlus dialog, Object item, View view, int position) {
    }
    })
    .create();
        dialog.show();
    Alessandro Balocco
    @AlexBalo
    Hi
    GuyDviri
    @GuyDviri
    hey falks what's up
    just one min..pls
    Error:(154, 39) error: constructor SimpleAdapter in class SimpleAdapter cannot be applied to given types;
    required: Context,List<? extends Map<String,?>>,int,String[],int[]
    found: Context,boolean
    reason: actual and formal argument lists differ in length
    this is the error
    do you have any apk of the Dialog Plus to run on my phone?
    Orhan Obut
    @orhanobut
    the error seems not related to dialogplus
    SimpleAdapter requires
    public SimpleAdapter(Context context, List<? extends Map<String, ?>> data,
    int resource, String[] from, int[] to)
    that’s why you get a compile error
    GuyDviri
    @GuyDviri
    yes , just copy it from the debug log
    Orhan Obut
    @orhanobut
    is it for testing to see dialog plus or you really need simpleadapter?
    you can try ArrayAdapter
    GuyDviri
    @GuyDviri
    no for now ..
    without the adapter it's don't compile
    Orhan Obut
    @orhanobut
    you need to pass correct parameters to the simple adapter
    GuyDviri
    @GuyDviri
    i plan to use this dialog for future tasks, like let the use pick 3 state out of a list do you think i can do it with yours dialog
    what the correct parameters for simple info dialog with one button
    Orhan Obut
    @orhanobut
    basically you want to have 3 button in dialog right?
    list with 3 items
    if that so, just use ArrayAdapter
    and use
    it will be ok
    or if you want shiny/different style, you need to create your own adapter
    Stefan Wegener
    @StefanWegener
    Hi. First of all, great work. Is there any option to disable the selection highlight? I want a Dialog without the possibility to click on the items.
    Stefan Wegener
    @StefanWegener
    Another question :) Is ist possible to enable scrolling when adapt has to many items?
    Orhan Obut
    @orhanobut
    hey, thanks. Hmm for the first question, you can actuall use customview in that case, for the listview and gridview, there is no option to disable selection unfortunately . Second question: if it is listview or gridview, there will be automatically scrolling
    but to answer all, you can create a customview and put a listview (which you disable everything), then you can use it in your case
    Stefan Wegener
    @StefanWegener
    ok cool. thx for the fast answer :)
    Orhan Obut
    @orhanobut
    you’re welcome :)
    David AG
    @siempredelao
    Hi! I'm trying to add the library to gradle but it throws an error.
    Failed to resolve: com.orhanobut:dialogplus.1.6

    I've added this in my gradle

    compile 'com.orhanobut:dialogplus:1.6@aar'

    Any guess what can happen? I know it's to few information :(