Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 14:05
    gautierhattenberger closed #2516
  • 14:05

    gautierhattenberger on master

    [create_module] restore generat… (compare)

  • 14:02
    gautierhattenberger commented #2513
  • 13:37
    gautierhattenberger opened #2516
  • 13:13

    gautierhattenberger on master

    [gps] fix typo (#2515) (compare)

  • 13:13
    gautierhattenberger closed #2515
  • 11:38
    gautierhattenberger labeled #2515
  • 11:38
    gautierhattenberger labeled #2515
  • 11:38
    gautierhattenberger opened #2515
  • 11:38
    gautierhattenberger milestoned #2515
  • 11:36

    gautierhattenberger on update_ocaml_compat

    (compare)

  • 11:35
    gautierhattenberger closed #2512
  • 11:35

    gautierhattenberger on master

    [pprzlink] update version upda… [ocaml] fix and update for late… [sim] change name of stdlib mod… and 9 more (compare)

  • 10:03
    tomvand synchronize #2514
  • 09:47
    Travis paparazzi/paparazzi (update_ocaml_compat) passed (7853)
  • 09:46
    tomvand commented #2514
  • 09:20
    gautierhattenberger synchronize #2512
  • 09:20

    gautierhattenberger on update_ocaml_compat

    [pprzlink] update version pprz… [device] properly match pprzlin… (compare)

  • 08:53
    gautierhattenberger review_requested #2512
  • 08:53
    gautierhattenberger commented #2512
averroken
@averroken
ah, that is another thing
ikenshini
@ikenshini
yes - but it works with the AR Drone, it is used for autonomous flights - much easier than programming a drone without it
but if you're doing something simple, AT commands can be used
averroken
@averroken
what i'm trying to do is control a ar drone with a kinect v1.
but i didn't understand how the at commands works, thats more the problem.
Dan Berry
@dgberry1
Has anybody had this error when installing the gcc-arm-embedded repository?
Errors were encountered while processing:
/var/cache/apt/archives/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Felix Ruess
@flixr
@dgberry1 that seems to be a bug in ubuntu packaging: https://bugs.launchpad.net/ubuntu/+source/gcc-4.8-armhf-cross/+bug/1557205
Dan Berry
@dgberry1
@flixr Okay I'm checking it out. I found other having this issue too.
does the 4.9 version work with paparazzi?
Felix Ruess
@flixr
yes, we also ran into this bug in our travis builds, that's why I disabled them for now (as they always error because of this)
4.9 should work... but I haven't tested it...
Dan Berry
@dgberry1
okay thanks.
I might give it a try. I did find a note about Nvidia video being the culprit.
Dan Berry
@dgberry1
I found this command to get the cross compiler to install.
sudo apt-get -o Dpkg::Options::="--force-overwrite" install -f
It worked and I was able to move forward with the installation
rambalakrishnan
@rambalakrishnan
the wiki says that 0.017s is the minimum period for telemetry messages. is that also true of ground-to-aircraft messages? i would like to set a joystick update frequency in excess of 60Hz
Gautier Hattenberger
@gautierhattenberger
@rambalakrishnan you should be able to increase the update rate of the joystick by changing the period parameter in your joystick file. The smallest theoretical period is 1ms, but it is probably way to much for the telemetry. 60Hz should be fine if you don't have too much downlink telemetry or enough bandwidth.
averroken
@averroken
thanks for the information, problem solved
Felix Ruess
@flixr
if anyone has a launchpad account, maybe also mark bug https://bugs.launchpad.net/ubuntu/+source/gcc-4.8-armhf-cross/+bug/1557205 as "this bug affectes me"... maybe they will fix it faster then...
ah, at least a fix is now proposed...
HooperFly
@hooperfly
Beta release 0.2.1 of the Flying Robot Command available for public consumption: https://github.com/paparazzi/flyingrobotcommander
Gautier Hattenberger
@gautierhattenberger
nice work ! (and nice picture ;) )
Felix Ruess
@flixr
ah, the ubuntu packaging bug in armhf-cross has been fixed :-)
Dan Berry
@dgberry1
@flixr that is good.
Dan Berry
@dgberry1
I've downloaded and installed the DFU-Util and I am having trouble flashing my Elle0.

make1: Leaving directory /home/dan/paparazzi/sw/airborne' cd sw/airborne; make TARGET=ap upload Using "arch/stm32/elle0.ld" as ldscript for target "ap". make[1]: Entering directory/home/dan/paparazzi/sw/airborne'
Using dfu-util at 0x08000000
Cannot open device
dfu-util 0.5

(C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
(C) 2010-2011 Tormod Volden (DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Filter on vendor = 0x0483 product = 0xdf11
Opening DFU USB device... make1: [upload] Error 1
make1: Leaving directory `/home/dan/paparazzi/sw/airborne'
make:
[ap.upload] Error 2
make: Leaving directory `/home/dan/paparazzi'

FAILED 'make -C /home/dan/paparazzi -f Makefile.ac AIRCRAFT=Fury ap.upload' with code 2

Felix Ruess
@flixr
you might want to try with a newer dfu-util version
what distro/version are you using?
Dan Berry
@dgberry1
Run version: v5.9_devel-359-g63a7b79
Build version: v5.9_devel-359-g63a7b79
Felix Ruess
@flixr
I mean your linux distro
Dan Berry
@dgberry1
Ubuntu 14.04
dfu-util is version 0.5
Felix Ruess
@flixr
then you can use dfu-util from my ppa (I backported 0.8 to 14.04): https://launchpad.net/~flixr/+archive/ubuntu/backports
Dan Berry
@dgberry1
my dfu-util is version 0.9
it is still not uploading

make1: Leaving directory /home/dan/paparazzi/sw/airborne' cd sw/airborne; make TARGET=ap upload Using "arch/stm32/elle0.ld" as ldscript for target "ap". make[1]: Entering directory/home/dan/paparazzi/sw/airborne'
Using dfu-util at 0x08000000
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: Cannot open DFU device 0483:df11
dfu-util: No DFU capable USB device available
make1: [upload] Error 74
make1: Leaving directory `/home/dan/paparazzi/sw/airborne'
make:
[ap.upload] Error 2
make: Leaving directory `/home/dan/paparazzi'

FAILED 'make -C /home/dan/paparazzi -f Makefile.ac AIRCRAFT=Fury FLASH_MODE=DFU-UTIL ap.upload' with code 2

Dan Berry
@dgberry1
using lsusb, I can see the device.
Bus 003 Device 005: ID 0483:df11 STMicroelectronics STM Device in DFU Mode
Felix Ruess
@flixr
dfu-util: Cannot open DFU device 0483:df11
do you have access rights to it?
Dan Berry
@dgberry1
I forgot how to check
I was going to try a different USB cable too
Felix Ruess
@flixr
ls -l /dev/yourdevice
dmesg | tail should show the shorter path to the device from when you connected it
Dan Berry
@dgberry1
[ 461.718677] usb 3-1.2: Product: STM32 BOOTLOADER
[ 461.718680] usb 3-1.2: Manufacturer: STMicroelectronics
[ 461.718682] usb 3-1.2: SerialNumber: 307532553332
[ 476.361482] usb 3-1.2: USB disconnect, device number 10
[ 477.266109] usb 1-4: new full-speed USB device number 4 using xhci_hcd
[ 477.395444] usb 1-4: New USB device found, idVendor=0483, idProduct=df11
[ 477.395451] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 477.395455] usb 1-4: Product: STM32 BOOTLOADER
[ 477.395458] usb 1-4: Manufacturer: STMicroelectronics
[ 477.395460] usb 1-4: SerialNumber: 307532553332
I think i'm missing udev rules
I added the udev rule and I am running