Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 08:27
    noether commented #2489
  • Feb 16 21:50
    jburns11 commented #2489
  • Feb 16 10:14
    noether commented #2489
  • Feb 14 21:11
    jburns11 commented #2489
  • Feb 14 20:58
    jburns11 commented #2489
  • Feb 14 20:56
    jburns11 synchronize #2489
  • Feb 14 14:17
    noether commented #2489
  • Feb 13 19:57
    jburns11 commented #2489
  • Feb 13 18:23
    jburns11 synchronize #2489
  • Feb 13 08:34
    noether commented #2489
  • Feb 13 08:29
    noether assigned #2489
  • Feb 13 05:49
    jburns11 synchronize #2489
  • Feb 12 23:17
    jburns11 commented #2489
  • Feb 12 23:13
  • Feb 12 22:46
    jburns11 synchronize #2489
  • Feb 12 22:33
  • Feb 12 22:06
    jburns11 synchronize #2489
  • Feb 12 22:03
    jburns11 opened #2489
  • Feb 12 14:00
    Fabien-B commented #2483
  • Feb 11 08:25
    noether commented #2488
Gautier Hattenberger
@gautierhattenberger
@rambalakrishnan you should be able to increase the update rate of the joystick by changing the period parameter in your joystick file. The smallest theoretical period is 1ms, but it is probably way to much for the telemetry. 60Hz should be fine if you don't have too much downlink telemetry or enough bandwidth.
averroken
@averroken
thanks for the information, problem solved
Felix Ruess
@flixr
if anyone has a launchpad account, maybe also mark bug https://bugs.launchpad.net/ubuntu/+source/gcc-4.8-armhf-cross/+bug/1557205 as "this bug affectes me"... maybe they will fix it faster then...
ah, at least a fix is now proposed...
HooperFly
@hooperfly
Beta release 0.2.1 of the Flying Robot Command available for public consumption: https://github.com/paparazzi/flyingrobotcommander
Gautier Hattenberger
@gautierhattenberger
nice work ! (and nice picture ;) )
Felix Ruess
@flixr
ah, the ubuntu packaging bug in armhf-cross has been fixed :-)
Dan Berry
@dgberry1
@flixr that is good.
Dan Berry
@dgberry1
I've downloaded and installed the DFU-Util and I am having trouble flashing my Elle0.

make1: Leaving directory /home/dan/paparazzi/sw/airborne' cd sw/airborne; make TARGET=ap upload Using "arch/stm32/elle0.ld" as ldscript for target "ap". make[1]: Entering directory/home/dan/paparazzi/sw/airborne'
Using dfu-util at 0x08000000
Cannot open device
dfu-util 0.5

(C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
(C) 2010-2011 Tormod Volden (DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Filter on vendor = 0x0483 product = 0xdf11
Opening DFU USB device... make1: [upload] Error 1
make1: Leaving directory `/home/dan/paparazzi/sw/airborne'
make:
[ap.upload] Error 2
make: Leaving directory `/home/dan/paparazzi'

FAILED 'make -C /home/dan/paparazzi -f Makefile.ac AIRCRAFT=Fury ap.upload' with code 2

Felix Ruess
@flixr
you might want to try with a newer dfu-util version
what distro/version are you using?
Dan Berry
@dgberry1
Run version: v5.9_devel-359-g63a7b79
Build version: v5.9_devel-359-g63a7b79
Felix Ruess
@flixr
I mean your linux distro
Dan Berry
@dgberry1
Ubuntu 14.04
dfu-util is version 0.5
Felix Ruess
@flixr
then you can use dfu-util from my ppa (I backported 0.8 to 14.04): https://launchpad.net/~flixr/+archive/ubuntu/backports
Dan Berry
@dgberry1
my dfu-util is version 0.9
it is still not uploading

make1: Leaving directory /home/dan/paparazzi/sw/airborne' cd sw/airborne; make TARGET=ap upload Using "arch/stm32/elle0.ld" as ldscript for target "ap". make[1]: Entering directory/home/dan/paparazzi/sw/airborne'
Using dfu-util at 0x08000000
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: Cannot open DFU device 0483:df11
dfu-util: No DFU capable USB device available
make1: [upload] Error 74
make1: Leaving directory `/home/dan/paparazzi/sw/airborne'
make:
[ap.upload] Error 2
make: Leaving directory `/home/dan/paparazzi'

FAILED 'make -C /home/dan/paparazzi -f Makefile.ac AIRCRAFT=Fury FLASH_MODE=DFU-UTIL ap.upload' with code 2

Dan Berry
@dgberry1
using lsusb, I can see the device.
Bus 003 Device 005: ID 0483:df11 STMicroelectronics STM Device in DFU Mode
Felix Ruess
@flixr
dfu-util: Cannot open DFU device 0483:df11
do you have access rights to it?
Dan Berry
@dgberry1
I forgot how to check
I was going to try a different USB cable too
Felix Ruess
@flixr
ls -l /dev/yourdevice
dmesg | tail should show the shorter path to the device from when you connected it
Dan Berry
@dgberry1
[ 461.718677] usb 3-1.2: Product: STM32 BOOTLOADER
[ 461.718680] usb 3-1.2: Manufacturer: STMicroelectronics
[ 461.718682] usb 3-1.2: SerialNumber: 307532553332
[ 476.361482] usb 3-1.2: USB disconnect, device number 10
[ 477.266109] usb 1-4: new full-speed USB device number 4 using xhci_hcd
[ 477.395444] usb 1-4: New USB device found, idVendor=0483, idProduct=df11
[ 477.395451] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 477.395455] usb 1-4: Product: STM32 BOOTLOADER
[ 477.395458] usb 1-4: Manufacturer: STMicroelectronics
[ 477.395460] usb 1-4: SerialNumber: 307532553332
I think i'm missing udev rules
I added the udev rule and I am running
Now off to calibrate
Felix Ruess
@flixr
yeah, our udev rules allow access to dfu devices for the plugdev group
Dan Berry
@dgberry1
@flixr Thanks. I could have more issues, but I'm getting the troubleshooting side of this figured out.
Dan Berry
@dgberry1
Calibration complete. Now flight test
HooperFly
@hooperfly
Six flying robots arming and disarming their motors using the Flying Robot Commander - https://www.instagram.com/p/BDuem4jOiRY
HooperFly
@hooperfly
Daylight version of FRC arming/disarming six multirotors: https://www.instagram.com/p/BDwlFTkuidg/
Deon Blaauw
@deonblaauw
Hi guys, question about accelerometer vibration on the Bebop 2. There is a video tutorial showing that you need to place the drone on the ground, place your hand on top of it, then increase the throttle. The idea is to see less than 4m/s/s vibration on the accelerometers (https://www.youtube.com/watch?v=eojAPZvT1Ck&index=3&list=PL_KSX9GOn2P_LUXJOQxc6PLr7c7eTUs98). When I did it on my drone however, the vibration profile hit 6-7 m/s/s. Is this something I should be worried about? If so, are there any filters I should be looking at adjusting before flight? The video is aimed at the ARdrone, and I'm using the Bebop 2, so not sure if the 4m/s/s threshold technically applies in my case... I did fly with the Bebop 2 using the stock Bebop 2 AP and it was all fine so I'm pretty sure that the mechanical damping is fine. Just want to make 100% sure before I start flight testing.
Bart Slinger
@bartslinger
You might want to set AHRS_GRAVITY_HEURISTIC_FACTOR to 0. Must say that I have not tried it on bebop2, but I recommend it for a first test flight in which you try to hover.
diardanoraihan
@diardanoraihan
Hello guys, the master, is there any suggestion for us about how to choose the appropriate control subsystem ( normal/adaptive/new/ energy/etc) for flapping wings (fixed wing) ? especially in type of stabilization ( attitude / adaptive )
What is the big different between both of them (attitude & adaptive ) ?
Is there any more explanation beside in the wiki so that we can understand any further about the technic of implementation ? Some papers will be helpfull actually
Thank you :)
Deon Blaauw
@deonblaauw
@bartslinger Thanks, will give it a try.
diardanoraihan
@diardanoraihan
please any suggestion guys ? :)
diardanoraihan
@diardanoraihan
In http://wiki.paparazziuav.org/wiki/Control_Loops#Fixed-wing_autopilot, we much talk about throttle, pitch, and roll loop, but no yaw. My project doesn't use roll deflection to turn, instead just Yaw deflection. So is there any possibility to make this can work in AUTO2 ?
Thanks again :)
HooperFly
@hooperfly
Hope you are enjoying your birthday! :+1: :cake: :balloon:
Dan Berry
@dgberry1
I've created new messages in the datalink section of the message.xml file. I then added it to the /sw/ext/pprzlink/message_definitions/v1.0 folder. ( kept the original, just in case of problems). Then in the paparazzi folder I ran "make clean" and then "make". This is the error that was created when doing the make.
Generate C messages (Python) at location /home/dan/paparazzi/var/include/pprzlink
Validation skipped for message_definitions/v1.0/messages.xml.
Parsing message_definitions/v1.0/messages.xml
Found 244 PPRZLink message types in XML file message_definitions/v1.0/messages.xml
Generating C implementation in /home/dan/paparazzi/var/include/pprzlink/messages.h
PPRZXML telemetry class from message_definitions/v1.0/messages.xml (244 message)
Copying fixed headers
Validation skipped for message_definitions/v1.0/messages.xml.
Parsing message_definitions/v1.0/messages.xml
Traceback (most recent call last):
File "./tools/generator/gen_messages.py", line 105, in <module>
gen_messages(args)
File "./tools/generator/gen_messages.py", line 70, in gen_messages
xml = pprz_parse.PPRZXML(fname, opts.class_name, opts.protocol)
File "/home/dan/paparazzi/sw/ext/pprzlink/tools/generator/pprzparse.py", line 148, in _init
p.ParseFile(f)
File "/home/dan/paparazzi/sw/ext/pprzlink/tools/generator/pprz_parse.py", line 124, in start_element
self.message[-1].fields.append(PPRZField(attrs['name'], attrs['type'], self))
File "/home/dan/paparazzi/sw/ext/pprzlink/tools/generator/pprzparse.py", line 65, in _init
raise PPRZParseError("unknown type '%s'" % type)
pprz_parse.PPRZParseError: unknown type 'string'
make1: [pygen_messages] Error 1
make:
[pprzlink_protocol] Error 2
Gautier Hattenberger
@gautierhattenberger
@dgberry1 you cannot use string as type for telemetry or datalink messages (only the ground messages can do that). But you can define a char[] type, then you can only use one field like this and place it in last position (variable length array). Last option is char[x] where x is a fixed size so it as to be large enough and you can have several fields like this in your message.
Dan Berry
@dgberry1
I modified my message.XML and was able to compile and flash. :-)
Now I have a question and I know it is an it depends on need, but are there any messages that need to be there? I'm trying to slow the telemetry activity for a particular application. I am thinking of creating multiple message.XML files so I can have one for this one application and the other for everything else.