These are chat archives for pavelk2/social-feed

18th
Aug 2016
Jen Yang
@blamejen
Aug 18 2016 03:54
Hello. Has anyone tried with webpack?
Martijn Gastkemper
@martijngastkemper
Aug 18 2016 06:10
Yes, but it's very ugly. The trouble is the Codebird dependency. It won't compile so I manually added it to my code.
Do you have a specific error?
Jen Yang
@blamejen
Aug 18 2016 11:02
Yes same problem. Codebird.i tried with npm install with dependencies but still having a same issue. It would be great if someone can share a solution if there are.
Martijn Gastkemper
@martijngastkemper
Aug 18 2016 11:09

Loading Codebird via NPM isn't possible. I've manually loaded codebird.es7.js in my project. I use https://github.com/vigetlabs/gulp-starter .
I've added the following to webpack-multi-config.js:
if (config.tasks.js.globalLibraries) {
webpackConfig.plugins.push(
new webpack.ProvidePlugin(config.tasks.js.globalLibraries)
)
}

In config.js i've added
globalLibraries": {
"Codebird": __dirname + "/../assets/javascripts/lib/codebird.es7"
}

Jen Yang
@blamejen
Aug 18 2016 11:13
Thanks I should try this thanks!