Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 07 2020 07:44

    dependabot[bot] on npm_and_yarn

    (compare)

  • Sep 07 2020 07:44

    dependabot[bot] on npm_and_yarn

    (compare)

  • Sep 07 2020 07:44

    dependabot[bot] on npm_and_yarn

    (compare)

  • Sep 07 2020 07:44

    dependabot[bot] on npm_and_yarn

    (compare)

  • Sep 07 2020 07:44

    dependabot[bot] on npm_and_yarn

    (compare)

  • Sep 07 2020 07:44

    dependabot[bot] on npm_and_yarn

    (compare)

  • Sep 07 2020 07:44
    dependabot[bot] commented #1293
  • Sep 07 2020 07:44
    dependabot[bot] commented #1292
  • Sep 07 2020 07:44
    dependabot[bot] commented #1291
  • Sep 07 2020 07:44
    dependabot[bot] commented #1290
  • Sep 07 2020 07:44
    MoOx closed #1293
  • Sep 07 2020 07:44
    dependabot[bot] commented #1288
  • Sep 07 2020 07:44
    MoOx closed #1292
  • Sep 07 2020 07:44
    dependabot[bot] commented #1287
  • Sep 07 2020 07:44
    MoOx closed #1291
  • Sep 07 2020 07:44
    MoOx closed #1290
  • Sep 07 2020 07:44
    MoOx closed #1288
  • Sep 07 2020 07:44
    MoOx closed #1287
  • Sep 07 2020 07:44

    MoOx on master

    DEPRECATED (compare)

  • Sep 03 2020 23:50
    dependabot[bot] labeled #1293
MoOx
@MoOx
@ArthurClemens probably an issue with the parser
Is this better with <video ></video><video></video>? (not self closing tags)?
Arthur Clemens
@ArthurClemens
yes, that works
MoOx
@MoOx
Can you open an issue about that @ArthurClemens please? As a reminder for me. (will work on phenomic this month)
Thank you!
Arthur Clemens
@ArthurClemens
Done
MoOx
@MoOx
👍
Cyrille Perois
@drazik
Hello. I am trying to get coloration on my code blocks. I see that remark-highlights is used. I specified the language for each of my code blocks (put javascript after the 3 markdown backticks to open the block), but I don't get any colors. I also installed language-javascript package, in case it was needed, but still nothing. Do I miss something ?
Cyrille Perois
@drazik
OK I figured it out : I didn't understand that I had to import a theme by myself. I thought there was a default one :)
Thomas Lee
@tleef
How do we add babel plugins?
For example, I want to add babel-plugin-styled-components
Thomas Lee
@tleef
It doesn't look like .babelrc is picked up, makes sense, I was also looking for a way to customize the babel plugins through package.json or by creating a custom phenomic plugin. I couldn't find any way to do it.
Thomas Lee
@tleef
The only thing I could thing of that might work is create my own version of plugin-bundler-webpack with a one-line-change to add babel-plugin-styled-components to the babel plugins. Then I'd have to create my own phenomic preset which uses my plugin-bundler-webpack instead of the default one
I figured that was a bit much to change one bit of config so I wanted to ask first
MoOx
@MoOx
@tleef For now you can do that via a custom webpack config that inherit the default one. Example here https://github.com/MoOx/maxim-hylian.fr/blob/master/webpack.config.js
Thomas Lee
@tleef
@MoOx Thanks!
@MoOx I want to ask if you need any help getting to v1. You are so close but its been a while without any new commits. Is there something blocking?
Thomas Lee
@tleef
Of f the top of my head the only major improvement I can see is continuity between the compiled and debug versions of the site. I've had problems with differences in both directions. Things working in the debug version that don't work once compiled and things working in the compiled version that don't work when using the debug server.
Thomas Lee
@tleef
When something doesn't work in the compiled version its generally just an issue with server side rendering. Not too tough to figure out. On the other hand. I've been running into issues with styled-components where sometimes they don't load the css in the debug version but always work as expected with the compiled version.
MoOx
@MoOx
My life is the current blocker :/
In addition to the proposal you make (that I have in mind already, and that should not be that hard to handle), I want to replace current database engine with some sql generated tables for better performance (hot loading can be currently pretty slow). I have started a wip and will continue on it as soon as I have enough mental strenght
Meanwhile if you want to work on something, feel free to open issue, and I can try to lead you from there :)
Arthur Clemens
@ArthurClemens
I am having troubles getting a working webpack configuration with Babel 7 and Phenomic.
MoOx
@MoOx
Tell me more :)
Arthur Clemens
@ArthurClemens
is this still required?
presets: [require.resolve("@phenomic/babel-preset”)]
MoOx
@MoOx
not if you have your own config
it's just a default config actually
for more details about this preset, you can take a look in it https://github.com/phenomic/phenomic/blob/master/packages/babel-preset/src/index.js
Arthur Clemens
@ArthurClemens
ok, thanks
MoOx
@MoOx
my pleasure
Arthur Clemens
@ArthurClemens
How should clientScripts work? I am adding "clientScripts": false to the phenomic entry in package.json, but I don’t see any difference.
MoOx
@MoOx
which version of phenomic? This option is gone in v1 as it's unecessary (the way to go instead is to make your own Html.js file and just omit the <Script /> https://github.com/phenomic/phenomic/blob/cdddbdc36624a1e3a716c9a568b87c2a0ca75613/examples/react-app-blog/Html.js#L28
Arthur Clemens
@ArthurClemens
ah, will try that
that also disables my blog post overview and js for screen interactivity (such as info dialogs)
MoOx
@MoOx
clientScripts was to disable all script and use phenomic as an html generator
<Script> is the same as this option was
What are you looking to do exactly @ArthurClemens ?
Arthur Clemens
@ArthurClemens
My blog overview (html source) does not contain links to individual blog posts. It would be nice to have these rendered as static html. But other js interactivity should still exist (like any other static html page with sprinkled js).
Removing <Script> is too radical
and it doesn’t solve the problem of my blog post overview
MoOx
@MoOx
well react needs js, you cannot really "split" the usage of react.
What you can do is to use an external script tag
(eg: put a script into /public and consume it old-school)
Arthur Clemens
@ArthurClemens
I’ve upgraded to beta.8 and I see some things have changed. My blog overview doesn’t work anymore, giving errors in the console GET http://localhost/socket.io/?EIO=3&transport=polling&t=MXOIc2f net::ERR_CONNECTION_REFUSED. What could be the reason? No errors in the terminal using DEBUG...
MoOx
@MoOx
From which version?
I didn’t changed anything not exposed in release notes
Arthur Clemens
@ArthurClemens
Perhaps it is a webpack issue
MoOx
@MoOx
Can you share a repro?
Arthur Clemens
@ArthurClemens
It is a private repo