Hmm.. I'm adding a new Stepper control (up/down buttons to increase and decrease values), along with a TextStepper to allow creating a custom up/down control.
The problem here is naming, and I usually go along with other frameworks but they are all over the place on this.. Gtk: SpinButton, WinForms: UpDownBase & NumericUpDown, Wpf (extended toolkit): ButtonSpinner & NumericUpDown, macOS: NSStepper as a separate control
I'm thinking for consistency sake, renaming NumericUpDown to NumericStepper
@cra0zy: you might also have insight on this, but it seems Gtk has no way to have a "SpinButton" without it being an Entry box as well.. I'm thinking just creating a themed control with two buttons for this case