Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Neelam Rani
    @neelamrani:matrix.org
    [m]
    Please guide
    Mayur Champaneria
    @github-mayur

    Hello All.

    Is this Core level error in Console?

    GET https://DOMAIN/admin/Ext/ux/form/MultiSelect.js?_dc=1625828414215 404 (Not Found) ext-all.js?_dc=9a33afacc268d9779bf6419639e8c208355e50c0:22

    Because file is not there at this Location.

    sngm
    @sngm

    Hello dear community!

    I have added a setting to an existing areabrick (image gallery). In the backend, a grid size can now be selected via 'Pimcore Select'.
    The brick is already included in some pages and snippets. But so far the new setting only takes effect when I open a single page in the backend and then save it. But now I don't want to open and save each page individually for the setting to be active. Does anyone have an idea how I could do this for the entire site? Or would this have to work 'out of the box'? I have tried setting a default value.

    {% if grid_select.isEmpty() %}
        {% do grid_select.setDataFromResource("3") %}
    {% endif %}
    Michael Frank
    @ITspirit
    In the Bundle&Bricks List there is a column "Configure". I know that with the old "plugins" it was possible to define a configuration which can be managed here. But, i can´t find if it is still supported? The documentation has no information about a "bundle configuration" possibility.
    Is this just for legacy support or is it still possible to use it?
    1 reply
    Prateek Suhane
    @psuhane
    Hi All,
    We are using a Data Importer extension in one of our project but the features available out of box are not sufficient. We need few more generic features. What new features we can expect in the upcoming releases of this extension?
    2 replies
    Katarzyna Kajzar
    @katwer
    Hi Guys!
    In Pimcore 6.8 I have no idea how to set prod env in my prod server.
    In Settings dev-mod is unchecked, when I try to write .env file with
    PIMCORE_ENVIRONMENT=dev
    I've 500 error on page. What sholud check?
    4 replies
    Dennis Pfahlbusch
    @dpfahlbusch_gitlab
    @solverat is there an eta when the seo bundle, schema bundle and emailizr are available/compatible with pimcore x? :-)
    1 reply
    Eelco Kruders
    @zetno
    Hi all, what's a pimcore X ready export tool (when enterprise is not an option yet)? Were using w-vision data definitions in pimcore 6.. but does not seem ready for pimcore 10? :(
    5 replies
    Dheeraj Verma
    @dheerajmindit_gitlab
    Hi Guys!
    Is it possible to achieve multi-tenancy in pimcore?
    3 replies
    Eelco Kruders
    @zetno
    Hi all, i'm using Datahub importer for g.e. categories. the object class names are becoming e.g. "import-60f29c4ab580c4.15577098". Is it possible the Datahub importer uses a name field instead of "import-" with some UUID?
    Andreas Wulf
    @mediafant
    @zetno - it is possible to define a key. Look at "ImportSettings/Mappings".
    1 reply
    subhash8785
    @subhash8785
    Hi Guys!
    subhash8785
    @subhash8785
    I have already incress the upload_max_filesize and post_max_size in php.ini
    Aleksandar Nikolić
    @aleksandarnikolic85
    image.png
    Hello all,
    I have a problem to setup my ES cluster. I changed my .env file and added two IPs, and the ES as ES is working, but when I want to re-index the stuff for website, I got this error:
    Also, the products are not loaded, just the unicorn is shown
    Can you please tell me what should I do to set up ES cluster in Pimcore
    brainium
    @brainium
    How can i access inputfields in pimcore with extJS, within some panel?
    I can access fields which are located at the „root“ of the class, but not within some other panels.
    1 reply
    JustMe69
    @JustMe69

    Hi there
    is pimcore 6 ready for composer 2?
    are dachcom-plugins for pimcore ready for composer2?
    What about coreshop 2 and composer2?
    Wvision and Data Definitions?

    any (good/bad) experiences?

    2 replies
    francescomulas
    @francescomulas
    hi guys, is there a way to show only specified languages for users or groups in localized data fields?
    2 replies
    Eelco Kruders
    @zetno
    can you use pimcore graphql queries by using HTTP GET with query parameter?
    1 reply
    Roelf
    @Sunohara666
    Does anyone know of a nice step by step upgrade guide for bundles from pimcore 6.9 to pimcore 10?
    prapraj
    @prapraj
    Hi, I am attempting to change custom layout of object while drop down change via startup js. On postOpenObject
    let cbType = object.edit.getLayout().query('combobox[name=markSegment]');
    cbType[0].on('select', function (cb, m) {
    if(cb.value = 'Lable') {
    console.log(object.edit.getLayout());
    });
    I do not find any functions on js object to switch custom layout. Any help will be greatly appreciated or another way to do it
    prapraj
    @prapraj
    Hi, I am able to switch custom Layout via startup js. Thanks
    afe038
    @afe038
    Hi, how can I add a new country? When I use the Pimcore country object, Kosovo i missing
    shashi5678
    @shashi5678
    Hi Everyobe
    getting a strange issue
    Getting Redirecting to Admin
    message whenever trying to access domain URL
    Bram Gerritsen
    @bramstroker

    I am in the process of migrating from pimcore 6 to pimcore 10.
    Have the following requirement in my composer.json:

    "minimum-stability": "dev",
    "prefer-stable": true,
    "require": {
        "pimcore/pimcore": "^10.0",
    }

    However composer is installing 10.x-dev (which seems a develop branch to me) instead of latest stable 10.0.7.
    How can I make sure only the latest stable is installed.

    In packagist also these versions are shown (10.x-dev and 10.0x-dev). https://packagist.org/packages/pimcore/pimcore

    1 reply
    Avinash Mishra
    @avinashpimcore

    Hi,
    has anybody encountered this error ever before?

    request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: "Scripts not found" at /var/app/current/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Controller/ControllerTrait.php line 294 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFoundHttpException(code: 0): Scripts not found at /var/app/current/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Controller/ControllerTrait.php:294)"} []

    Due to this, none of the pimcoreadmin bundle Javascripts are loading and "pimcore_admin_misc_scriptproxy" route is throwing 404

    Bruno Ramalho
    @bramalho

    Hi
    I'm having a problem getting video types in Datahub, the query:

            videoTest {
              type
              __typename
              data {
                __typename
                ... on asset {
                  fullpath
                }
              }
            }

    but I got the error "message": "Warning: Undefined array key \"data\""
    Does anyone knows why this happening, or am I writing the query in the wrong way?

    1 reply
    Eelco Kruders
    @zetno
    Hi all, i'm using w-vision export to CSV. in my mapping i have a reverse object relation. Does anyone know how i can get the related data in the w-vision export mapping?
    1 reply
    Jochen Califice
    @JochenCalifice
    image.png
    Hi! I'm trying to remove the "set to null" recycle bin icon beside checkboxes. anyone got an idea how to do this?
    Axel Tietje
    @xlttj
    This message was deleted
    Ibrahim1238
    @Ibrahim1238
    did somebody now how i can add tow items in the basket cart with same ID because wehn i do this it will always relapse with new one.
    2 replies
    abhiramalli
    @abhiramalli
    Question 3: What can be defined via permissions out of the box in Pimcore Admin Interface? ('Access rules for Pimcore elements via workspaces.; Field based permissions in data objects.; Permissions to most of main menu entries.; Visible Custom Layouts and Perspectives.; Access rules based on property values of elements.')
    Christopher Siegel
    @christopher-siegel
    Bildschirmfoto 2021-07-26 um 13.15.41.png
    If I open Requirements Check inside the pimcore backend, it shows PHP and composer as red, and all CLI tools as yellow.... any idea why? I was just copying DB tables and suddenly couldn't save my pimcore system settings anymore
    If i run the Check in CLI (bin/console pimcore:system:requirements:check) I get OK for all cli tools and php+composer
    Lennart Fries
    @Cruiser13
    @christopher-siegel is the additional $path variable in the system settings properly set? Are there paths in the /app/config/parameters.yml defined?
    Christopher Siegel
    @christopher-siegel
    Hey @Cruiser13 I've never had to set any of those. It was working before, then I tried to copy a few tables from my local to the staging server, that's when the problems started (or at least i noticed them, when i tried saving the system settings and got an error "saving failed")
    I've tried defining the path for php in /app/config/parameters.yml, but that didn't change anything. Everything besides saving the system settings is working – php and all that should be there.
    Sebastian Ortega
    @naitsabeseya_gitlab
    image.png

    good morning dear guys could you help me i'm installing pimcore skeleton
    but at the moment you want to make the clear
    I get the error

    Array to string conversion

    Christopher Siegel
    @christopher-siegel
    @Cruiser13 Okay it was probably happening because of a change in Laravel Forge (which we use to provision our servers). After adding the php path in parameters.yml i was able to save the system settings and add the whole $PATH manually. Then all executables showed as working again. Not sure why pimcore doesn't find the files itself... "which php" gets me the correct path...
    Anyway.. it's working now. Thanks for the help!
    Lennart Fries
    @Cruiser13
    @christopher-siegel I don't know why this fails sometimes - I think it might be due to the PHP executing that tests and some permission restrictions on the system. Great that the manual path in the parameters.yml fixed the issue.
    Dennis Pfahlbusch
    @dpfahlbusch_gitlab
    Hey @all, whats the best way to check for dependencies in an object-listing?