Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Coman Andreea
    @AndreeaComan94
    for demo version
    Ibrahim Tanović
    @ibrahim-tanovic
    Has anyone noticed that in latest Pimcore (v10.0.8) in Documents CMS one cannot add nested block editables that are being used in footer? It is possible to retrieve data for existing nested blocks there however, e.g. for 'Finden & Kaufen' level and 'Popular Brands', 'Autos im Angebot', etc. sublevels.
    jbuennagel
    @jbuennagel
    Hi everybody. This is my first contact with Pimcore. I'm trying to install the demo using the instructions at https://github.com/pimcore/demo#readme.
    The frontend looks fine (all the shiny cars), but when I login to the admin section, all I get is the loading animation. I would appreciate any help at all.
    6 replies
    Daniel Diesenreither
    @d.diesenreither_gitlab

    Hi community,
    can somebody tell me where to place icon's for areas in Pimcore 10. I've tried project/templates/areas/accordion/icon.png and project/public/app/areas/accordion/icon.png

    thanks

    4 replies
    Caue Moyano
    @cauemoyano
    hi everybody, for some reason when trying to upload/use an image this error message shows up after loading finishes...
    The process "'/usr/bin/nice' '-n 19' '/usr/bin/facedetect' '/opt/bitnami/pimcore/public/var/tmp/thumbnails/image-thumb480pimcore-system-treepreview/screw.jpg'" exceeded the timeout of 60 seconds.
    Has anyone faced this issue before? Any help is really appreciated.
    Timon Watteny
    @Timonwatteny
    Hello everyone, does anyone know if the data importer supports importing an array of dataobjects to a multi href? I am currently trying this with multiple different transformation pipeline options. I've tried exploding on my delimiter, then loading the dataobjects on key and even fullpath. There is no option to load a dataobject for every element (iterator) in my array so I would think that the importer auto detects this since the type has changed to dataObjectArray. For the objects that only have one element in the multi href it does work with this setup:
    Screenshot 2021-08-03 at 15.49.13.png
    Yentl Jacobs
    @jacobsyentl
    In follow-up to Timon's question. Is it even possible to import many-to-many relations at all with the default data importer???
    Manuel St.
    @manuakasam
    Guys, I have a CLI Process during which i need the user to go into the admin UI to do further changes and the continue within the CLI.
    Basically I create a new object. Save the object. Redirect the user to admin-ui. Have the user save changes.
    Now in CLI i want to continue. I do Object::getById($id, true); to force a re-query to the database but the object remains unchanged. Any ideas what could be the issue?
    Christian Flack
    @GALCF
    1 reply
    t_i_m_o
    @langert
    Hi,
    trying to migrate assets to a new configures aws3 storage by
    => bin/console pimcore:migrate:storage asset
    results in There are no commands defined in the "pimcore:migrate" namespace
    Why is the "migrate" missing and how can I get it?
    I run pimcore 10 skeleton in dev environment.
    4 replies
    Stephanos Malikotsinas
    @circular-code
    Unbenannt.PNG
    1 reply

    Hi Guys,

    does anyone know if it is possible to add general fields to all pimcore class layout or data components in an update safe way? How would I do it? Possibly via dependency injection? For example I want to add a "description" general field. Like shown in the picture

    thanks in advance, Steph :)
    Stew Night.
    @dooB1EE
    Hi there, I was just wondering if this is the right place for installation assistance of the community edition. I have tried installing it several times, both skeleton and demo - after getting past the SymLinks error and double-checking all system requirements I still get the same error of "Attempted to call function "set_time_limit" from namespace "Pimcore".
    Did you mean to call "\safe\set_time_limit"?"
    I'm hoping someone can lead me in the right direction, I'm assuming that the stable build should just work after install?
    I am running Ubuntu 20.04 with Runcloud.io managing the webapp
    mhmdhussein
    @mhmdhussein
    image.png
    Hello everyone,
    we have self-hosted Pimcore on Ubuntu 20.04, apache 2.4
    and it's too slow, after checking "System requirement check" I found this issue in the Filesystem
    what it is meaning, and how to solve it
    thanks in advance :)
    Archana Goyal
    @archanagoyal07
    Hello Everyone, How can I implement AJAX on pagination. I have multiple snippets in page with pagination. They are not refreshing on pagination click link.
    Trần Anh Tuấn
    @tuanta5_gitlab
    image.png
    Hello everyone please help me. I have created a check box field in the car object. So how do I get only the selected cars as highlight
    image.png
    Philipp Walser
    @Iblis
    Hi there! Still on my way of upgrading from pimcore 6.9.6 to pimcore x. I had issues with the controller references in the db. I executed the migration as mentioned in the upgrade docs before switching to pimcore x, but after the move to pimcore x, the controller references in the db still refer to AppBundle\Controller\DefaultController, instead of App\Controller.... manually fixing the db row made it work, but I wonder if I missed something because I would not have expected to do a manual 'migration' there.
    t_i_m_o
    @langert
    grafik.png
    Hi all, using pimcore 10.1 I get exceptions in backend, using pimcore_Cache()
    An exception has been thrown during the rendering of a template ("Warning: Undefined array key "pimcore_viewcache_legal_navigation_cache"").
    No Exception in Frontend. The expection is called at {% do cache.end() %} is there something to change?
    Artem Iksanov
    @bender-nvkz
    изображение.png

    Hi.

    Cannot use object of type Pimcore\Model\DataObject\Data\BlockElement as array after update from 6.8 to 6.9.
    In stack trace only pimcore core files.

    Did anyone have a similar one?

    Artem Iksanov
    @bender-nvkz

    I found the main problem. I can no longer create a Block field inside a Block field.
    Is it so conceived?

    The documentation doesn't say anything about this
    https://pimcore.com/docs/pimcore/6.9/Development_Documentation/Installation_and_Upgrade/Upgrade_Notes/index.html

    Artem Iksanov
    @bender-nvkz
    Interestingly, I cannot create a Block field inside a Block field via the context menu, but I can create a Block field outside and move it inside another Block field.
    brainium
    @brainium
    Hi guys, after installing datahub on 6.9.6. i can find the datahub icon within the sidebar-navigation, but i can’t find the datahub configuration inside settings-menu… anyone know what went wrong?
    1 reply
    Christian Flack
    @GALCF
    Hi everyone,
    I'm currently stuck at using a filter definition with a classification-store filter.
    I couldn't find anything related to this error, does this ring a bell for anyone who might be able to help?
    {
      "error": {
        "root_cause": [],
        "type": "search_phase_execution_exception",
        "reason": "",
        "phase": "fetch",
        "grouped": true,
        "failed_shards": [],
        "caused_by": {
          "type": "illegal_argument_exception",
          "reason": "maxSize must be >= 0 and < 2147483631; got: 2147483647"
        }
      },
      "status": 400
    }
    1 reply
    Maxim Balaganskij
    @mxbox_gitlab
    Hey everyone, after Updating to Pimcore X, and also changing our Docker Setup for it, i get an unspecified Loader for "Pimcore\Model\DataObject\[one of my classes]" was not found; Error. Meanwhile all classes are available in the correct directories, the permissions to all classes are set and the classes haven't changed at all, only Pimcore has. Has anybody encountered a similar error after an update?
    t_i_m_o
    @langert
    Hi all,
    how can a document condition be setup to filter by docTypeId? The column is not found in documents table..
    something like ....$listing->setCondition("docTypeId = 2")
    Is this the right place to ask? I did not found any docs for default conditions.
    4 replies
    vxhell
    @vxhell:matrix.org
    [m]

    Hi there,

    im having trouble executing the new dataimporter. I did a partial import yesterday ( some objects got imported into pimcore correctly) but after some time the import throw an error and since then i cant contiune / import new objects. Everytime im executing datahub:data-importer:process-queue-parallel from the cli im getting "ERROR: The command is already running". I have no clue how this can be, since i restarted my VM and also checked some DB tables like application_logs and others and purged the projects /var/tmp/datahub/dataimporter dir and then restart the prepartion. Everything without success. Getting always the command is already running. How to track down whats going on here ?

    t_i_m_o
    @langert
    hello again,
    how can I render a complete document with another base template?
    calling a controller by page/{id} via ajax. In the controller action I can now get the page object with \Pimcore\Model\Document\Page::getById($id);
    But how to get the whole document rendered by return $this->render('blank.html.twig')? Is this the right way?
    Mayur Champaneria
    @github-mayur
    hello, how to run bin/console migration:controller-reference while upgrading pimcore version to v10? It's not working.
    I tried to run with php bin/console migration:controller-reference
    php 8
    t_i_m_o
    @langert
    hello, struggling with the docs... https://pimcore.com/docs/pimcore/current/Development_Documentation/Documents/Editables/Renderlet.html
    In my controller I have this action but in editmode the renderlet calls en error => The controller must return a "Symfony\Component\HttpFoundation\Response" object but it returned an object of type Pimcore\Model\Asset\Image. This is right, the return are assets - but how to reponse them as a Rrsponse object? The actionis defined in a own controller in my bundle, not in the areabrick controller - does this matter?
    grafik.png
    pimcore-developer
    @pimcore-developer
    Hello Everyone,
    After installing new version of Pimcore (Pimcore X). I created a class and marked some fields as a non-editable and invisible And these changes are not reflecting on the object (object creation form). It was working in Pimcore older version. Please let me know is there any new setting to mark field as a non-editable or invisible. In addition, I am also able to reproduce this issue on Pimcore demo site : https://demo.pimcore.fun/admin
    questionmark78
    @questionmark78
    Hi,
    I noticed that when you enter an Upload Path on an image attribute in a dataobject and the path does not exist, it is not created when dragging in an image on the DataObject.
    Is this on purpose or shall I add this in a PR in here
    https://github.com/pimcore/pimcore/blob/f3abd295d3733495f938feb69f26c9d9f9c6572e/bundles/AdminBundle/Controller/Admin/Asset/AssetController.php#L449 ?
    t_i_m_o
    @langert
    hi,
    another try, to get on my challenge... can anyone give a hint to render a document with a custom template by using \Pimcore\Model\Document\Service() ... ->render($document). How can I define the template to be the document rendered with, instead the default template the document is build on?
    Wael-Hamdan
    @Wael-Hamdan

    Hello

    We need to upload 50 Gb of assets (images) from our network drive to Pimcore every month. We started doing this by converting the images to bytes and by using Datahub to upload the pictures as assets to Pimcore but it is too slow as it would take many days to complete.
    Is there a solution to overcome this downtime faced with datahub ? I am convinced that datahub was thought to handle such use cases and even handle Tb of data transfers easily.

    Your help would be much appreciated as this is very urgent.

    Thanks a lot.

    shanmuk sandeep
    @sandeep_dev:matrix.org
    [m]
    Hi Team
    Our company decide to deploy pimcore 10 with nginx into EKS cluster. Can some one help with Deployment and service files so i can deploy to the K8S cluster
    Tried searching in google. But couldn't find one. Please share the yaml files which could help my company to explore Pimcore product
    Roelf
    @Sunohara666
    I am implementing https://pimcore.com/docs/pimcore/current/Development_Documentation/Objects/Object_Classes/Data_Types/Dynamic_Select_Types.html , in pimcore 6.9 but my list is too big , so it needs to work through paginated ajax calls / autocompletion. Please advise! I can't find anything on this.
    patkul0
    @patkul0

    Hi guys, one question from me. What was the intention of changing the is_numeric() method with !empty() on line 45 of file models/User/AbstractUser/Dao.php? (https://github.com/pimcore/pimcore/commit/99a5e25721ad30f45f311282960cbf90e4bcb2d0#diff-7a228af14a3cf49a9ff64668b33a1218444fb752a70e2fd2f38e60b12231687e)

    Because of that, we have a problem in Pimcore with versions created by the user system (ID 0). Pimcore shows the user as empty in the Version tab of objects. Method empty treats 0 as empty :D so the condition looks broken.