Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Mayur Champaneria
    @github-mayur
    hello. Anybody knows how to solve this error came after upgrading to Pimcore v10.1.1?
    Symfony\Component\Translation\MessageCatalogue::addCatalogue(): Argument #1 ($catalogue) must be of type Symfony\Component\Translation\MessageCatalogueInterface, string given, called in D:\xampp\htdocs\Pimcore_Panasonic\pimcore_panasonic\vendor\pimcore\pimcore\lib\Translation\Translator.php on line 256
    image.png
    It came first while accessing pimcore login
    Patrick Rupp
    @patrick.rupp_gitlab
    Hey Guys,
    I have encountered a weird issue and I'm not sure if it is a bug or if I'm doing something wrong...
    The issue is that no matter what tenant I supply to the Ecommerce Factory's getCartManager function I always receive the same object.
    I have two different tenants and when I'm tring to restore the two carts from a users session this does not working. My assumption is that this is the case because the cartManager objects are the same.
    FYI: I have implemented the functionality the same way as seen here (https://github.com/pimcore/demo/blob/10.x/src/EventListener/AuthenticationLoginListener.php#L82) the only difference is that I basically do this twice . Once for the default cart and default tenant name and once for my custom cart and custom tenant name.
    Does anybody have an idea?
    12 replies
    bkoppenens
    @bkoppenens
    image.png
    2 replies
    I have a strange issue, almost clean install, and nothing happens on click on the plus-button
    also no errors...
    JustMe69
    @JustMe69
    @solverat I have problems with Formbuilder & pimcore 6.9
    the german version of a simple contact-form, with output of an mail-tpl, is sended.
    When I change to english page, no email is sended. english mail has its own mail-tpl which is configured.
    Caches etc are cleaned up
    What do I make wrong?
    1 reply
    Krzysztof Surdy
    @ksurdy1_gitlab
    Hey. Im having an issue with figuring out some feature. I have 2 classes Entity and EntityFamily. EntityFamily has relation to Entity, and Entity has reverse object relation to EntityFamily. I have gallery of photos withing EntityFamily class which i want to inherit this gallery to be seen and able to edit within Entity class. Whats important Entity can be a part of many EntityFamilies. Is there a way to do that natively or with some bundle? Any idead how to get this done in pimcore X? :)
    johanlindgren
    @johanlindgren

    Pimcore thumbnails are generated on the fly in the first request and cached for following requests. If a page includes 100 images there are 100 subrequest that potentially could cause alot of cpu use. One way to limit this problem is to run a batch and pregenerate the thumbnails.

    Anyone having performance issues with thumbnails? Any good solution on how throttle the cpu use?

    1 reply
    Jimerson Montiel Pastran
    @Jimerson21

    Hello everyone,

    Help. I am trying to install w-vision/DataDefinitions but I always get the following error:

    image.png

    I am using Pimcore version 10.1.1.

    Thank you.

    Aaron
    @aarongerig
    @Jimerson21 In order to be able to use DataDefinitions with Pimcore 10, you have to install the dev-master version for now.
    1 reply
    Jimerson Montiel Pastran
    @Jimerson21

    now I have this other error. Should I install coreshop first?

    image.png

    2 replies
    Shawn Crigger
    @shawncrigger_twitter
    Does anyone know how to change the extra params in a typeahead combobox, when I first create the store it sends some default values
    but then when people start typing, it still uses the default extra params
    store.png
    If I could somehow change those extraParams when a search value is typed in it would make this work
    savosik
    @savosik
    Hello, guys! Please help me with this question. I need to fill fields with data provided by outside services dictionary. But it dictionary counts over 9 millions values. I tried to make Service that provide data for dynamic select field, but all data can load only synchronously. How can I load data for select field asynchronously, for example by onKeyUp ?
    Neelam Rani
    @neelamrani:matrix.org
    [m]
    Hello , guys . i am getting the following error while upgrade pimcore 5.8 to 6
    Unused binding "Symfony\Contracts\HttpClient\HttpClientInterface" in service "instanceof.Monolog\Handler\HandlerInterface.0.Pimcore\Log\Handler\ApplicationLoggerDb".
    pimcore upgrade not complete please guide i need to upgrade pimcore 5.8 to 6
    punedo
    @punedo
    image.png
    1 reply
    any idea lovely developers?
    Chris Hoppe
    @choppe3766
    @punedo Maybe a CSS file is not loaded? What do you see in dev console in the browser?
    Artem Iksanov
    @bender-nvkz
    It's possibly to disable 'autoSave' task? Can't find something in configuration/docs.
    3 replies
    Chris Jung
    @campino2k
    This message was deleted
    Ibrahim1238
    @Ibrahim1238
    Hallo guys why pimcore dosn't suppot svg images i can't see the uploaded image in backend but png ....i see them
    1 reply
    image.png
    Aslam Jmk
    @aslamjmk_gitlab
    Hello
    irojasfs
    @irojasfs
    image.png
    2 replies

    Hello everyone,

    since a couple of weeks ago, I try to solve the question
    What are possible ways for attaching additional information to relations?, from Pimcore Academy, but I can't find the right answer.

    I have tried several options according to the information in the documentation and videos, but I am confused and stuck, if you could help me with the correct answer, I would really appreciate it.

    esisl
    @esisl

    php 7.4
    pimcore 6.7.1

    1. Create a class with Block. In the block there is a LINK field
    2. Create an object. I fill in a list of several entries. I keep it. I close the object editor.
    3. Everything is fine, the object is accessible from the code
    4. I open the editor, click "Save and Publish"
      I get an error!

    Drops when executing $this->update($isUpdate, $params); in /vendor/pimcore/pimcore/models/DataObject/AbstractObject.php

    In Windows, the problem is NOT reproduced.
    The problem occurs only when trying to save an Object containing a Block with a Link field

    Found this problem https://bugs.php.net/bug.php?id=76047
    It looks like a crash occurs when the top of the parent methods in the inheritance chain ends.

    Does anyone know anything about this?

    P.S. In https://demo.pimcore.fun/admin is NOT reproduced.

    1 reply
    lukasvitroleracc
    @lukasvitroleracc
    Has anyone tried overriding the preview function of documents in Pimcore?
    Timon Watteny
    @Timonwatteny
    It seems that the classes in the custom views is mandatory to fill in (since Pimcore X) but the perspectives editor does not provide this configuration, anyone else noticed this issue?
    t_i_m_o
    @langert
    Hi, defining a dialogBox for editables according to the docs, there is even no dialogBox Button shown in 10.1. In the demo I can not find a areaBrick with a dialogBox, too? Is it a bug?
    1 reply
    GALCF
    @GALCF
    Is there a 10.1 fix branch for hotfixes or do I open a PR to 10.0 / 10.x ?
    1 reply
    esisl
    @esisl

    Colleagues!
    After the fifth or sixth project on Pimсore, I had a strategic question:
    How to work with Pimcore?
    a) Take a skeleton and add everything you need with your hands
    b) Take ready-made extensions
    c) Write your extensions

    What advice for a beginner?

    2 replies
    vaishaliPimcore
    @vaishaliPimcore
    @dvesh3 @neha04 What is the best practice to implement new project in Pimcore X? Pimcore 6 is different from Pimcore 10 in case of file structuring .
    should we create custom bundle inside bundle folder ? or should we create all functionality inside single src folder (controller,service and all)?
    Please suggest.
    1 reply
    Katarzyna Kajzar
    @katwer
    Hi!
    What solution is better than
    Pimcore\Tool\Console::runPhpScriptInBackground( realpath(PIMCORE_PROJECT_ROOT . DIRECTORY_SEPARATOR . 'bin' . DIRECTORY_SEPARATOR . 'console'), 'gtv:test', PIMCORE_LOG_DIRECTORY . DIRECTORY_SEPARATOR . 'gtv-test.log' );
    I need do this task with unlimited memory, how it's possible?
    2 replies
    Jimerson Montiel Pastran
    @Jimerson21

    Hello everyone,

    I would like to know if there is a compatible version of dpfaffenbauer/ProcessManager with Pimcore 10.1.0.

    Thank you.

    Martin Muzatko
    @MartinMuzatko
    Hello. I am looking for a way to retrieve my product data via Rest API. Is there one in-built? I couldn't find anything in the documentation
    Martin Muzatko
    @MartinMuzatko

    OK.. I found in our app bundle a rest controller, but it only contains API for the given product :/

    /src/AppBundle/Controller/RestController.php

    geraldmcantor
    @geraldmcantor
    Hello folks, I was looking to setup Pimcore 6.x to authenticate against keycloak. I tried following a couple of guides around configuring the HWIOAuthBundle, but sadly I cannot get this to function properly. I followed this guide in particular, but no luck: https://github.com/hwi/HWIOAuthBundle/tree/master/Resources/doc. Is there another place I can look for guidance on setting up Pimcore login using keycloak? Thanks in advance.
    Om Bissa
    @opbissa_twitter
    Hi All, does anyone implemented stripe payment gateway in Pimcore Ecommerce Framework? wanted to check if there is any bundle available for the same
    Paul Clegg
    @cleggypdc
    @opbissa_twitter I did this about 4 years ago, its not in a bundle but perhaps the basics might help?
    I'll see if I can gist the bulk for you
    Paul Clegg
    @cleggypdc
    @opbissa_twitter Stripe payments, I haven't touched this in years and its written for PC4 but I hope that the same concepts in the ecom framework are still relevant today @fashxp
    ;-) https://gist.github.com/cleggypdc/2a4cea8544a9707e578c2043e393509c
    3 replies
    Michael Frank
    @ITspirit

    Are there any Best Practice recommendations how to achive a i18n setup where one language is a "default" language and it isn´t necessary to have a locale fragment in the URI?

    Setup is currently:

    [Site]
    |-- de
    |-- en
    |-- hu

    Unfortunately all URI will have the "/de" part for example in the URI. Is there a way to get rid of one of the local part without making them as a site.
    So that all languages will keep the local part, except one can be reached without it.

    Staticroutes seems not suitable. Route Annotations will be to specific.
    Any ideas or suggestions?

    2 replies
    mawlid
    @Mawlid
    Hi Guys, i am completely new to Pimcore and got a question: i am trying using Wysiwyg and with drap and drop added image. Now what i want is, to get the image metadata and use it. any help? thanks!
    vxhell
    @vxhell:matrix.org
    [m]
    Hi, im currently struggling with the pimcore dataimporter from pimcore x. I can Import basic data now, but what i cant make work is relations. Any guides how to import many to many /many to one relations?
    xanobius
    @xanobius
    Hi there. We recently updated from 6.8 to 6.9 and ever since the newsletters are not sent anymore. The test mail works fine, but the full newsletter get stuck in the tmp_store and is never sent. Has somebody an idea why that could be? I couldn't find anything in the update notes
    9 replies