Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    irojasfs
    @irojasfs

    Hello everyone,

    since a couple of weeks ago, I try to solve the question
    What are possible ways for attaching additional information to relations?, from Pimcore Academy, but I can't find the right answer.

    I have tried several options according to the information in the documentation and videos, but I am confused and stuck, if you could help me with the correct answer, I would really appreciate it.

    esisl
    @esisl

    php 7.4
    pimcore 6.7.1

    1. Create a class with Block. In the block there is a LINK field
    2. Create an object. I fill in a list of several entries. I keep it. I close the object editor.
    3. Everything is fine, the object is accessible from the code
    4. I open the editor, click "Save and Publish"
      I get an error!

    Drops when executing $this->update($isUpdate, $params); in /vendor/pimcore/pimcore/models/DataObject/AbstractObject.php

    In Windows, the problem is NOT reproduced.
    The problem occurs only when trying to save an Object containing a Block with a Link field

    Found this problem https://bugs.php.net/bug.php?id=76047
    It looks like a crash occurs when the top of the parent methods in the inheritance chain ends.

    Does anyone know anything about this?

    P.S. In https://demo.pimcore.fun/admin is NOT reproduced.

    1 reply
    lukasvitroleracc
    @lukasvitroleracc
    Has anyone tried overriding the preview function of documents in Pimcore?
    Timon Watteny
    @Timonwatteny
    It seems that the classes in the custom views is mandatory to fill in (since Pimcore X) but the perspectives editor does not provide this configuration, anyone else noticed this issue?
    t_i_m_o
    @langert
    Hi, defining a dialogBox for editables according to the docs, there is even no dialogBox Button shown in 10.1. In the demo I can not find a areaBrick with a dialogBox, too? Is it a bug?
    1 reply
    GALCF
    @GALCF
    Is there a 10.1 fix branch for hotfixes or do I open a PR to 10.0 / 10.x ?
    1 reply
    esisl
    @esisl

    Colleagues!
    After the fifth or sixth project on Pimсore, I had a strategic question:
    How to work with Pimcore?
    a) Take a skeleton and add everything you need with your hands
    b) Take ready-made extensions
    c) Write your extensions

    What advice for a beginner?

    2 replies
    vaishaliPimcore
    @vaishaliPimcore
    @dvesh3 @neha04 What is the best practice to implement new project in Pimcore X? Pimcore 6 is different from Pimcore 10 in case of file structuring .
    should we create custom bundle inside bundle folder ? or should we create all functionality inside single src folder (controller,service and all)?
    Please suggest.
    1 reply
    Katarzyna Kajzar
    @katwer
    Hi!
    What solution is better than
    Pimcore\Tool\Console::runPhpScriptInBackground( realpath(PIMCORE_PROJECT_ROOT . DIRECTORY_SEPARATOR . 'bin' . DIRECTORY_SEPARATOR . 'console'), 'gtv:test', PIMCORE_LOG_DIRECTORY . DIRECTORY_SEPARATOR . 'gtv-test.log' );
    I need do this task with unlimited memory, how it's possible?
    2 replies
    Jimerson Montiel Pastran
    @Jimerson21

    Hello everyone,

    I would like to know if there is a compatible version of dpfaffenbauer/ProcessManager with Pimcore 10.1.0.

    Thank you.

    Martin Muzatko
    @MartinMuzatko
    Hello. I am looking for a way to retrieve my product data via Rest API. Is there one in-built? I couldn't find anything in the documentation
    Martin Muzatko
    @MartinMuzatko

    OK.. I found in our app bundle a rest controller, but it only contains API for the given product :/

    /src/AppBundle/Controller/RestController.php

    geraldmcantor
    @geraldmcantor
    Hello folks, I was looking to setup Pimcore 6.x to authenticate against keycloak. I tried following a couple of guides around configuring the HWIOAuthBundle, but sadly I cannot get this to function properly. I followed this guide in particular, but no luck: https://github.com/hwi/HWIOAuthBundle/tree/master/Resources/doc. Is there another place I can look for guidance on setting up Pimcore login using keycloak? Thanks in advance.
    Om Bissa
    @opbissa_twitter
    Hi All, does anyone implemented stripe payment gateway in Pimcore Ecommerce Framework? wanted to check if there is any bundle available for the same
    Paul Clegg
    @cleggypdc
    @opbissa_twitter I did this about 4 years ago, its not in a bundle but perhaps the basics might help?
    I'll see if I can gist the bulk for you
    Paul Clegg
    @cleggypdc
    @opbissa_twitter Stripe payments, I haven't touched this in years and its written for PC4 but I hope that the same concepts in the ecom framework are still relevant today @fashxp
    ;-) https://gist.github.com/cleggypdc/2a4cea8544a9707e578c2043e393509c
    3 replies
    Michael Frank
    @ITspirit

    Are there any Best Practice recommendations how to achive a i18n setup where one language is a "default" language and it isn´t necessary to have a locale fragment in the URI?

    Setup is currently:

    [Site]
    |-- de
    |-- en
    |-- hu

    Unfortunately all URI will have the "/de" part for example in the URI. Is there a way to get rid of one of the local part without making them as a site.
    So that all languages will keep the local part, except one can be reached without it.

    Staticroutes seems not suitable. Route Annotations will be to specific.
    Any ideas or suggestions?

    2 replies
    mawlid
    @Mawlid
    Hi Guys, i am completely new to Pimcore and got a question: i am trying using Wysiwyg and with drap and drop added image. Now what i want is, to get the image metadata and use it. any help? thanks!
    vxhell
    @vxhell:matrix.org
    [m]
    Hi, im currently struggling with the pimcore dataimporter from pimcore x. I can Import basic data now, but what i cant make work is relations. Any guides how to import many to many /many to one relations?
    xanobius
    @xanobius
    Hi there. We recently updated from 6.8 to 6.9 and ever since the newsletters are not sent anymore. The test mail works fine, but the full newsletter get stuck in the tmp_store and is never sent. Has somebody an idea why that could be? I couldn't find anything in the update notes
    9 replies
    geraldmcantor
    @geraldmcantor
    Hi folks. I had posted a question on Sep 3 about setting up Pimcore to authenticate against Keycloak. Does anyone have any pointers on how to set this up? I followed this doc: https://github.com/hwi/HWIOAuthBundle/tree/master/Resources/doc. Unfortunately, when following the link to auth with Keycloak, I get an "OOOOPS ...
    Sorry, the page you're looking for has gone." Any help or direction to additional resources in this area would be greatly appreciated.
    Manuel St.
    @manuakasam
    Sometimes when I'm using the Pimcore Admin UI for more than a couple of minutes I start getting permission errors every time I try to perform any action. Pimcore is only opened in that one window. Any pointers as to why that keeps happening? Totally irregular and super frustrating.
    3 replies
    brainium
    @brainium
    Hey guys… after migrating to Pimcore 10 float inputs are converted to string in case of using a german format (f.e. 10,6 -> 10). systemlanguage is set to german. anything i could do?
    Justin Frisch
    @dasgecko
    I'm having the same problem -> Float input fields are only accepting periods (i.e. 10.6) and not the German localization with commas (i.e. 10,6). This is working correctly in the old 6.9 version, however doesn't seem to be working in the 10.1.2 version. In the 6.9 version, if I changed the users language / language input it would automatically switch all fields accordingly and only allow the float separator for that language. Any help with this would be great!
    Andrei Marosan
    @andreimarosan_gitlab
    Hello, i just want to make a upgrade from pimcore 6.6.3 to pimcore X, and for the search i am using dachcom-digital/lucene-search 2.2.3. Is this bundle still compatible with pimcore X? If not, what are other bundles that i can use for search?
    Ismail Rangwla
    @Yuki1602
    Script Pimcore\Composer::clearCache handling the pimcore-scripts event terminated with an exception
    this error comes when installing the bundlegenerator
    Katarzyna Kajzar
    @katwer

    Hi guys! Probably I'm doing stupid mistake.. I've good working command task, where I induce it from cmd, when I start it from controller, this way:
    $process = new Process([PIMCORE_PROJECT_ROOT . '/bin/console', 'checker:import:photo -assetId='.$checkerFile->getAssetId().' -checkerRowId='.$checkerFile->getId()]); $process->setTimeout(null); $process->run();

    i get error:

    ``The command "'/var/www/html/pimcore/bin/console' 'checker:import:photo -assetId=938 -checkerRowId=562675'" failed.

    Exit Code: 1(General error)

    Working directory: /var/www/html/pimcore/web

    Output:

    Error Output:

    Command "checker:import:photo -assetId=938 -checkerRowId=562675" is not def
    ined.

    Did you mean one of these?
    checker:import:photo
    definition:import:class
    definition:import:customlayout
    definition:import:fieldcollection
    definition:import:objectbrick
    ``
    What's going on?

    Marimchen
    @Marimchen

    Hi, I am very very new to pimcore. I am trying to install the data-hub bundle with composer, but it always fails with the following error - can someone help me with that?:

    Pimcore\Composer::postInstall
    Pimcore\Composer::clearCache
    Script Pimcore\Composer::clearCache handling the pimcore-scripts event terminated with an exception

    [ErrorException]
    proc_open() expects parameter 1 to be string, array given

    Paul Clegg
    @cleggypdc
    Hey all, for those who default to discord I've set up a Pimcore community discord server (thought why not give this a shot). I believe this could help make the platform more accessible, please feel free to join, its fresh off the discord production line so feedback on channels, topics etc would be much appreciated: https://discord.gg/JXvR2AdpZq
    Michael Frank
    @ITspirit
    In the Release Files (zip/tar.gz) starting with Version 10.1.2 the "tests" folder are missing?! @fashxp any reasons why? Without the tests folder codeception won´t run. The folder is still in the github - Repo, but not anymore in the Release Files (which for example are loaded via satis).
    5 replies
    Sergey Poprovka
    @sergeypoprovka
    Hey everybody! Hope you're all doing good :)
    I have problem with passing exam at Pimcore Academy. Somebody passed "Senior developer" course there? And especially the part about new things at Pimcore 6.9?
    I tried everything already - but it seems like something is wrong there? Or I'm missing something... Could somebody help me with that? Any advise appreciated :)
    Sergey Poprovka
    @sergeypoprovka

    And if somebody knows the proper answer for this one - that would be just great! :)

    Which built-in Pimcore features can be used for reporting?

    • Object Bricks
    • Dynamic Text Labels
    • Calculated Values
    • Preview I-Frame Panel
    • Notification System
    • BI Module
    • Custom Reports
    • Pimcore Assets

    Options 2,3,4 are mentioned at the Academy's videos, but this answer is wrong :(

    Tomasz Dydynski
    @tomasz.dydynski_gitlab
    hello
    Please for help. How i can import product variants via Data Importer https://pimcore.com/docs/data-importer/current/ on PIMCORE X ?
    JustMe69
    @JustMe69
    @solverat
    Is there no actual version compatible with pimcoreX?
    for dachcom/toolbox and dachcom/formbuilder?
    even with minimum-stability to dev - composer tells me, that pimcore 10 is not matching as dependency?
    Problem 1
        - Root composer.json requires dachcom-digital/toolbox dev-master -> satisfiable by dachcom-digital/toolbox[dev-master].
        - dachcom-digital/toolbox dev-master requires pimcore/pimcore ^6.0 -> found pimcore/pimcore[v6.0.0, ..., 6.9.x-dev] but it conflicts with your root composer.json require (^10.0).
    3 replies
    GALCF
    @GALCF
    A question regarding the dynamic search bundle: Is there a "pimcore-document content extractor" somewhere that I am missing? Or do I need to define exactly how the document content gets fetched and indexed?
    1 reply
    Luigi DK
    @igio80:matrix.org
    [m]
    Hello to all. I just started looking at pimcore features. I am interested in the Community version and in particular the MDM part. I saw the demo but I could not understand if it is possible with the basic version to import existing databases via api and harmonize the information with Pimcore's MDM. Can someone help me?
    Nils Abegg
    @nilsabegg
    This message was deleted
    1 reply
    Nils Abegg
    @nilsabegg
    Hello everyone. I try for one day to get the data hub working as in the Docs and it's really frustrating. I already updated to 6.9 and 1.0.8 since I thought it might be the Problem that I don't have the current version. In the docs are examples that just don't work in my case. Is it possible to access assets via a traditonal rest API in Pimcore 6.9?
    Or what GraphQL query do I need to get all assets which filename contain a given string? I tried everything what is in the docs, but I am still not any step closer to the goal. getAssets is just not working. GetAsset doesn't accept an Filter, GetAssetListing seems to be completely useless. What am I missing? I am pretty sure I just dont get a little detail. Could someone please point me in the right direction? Thanks in advance for any help.
    Nils Abegg
    @nilsabegg
    I found the webdav thing for assets now, but I can't believe it's really the only way to traverse through all the folders and search for the assets myself. What version of Pimcore and data hub do I need to get the examples in the docs working?
    Josef Aichhorn
    @weisswurstkanone
    image.png
    7 replies
    @nilsabegg
    Eldar Gazaliev
    @MyZik
    Hello! How can I add with JS an asterisk to field label, if object was loaded?
    Lakshya Duggal
    @duggallakshya:matrix.org
    [m]
    Hi everyone! I have just started working on pimcore.
    I found an error ("cmf.action_trigger.queue" service is deprecated) while calling a trigger for an activity in customer automation rules created through webservices api for activities.
    Lakshya Duggal
    @duggallakshya:matrix.org
    [m]
    php.INFO: User Deprecated: The "cmf.event_listener.action_trigger" service is deprecated. Use "CustomerManagementFrameworkBundle\ActionTrigger\Queue\QueueInterface" ins$
    [2021-09-23T00:33:28.130350+00:00] php.INFO: User Deprecated: The "cmf.action_trigger.queue" service is deprecated. Use "CustomerManagementFrameworkBundle\ActionTrigger\Queue\QueueInterface" instead {"ex$
    [2021-09-23T00:33:28.332222+00:00] doctrine.DEBUG: SELECT id FROM assets LIMIT 1 [] []
    Rushit Khunt
    @rushit-credencys

    Hello devs,

    We have implemented ElasticSearch with the product class and it's working fine, Now we want to add ElasticSearch on one another class.

    To do this we have done all configurations the same as the product with multiple tenants on elastic-search.yml but indexing is not working, taking data of product class only.

    Is there anyone have an idea how we can implement it?

    abhishekceon
    @abhishekceon
    Hi All, We are experiencing a problem with the key binding section of the Pimcore User section. Even if the user doesn’t have the right to perform any action but using key binding still he/she can do. For example of the user is not allowed to unpublish from rights but using a shortcut key can do.Can anyone please suggest any workaround to stop this?
    Pravin chaudhary
    @pdchaudhary
    Hi, is it possible to use Pimcore as an identity provider for some other site requiring SSO?