Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    JustMe69
    @JustMe69
    Hi,
    I want so select objects depending on their modification date, get al list of them, but I don't fetch results.
    How to retrieve them?
    My tries i.e:
    $customers = CoreShopCustomer::getList(
                [
                    'condition' => sprintf(
                        'modificationDate > "%s"',
                        $yesterday
                    ),
                    'orderKey' => 'sortorder',
                    'order' => 'ASC'
                ]
            );
    3 replies
    Michael Frank
    @ITspirit

    Just struggeling with DataHub GraphQL - i always recieve an emtpy result.
    Just doing this:

    {
      getEmployeeListing {
        totalCount
      }
    }

    and recieve:

    {
      "data": {
        "getEmployeeListing": {
          "totalCount": 0
        }
      }
    }

    But there are a lot of objects (published of course). No other Limitation on General Definition.

    If i query for a specific one via getEmployee(id:12345) i get a result.

    So what´s wrong with the Listing?

    1 reply
    Tarun Mahajan
    @tarun.mahajan_gitlab

    HI Team i am getting this error after running the

    composer require annotations asset orm-pack twig \
    logger mailer form security translation validator

    Problem 1

    - Root composer.json requires symfony/asset ^5.3, found symfony/asset[v5.3.0, v5.3.2, v5.3.4] but these were not loaded, likely because it conflicts with another require.

    Problem 2

    - pimcore/pimcore is locked to version v6.8.10 and an update of this package was not requested.
    - pimcore/pimcore v6.8.10 requires sensio/framework-extra-bundle ^5.4 -> found sensio/framework-extra-bundle[v5.4.0, ..., v5.6.1] but it conflicts with your root composer.json require (^6.2).

    Problem 3

    - pimcore/skeleton is present at version dev-main and cannot be modified by Composer
    - sensio/framework-extra-bundle v6.2.0 requires symfony/config ^4.4|^5.0|^6.0 -> satisfiable by symfony/symfony[v4.4.18].
    - pimcore/skeleton dev-main conflicts with symfony/symfony v4.4.18.
    - Root composer.json requires sensio/framework-extra-bundle ^6.2 -> satisfiable by sensio/framework-extra-bundle[v6.2.0].

    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

    Tarun Mahajan
    @tarun.mahajan_gitlab
    Hi @duggallakshya:matrix.org

    we are getting this issue

    composer require annotations asset orm-pack twig \
    logger mailer form security translation validator

    Problem 1

    • Root composer.json requires symfony/asset ^5.3, found symfony/asset[v5.3.0, v5.3.2, v5.3.4] but these were not loaded, likely because it conflicts with another require.

    Problem 2

    • pimcore/pimcore is locked to version v6.8.10 and an update of this package was not requested.
    • pimcore/pimcore v6.8.10 requires sensio/framework-extra-bundle ^5.4 -> found sensio/framework-extra-bundle[v5.4.0, ..., v5.6.1] but it conflicts with your root composer.json require (^6.2).

    Problem 3

    • pimcore/skeleton is present at version dev-main and cannot be modified by Composer
    • sensio/framework-extra-bundle v6.2.0 requires symfony/config ^4.4|^5.0|^6.0 -> satisfiable by symfony/symfony[v4.4.18].
    • pimcore/skeleton dev-main conflicts with symfony/symfony v4.4.18.
    • Root composer.json requires sensio/framework-extra-bundle ^6.2 -> satisfiable by sensio/framework-extra-bundle[v6.2.0].

    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently

    JustMe69
    @JustMe69

    Hi,
    I'm trying to fetch objects on their modificationDate. This field is inherited by pimcore models/DataObject/AbstractObject.php

    My code:

        $yesterday = 1629770717;
    
        /** @var CoreShopCustomer\Listing $customers */
        $list = new CoreShopCustomer\Listing();
        $list->setCondition("o_modificationDate > $yesterday",
            [
                'orderKey' => 'sortorder',
                'order' => 'ASC'
            ]
        );
    
        $list->onCreateQueryBuilder(function (\Doctrine\DBAL\Query\QueryBuilder $queryBuilder) {
            echo $queryBuilder->getSQL();
        });
    
        $customers = $list->load();

    the echo prints:
    SELECT object_12.o_id as o_id, o_type FROM object_12 WHERE (o_modificationDate > 1629770717 AND object_12.o_type IN ('object','folder')) AND object_12.o_published = 1
    objects_12 is a view, not a table.
    shows 188 rows which is the same as all rows for classId 12

    When I look into DB and query directly on objects-table
    SQL: SELECT * FROM objects o WHERE o.o_classId = '12' AND o.o_modificationDate > 1629770717
    it shows only 21 rows

    o_modificationDate is stored only in objects-table.

    In the view-SQL is no calculation or modification on the values of the combined tables.

    So why do I get all existing objects and not as wished the subset?
    How can I really get the objects dependinon o_modificationDate?

    11 replies
    brainium
    @brainium
    any news on quantity values regarding datahub in pimcore x? maybe someone knows a workaround? i need to import data with lots of quantity values…
    2 replies
    Manuel St.
    @manuakasam
    Hey guys, does anyone know if there's a simple (possibly inbuilt) functionality to "log in as a user"?
    So that an admin can impersonate any customer (CMF) on the frontend website?
    1 reply
    Aaron
    @aarongerig
    @manuakasam Maybe this guide "How to impersonate a User" will help you achieve what you are looking for? https://symfony.com/doc/current/security/impersonating_user.html
    Jp
    @VeiJar1
    Hey, is there a quick way to get asset full public url?
    Marko
    @cuca24

    @brusch @diveshpahuja

    Hi i was wondering if i could do PR to elasticsearch to use basic authentication here: https://github.com/pimcore/pimcore/blob/e105061a46008e091dd61bf361ee6079b9d95a71/bundles/EcommerceFrameworkBundle/IndexService/Worker/ElasticSearch/AbstractElasticSearch.php#L199

    The username and password could be provided through yml file where host is set up.

    Shell i proceed with the PR, or there is a reason why basic auth isn't included

    _

    Ismail Rangwla
    @Yuki1602
    I need to get the values from the Change Password field in the Myprofile section in pimcore backend admin how can i do thi s?
    mzcentric
    @mzcentric
    how to manage cart by session and not by database any example?
    1 reply
    Valentin
    @valentin-

    Hi, the full page cache is activated but doesn't take effect because of targeting rules. Targeting isn't used in the project, how can i disable targeting globally in the project? I couldn't find anything in the docs. It's a Pimcore X project.

    x-pimcore-output-cache-disable-reason: Targeting matched rules/target groups

    1 reply
    ncode_99
    @ncode_99:matrix.org
    [m]
    What could be a possible reason for navigation showing unpublished (non-existent) pages/documents? And what is weird, sometimes it shows those unpublished documents, sometimes it does not
    Andreas Schmidt
    @schmidt-travixmedia
    Hi, is it possible to move data objects, assets or documents to the recycle bin programmatically via the Pimcore API? I examined the Ajax requests that are sent to the Server when I delete objects via the Pimcore Admin Backend, there seems to be a whole bunch of things/requests that need to be done for "moving" objects to the recycle bin.
    Ismail Rangwla
    @Yuki1602
    onTreeNodeContextmenu override not working any solutions?
    In tree.js file
    ncode_99
    @ncode_99:matrix.org
    [m]
    I have a problem with a pimcore app, where when i request a certain page that is unpublished, it keeps on redirecting to that page. Basically, the page does not exist, and i configured pimcore to open a 404 page. When the request for the unpublished page happens, pimcore does return the 404 page, but then again a request for the unpublished page happens, and this keeps going over and over again. It just keep on trying to request the unpublished page. And it just happens with some pages. For example i have another page that is also unpublished, and when i request it, a 404 page is displayed normally, no redirecting or anything
    Thijs Windels
    @thijswindels_gitlab
    image.png
    5 replies
    Hello everyone. I was wondering if it is possible to render an image in an xlsx export (from the overview grid) of Pimcore 6.9? I'm able to render the image in the overview grid and tried to use the Image Renderer in my grid config, but this has no effect on the actual xlsx-export.
    Frederik Hulleman
    @fhulleman
    Hi guys, I'm looking for more info regarding graphql query filtering (on date time modified). But I can't open this link. Can anyone help? Thanks a lot!
    https://pimcore.com/docs/pimcore/current/Development_Documentation/Web_Services/Query_Filters.html
    ncode_99
    @ncode_99:matrix.org
    [m]

    :point_up: Edit: I have a problem with a pimcore app, where when i request a certain page that is unpublished, it keeps on redirecting to that page. Basically, the page does not exist, and i configured pimcore to open a 404 page. When the request for the unpublished page happens, pimcore does return the 404 page, but then again a request for the unpublished page happens, and this keeps going over and over again. It just keep on trying to request the unpublished page. And it just happens with some pages. For example i have another page that is also unpublished, and when i request it, a 404 page is displayed normally, no redirecting or anything

    EDIT: It seems to happen for a certain path: for example /en/Test/any_path_that_does_not_exist --> it opens a 404 page, and tries to open that path again, over and over again. If i request a page that does exist /en/Test/page_that_exists it opens it normally

    :point_up: Edit: I have a problem with a pimcore app, where when i request a certain page that is unpublished, it keeps on redirecting to that page. Basically, the page does not exist, and i configured pimcore to open a 404 page. When the request for the unpublished page happens, pimcore does return the 404 page, but then again a request for the unpublished page happens, and this keeps going over and over again. It just keep on trying to request the unpublished page. And it just happens with some pages. For example i have another page that is also unpublished, and when i request it, a 404 page is displayed normally, no redirecting or anything

    EDIT: It seems to happen for a certain path: for example /en/Test/any_path_that_does_not_exist --> it opens a 404 page, and tries to open that path again, over and over again. If i request a page that does exist /en/Test/page_that_exists --> it opens it normally
    Also the /Test/ part is a link

    developer7
    @developer7:matrix.org
    [m]
    Hi Can anyone help , When i try to view acedamy videos it take too much time to load (after 1min 19 sec it doesnt get loaded), I have check the same with multiple internet connection
    Ismail Rangwla
    @Yuki1602
    @developer7:matrix.org It was the same for me i just waited for them to load
    1 reply
    Jp
    @VeiJar1
    Hey, how to check in ObjectListener class, if object data has not changed?
    5 replies
    Ivan Blažević
    @blazevici
    This message was deleted
    1 reply
    ncode_99
    @ncode_99:matrix.org
    [m]
    How can i fix 'areabrick test is not registered' after renaming/removing the brick?
    1 reply
    Katarzyna Kajzar
    @katwer
    Hi!
    How could I get field definition from object?
    4 replies
    Katarzyna Kajzar
    @katwer
    image.png
    3 replies
    h6585
    @h6585

    Hi,

    I am unable to install pimcore on my Ubuntu installation on Windows 10.

    This is the error message that I get:

    ' Problem 1

    - facade/ignition is locked to version 2.14.1 and an update of this package was not requested.
    - Conclusion: don't install pimcore/pimcore v6.9.1 (conflict analysis result)
    - Conclusion: don't install pimcore/pimcore v6.9.2 (conflict analysis result)
    - Conclusion: don't install pimcore/pimcore v6.9.3 (conflict analysis result)
    - Conclusion: don't install pimcore/pimcore v6.9.4 (conflict analysis result)
    - Conclusion: don't install pimcore/pimcore v6.9.5 (conflict analysis result)
    - Conclusion: don't install pimcore/pimcore v6.9.6 (conflict analysis result)
    - Conclusion: don't install pimcore/pimcore v6.9.0 (conflict analysis result)
    - facade/ignition 2.14.1 requires monolog/monolog ^2.0 -> satisfiable by monolog/monolog[2.0.0-beta1, ..., 2.x-dev (alias of dev-main)].
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.3.5.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.3.4.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.3.3.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.3.2.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.3.1.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.3.0.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.2.0.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.1.1.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.1.0.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.0.2.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.0.1.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.0.0.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.0.0-beta2.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.0.0-beta1.
    - pimcore/pimcore 6.9.x-dev conflicts with monolog/monolog 2.x-dev.
    - Root composer.json requires pimcore/pimcore ^6.9 -> satisfiable by pimcore/pimcore[v6.9.0, ..., 6.9.x-dev].'
    37 replies
    shashanks0110
    @shashanks0110
    hello folks, any insights on matamo integration with pimcore10?
    1 reply
    bkoppenens
    @bkoppenens
    This chat is really horrible for (community) support and building a history to look if someone has had your problem before. I mean, the forum was not great but this is just like a black hole.
    2 replies
    Kevin Horst
    @head1328
    I have some questions about this: https://pimcore.com/docs/pimcore/current/Development_Documentation/Deployment/Deployment_Tools.html#page_Pimcore-Class-Definitions
    • After creating some classes on my local machine with dev-mode on and PIMCORE_CLASS_DEFINITION_WRITABLE=true, I copy the definition files from /var/classes/definitions-*.php to /config/pimcore/classes/
    • Because of the .gitignore file I commit both folders with same definition classes
    • on my remote machine without PIMCORE_CLASS_DEFINITION_WRITABLE I have to execute pimcore:deployment:classes-rebuild -c but this results in: In ClassDefinition.php line 442: definitions in config/pimcore folder cannot be overwritten
    1 reply
    mzcentric
    @mzcentric
    ffmpeg.png
    mzcentric
    @mzcentric
    for installing ffmpeg binaries on windows 10 platform (A hint )
    Silverado2791
    @Silverado2791

    @dpfaffenbauer
    Hi, I have installed v.10.1.4 on a dev server. ffmpeg is installed and the assets are stored on local db. I can preview images and pdf but the video preview does not work even if I add ffmpeg to PATH manually

    dev.log => pimcore.ERROR: Exception: No 'ffmpeg' executable found, please install the application or add it to the PATH (in system settings or to your PATH environment variable in

    [dnu@ ~]$ ffmpeg -version
    ffmpeg version 3.4.8 Copyright (c) 2000-2020 the FFmpeg developers
    built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-39)
    configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --docdir=/usr/share/doc/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic' --extra-ldflags='-Wl,-z,relro ' --extra-cflags=' ' --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3 --enable-bzlib --disable-crystalhd --enable-fontconfig --enable-gcrypt --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libcdio --enable-libdrm --enable-indev=jack --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmp3lame --enable-nvenc --enable-openal --enable-opencl --enable-opengl --enable-libopenjpeg --enable-libopus --disable-encoder=libopus --enable-libpulse --enable-librsvg --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvidstab --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzvbi --enable-avfilter --enable-avresample --enable-libmodplug --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-libmfx --enable-runtime-cpudetect
    libavutil 55. 78.100 / 55. 78.100
    libavcodec 57.107.100 / 57.107.100
    libavformat 57. 83.100 / 57. 83.100
    libavdevice 57. 10.100 / 57. 10.100
    libavfilter 6.107.100 / 6.107.100
    libavresample 3. 7. 0 / 3. 7. 0
    libswscale 4. 8.100 / 4. 8.100
    libswresample 2. 9.100 / 2. 9.100
    libpostproc 54. 7.100 / 54. 7.100

    Jp
    @VeiJar1

    Hey, I have a Dataobject that has ManyToOne relation to another Dataobject. Now I need to get all the related dataobjects.

    Documentation states:
    $relationId = 162;
    $list = new \Pimcore\Model\DataObject\Example\Listing();
    $list->setCondition("mySingleRelation__id = ".$relationId);

    But I can't wrap my head around on what does "mySingleRelation__id" refer to in my case?

    2 replies
    esisl
    @esisl

    Hi!
    Looking at the documentation:
    https://pimcore.com/docs/pimcore/current/Development_Documentation/Development_Tools_and_Details/Email_Framework/Pimcore_Mail.html

    But if I try to do this in my code, I get:
    [2021-10-14 11:37:29] request.CRITICAL: Uncaught PHP Exception Symfony\Component\ErrorHandler\Error\UndefinedMethodError: "Attempted to call an undefined method named "embedFromPath" of class "Pimcore\Mail".

    What's wrong?

    2 replies
    jantomicky
    @jantomicky
    Question, is the direct_sql_query grid toolbar button enabled for administrators only because of SQL "injection" concerns? It works great for searching for multiple values of a certain column (using IN or just OR), but regular users can't use it. Grid filters and the search input don't really offer our users what they need. I am wondering what the best solution would be here.
    2 replies
    rohi
    @irojasfs

    hi everyone

    can anyone help me, i am trying to consume an external api/endpoint in pimcore, do you have any idea or way to do this? or what would be the most appropriate way to do it?

    1 reply
    adibreaban
    @adibreaban

    Hello all,

    We're trying to get information about the Target Group of a document, but we don't want to get "Assigned Target Groups" but the "Document Target Groups" (so only the matched one which has actual personalized content).
    Anyone did this before? From what I've seen, we'd have to extend a lof ot things and maybe there's an easier way than that.

    Thanks,
    Adi

    Iida
    @iibs

    I'm trying to practice making custom persistent models through Doctrine ORM, but I seem to keep getting stuck on different obstacles on the way. I have succesfully made my entity, but when I try to run bin/console make:migration, I get an error "The schema provider is not available".

    Does Pimcore have a default schema provider, or do I have to make one myself?

    behrus heidar
    @behrus_heidar_twitter
    Hi, is that a bug? If i create custom layouts for a class and assign it to a user. Everything also fits within a product. But when the user goes over the grid and configures the grid in grid options, everything is displayed again and he can select everything from the class!
    MHGanainy
    @MHGanainy
    Hi All,
    I am just starting to investigate the pimcore Ecommerce Bundle. Is there are any tips or advice other than reading the document and understanding the Demo
    Regards.
    Alexander Gaal
    @alexander.gaal_gitlab
    Bildschirmfoto 2021-10-15 um 21.54.29.png
    Hi, anyone ever ran into something like this?
    1 reply
    There shouldn't be any plus symbols.
    Indal
    @indalraj
    Hi all,