Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    frithjof
    @frithjof
    @sarelvdm i think you did not understand what pimcore is ... it helps you build such a db yourself not query existing databases
    i think you are looking for something like https://icecat.biz/de
    rohi
    @irojasfs
    hi all, can you help me, how can I have a typical role crud to create and assign custom roles to customers in the frontend if I am using Customer Management Framework?
    I'm working with pimcore 10, thanks in advance.
    JustMe69
    @JustMe69
    grafik.png
    Hi there,
    pimcore offers the datatype 'language' which means selection of language. see picture above.
    Has someone an example where it is used in a form? I Don't find anything in pimcore docu how to access this selection. Which dataType in the form has to be used, what could I search in code?
    or how can I define which languages should be selectable?
    Any hints are welcome
    Alexander Weese
    @WebArtAllgaeu
    is there a way where i can automatically authenticate a pimcore backend user against a custom firewall in the frontend ? some of the templates of the protected frontend part of my application need to be editable by the editors in the backend. i am working with pimcore 10 btw
    Divesh
    @dvesh3

    Hey Pimconauts! 👨‍🚀
    Pimcore Inspire is just around the corner.🚀
    Don't miss a chance to get some great insights.

    If you have not registered? Get your ticket here and see you on November 18:
    👉 https://bit.ly/3kplzKe

    Skynet Jamnagar
    @skynetjam
    Hey guys
    Have anyone use reactJs with pimcore if yes can anyone share their repo link so we can have just basic idea how if work
    Tulsi-Jha
    @Tulsi-Jha
    Hello friends, Not able to install Pimcore data hub plugin in latest pimcore 10.2.x, noticed same behaviour on https://demo.pimcore.fun/. Has anyone else face this issue ? @dvesh3
    5 replies
    cmuench
    @cmuench:muench.dev
    [m]
    Hi. I created a calculated value field "age" which is calculated during runtime. Is it possible to support "filters" and "sorting" for that? I have less data to sort (< 200 records).
    1 reply
    Thomas Heiz
    @thomas_heiz_gitlab
    Hello together, hope you're all fine.. I'm relative new to pimcore, maybe someone can help me ;) I need to change the URL of generated Thumbnails, I think I have to change the __toString() method in \Pimcore\Model\Asset\Image\Thumbnail but I have no idea how I can do that, is this possible at all? Thank you
    1 reply
    Jeroen Desloovere
    @jeroendesloovere
    Small question about inheritance, a simplified example:
    • I have a mother object (= parent) with a price of € 100 and a child with price inheritance
    • I adjust the child price to € 90 and save it
    • What if I now realize that I actually want to keep inheritance from the parent
      => Is it correct that I'm screwed now, because there seems no functionality to activate the inheritance again for this field? Is that right, or am I missing something?
    3 replies
    Axel Tietje
    @xlttj

    Hi all, I'm experiencing a problem with static routes in 10.2.

    When I use xdebug and follow step by step, the code in https://github.com/pimcore/pimcore/blob/10.2/lib/Routing/Staticroute/Router.php#L325 – the callback function to order routes – seems to be never excecuted, which means that static routes are not ordered by priority which in turn results in 404 errors in my project. Is that a bug or a feature?

    1 reply
    Bram Gerritsen
    @bramstroker
    Screenshot 2021-11-17 at 13.39.34.png
    Hi I have upgraded our test environment from pimcore 6 to pimcore X. Functionality wise everything seems ok, but I have a strange issue in the GUI. Black borders are shown around extjs components, and also a blue D. see the screenshot.
    Anyone has a clue?
    2 replies
    frithjof
    @frithjof
    hey ... i think i missed the info ... but what tech will be the replacement for extjs?
    Stefan Hagspiel
    @solverat
    Still a secret
    MiayaSG
    @MiayaSG
    Hi, good evening. I am running a project with PIMCORE and one of the requirement is to redirect old website (HTML) URLs to the new website that being built by PIMCORE. But my vendor told me this redirection can not be done…. I am wondering is it true? As redirection is pretty easy task.if can do, how to challenge back vendor ( I am not very tech, I am
    1 reply
    ( I am not tech, I am a PM) . Welcome suggestion. Thanks
    Silviu Stefaniu
    @Gogtsu
    FYI. I had a problem with a clone from pimcore skeleton with images. In the readme it says to give permission to var/* to www-data, but in order for the uploaded images to work, you have to give permissions to public/var as well
    Raj Aryan
    @rajaryann
    What is the version of the Process Manager compatible with Pimcore v5.8
    5 replies
    Chauhan Mukesh
    @Chauhan-Mukesh
    I had deleted admin by mistake what shoud i do now
    2 replies
    Valentin
    @valentin-
    Hi, I'm sending a mail inside a controller and use setParam('htmlField') to insert content containing html. But the code for {{htmlField}} ist rendered as plain text, showing the html tags. Is it possible to render the field as html?
    2 replies
    baloraki
    @baloraki
    Hi,
    can someone tell me about ui 2.0, if there is more info on it there already?
    https://pimcore.com/en/developers/roadmap
    Jp
    @VeiJar1
    Hey, how to check if my image Asset already exists in Pimcore? These images come from an external source
    2 replies
    Daniel
    @danielczestki
    Hi. Can some one tell me is it possible to enable sorting on grid in Object Search ??
    1 reply
    Patrick Puecher
    @puecher
    Hey, I have ~10.000 Document Pages which are heavily linked each other in ~10 WYSIWYG editors (~30 links per Page). When I open a Page the PHP process loops all linked documents even if the max items on queue is set to 50. It takes a minute or two (seems like an endless loop). Is this a normal behavior and how can I exit earlier? Does pimcore:cache:warming resolve the problem? [Pimcore 6.9] Thanks.
    fmedv
    @fmedv_twitter

    Hi there,
    I was trying to override a DataObject class (as documented in https://pimcore.com/docs/pimcore/current/Development_Documentation/Extending_Pimcore/Overriding_Models.html)
    My config.yaml looks like this:

    `

    pimcore:
        models:
            class_overrides:
                'Pimcore\Model\DataObject\BlogEntry': 'App\Model\DataObject\BlogEntry'

    `

    and the App\Model\DataObject\BlogEntry class looks like this:

    `

    <?php 
    
    namespace App\Model\DataObject; 
    
    use Pimcore\Model\DataObject\BlogEntry\Listing as BlogEntryListing;
    
    class BlogEntry extends \Pimcore\Model\DataObject\BlogEntry {
    
        private function setShowOnHomepageParent(?bool $showOnHomepage)
        {
            parent::setShowOnHomepage($showOnHomepage);
        }
    
        /**
        * Set showOnHomepage
        * @param bool|null $showOnHomepage
        * @return \App\Model\DataObject\BlogEntry
        */
        // this method already exists and is meant to be overriden
        public function setShowOnHomepage(?bool $showOnHomepage)
        {
            if ( $showOnHomepage == true ) {
                // Get all blog entries that are not the current object
                $temp_blog_entry_listing = new BlogEntryListing();
                $temp_blog_entry_listing2->setCondition("id != ?", $this->getId());
                $temp_blog_entry_listing->load();
    
                // Set showOnHomepage to false on all those blog entries
                foreach ( $temp_blog_entry_listing as $key => $blog_entry ) {
                    $blog_entry->setShowOnHomepageParent(false);
                }
            }
    
            $this->setShowOnHomepageParent($showOnHomepage);
    
            return $this;
        }
    }

    `

    Unfortunately when adding a new blogEntry object (in the admin panel via DataObjects) I get the following error message:
    Attempted to load class "BlogEntry" from namespace "App\Model\DataObject". Did you forget a "use" statement for "Pimcore\Model\DataObject\BlogEntry"?
    Server threw exception - could not perform action. Please reload the admin interface and try again.

    What am I doing wrong?

    5 replies
    Katarzyna Kajzar
    @katwer
    Hello!
    In pimcore admin I can throw new error with notification for user: throw new pimcore.error.ActionCancelledException('Cancelled by user');
    How can I set notification without cancelled current action?
    2 replies
    Marimchen
    @Marimchen
    Hi, I am very new to pimcore and have a question on Realtions. My Product-Class has a one-to-many relation to my SubCategory-Class and the SubCategory-Class has the Many-to-Many realtion to Product-Class. Now when I assign productA to subCategoryA, the Product does not appear in at SubCategory in this table. Just why? Is there something I can do, to see all Products which are assigned to SubCategoryA somehow?
    2 replies
    Hendrik Hoekstra
    @admin97_gitlab
    Two questions about the pimcore X mail settings, 1. how to set up pimcore mail settings for a mailtrap.io account? 2. why are .env and config/config.yaml included in the repository, when that is the recommended place to add mail account credentials?
    2 replies
    Yentl Jacobs
    @jacobsyentl
    Goodmorning fellas. As you know it's possible to read statistics from your Pimcore instance by surfing to: https://your-instance.com/admin/index/statistics
    However, I was wondering if you could do the same with a tool like postman (no-login) by sending an api-key in the headers? This doesn't seem to work for me :(
    Hendrik Hoekstra
    @admin97_gitlab
    Does anybody know from the top of your head, where the data importer stores the config and the uploaded files?
    4 replies
    Hendrik Hoekstra
    @admin97_gitlab
    image.png
    I am struggling with the datahub and data-importer bundle for some time now and could use some help. Any idea what is causing the "Add configuration" button to be disabled?
    Hendrik Hoekstra
    @admin97_gitlab
    image.png why?? there are no user-right problems that i know of :(
    6 replies
    Alexander Gansky
    @gansky-alexander

    Hello, all !

    I am implementing my own login action and i need to implement user authentication programmatically. I checked a lot of information and tried couple of approaches, but any of them is not working. Could anyone help me with that ?

    This is my code:

    /**
    * Login
    */
    public function authAction(
            Request $request,
            AuthenticationManagerInterface $authenticationManager
        ) {
            $username = $request->get('username');
            $password = $request->get('password');
    
            if (empty($username) && empty($password)) {
                throw new NotFoundHttpException();
            }
    
            /** @var \Pimcore\Model\User $user */
            $user = Authentication::authenticatePlaintext($username, $password);
    
            if ($user) {
                $authenticationManager->authenticate(new UsernamePasswordToken($user->getEmail(), null, 'demo_frontend', $user->getRoles()));
            }
        }

    I have a user after "authenticatePlaintext", but when i call $authenticationManager->authenticate( i got redirecting to "login" action and user is authenticated as "anon.". How can i authenticate user as a user?

    Thank you in advance

    SpeedySynchro
    @SpeedySynchro

    Hello everyone
    I'm trying to install primcore 10.1.7 but I get this error.
    Script Pimcore\Composer::clearCache handling the pimcore-scripts event terminated with an exception

    Can anyone help me?

    Chauhan Mukesh
    @Chauhan-Mukesh
    image.png
    hello I am trying to run command php bin/console pimcore:deployment:classes-rebuild -d -c -vvv but getting following error
    any idea
    image.png
    i am not able to get listing here
    Katarzyna Kajzar
    @katwer
    Hello!
    What is the diffrence between "Custom Metadata" and "Properties" in assets?
    I need to inform system with languages use some assets (product card). Sometimes it's one language, often more or all avabile languages. What would you use in this case?
    frithjof
    @frithjof
    i would assign lang specific assets to product object
    1 reply
    Ibrahim Tanović
    @ibrahim-tanovic
    Hi everyone! I haven't unfortunatelly been able to apply settings on data objects regarding versioning. No matter what is configured in system settings on number of steps to keep for an object, an endless amount of versions is being generated every time an object is saved/published.
    Ulli
    @chris:matrix.ullihome.de
    [m]
    Hi, after installing the DataHub Bundle in Skeleton no Icon appears to access it, has anyone solved this issue ?
    johanlindgren
    @johanlindgren
    It has been working for me? Have you enabled, installed and reloaded the admin interface
    Ulli
    @chris:matrix.ullihome.de
    [m]
    yes