Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    robin-ntriga
    @robin-ntriga
    Also: renaming the Asset folder that works makes no difference.
    arulselvan008
    @arulselvan008
    Hi , Am able to connect Soap API in PHP code , but the response is encoded , How read XML file in pimcore ?
    2 replies
    abhiramalli
    @abhiramalli
    how to create one to many relationship in pimcore ,can any share an example
    1 reply
    johanlindgren
    @johanlindgren
    @robin-ntriga check your graphql definition in data hub, maybe you assigned a specific folder of assets to expose?
    abhiramalli
    @abhiramalli
    will symfony maker bundle will work in pimcore 10.5??
    AlephDev
    @AlephCode

    Hello!, i would like to ask something

    I want to upgrade a pimcore 6.9 project to pimcore 10, my question is

    Do I have to update all php templates engine to be able to upgrade to pimcore 10 or can I first upgrade to pimcore 10 and then gradually update the templates?

    What do you recommend, the problem is that there are many templates with the php engine and a new website will be made with new HTML, I don't know what I should do.

    4 replies
    AlephDev
    @AlephCode
    How Can I check if my bundles are compatible with pimcore X? I'll upgrade pimcore 6.9 to pimcore X, and I use ECommerceFrameworkBundle, this is compatible or Shoud I upgrade a ECommerceFramework first?
    3 replies
    Vikash kumar
    @vikashkumarkushwaha
    force password change on the first login in pimcore app
    yamenalahlas
    @yamenalahlas

    Hello again,
    I am trying to extends the AssetController, because I want to customize a method.
    When I do this it commes no Assets tree and no DataObjects tree in the admin ui.

    <?php
    
    namespace App\Controller;
    
    use Pimcore\Bundle\AdminBundle\Controller\Admin\Asset\AssetController;
    
    class CustomAssetController extends AssetController
    {
    }

    Could someone help me!

    Vikash kumar
    @vikashkumarkushwaha
    how to make forgot password in picmore
    1 reply
    balaji jadhav
    @balaji.jadhav_gitlab
    How te set default value option provider pimcore ...I am set value
    return $context['object']->getcontractYear();
    Not showing in dropdown but console showing result
    Dream
    @dream811
    Hi
    1 reply
    I met an error after installed pimcore
    Areabrick\AreabrickManager.php Line: 129
    image.png
    I am not sure what is the reason
    the pimcore version is 11
    some guys it will be fine on 10.5
    but I don't know how to install special version(10.5)
    Please help me
    php version is 8.1
    working on windows environment
    Dream
    @dream811
    Hello, dear guys
    brainium
    @brainium
    Hey guys, i have a problem with images in a fresh new installation. I can upload images, but no preview and no thumbnails are generated. Clicking the original download button serves a working image file... what could be wrong?
    4 replies
    vignesh-munisamy
    @vignesh-munisamy

    We have enabled 18 languages for the product. We have implemented field disable logic functionality based on another field value.

    In our data object we have 9 tabs. In each tab have different localized fields, we are changing language tab from one to another and we are executing event listener. The event listener we have written is only working in the first tab of data object and first set of localized fields. This is not working for the rest of localized fields.
    languageTabs=object.edit.dataFields.localizedfields.tabPanel.tabBar;
    languageTabs && languageTabs.items && languageTabs.items.items.map((langTab)=>{
         langTab.addListener('activate',()=>{
    console.log("language Tab activate executed");
    });
    });

    1 reply
    Sawant Shah
    @sawant

    Hello everyone, I am having issues with a CKEditor plugin. One of the plugins I am trying to add requires the clipboard plugin. Now, the clipboard plugin is technically not part of Pimcore core (https://github.com/pimcore/pimcore/tree/10.5/bundles/AdminBundle/Resources/public/js/lib/ckeditor/plugins/clipboard), but it does seem to be getting referenced/used by it's sub-plugin: clipboard/dialogs/paste.js (e=CKEDITOR.plugins.clipboard in the paste.js file; also can be clearly seen in the non-minified file in CKEditor Github repo - https://github.com/ckeditor/ckeditor4/blob/master/plugins/clipboard/dialogs/paste.js).

    So question is: which clipboard plugin is being referenced in paste.js? Is there any other place where clipboard plugin may be available in pimcore?

    P.S. The build-config.js file in pimcore's CKEditor does contain 'clipboard': 1 but A, I don't see any clipboard plugin.js file being available anywhere after having Pimcore up and running, and B, it says in that very file This file is not used by CKEditor, you may remove it.

    rushrakholiya
    @rushrakholiya
    Hello everyone,
    Anyone faced an issue of 302 browser cache? is there any specific configurations or steps to resolve this for pimcore?
    rushrakholiya
    @rushrakholiya
    Hello,
    Does anybody facing performance issue with pimcore 6 + s3 integration?
    atulbajpai12
    @atulbajpai12
    Hi
    Can we installed Pimcore with Postgresql database ?
    4 replies
    if anyone know please confirm me.
    agendartobias
    @agendartobias
    Hey, can i install pimcore on seperate DB server?
    esorthapa
    @esorthapa
    @agendartobias yes
    @vignesh-munisamy
    @vignesh-munisamy , it can be possible but need to check your code.
    calistatanaka
    @calistatanaka
    Hello, I'm doing the Pimcore Junior Developer Certificate, I'm stuck only on this one question to complete the certification, wondering if anyone can help and know the correct answer to this? "What concepts can be used to add or reorder multiple elements in a template without editing the template file?" (- Renderlets, - Areabricks,
    • Blocks, - Scheduled Blocks) - can tick more than one answer.
    Neelam Rani
    @neelamrani:matrix.org
    [m]
    CMS Toolbox not working Pimcore
    brainium
    @brainium
    Hi guys, is there a way in Pimcore like in Typo3 for example to test the functionality of imagemagick? I have the feeling that the image generation does not work correctly. The images are displayed but the manipulations of the thumbails don't seem to run correctly...
    1 reply
    Rahat Hameed
    @rahatartnight:matrix.org
    [m]

    Hello Everyone,
    We are stuck on strange issue on pimcore login page.
    https://pimcore-admin.ournights.rocks/admin/

    The response I see in browser. is mentioned below.
    {"status":-2,"error":"Access deny","message":"Access deny"}

    I also checked error logs on sever, which are mentioned below.
    10.244.2.113 - 19/Oct/2022:12:38:30 +0000 "GET /index.php" 200
    [2022-10-19T14:38:51.896710+02:00] security.ERROR: Detected CSRF attack on /admin/login/login {"request":"/admin/login/login"} []
    10.244.2.113 - 19/Oct/2022:12:38:51 +0000 "POST /index.php" 401

    Any help how to fix it is highly appreciated.
    Have a good day.

    Rahat Hameed
    @rahatartnight:matrix.org
    [m]

    :point_up: Edit: Hello Everyone,
    We are stuck on strange issue on pimcore login page.
    https://pimcore-admin.ournights.rocks/admin/

    The response I see in browser. is mentioned below.
    {"status":-2,"error":"Access deny","message":"Access deny"}

    I also checked error logs on sever, which are mentioned below.
    10.244.2.113 - 19/Oct/2022:12:38:30 +0000 "GET /index.php" 200 \[2022-10-19T14:38:51.896710+02:00\] security.ERROR: Detected CSRF attack on /admin/login/login {"request":"/admin/login/login"} \[\] 10.244.2.113 - 19/Oct/2022:12:38:51 +0000 "POST /index.php" 401

    Any help how to fix it is highly appreciated.
    Have a good day.

    :point_up: Edit: Hello Everyone,
    We are stuck on strange issue on pimcore login page.
    https://pimcore-admin.ournights.rocks/admin/

    The response I see in browser. is mentioned below.
    {"status":-2,"error":"Access deny","message":"Access deny"}

    I also checked error logs on sever, which are mentioned below.

    security.ERROR: Detected CSRF attack on /admin/login/login {"request":"/admin/login/login"} \[\] 10.244.2.113 - 19/Oct/2022:12:38:51 +0000 "POST /index.php" 401

    Any help how to fix it is highly appreciated.
    Have a good day.

    :point_up: Edit: Hello Everyone,
    We are stuck on strange issue on pimcore login page.
    https://pimcore-admin.ournights.rocks/admin/

    The response I see in browser. is mentioned below.
    {"status":-2,"error":"Access deny","message":"Access deny"}

    I also checked error logs on sever, which are mentioned below.

    10.244.2.113 -  19/Oct/2022:12:38:51 +0000 "POST /index.php" 401

    Any help how to fix it is highly appreciated.
    Have a good day.

    Jeremy Noonan
    @jeremygnoonan
    Hi folks!
    Curious on if we are approaching the data importer wrong. We're trying to map in an XML file, and are having issues assigning a sub-property of an XML element to a field. We have the format <Product><PIData><ProductCode>MyCode</ProductCode><Brand>MyBrand</Brand></PIData></Product>
    3 replies
    Rahat Hameed
    @rahatartnight:matrix.org
    [m]

    :point_up: Edit: Hello Everyone,
    We are stuck on strange issue on pimcore login page.
    https://pimcore-admin.ournights.rocks/admin/

    The response I see in browser. is mentioned below.
    {"status":-2,"error":"Access deny","message":"Access deny"}

    I also checked error logs on sever, which are mentioned below.

    10.244.2.113 -  19/Oct/2022:12:38:30 +0000 "GET /index.php" 200
    [2022-10-19T14:38:51.896710+02:00] security.ERROR: Detected CSRF attack on /admin/login/login {"request":"/admin/login/login"} []
    10.244.2.113 -  19/Oct/2022:12:38:51 +0000 "POST /index.php" 401

    Any help how to fix it is highly appreciated.
    Have a good day.

    francescomulas
    @francescomulas

    Helloo!!
    I'm trying to add a button to save and reload to the object template, is there a way to force save waiting before reload? Here the instruction I'm using
    this.object.save();
    this.object.reload();

    At the moment the object is reloading without waiting so I can't see the updates
    Any help?

    Martina Lindenhofer
    @MLindenhofer
    Hi everyone, my question is about Data-Importer bundle. I need to import variants from my xml-file, but I'm failing with passing the data correctly. Does someone of you know how to deal with the new DataTarget "SYSTEM Object Type ("variant"|"object")" ? I tried an array but it doesn't work
    Valentin
    @valentin-
    Hi, when trying to drag&drop sort objects with manual sorting in (paginated) folders, Pimcore now advices to use the Search & Move feature. I don't understand the concept of moving objects to a specific position/order using this feature. Can someone explain this to me? (Pimcore 10.5)
    Brij Kishor
    @BrijKishorIND_twitter
    Any pimcore API Link here?
    sanjay chaudhary
    @sanjay.chaudhary:matrix.org
    [m]
    Hi team i am new with pimcore
    2 replies
    getting issue in frontend Areabrick hero-teaser is not registered File: C:\xampp\htdocs\pimcore\vendor\pimcore\pimcore\lib\Extension\Document\Areabrick\AreabrickManager.php Line: 129