Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Aug 08 16:56
    anewuser commented #114
  • Aug 08 03:28
    anewuser commented #114
  • Aug 08 03:21
    anewuser commented #114
  • Aug 08 00:46
    anewuser edited #117
  • Aug 07 22:23
    anewuser opened #119
  • Aug 07 22:21
    anewuser opened #118
  • Aug 07 21:31
    anewuser opened #117
  • Aug 07 21:28
    anewuser opened #116
  • Aug 07 21:21
    anewuser edited #115
  • Aug 07 21:20
    anewuser opened #115
  • Aug 07 21:16
    anewuser commented #99
  • Aug 07 21:15
    anewuser commented #99
  • Aug 07 21:14
    anewuser commented #99
  • Aug 07 21:10
    anewuser commented #99
  • Aug 07 21:08
    anewuser commented #99
  • Aug 07 21:08
    anewuser commented #99
  • Aug 07 21:05
    anewuser commented #99
  • Aug 07 21:03
    anewuser commented #99
  • Aug 07 13:42
    onli closed #112
  • Aug 07 13:42

    onli on master

    select only inputs and preview … (compare)

nuentes
@nuentes
I realize it's Christmas and all, but all of my Pipes have been reporting Internal Server Error since yesterday. A few of my IFTTT applets that are based on pipes RSS feeds have even been disabled by IFTTT due to too many failures. When I click on the Feed link in pipes.digital, I get an immediate Internal Server Error message for all of my pipes.
onli
@onli
@nuentes I'm sorry about that. I fixed a bug that might have caused this. Are your pipes working again now?
nuentes
@nuentes
Boom - solved! Also, no apologies needed. You run a great service. Much appreciated. Thanks so much, and have a great Christmas.
onli
@onli
Thanks, you too :)
Slub Design
@SlubDesign_twitter

Hi again- I'm on a mission to host Pipes-CE as a Docker container on a Synology 920+. Thanks to others, I successfully have a functioning container. I realize you may not know about Docker, but the first question is about self-hosting setup. I can access the container fine on my network, I can start the sign-in process, receive the resulting email, but when I enter the code (or go to the link), I get:
Access to 10.x.x.x:9292 was denied
You don't have authorization to view this page.
HTTP ERROR 403
on http://10.x.x.x:9292/_browserid_assert

Any idea how to resolve this?

onli
@onli
I'm not sure whether you run into the flakyness of sinatra/Rack with the portier gem or whether the ip is the problem. That's a private ip, right?
You can try: Login with a different browser, or try to login with a gmail address
And : Did you start the pipes process with the puma command?
ukuleleman
@ukuleleman_twitter
Hi onli- Your tip on using a gmail account worked! That'll be fine for a long time. And yes, it is a private IP. My next goal is to figure out how to make the resulting pipes useful to my clients on their websites (need to create public ip)...
onli
@onli
Great that it worked :) You can consider hosting it on a small digitalocean dyno or something like this
But probably the Synology has a way to get a public ip integrated
lluís
@lluisaliano__twitter
Hello, I tried to run pipes on a virtual machine, I followed the instructions on the github and everything was allright but when I tried to see the final pipe I get this error: required variables of maker.channel are not set: link
Do you know what is the problem? I think it is something easy to solve but I am a bit noob on this.
onli
@onli
Hi
Did you try it with a simple pipe, one with only a feed block? It might be block specific
lluís
@lluisaliano__twitter
Hello, I checked it again and you were right, this only happens when I use combine block.
Do you know any solution?
Thank you so much.
onli
@onli
I will need to patch the CE version to debug that. It's necessary anyway - but it might take a bit.
Have a look whether the error is thrown in the combine block. If not, you can still try to use a feed builder block to get a better result. But if it's in the combine block the error might be in there, then we'll have to look at that in detail
lluís
@lluisaliano__twitter
The feed builder block is not working to, I get the same error. I think the error only occurs when you use a block to create a new feed.
If you are going to patch the CE version, could you add some kind of option to add custom favicons to the final feed?
onli
@onli
So that an individual feed in the feedreader has a custom icon?
I'm not sure that's possible, some of them might just get the site's main favicon
That you could swap out of course
lluís
@lluisaliano__twitter
Yes, I mean, if you could change the icon of the final pipe, the feedreader would use that icon instead of pipes' icon.
onli
@onli
Love the idea, just think it's not possible. As far as I know the feedreader takes the icon from the main url, so pipes.digital/favicon.ico (or your instance)
lluís
@lluisaliano__twitter
I dont know how exactly works but if you check the bbc world feed, http://feeds.bbci.co.uk/news/video_and_audio/world/rss.xml
it has no favicon, and in my reader appears one, specifically, the image which is in this lines code:
<image>
<url>https://news.bbcimg.co.uk/nol/shared/img/bbc_news_120x60.gif</url>
<title>BBC News - World</title>
<link>https://www.bbc.co.uk/news/</link>
</image>
I think there might be a way to do it
onli
@onli
Oh, that's nice!
https://cyber.harvard.edu/rss/rss.html <-- right, it's in the spec. Never noticed it
lluís
@lluisaliano__twitter
so do you think that there is a way to add this feature?
onli
@onli
I'll have a look.
You can add it probably manually with an insert block, but the tricky thing would how to create the XML to add. Download it somewhere? Not ideal. First, support for ruby 3.1!
onli
@onli
I think that worked well. The combine block should now work again.
Github has issues today, https://github.com/pipes-digital/pipes might show a wrong state. The current release should be "Fix: Combine block did not create an output feed"
lluís
@lluisaliano__twitter
Thank you so much.
About custom favicon, I think you could use as input the same rss feed that of the official feed you want to use. I dont know if that could work.
onli
@onli
Yeah, that would work
Take the bbc feed, extract the image element from the channel, insert it into your target Feed. Could even use a rpaalce block to change the image to a different one
I'm always happy if blocks can do the work of a config option :)
lluís
@lluisaliano__twitter
exact, but I dont know exactly how to do it, I'll have to check the docs to see how it works
Thank you for all your work, you are a master :) and i really love pipes.
onli
@onli
Do that, and if you get blocked write here and I'll help you
Thank you! I really am happy when people like Pipes :)
lluís
@lluisaliano__twitter
Hello again, I've been trying to do what you said, extracting the image element using a extract block and then inserting it back at the output feed.
I tried to do it from this feed:
https://www.elespanol.com/rss
In the extract block and in the insert block I wrote this: rss/channel/image
Although all that the output feed in the source code didn't have the image element.
lluís
@lluisaliano__twitter
Now I tried to do the same with the title and it worked.
lluís
@lluisaliano__twitter
I think I can't change the image element because in the output pipe, there is not any image element.
onli
@onli

Hm, it works for me. Try this:

  1. Don't use the elespanol feed, it's bound to make issues with all that CDATA declarations. The BBC feed should work
  2. Extract //channel/image and set the attribute to extract to OuterXml
  3. Then insert it to the target feed with this xpath: /rss/channel

This will add the image to the bottom of the channel, under the items. But that shouldn't matter for the image element to work

lluís
@lluisaliano__twitter
Now it appears on the output feed, but my rss reeder doesn't change the image.
This is my ouput feed, is it okey?
https://www.pipes.digital/feed/59VvdR9A?
onli
@onli
I think it's missing the image element. The pipe is inserting a new link at //channel/link, but that's not the image element
Extract //channel/image from the BBC feed and add it to /rss/channel, then it will work
lluís
@lluisaliano__twitter
It results that my reader(reeder 5) takes the image from the favicon that is on the page inserted on the link element.
I make that work so the icon gets changed now but I still have problems to see the cnbc or bbc world preview images and I think that's not possible to solve if the feed issuer does not change the format.
I think I will keep it like I have it now.
Thank you for all your help.
onli
@onli
No problem :)