These are chat archives for pjlsergeant/test-bdd-cucumber-perl

29th
Feb 2016
Erik Huelsmann
@ehuelsmann
Feb 29 2016 06:38
Hi. Regarding the Perl workshop, I hadn't thought of going, but if you'll be there, I'll definitely want to go and meet you, yes!
Peter Sergeant
@pjlsergeant
Feb 29 2016 07:21
Hahah, I'll see you there then
Erik Huelsmann
@ehuelsmann
Feb 29 2016 08:37
just sent a PR I hope will interest you. (I don't have a personal need for it, at this point, but it could help claiming a 1.0 version, if you want)
@pjlsergeant ^^ ; need to head to work now :-) (but had to get that PR out of my system before being able to concentrate on other work)
Erik Huelsmann
@ehuelsmann
Feb 29 2016 08:46
hmm. one message seems to have gotten lost due to WIFI connectivity issues.
so, I said that my own work depends on having #88 released at some point (I'm not asking to hurry or putting pressure, just mentioning), but I have no need at all - personally - for #89 and I don't forsee a need in the short term either.
talk later!
Peter Sergeant
@pjlsergeant
Feb 29 2016 11:20
So I should push what's in master as a releas
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:35
Did you merge #88 then? /me checks
Bah. I completely missed your Windows comments re #88
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:40
But I see #88 isn't merged yet, so then my answer to your question would be "no"
I'll get that remark fixed. Is that enough for merging #88?
If not, what more is needed?
@pjlsergeant ^^^
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:54
@pjlsergeant another question: why do you test 5.8, but not 5.10 and 5.12?
Peter Sergeant
@pjlsergeant
Feb 29 2016 11:54
5.8 is min supported version. Guess we could add more but shrug
I can fix the pr and release if you're busy
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:55
I just committed the windows fix.
but that 5.8 build failed too.
same error.
Peter Sergeant
@pjlsergeant
Feb 29 2016 11:56
k
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:56
the others all succeeded.
Could it be that File::Spec needs to be declared as a dep on 5.8?
it's not in the dependency list. But I don't know when it went into Core
Peter Sergeant
@pjlsergeant
Feb 29 2016 11:57
Hrm, one moment, there's a bot on irc.perl.org that's know
"File::Spec was first released with perl 5.00405 (released on 1999-04-29)"
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:58
ok. it's actually in the examples of Module::Core :-)
5.4
Peter Sergeant
@pjlsergeant
Feb 29 2016 11:58
I have some moments now, I'll download an appropriate Perl and have a look
Erik Huelsmann
@ehuelsmann
Feb 29 2016 11:58
(print Module::CoreList->first_release('File::Spec'); # prints 5.00405)
you mean for the 5.8 failures?
if you could, please, because I'm going to be busy again the rest of the day.
but I'll be around to help with small things or questions.
Peter Sergeant
@pjlsergeant
Feb 29 2016 12:00
Yep
I'll get that patch in and released too
Erik Huelsmann
@ehuelsmann
Feb 29 2016 12:00
but I'm on the customer's wifi; not really my place to start downloading a Perl dist or even an iso.
Peter Sergeant
@pjlsergeant
Feb 29 2016 12:00
I have some minutes now
Erik Huelsmann
@ehuelsmann
Feb 29 2016 12:00
great!
thanks!
#89 isn't even for me. it's more for completeness.
(and because it was easy)
so, if you want to take a closer look on that feel free to.
Peter Sergeant
@pjlsergeant
Feb 29 2016 12:04
Yep, looks good
Erik Huelsmann
@ehuelsmann
Feb 29 2016 12:04
oh. regarding Dutch Perl workshop: your LinkedIn profile says you're in the far east and your waking hours suggest the same. Are you flying in specifically for the workshop??
Peter Sergeant
@pjlsergeant
Feb 29 2016 12:05
Yes :-)
I live in Bangkok
But I work as a recruiter. So I fly to all my favourite conferences
Erik Huelsmann
@ehuelsmann
Feb 29 2016 12:06
Sounds good :-)
Peter Sergeant
@pjlsergeant
Feb 29 2016 12:47
Can't replicate, but I have got a weird error message, which is a start
Erik Huelsmann
@ehuelsmann
Feb 29 2016 12:47
ok. what's the error?
Erik Huelsmann
@ehuelsmann
Feb 29 2016 13:29
hmm. it seems you stopped tagging releases after 0.40
is that intentional?
Peter Sergeant
@pjlsergeant
Feb 29 2016 13:39
No, I'm just lazy
The error has to do with YAML::Syck
I think I've got a silly but effective workaround
I think you got unlucky regarding 5.8.8 instead of 5.8.9 which is what Travis CI used to use
Let's see if this builds
I'll tag this release, too
OK, that was effective. Such odd.
Peter Sergeant
@pjlsergeant
Feb 29 2016 13:44
Released
Erik Huelsmann
@ehuelsmann
Feb 29 2016 13:45
Great! Thanks!
Erik Huelsmann
@ehuelsmann
Feb 29 2016 14:17
that opens up the creation of "step libraries" in the LedgerSMB project.
Peter Sergeant
@pjlsergeant
Feb 29 2016 15:11
Curious to see how they pan out
Erik Huelsmann
@ehuelsmann
Feb 29 2016 15:42
I'll definitely keep you posted!
Erik Huelsmann
@ehuelsmann
Feb 29 2016 15:47
should make up for a nice example project :-)
btw, I'll be factoring some things out of the ledgersmb project into a stand-alone project for web-testing.
Erik Huelsmann
@ehuelsmann
Feb 29 2016 17:25
are you planning a talk for the dutch perl workshop? or just socializing?
ehuelsmann @ehuelsmann wonders if he should submit one, since only one has been accepted so far
Peter Sergeant
@pjlsergeant
Feb 29 2016 21:08
Just socialising at that one. I've submitted Cucumber related master classes to both YAPCs