Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 17 2019 02:06
    boxofrox opened #3309
  • Dec 16 2019 20:35
    Bascy opened #3308
  • Dec 16 2019 18:56
    irukard commented #3078
  • Dec 16 2019 15:53
    cychai1995 edited #3307
  • Dec 16 2019 15:53
    cychai1995 opened #3307
  • Dec 16 2019 04:57
    lackdaz commented #3286
  • Dec 16 2019 04:55
    lackdaz commented #3286
  • Dec 16 2019 04:55
    lackdaz commented #3286
  • Dec 16 2019 04:49
    lackdaz commented #3286
  • Dec 16 2019 04:48
    lackdaz commented #3286
  • Dec 16 2019 04:47
    lackdaz commented #3286
  • Dec 15 2019 21:21
    mlewand opened #3306
  • Dec 14 2019 15:23
    hmaarrfk opened #3305
  • Dec 14 2019 15:16
    hmaarrfk commented #3296
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:28
    HeathPetersen opened #3304
  • Dec 13 2019 17:53
    burnsed commented #3120
RoBo
@gauravsharma013
If yes where exactly it has to be done, I do not seem to find it.
Shawn A
@tablatronix
Does anyone have any tips on installing a specific git tag or commit framework, say espressifesp8266#2.3.0, i cannot for the life of me get it working. I tried staging, then changing version in platform.json etc.
Ivan Kravets
@ivankravets
The PlatformIO team doesn't provide support here anymore.
Please use https://community.platformio.org/ instead.
Rui Azevedo
@neu-rah
@ivankravets please change this room title to say so :)
Victor Tseng
@Palatis
i thought it does, there's a sticky post pop-up everytime you login
upload_port = 192.168.0.3 // for OTA
Rui Azevedo
@neu-rah
i'm always logged in, so i must have missed, thanks
Victor Tseng
@Palatis
@Datseris probably nonsense... turn your screen portrait?
blob
this is super cool\
Mikk Kiilaspää
@Mikk36
Hey
Slightly unrelated to the software itself, but maybe someone is still willing to help
I got this ESP32 board here with an onboard LED, that's working (well, was blinking with factory firmware), but there's no docs about what GPIO pin it's using
Probing with continuity didn't seem to help either
How do I find out what GPIO it's using?
Just blindly start incrementing GPIO pins for a blink example?
Ash
@ashthespy
@Mikk36 Depends on the board, but generally it isn't advised to blindly start toggling GPIO pins..
Mikk Kiilaspää
@Mikk36
Well, not completely randomly, I guess, because ESP32 datasheet specifies some pins as reserved for the SPI flash
Only the ones available and specced as IO
Ash
@ashthespy
What board do you have? If it's one of the usual suspects, some google foo should get you the pins as well ;-)
Mikk Kiilaspää
@Mikk36
Similar board to Espressif ESP32 devkitc v4 (same pin layout) but it has an extra LED on it (espressif one only has power LED)
Your link --> https://github.com/Nicholas3388/LuaNode --> the dropbox link. But it looks like standard nodemcu board
Mikk Kiilaspää
@Mikk36
Bleh, why did I skip that :)
That GPIO number, that is
Started secondguessing if it's a direct pin number or just a gpio number and then skipped right before that number
Ash
@ashthespy
Haha, happens to the best of us!
Mikk Kiilaspää
@Mikk36
Thanks :)
Main program file is just the one that has a function app_main() in it?
Ie it looks for it automatically?
Ash
@ashthespy
umm - no idea I don't use LUA..
Mikk Kiilaspää
@Mikk36
I mean in platform.io
Ash
@ashthespy
Yes, I'd guess so
Mikk Kiilaspää
@Mikk36
It's a generic ESP32 board, that LuaNode link is just as one option for using that board
Ash
@ashthespy
Yes!
I'd recommend you use the platformIO board manager, and set up a blinky test with the framework of your choice
Mikk Kiilaspää
@Mikk36
That's what I did
Ash
@ashthespy
What framework did you pick?
Mikk Kiilaspää
@Mikk36
esp-idf
Since it's the official one for ESP
Ash
@ashthespy
but, you are having issues?
Mikk Kiilaspää
@Mikk36
Not any more, because we figured the pin number out
Ash
@ashthespy
Good luck then!
Ghost
@ghost~58924f23d73408ce4f47802b
Is there a way to only upload 1 [env] when you've got multiple [env]s defined in platformio.ini?
Aldrin Leal
@aldrinleal
@bertmelis use '-e <env>' on it
Ghost
@ghost~58924f23d73408ce4f47802b
aha. thanks!
Mikk Kiilaspää
@Mikk36
image.png
Why am I getting this include error?
The rest of the header files from lib dir are correctly included, but not this one