by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 17 2019 02:06
    boxofrox opened #3309
  • Dec 16 2019 20:35
    Bascy opened #3308
  • Dec 16 2019 18:56
    irukard commented #3078
  • Dec 16 2019 15:53
    cychai1995 edited #3307
  • Dec 16 2019 15:53
    cychai1995 opened #3307
  • Dec 16 2019 04:57
    lackdaz commented #3286
  • Dec 16 2019 04:55
    lackdaz commented #3286
  • Dec 16 2019 04:55
    lackdaz commented #3286
  • Dec 16 2019 04:49
    lackdaz commented #3286
  • Dec 16 2019 04:48
    lackdaz commented #3286
  • Dec 16 2019 04:47
    lackdaz commented #3286
  • Dec 15 2019 21:21
    mlewand opened #3306
  • Dec 14 2019 15:23
    hmaarrfk opened #3305
  • Dec 14 2019 15:16
    hmaarrfk commented #3296
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:41
    Misterion96 edited #3303
  • Dec 13 2019 19:28
    HeathPetersen opened #3304
  • Dec 13 2019 17:53
    burnsed commented #3120
Stavros Korokithakis
@skorokithakis
I'm trying to upload some code with Arduino as ISP but it fails with "first mismatch at byte 0x0002", but it works with the Arduino IDE
The only different flag (apart from the config file) between the two is -D
Ah, passing -e fixes it, but by default it won't work (heads up)
Ivan Kravets
@ivankravets
Hi
Do you use pio run -t program?
It’s better to ask here https://community.platformio.org/
There should be a solution
Stavros Korokithakis
@skorokithakis
@ivankravets No, I use upload (should I use program)?
The solution is to add -e to upload_flags
Ivan Kravets
@ivankravets
Or program target
Stavros Korokithakis
@skorokithakis
Hmm I'm not familiar with program but I'll look into it, thank you
I can't find the documentation, do you know where it is? It's too common a word
geoffb
@drgeoffb
.
A C SREEDHAR REDDY
@a-c-sreedhar-reddy
I have library in lib folder. But it requires PUBSUBCLIENT where can I mention that?
Snepscheut
@Snepscheut
Library in platform.
Ash
@ashthespy
pio seems to be downloading the framework package each time I build the project.. How do I debug this?
Ivan Kravets
@ivankravets
A Community support has moved to https://community.platformio.org/
Dreamcat4
@dreamcat4_gitlab
ho there
i keep noticing when i have multiple Projects open in my 'Untitled' Workspace, it screws things up
like, PlatformIO finds the 1st open file of the same name, and if it's from a different project it breaks
for example the platform.ini (or a main.cpp)
question: is there a solution that lets multiple projects open at the same time? (rather than closing other projects)
?
Mike Dunston
@atanisoft
@dreamcat4_gitlab if you have multiple PIO projects open at one time, you might be able to workaround the issue by opening the platformio.ini file and clicking the buttons. The other option is go into the PIO button and click through to the right build config ( or project)
Dreamcat4
@dreamcat4_gitlab
It sounds like you want me to click on the 'Start Debugging' button in the bottom status bar. rather than the menu
because i've now closed the other project, and it's open file. the error still occurs
hmm
Mike Dunston
@atanisoft
no
not debugging
on the left side click the alien (pio) button
in there you should be able to select from one of the active configurations
or projects possibly
I've always opened the platformio.ini file of the project I want to build and it just works
Dreamcat4
@dreamcat4_gitlab
you mean 'Open Project' from PIO Home ?
Mike Dunston
@atanisoft
no
if you have multiple folders open in VS Code you can open the platformio.ini file for the project you want to build and it should build that project via the buttons at the bottom navigation bar
Dreamcat4
@dreamcat4_gitlab
No source file named /home/id/Documents/PlatformIO/Projects/blue-pill-arduino-blink/src/main.cpp. (from break-insert "/home/id/Documents/PlatformIO/Projects/blue-pill-arduino-blink/src/main.cpp:22")
because that is the main.cpp file from the other project, which is now closed
i did what you said, and i'm debugging not building
Mike Dunston
@atanisoft
then you may not have options
Dreamcat4
@dreamcat4_gitlab
ok i believe i have noticed now that my breakpoints list is universal across all open projects
so the old breakpoint from the (now closed) other project is still listed and enabled in there
disabling those breakpoints has supressed the error msg
to so i guess that is the 'VSCode Universal Debugger'. it would be nice if they had it keep seperate state for each open project
Mike Dunston
@atanisoft
could be
Dreamcat4
@dreamcat4_gitlab
interesting, now that i have it working that this mbed environment isn't interrupting the while() loop. When i set a breakpoint inside there. perhaps that might be because it's RTOS
doing weird stuff
Mike Dunston
@atanisoft
good luck!
Dreamcat4
@dreamcat4_gitlab
thanks