Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    NicolasGoeddel
    @NicolasGoeddel
    Hopefully an easy question: How to define a BrowserView with a form which can be called by an anonymous user and which is able to create new content objects, delete or modify them.
    Peter Mathis
    @petschki
    @NicolasGoeddel I know, this is source only, but there's a easyform plugin which should do the trick: https://github.com/collective/collective.easyformplugin.createdx
    at least the creation part ...
    NicolasGoeddel
    @NicolasGoeddel
    @petschki Sorry, I already figured it out. I use the permission zope.Public in configure.zcml and a modified execute_under_special_role script which runs some functions with the manager role.
    Érico Andrei
    @ericof
    Hello all, who is the Jenkins wizard that can help me with a failing test? :-)
    This is the test https://jenkins.plone.org/job/pull-request-5.2-3.6/637/ and it seems totally unrelated to changes I made
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] https://plone.com/try-plone/ few of the static assets are loading
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] email sent to admins@plone.org
    [Steve Piercy (stevepiercy), irc.freenode.net] and bounced as spam
    [Steve Piercy (stevepiercy), irc.freenode.net] nice
    [Steve Piercy (stevepiercy), irc.freenode.net] The owner of the group can choose to enable message moderation instead of bouncing these emails.
    [Steve Piercy (stevepiercy), irc.freenode.net] More information can be found here: https://support.google.com/a/answer/168383.
    Plone Chat
    @plone-chat
    [Ericof (ericof), irc.freenode.net] Thanks stevepiercy. We are taking a look at it
    Peter Mathis
    @petschki
    Hi, is something wrong with jenkins at the moment? I get this when submitting a PR: https://jenkins.plone.org/job/pull-request-5.2-3.6/641/console
    Jens W. Klein
    @jensens
    @petschki "mr.developer: The package 'plone.app.standardtiles' from auto-checkout has no source information." looks like its not in the sources section
    @petschki so, it is not there, because it is not in core, only in the ecosystem pinnings.
    Peter Mathis
    @petschki
    @jensens ah ... so I should use the add-on pipeline instead of pull-request ...
    Plone Chat
    @plone-chat
    [shastry (shastry_), irc.freenode.net] Hi. I need some help with unicode in pt files. How can I output something like: var t='ø';
    Maik Derstappen
    @MrTango
    shastry: how did you try to do it? maybe try with structure like: <span tal:content="structure whateveryoutstringis"></span> this way no html encoding happens
    Plone Chat
    @plone-chat
    [shastry (shastry), irc.freenode.net] MrTango: structure didn't work. I ended up returning escaped text from the function. Like '\\u00F8'. That way, I got var t='\u00F8';
    Maik Derstappen
    @MrTango
    how did you define the string?
    Plone Chat
    @plone-chat
    [shastry (shastry), irc.freenode.net] MrTango: Initially, I had `return u'ø'` in a utf8 encoded .py file (it's a rapido file), then I just did return '\\u00F8'.
    Maik Derstappen
    @MrTango
    shasty u'ø' should work without structure, i guess
    Plone Chat
    @plone-chat
    [realname (MrTango), irc.freenode.net] shastry: ^^
    Plone Chat
    @plone-chat
    [shastry (shastry), irc.freenode.net] MrTango: Strangely it didn't. It became "&#195;&#184;" (don't know what that is) in html. And, a literal ø in the .pt file became &#248;
    [Bill Schindler (bitranch), irc.freenode.net] shastry: that "&#195;&#184;" is the utf-8 encoding
    T. Kim Nguyen
    @tkimnguyen
    joshuazong
    @joshuazong
    I am receiving an error on Plone 5.2 / Python 3.7 with plone.app.mosaic 2.2.1 throwing an error when attempting to run 'instance fg' . Is there a version that is compatible with 5.2 or is this a good issue to throw into the github repo issues?
    Peter Mathis
    @petschki
    Joshuazong Versions in 5.2/versions.cfg ecosystem should work. An issue in the mosaic repo with details (trackback) much appreciated.
    joshuazong
    @joshuazong
    @petschki I ran a fresh buildout and mosaic installed without issue. I was using the 5.2 training buildout, so currently assuming that something with my training material updates to the buildout caused the issue. Will hold off on creating the issue within the mosaic repo for the moment.
    Espen Moe-Nilssen
    @espenmn
    @joshuazong @petschki . Mosaic should work with 5.2 both in python 2.7 and 3. That said. I have a lot of issues with unicode errors and the built in templates. So you might need to look at the versions of the requirements of Mosaic ( I have downgraded some and use my own forks for others)
    T. Kim Nguyen
    @tkimnguyen
    @joshuazong best to ask this sort of thing in the forum https://community.plone.org and include the full error trace and maybe the version pins you used
    T. Kim Nguyen
    @tkimnguyen
    Plone Foundation Board selects officers for 2019-2020: https://plone.org/news/2019/plone-foundation-board-officers-selected-for-2019-2020
    Maik Derstappen
    @MrTango
    @petschki you documented the usage of plone.app.mosaic for Plone 5.1 here: https://github.com/plone/plone.app.mosaic/commit/ec5ef8fbbb805c18aad30d90007d2217263bdd3e#diff-88b99bb28683bd5b7e3a204826ead112R99 is this working for you? Because this version of plone.app.contenttypes breaks the RichText on Plone5.1.6 for me.
    Maik Derstappen
    @MrTango
    so basically plone.app.contenttypes >= 2.0.0 seems not working on 5.1.6
    i get a No behavior registration found for behavior named: "plone.app.contenttypes.behaviors.richtext.IRichText" there, which explains the missing RichText field
    Plone Chat
    @plone-chat
    [ksuess (ksuess), irc.freenode.net] Hi everyone!
    [ksuess (ksuess), irc.freenode.net] Volto: How to edit a front-page?
    [ksuess (ksuess), irc.freenode.net] Plone is up and running. A slightly customized react app is up and running; pages can be added and edited with blocks. But the front-page is blank and cannot be edited
    [ksuess (ksuess), irc.freenode.net] Volto 4.0.0 alpha 11
    Maik Derstappen
    @MrTango
    ksuess, make sure you installed the folderishtype addon in the quickinstaller, i had problems last time, because i didn't do it.
    Peter Mathis
    @petschki
    @MrTango I just installed mosaic 2.2.1 on top on plone 5.1 using the actual coredev buildout with the following local.cfg:
    [buildout]
    extends =
        core.cfg
        https://raw.githubusercontent.com/plone/plone.app.mosaic/master/versions.cfg
    eggs +=
        plone.app.mosaic
    without any error
    Plone Chat
    @plone-chat
    [ksuess (ksuess), irc.freenode.net] @ MrTango / still not editable, no matter if a default page in plone backend is chosen or not.
    [ksuess (ksuess), irc.freenode.net] needed to enable behavior "enable blocks..." for dexterity pages
    [ksuess (ksuess), irc.freenode.net] i thnk this lacks for plone site type
    [ksuess (ksuess), irc.freenode.net] an earlier plone instance: in properties there are blocks_layout and blocks fields that i think do the trick
    [ksuess (ksuess), irc.freenode.net] localhost:3000/edit says: Cannot read property 'length' of undefined
    Plone Chat
    @plone-chat
    [ksuess (ksuess), irc.freenode.net] solved: kitconcept.voltodemo needs to be installed: it enables volto blocks on plone site itself
    Piero Nicolli
    @pnicolli
    Yes, installing kitconcept.voltodemo is the fastest way to get your plone instance up and running at this time