Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Maik Derstappen
    @MrTango
    @NicolasGoeddel hihi, indeed, Gitter makes it possible :)
    @NicolasGoeddel btw for your usecase you don't need the view, you could just allow contributor for anonymous in theat folder and use the normal add link from the add menu. We do that for the talk submission on plonetagung.de too.
    @AlbertDavid94 you can check the headers in the browser inspector and compair this with your CORS config.
    Maik Derstappen
    @MrTango
    @ramiroluz it seems that there where already some Plone 5 releated commits before the split into 1.x branch. It should be safe to revert or change them in the 1.x branch. Some of the changes might be solvable by adding missing dependencies which are not installed in Plone 4 by default.
    Ramiro Batista da Luz
    @ramiroluz
    @MrTango right, adding plone.api as a dependency solved one problem. The other looks like something related to the depecretion of Archetypes in plone 5, I don't know. But it seens not needed in plone 4.
    @petschki thanks, I will do that. The workflow for PR's I intend to follow from now on is: discuss a little, create an issue, a working branch for the issue, a WIP pull request with small commits, then a final pull request.
    AlbertDavid
    @AlbertDavid94
    @MrTango how do I check the headers in the browser inspector?
    Maik Derstappen
    @MrTango
    depends on your browser, but usually the inspector opens with F12 and there you can see all requests. When you click on them you can see also headers.
    AlbertDavid
    @AlbertDavid94
    I'm in the chromium inspector. I'm logging the XMLHttpRequests but it doesn't show any headers...
    I'm in the console tab though
    ah right, I found it under "network"
    Maik Derstappen
    @MrTango
    it has to have showing the request activated, not sure whats the default, but normaly you should see every request your app does there
    AlbertDavid
    @AlbertDavid94

    So I found the file where I have to edit the entries

    When adding this plone:CORSPolicy, I get an error:
    ConfigurationError: ('Unknown directive', u'http://namespaces.plone.org/plone', u'CORSPolicy')

    wat do

    Maik Derstappen
    @MrTango
    @AlbertDavid94 add this to the first tag of the zcml file: xmlns:plone="http://namespaces.plone.org/plone"
    AlbertDavid
    @AlbertDavid94
    @MrTango I already did. That's the thing that is causing this error :\

    zope.configuration.xmlconfig.ZopeSAXParseException: File "/usr/local/Plone/zeocluster/parts/client1/etc/site.zcml", line 10.0, unbound prefix

    It gives this error when I try to restart senaite

    line 10 is
    <plone:CORSPolicy
    Peter Mathis
    @petschki
    @AlbertDavid94 you have to add the line <include package="plone.rest" file="meta.zcml" /> before this plone:CORSPolicy line
    there's the definition of this prefix
    note: seems enought to include package="plone.rest" only because the meta.zcml is included there already ...
    AlbertDavid
    @AlbertDavid94
    so just to be clear
    <configure
        xmlns="http://namespaces.zope.org/zope"
        xmlns:meta="http://namespaces.zope.org/meta"
        xmlns:five="http://namespaces.zope.org/five"
        xmlns:plone="http://namespaces.plone.org/plone">
    
      <include package="Products.Five" />
      <meta:redefinePermission from="zope2.Public" to="zope.Public" />
      <include package="plone.rest" file="meta.zcml" />
      <plone:CORSPolicy
          allow_origin="*"
          allow_credentials="true"
          expose_headers="Content-Length,X-My-Header"
          allow_headers="Accept,Authorization,Content-Type,X-Custom-Header"
          max_age="3600"/>
    
      <!-- Load the meta -->
      <include files="package-includes/*-meta.zcml" />
      <five:loadProducts file="meta.zcml"/>
    
      <!-- Load the configuration -->
      <include files="package-includes/*-configure.zcml" />
      <five:loadProducts />
    
      <!-- Load the configuration overrides-->
      <includeOverrides files="package-includes/*-overrides.zcml" />
      <five:loadProductsOverrides />
    
    
      <securityPolicy
          component="AccessControl.security.SecurityPolicy" />
    
    </configure>
    that's supposed to be my site.zcml?
    AlbertDavid
    @AlbertDavid94
    it doesn't würk very well
    Peter Mathis
    @petschki
    @AlbertDavid94 Since I've never touched site.zcml manually the buildout config from volto/api maybe gives you a hint ... see the CORSPolicy defined in zcml-additional ... https://github.com/plone/volto/blob/master/api/base.cfg ... maybe worth a try
    AlbertDavid
    @AlbertDavid94
    thx, I'll look into it
    Ramiro Batista da Luz
    @ramiroluz
    Done. @petschki , @MrTango . Was trying to get ride of unnecessary changes in the 1.x branch. But didn't figured out how to do it, so I made some minor changes on the 1.x HEAD. collective/Products.windowZ#10
    Made a draft pull request.
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] my Google Fu is failing me. Can someone direct me to docs that describe the various default roles and groups in Plone, and what are their permissions?
    [Steve Piercy (stevepiercy), irc.freenode.net] nm, found it by searching community https://community.plone.org/t/grant-permissions/7517/2?u=stevepiercy
    Plone Chat
    @plone-chat
    [Trackball (trackball), irc.freenode.net] https://docs.plone.org/manage/deploying/production/restarts.html I can't get Plone to start with this guide. the user plone_daemon doesn't seem to have permission to do `sudo -u plone_daemon bin/plonectl start`. but plone starts just fine, if i do `bin/plonectl start` as root user
    NicolasGoeddel
    @NicolasGoeddel
    I am working with Skins layers in PLone 5.2 and found out that only a few file types can be accessed through the browser, e.g. ico, png and js. But I also need ttf and some other file extensions to be publicly available.
    NicolasGoeddel
    @NicolasGoeddel
    Or what's a modern way to make files like ttf, png, jpg, js and similar accessible from everywhere and without something like domain/++plone++my.package.name/ using the browser/static thing?
    Plone Chat
    @plone-chat
    [https://webchat.freenode.net (admin-test), irc.freenode.net] Hi, ich habe eine Webformualr in Plone erstellt und ein Datumsfeld angelegt.
    [https://webchat.freenode.net (admin-test), irc.freenode.net] Nun möchte ich beim Aufrufen, des Webformulars gleich der heutige Tag im Datumsfeld angezeigt wird. Wie kann ich dies im xml Editor hinterlegen?
    NicolasGoeddel
    @NicolasGoeddel
    How can I add other file types than png, ico, js, ... to a skin directory? I want to make ttf and woff files avaiable through skins but it does not work. See also: https://community.plone.org/t/skin-layer-and-valid-file-extensions/10865
    Mikel Larreategi
    @erral
    @NicolasGoeddel you can add '.dtml' as extension and they will show in the skins folder
    file.ttf -> file.ttf.dtml
    itvamsi
    @itvamsi
    Hello
    Hello, i have few queries about plone
    can anyone reply
    Maik Derstappen
    @MrTango
    @itvamsi please just ask your question, if anyone knows the anwers and has time, they will respond. Do not ask to ask a question ;)
    itvamsi
    @itvamsi
    Hi, few days back, i came to know about Plone. I learned that it helps in build websites with out much complexity. But, i cannot find detailed step by step procedure in designing websites in plone. Please, can anyone give me a link or pdf doc which helps me in quick start.
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] @itvamsi https://training.plone.org/5/theming/index.html
    batistazero
    @batistazero
    hi
    im successfull install plone in rhel 7
    i cant see any service up
    need to start manually
    AlbertDavid
    @AlbertDavid94

    I'm updating an application using sudo -u plone_buildout bin/buildout.
    First time running, I get the following error:

    While:
        Initializing.
    Error: Error downloading extends for URL http://dist.plone.org/version/zope-2-13-27-versions.cfg: <urlopen error [Errno -3] Temporary failure in name resolution>

    Now, knowing that an installation script is a deterministic piece of software, I frustratingly re-run the command from above. This should give me the same error but weirdly, it doesn't. Instead, this time it says that zopetoolkit cannot be downloaded [Errno -110]

    Being intrigued by this result, I re-run the same command, this time spitting out that plone release 4.3.18 couldn't be downloaded because the network is not reachable [Errno 110]. After retrying this command, those are the random errors that it keeps spitting out.

    My question is: wat do?

    itvamsi
    @itvamsi
    hi, i want to include bootstrap web component library into plone, can anyone provide me procedure?