Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    AlbertDavid
    @AlbertDavid94
    so just to be clear
    <configure
        xmlns="http://namespaces.zope.org/zope"
        xmlns:meta="http://namespaces.zope.org/meta"
        xmlns:five="http://namespaces.zope.org/five"
        xmlns:plone="http://namespaces.plone.org/plone">
    
      <include package="Products.Five" />
      <meta:redefinePermission from="zope2.Public" to="zope.Public" />
      <include package="plone.rest" file="meta.zcml" />
      <plone:CORSPolicy
          allow_origin="*"
          allow_credentials="true"
          expose_headers="Content-Length,X-My-Header"
          allow_headers="Accept,Authorization,Content-Type,X-Custom-Header"
          max_age="3600"/>
    
      <!-- Load the meta -->
      <include files="package-includes/*-meta.zcml" />
      <five:loadProducts file="meta.zcml"/>
    
      <!-- Load the configuration -->
      <include files="package-includes/*-configure.zcml" />
      <five:loadProducts />
    
      <!-- Load the configuration overrides-->
      <includeOverrides files="package-includes/*-overrides.zcml" />
      <five:loadProductsOverrides />
    
    
      <securityPolicy
          component="AccessControl.security.SecurityPolicy" />
    
    </configure>
    that's supposed to be my site.zcml?
    AlbertDavid
    @AlbertDavid94
    it doesn't würk very well
    Peter Mathis
    @petschki
    @AlbertDavid94 Since I've never touched site.zcml manually the buildout config from volto/api maybe gives you a hint ... see the CORSPolicy defined in zcml-additional ... https://github.com/plone/volto/blob/master/api/base.cfg ... maybe worth a try
    AlbertDavid
    @AlbertDavid94
    thx, I'll look into it
    Ramiro Batista da Luz
    @ramiroluz
    Done. @petschki , @MrTango . Was trying to get ride of unnecessary changes in the 1.x branch. But didn't figured out how to do it, so I made some minor changes on the 1.x HEAD. collective/Products.windowZ#10
    Made a draft pull request.
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] my Google Fu is failing me. Can someone direct me to docs that describe the various default roles and groups in Plone, and what are their permissions?
    [Steve Piercy (stevepiercy), irc.freenode.net] nm, found it by searching community https://community.plone.org/t/grant-permissions/7517/2?u=stevepiercy
    Plone Chat
    @plone-chat
    [Trackball (trackball), irc.freenode.net] https://docs.plone.org/manage/deploying/production/restarts.html I can't get Plone to start with this guide. the user plone_daemon doesn't seem to have permission to do `sudo -u plone_daemon bin/plonectl start`. but plone starts just fine, if i do `bin/plonectl start` as root user
    NicolasGoeddel
    @NicolasGoeddel
    I am working with Skins layers in PLone 5.2 and found out that only a few file types can be accessed through the browser, e.g. ico, png and js. But I also need ttf and some other file extensions to be publicly available.
    NicolasGoeddel
    @NicolasGoeddel
    Or what's a modern way to make files like ttf, png, jpg, js and similar accessible from everywhere and without something like domain/++plone++my.package.name/ using the browser/static thing?
    Plone Chat
    @plone-chat
    [https://webchat.freenode.net (admin-test), irc.freenode.net] Hi, ich habe eine Webformualr in Plone erstellt und ein Datumsfeld angelegt.
    [https://webchat.freenode.net (admin-test), irc.freenode.net] Nun möchte ich beim Aufrufen, des Webformulars gleich der heutige Tag im Datumsfeld angezeigt wird. Wie kann ich dies im xml Editor hinterlegen?
    NicolasGoeddel
    @NicolasGoeddel
    How can I add other file types than png, ico, js, ... to a skin directory? I want to make ttf and woff files avaiable through skins but it does not work. See also: https://community.plone.org/t/skin-layer-and-valid-file-extensions/10865
    Mikel Larreategi
    @erral
    @NicolasGoeddel you can add '.dtml' as extension and they will show in the skins folder
    file.ttf -> file.ttf.dtml
    itvamsi
    @itvamsi
    Hello
    Hello, i have few queries about plone
    can anyone reply
    Maik Derstappen
    @MrTango
    @itvamsi please just ask your question, if anyone knows the anwers and has time, they will respond. Do not ask to ask a question ;)
    itvamsi
    @itvamsi
    Hi, few days back, i came to know about Plone. I learned that it helps in build websites with out much complexity. But, i cannot find detailed step by step procedure in designing websites in plone. Please, can anyone give me a link or pdf doc which helps me in quick start.
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] @itvamsi https://training.plone.org/5/theming/index.html
    batistazero
    @batistazero
    hi
    im successfull install plone in rhel 7
    i cant see any service up
    need to start manually
    AlbertDavid
    @AlbertDavid94

    I'm updating an application using sudo -u plone_buildout bin/buildout.
    First time running, I get the following error:

    While:
        Initializing.
    Error: Error downloading extends for URL http://dist.plone.org/version/zope-2-13-27-versions.cfg: <urlopen error [Errno -3] Temporary failure in name resolution>

    Now, knowing that an installation script is a deterministic piece of software, I frustratingly re-run the command from above. This should give me the same error but weirdly, it doesn't. Instead, this time it says that zopetoolkit cannot be downloaded [Errno -110]

    Being intrigued by this result, I re-run the same command, this time spitting out that plone release 4.3.18 couldn't be downloaded because the network is not reachable [Errno 110]. After retrying this command, those are the random errors that it keeps spitting out.

    My question is: wat do?

    itvamsi
    @itvamsi
    hi, i want to include bootstrap web component library into plone, can anyone provide me procedure?
    Maik Derstappen
    @MrTango
    @itvamsi try the plonetheme.tokyo this uses bootstrap and you can use this as a start. but be awere that they are not using any Diazo to theme, as documented in the training. They are using an retro approach, where you just overide templates, as you need. This is simpler for you i guess.
    @batistazero you can use supervisord to manage the plone instances or even create systemd script to do it. If you just want to start it as daemon, you run ./bin/instance start or ./bin/zeoserver start and ./bin/client1 start, depending on if you have a standalone or zeo setup. More infos you should find in the docs.
    kimmu
    @kimmu
    Hi, a bit basic question. Is there a default view page template in plone? (archetypes). umm beginner here. Thank you!!
    Because I'm trying to override the default view
    Maik Derstappen
    @MrTango
    @kimmu default view of what? please explain a bit what you want to archive
    itvamsi
    @itvamsi
    Dear Maik, can you please explain how to install plonetheme.tokyo
    itvamsi
    @itvamsi
    Dear Maik,I am using plone 5.2 and python 3.6, i just tried to install but am getting error
    kimmu
    @kimmu
    @MrTango default view page template of content item items
    for the "View" tab of each content item
    Maik Derstappen
    @MrTango
    @kimmu you can define the avaiable views for each CT in portal_types in the ZMI or define it better in /profiles/types/YourType.xml in your add-on package
    the default here is the name view for all fo them, then the view registration in the configure.zcml registers a view under that name for a content type specific interface. So the internal lookup only finds one view with the name view for a content type. You can always give a view diffenrent name and change the FTI settings in portal_types from view to 'my_custom_view_name'
    Plone Chat
    @plone-chat
    [Steve Piercy (stevepiercy), irc.freenode.net] @itvamsi We can't help you without more information. What is the error message?
    Flip McFadden
    @flipmcf
    can I get a hand running the tests for plone.formwidget.namedfile ?
    simple /bin/test -s plone.formwidget.namedfile is telling me it can't find the module, and i've been kind of stuck for an hour or so.
    Maik Derstappen
    @MrTango
    @flipmcf is it installed, does the bin/test contain the package?
    Flip McFadden
    @flipmcf
    bin/test does not contain the package in it's sys.path[0] in fact, sys.path is quite small.
    got one test running using absoluate paths in --path parameter, only to get stuck on yet another import (Acquisition). Should the test file be built to have all my eggs and src packages in the path?
    Flip McFadden
    @flipmcf
    I would expect bin/test to contain a long list of paths, very much like bin/instance right?
    Maik Derstappen
    @MrTango
    @flipmcf yes that should be the case, check if you actually added the eggs to the test part in buildout