Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 01 17:43
    tiari opened #548
  • Sep 09 22:30

    flogo-oss on gh-pages

    Deploy TIBCOSoftware/flogo to g… (compare)

  • Sep 09 22:29

    flogo-oss on gh-pages

    Deploy TIBCOSoftware/flogo to g… (compare)

  • Sep 09 22:25

    mellistibco on master

    Update README.md (#547) https:… (compare)

  • Sep 09 22:25
    mellistibco closed #547
  • Sep 09 22:24
    anborg opened #547
  • Sep 09 22:22
    mellistibco closed #546
  • Sep 09 22:09
    anborg edited #546
  • Sep 09 22:07
    anborg opened #546
  • Sep 08 17:46
    fcastill labeled #545
  • Sep 08 17:45
    fcastill labeled #545
  • Sep 04 22:53
    acoard-aot opened #545
  • Aug 27 17:41

    flogo-oss on gh-pages

    Deploy TIBCOSoftware/flogo to g… (compare)

  • Aug 27 17:40

    flogo-oss on gh-pages

    Deploy TIBCOSoftware/flogo to g… (compare)

  • Aug 27 17:36

    mellistibco on master

    Add ARM64 in travis (#544) Sig… (compare)

  • Aug 27 17:36
    mellistibco closed #544
  • Aug 27 10:26
    odidev opened #544
  • Aug 14 14:23

    flogo-oss on gh-pages

    Deploy TIBCOSoftware/flogo to g… (compare)

  • Aug 14 14:19

    mellistibco on master

    correct cli example command (#5… (compare)

  • Aug 14 14:19
    mellistibco closed #543
Leon Stigter
@retgits
If you’re running on windows you’ll need to use either the set command first to create an environment variable or add them using the control panel (the way you’re trying it now is how it works in Linux / macOS)
sivagtibco
@sivagtibco
Hi Leon I did that before I test
But the variable which I specified is not picking from the file
Leon Stigter
@retgits
Also, can you just run SET and check the variable you created is present?
sivagtibco
@sivagtibco
I did set also before I run it
Leon Stigter
@retgits
No, I mean when you run “SET” (don’t add anything) it shows all environment variables your terminal on windows knows about
Can you check if you run that, that the variable you created exists?
sivagtibco
@sivagtibco
YES
sorry for caps
ComSpec=C:\WINDOWS\system32\cmd.exe
DriverData=C:\Windows\System32\Drivers\DriverData
FLOGO_APP_PROPS_OVERRIDE=C:\Users\sganise\Downloads\props.json
Leon Stigter
@retgits
Hmm I don’t have my windows machine here to debug that issue 🤔 your environment is set properly
sivagtibco
@sivagtibco
ok
do we have any trigger available for ems queue receiver?
Leon Stigter
@retgits
Yeah, I think that @mmussett created one... you might want to check in his GitHub repos
sivagtibco
@sivagtibco
ok.. i checked it here https://tibcosoftware.github.io/flogo/showcases/ but do see only for send .. but nothing for receiver..
https://github.com/mmussett/ems i will check this..
Alexandre Vazquez
@alexandrev
@sivagtibco if you have Powershell
you can try this
$Env:FLOGO_APP_PROPS_OVERRIDE=<PATH>
it works for me
sivagtibco
@sivagtibco
ok thank you let me try that
Alexandre Vazquez
@alexandrev
sure, just let me know how it went
hi guys, do we have something to write into an Oracle database?
obloquy
@obloquy
In Flogo rules there is a quite active branch called 'store' which seems to be adding a Redis backing store to the rule engine. Is there a rough timeframe for merging that with master?
Aaron Chipper
@aaronchipper

In Flogo rules there is a quite active branch called 'store' which seems to be adding a Redis backing store to the rule engine. Is there a rough timeframe for merging that with master?

+1 for this - I'd love to see that as well.

Matt Ellis
@mellistibco
@jpark800
sivagtibco
@sivagtibco
@alexandrev powershell i tried but not worked.. :(
Alexandre Vazquez
@alexandrev
ouch @sivagtibco , could you share the output you've got and the steps done?
sivagtibco
@sivagtibco
PS C:\code\FLOGO\cli\commands\healthcheckgvapp\bin> $Env:FLOGO_APP_PROPS_OVERRIDE="C:\Code\FLOGO\props.json"
PS C:\code\FLOGO\cli\commands\healthcheckgvapp\bin> .\healthcheckgvapp.exe
2019-06-20T23:40:09.197-0700 INFO [flogo.engine] - Starting app [ healthcheckgvapp ] with version [ 0.0.1 ]
2019-06-20T23:40:09.198-0700 INFO [flogo.engine] - Engine Starting...
2019-06-20T23:40:09.198-0700 INFO [flogo.engine] - Starting Services...
2019-06-20T23:40:09.198-0700 INFO [flogo] - ActionRunner Service: Started
2019-06-20T23:40:09.198-0700 INFO [flogo.engine] - Started Services
2019-06-20T23:40:09.198-0700 INFO [flogo.engine] - Starting Application...
2019-06-20T23:40:09.199-0700 INFO [flogo] - Starting Triggers...
2019-06-20T23:40:09.202-0700 ERROR [flogo] - Trigger [ receive_http_message ]: Error Starting
github.com/project-flogo/core/support/log.(*zapLoggerImpl).Errorf
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/support/log/zap.go:65
github.com/project-flogo/core/support/managed.Start
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/support/managed/managed.go:64
github.com/project-flogo/core/app.(*App).Start
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/app/app.go:178
github.com/project-flogo/core/engine.(*engineImpl).Start
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/engine/engineimpl.go:169
github.com/project-flogo/core/engine.RunEngine
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/engine/engine.go:38
main.main
C:/Code/FLOGO/cli/commands/healthcheckgvapp/src/main.go:49
runtime.main
c:/go/src/runtime/proc.go:200
2019-06-20T23:40:09.203-0700 ERROR [flogo] - error starting Trigger[receive_http_message] : listen tcp :8002: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.
github.com/project-flogo/core/support/log.(*zapLoggerImpl).Error
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/support/log/zap.go:43
github.com/project-flogo/core/engine.RunEngine
C:/Users/sganise/go/pkg/mod/github.com/project-flogo/core@v0.9.2/engine/engine.go:40
main.main
C:/Code/FLOGO/cli/commands/healthcheckgvapp/src/main.go:49
runtime.main
c:/go/src/runtime/proc.go:200
Failed to start engine: error starting Trigger[receive_http_message] : listen tcp :8002: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.
where as in the json i had given 8002 port but i am trying to update this port in the config with 8003
{ "port": 8003 }
as it is still checking the one i had given in my actual app (as 8002) it is failing ( another app already running on 002)
Alexandre Vazquez
@alexandrev
can you share the app code and props file by mail so I can check at my end?
sivagtibco
@sivagtibco
can i attach a file here?
Alexandre Vazquez
@alexandrev
not sure..
sivagtibco
@sivagtibco
@alexandrev is this tibco.com?
i can send a mail
Alexandre Vazquez
@alexandrev
hi @sivagtibco I'm able to reproduce it
with 0.9.0
I have two issues guys. a) not able to update to 0.9.2 ... do you know why ? I'm doing the go get -u .... but still in 0.9.0
b) can anyone test if override props still works? I'm able to do it in FE but not in OSS
Samip Kothari
@skothari-tibco
May be flogo update github.com/project-flogo/core. I checked the override, you are correct it doesn’t work. Currently I have a workaround and we can fix it eventually. For work around just add _ "github.com/project-flogo/core/app/propertyresolver” in the import of src/main.go and make sure you have set the env variable FLOGO_APP_PROPS_JSON.
Abram Van Der Geest
@abramvandergeest
Hi all, we just created a new channel for ml related questions: https://gitter.im/project-flogo/developers
so come on by if you have questions or if you are interested in ml
and the link is actually: https://gitter.im/project-flogo/Ml
Matt Ellis
@mellistibco
@skothari-tibco not eventually :) Can we fix that now?
Samip Kothari
@skothari-tibco
@mellistibco sure thing.
Matt Ellis
@mellistibco
Thanks
Frank Martinez
@fm-tibco
to use the json property override resolve, you can also add github.com/project-flogo/core/app/propertyresolver to the imports section of your flogo.json