Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 18 11:18
    huornlmj opened #1850
  • Sep 17 21:31
    webknjaz commented #1840
  • Sep 16 21:53
    webknjaz commented #1840
  • Sep 16 20:07
    tronghieu1987 commented #1708
  • Sep 16 13:55
    jaraco commented #1840
  • Sep 16 13:42
    pganssle commented #1840
  • Sep 15 21:25
    webknjaz commented #1840
  • Sep 12 13:38
    con-f-use commented #1650
  • Sep 12 13:23
    con-f-use commented #1650
  • Sep 12 13:12
    con-f-use commented #1650
  • Sep 11 17:14
    jaraco synchronize #1690
  • Sep 11 17:14
    jaraco edited #1690
  • Sep 11 17:14

    jaraco on deterministic-provides-extras

    Update changelog. Ref #1690. (compare)

  • Sep 11 17:14
    gaborbernat commented #1650
  • Sep 11 17:12
    jaraco closed #1650
  • Sep 11 17:12
    jaraco commented #1650
  • Sep 11 17:10
    jaraco edited #1690
  • Sep 11 17:07

    jaraco on deterministic-provides-extras

    Move version to setup.cfg Move bumpversion config to .bum… Merge pull request #1687 from p… and 100 more (compare)

  • Sep 11 17:07
    jaraco synchronize #1690
  • Sep 11 17:06
    jaraco commented #1690
drocsid
@drocsid

@ionox0 or channel I'm trying to use airflow[qds] from an inherited setup.py project but not sure how to specify. You mention something similar above. My setup.py setup() has

install_requires=[
        'apache-airflow>=1.7.0,<1.11.0',
        'jinja2>=2.10.0',
        'werkzeug>=0.15.0'

    ],

but I don't know how to add the qds module. Can anybody help? I've tried to search this out but am just getting more confused.

Ian
@ionox0
'apache-airflow[qds]>=1.7.0,<1.11.0’
does that work?
im no expert
drocsid
@drocsid
I didn't think it did let me try again
So I try that and the pip install -e . but then when I bring up airflow I get
line 32, in <module>
    from qds_sdk.qubole import Qubole
ImportError: No module named qds_sdk.qubole
Done.
so it allows the install but it looks like it doesn't let me load the qds module.
Ian
@ionox0
might need to use extras_require?
drocsid
@drocsid
I tried that also already
Ian
@ionox0
setup(
    name="Project-A",
    ...
    extras_require={
        'PDF':  ["ReportLab>=1.2", "RXP"],
        'reST': ["docutils>=0.3"],
    }
)
you could try with python setup.py install as well
drocsid
@drocsid
install_requires=[
        'apache-airflow>=1.7.0,<1.11.0',
        'jinja2>=2.10.0',
        'werkzeug>=0.15.0'

    ],
    extras_require=[
        'qds' : 'airflow[qds]',
        ]
above people are saying not so use python setup.py install but to use pip install instead.
Ian
@ionox0
could it be
    extras_require=[
        'apache-airflow' : ‘qds',
        ]
nah nvm
drocsid
@drocsid
From the extras_require description it sounds like that's for defining my own project modules
Ian
@ionox0
right right
it does look like its installing qds
but install is erroring
Ian
@ionox0
Maybe qds_sdk.qubole is also a requirement?
Try with qds-sdk also in install_requires?
drocsid
@drocsid
That looks like it was the issue. My bad. Thanks!
Ian
@ionox0
Cool, awesome
drocsid
@drocsid
Well it was able to initalize the database without exception but then when I started the webserver I got No module named qds_sdk.qubole again...
from the webserver ui
despite adding it to install_requrires
Ian
@ionox0
what does pip show qds-sdk say?
drocsid
@drocsid
pip show qds-sdk
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Name: qds-sdk
Version: 1.12.0
Summary: Python SDK for coding to the Qubole Data Service API
Home-page: https://github.com/qubole/qds-sdk-py
Author: Qubole
Author-email: dev@qubole.com
License: Apache License 2.0
Location: /private/tmp/id-core-test/id-correlation-offline/env/lib/python2.7/site-packages
Requires: requests, boto, inflection, six, urllib3
Required-by: idc-offline
Ian
@ionox0
are you using a virtualenv? if so is your webserver installed within / using that same virtualenv?
(or using conda)?
drocsid
@drocsid
Yeah I'm not sure what I did wrong that time but it does seem to be working on another attempt. Thanks for the help!
Ian
@ionox0
Np!
Thomas Robitaille
@astrofrog
Is there a document somewhere that describes that the plan for Python packaging is to move away from setuptools commands? I've read it in a few comments but I'd like to find a more official place where this is mentioned so that I can use this to convince the developer communities I'm part of to move in that direction.
Paul Ganssle
@pganssle
No.
It's true that you should, and almost certainly there is at least documentation that says not to use specific commands.
Like upload and register for example are deprecated.
Other stuff it's more complicated and I'd rather err on the side of a "soft launch" rather than add more churn and conflicting documentation when we don't know when the replacements are ready yet.
We can probably deprecate install in the documentation and test entirely.
Ronny Pfannschmidt
@RonnyPfannschmidt
is there any way for setuptools to obtain access to the egg/dist-info folder pip makes before copying out a folder from a build?
Paul Ganssle
@pganssle
I think setuptools makes that folder.
Ronny Pfannschmidt
@RonnyPfannschmidt
@pganssle pip uses setuptools to make that folder, but then the next call to setuptools from pip happens somewhere else
@pganssle im wonderring, because i need setuptools_scm to figure the actual version, and pip copies everything away which makes things strange
Paul Ganssle
@pganssle
I dunno, I would only count on whatever PEP 517 says.
It seems like prepare_metadata_for_build_wheel is at least partially designed for this.
Not sure how that translates into setuptools_scm space.
Ronny Pfannschmidt
@RonnyPfannschmidt
same - i have no idea how to get the metadata i need ^^
Thomas Robitaille
@astrofrog
Hi all, is there a way in setuptools to check whether a version number (e.g. 1.3) satisfies a version specifier? (e.g. ~= 0.9, >= 1.0, != 1.3.4.*, < 2.0)
Thomas Robitaille
@astrofrog
I just found https://packaging.pypa.io/en/latest/specifiers/ which answers my question
damien
@damienstanton
Hi all, I am building a local package that needs to include a single pre-compiled .so file. I've tried including this in package_data or data_files fields, but it's not working. Additionally, in my wrapper for the C interface, what path is appropriate to pass into the call to cdll.LoadLibrary("mylib.so")? All the documentation I've found has explained how to include, compile, and link C sources directly, but this isn't what I am doing. Any help is much appreciated :pray: