Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 22:18
    knaaptime opened #22
  • 22:10
    knaaptime commented #20
  • 21:58

    github-actions[bot] on gh-pages

    Initial orphan branch Fix README Update documentation and 10 more (compare)

  • 21:53

    knaaptime on master

    update infrastructure tweak docs.conf update gha and 6 more (compare)

  • 21:53
    knaaptime closed #16
  • 21:24
    knaaptime commented #16
  • 20:39
    knaaptime commented #18
  • 17:59
    JamesSaxon commented #16
  • 17:56
    ljwolf commented #16
  • 17:55
    ljwolf commented #16
  • 17:52
    JamesSaxon commented #18
  • 17:51
    JamesSaxon commented #18
  • 17:47
    martinfleis commented #16
  • 17:39
    JamesSaxon commented #16
  • 17:38
    JamesSaxon commented #16
  • 17:37
    JamesSaxon commented #16
  • 17:35
    jGaboardi added as member
  • 17:34
    knaaptime added as member
  • 06:34
    knaaptime synchronize #16
  • 00:37
    knaaptime synchronize #16
Levi John Wolf
@ljwolf
but, @martinfleis you should have full admin over pysal/momepy
Martin Fleischmann
@martinfleis
I do, yes
Levi John Wolf
@ljwolf
this is an organization-level thing I think
Martin Fleischmann
@martinfleis
yeah, that is why I wasn't able to switch it on
Levi John Wolf
@ljwolf
right, ok
Dani Arribas-Bel
@darribas
hello, can anyone confirm these is a full and current list of all the federated packages? https://github.com/darribas/gds_env/pull/68/files
Sergio Rey
@sjsrey
3 replies
Dani Arribas-Bel
@darribas
hey, I think a fresh install of pysal is potentially broken now: pysal/segregation#190
eli knaap
@knaaptime
i saw the error go up last on the nightlies yesterday. I think its a quick fix over in rvlib
i think you could get around it by pinning whatever the prior release of pyyaml is
but i can get a new rvlib released quickly that will fix
Dani Arribas-Bel
@darribas
Cool! If you’re planning on releasing soon, I might hold on until that. The container has so many libraries that I’m learning the hard way pinning a given variable feels great at night but you usually regret it in the morning :smile:
eli knaap
@knaaptime
should be resolved
Dani Arribas-Bel
@darribas
wahooo!!!
are you planning to cut a new release? I can install from master otherwise so no big deal
eli knaap
@knaaptime
the fix was upstream in rvlib, so no need for a new release just yet
Dani Arribas-Bel
@darribas
ahhhh so rvlib has been fixed
sorry, got it, cool!
yeah they have a release from yesterday on pypi, amazing!
eli knaap
@knaaptime
that was me :P
Dani Arribas-Bel
@darribas
oh cool!
eli knaap
@knaaptime
they gave me the rvlib keys a few months ago, said i might as well take it over
Dani Arribas-Bel
@darribas
nice!!!
eli knaap
@knaaptime
especially useful in situations like this
rohitsinghsalyan
@rohitsinghsalyan
I was working with the pointspat package. While I am importing the NND functions G, F, J, K, L, I am getting an import error.
ImportError: cannot import name 'G' from 'pointpats'
I checked in the package source code, It has been added to deprecated functions. Can you let me know why it has been deprecated, Is it still okay to use it ?
Levi John Wolf
@ljwolf
that API should do you fine
rohitsinghsalyan
@rohitsinghsalyan
Thanks @ljwolf this was really helpful.
Levi John Wolf
@ljwolf
huh, scipy is considering moving to lazy loading of submodules
maybe we should consider their implementation once it comes out?
Martin Fleischmann
@martinfleis
For meta? Maybe, that can take a while to import. But I’m not sure it is worth applying in sub packages. Is there any in particular that would benefit from it?
Levi John Wolf
@ljwolf
Yes, for the metapackage
subpackage load times are so heterogeneous that it'd help (I think)
it'd be nice to be able to explore the lib/explore/model/viz hierarchy without loading the modules directly, and then also to see the modules (e.g. with tab completion) without forcing them to be imported.
Martin Fleischmann
@martinfleis
Worth exploring
eli knaap
@knaaptime
there's pypa/setuptools#2849 in the latest setuptools that
is affecting installation for the pacakges where we just adopted versioneer
presumably should be fixed before too long because looks like it's caused a lot of breakage
eli knaap
@knaaptime
actually may already be fixed, but caused a few breakages in the tests overnight
Levi John Wolf
@ljwolf
by my records, we have a PySAL meeting today, yes?
I have @sjsrey chairing?
Martin Fleischmann
@martinfleis
yes
Taylor Oshan
@TaylorOshan
link?
Martin Fleischmann
@martinfleis
Levi John Wolf
@ljwolf
fyi @martinfleis, is weights.Voronoi used in momepy?
Taylor Oshan
@TaylorOshan
I am available to chair next meeting
eli knaap
@knaaptime
cool, i swapped you on the sched :)
Taylor Oshan
@TaylorOshan
:thumbsup: