Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 07:56
    ehmoussi starred pythonnet/pythonnet
  • May 15 21:29
    ahbrosha starred pythonnet/pythonnet
  • May 15 18:16
  • May 15 03:05
    lostmsu synchronize #1134
  • May 15 02:48

    lostmsu on master

    use PyType instances instead of… (compare)

  • May 15 02:48
    lostmsu closed #1431
  • May 15 02:32
    lostmsu synchronize #1431
  • May 14 12:06

    lostmsu on master

    dispose all temporary objects i… (compare)

  • May 14 12:06
    lostmsu closed #1456
  • May 14 12:01
    lostmsu opened #1456
  • May 14 05:28
    lostmsu synchronize #1431
  • May 13 20:43
    spynetcamera opened #1455
  • May 13 09:57
    lostmsu commented #1454
  • May 13 01:25
    today4king starred pythonnet/pythonnet
  • May 12 20:54
    Evangelink commented #1453
  • May 12 10:40
    Worble opened #1454
  • May 12 10:06
    spig95 starred pythonnet/pythonnet
  • May 12 06:32
    liu-plus-wei starred pythonnet/pythonnet
  • May 11 06:31
    m-rossi commented #1262
  • May 11 04:30
    vipulpatel2103 commented #1262
elTRexx
@elTRexx
So yeah that work, but I don't get back the more "elegant" way I was using before with environment variables to just "import" a script .
Doesn't it be possible to play with "scope" variable like I did finally, but using Py.Import() (or something similar involving scope I suppose) ?
Amaury Levé
@Evangelink
Hi there,
Sorry for the stupid question but I am pretty new to your tool and I can't find any help (looked at SO and issues) about converting a numpy array into a c# collection. This thread seems to be the closestpythonnet/pythonnet#623
LuckyGuySam
@LuckGuySam
Hi, I try to use C# call python with pythonnet. I need to switch the python visual env, but after PythonEngine.Initialize() I can't change my visual env. How can I do? Can I initialize a lot of python visual env and switch when I need ?
Andy Salerno
@andysalerno:matrix.org
[m]
Hi all, is there any possibility of a RC/beta/pre-release of 3.0 on pypi? I've been playing with the "netcore3.1" integration by pulling builds from the build agent, and I'm curious how far off an RC is (apologies if this is asked 100x a day)
maye1115
@maye1115
Hello,there are python37 38 on my computer.I set the system variable to pyhton38 in the code "Environment.SetEnvironmentVariable...EnvironmentVariableTarget.Process". But I uninstall python38, it prompts that DLL python38 cannot be found,I repointed to python37 and it didn’t work.
András Mózes
@mozesa
Hello! When there is a String argument, should I use String("string") or it is just enough to use bare "string"? Thanks in advance.
slide-o-mix
@slide-o-mix:matrix.org
[m]
I use the latter
András Mózes
@mozesa
:thumbsup: I noticed too, that it works, but I was confused.
There should be one-- and preferably only one --obvious way to do it. :smile:
András Mózes
@mozesa
Hello! I use clr within a python worker thread. There is test for the exactly same situation, but I am a bit confused with threading support 😕 I don't own the c# assemblies I use with clr so I don't think it contains any PythonEngine.BeginAllowThreads() calls. Should I deal with GIL, or it's just not concerned to me? I appreciate any help as I have been dealing with it only for a couple of days. Thanks!
András Mózes
@mozesa
Hello! Could someone elaborate on call into managed code by Python-spawned threads.
I would like to avoid the starvation of main Python thread - the managed code is an OPC UA client implementation.
SB6988
@SB6988

Hi everybody, I am trying to use some nugets (Microsoft.ML. ProbabilisticModels specifically) in Python and I am trying to leverage pythonnet. However, I get the following error:

SystemPlatformNotSupportedException: Operation is not supported on this platform

After a list of functions that throw this error. I get:

The above exception was the direct cause of the following exception:

SystemPlatformNotSupportedError: Current platform is not supported by the current compiler choice Auto. Try a different one.

Does anybody now what is the root cause of this platform error? How do I change a compiler choice? Or is there a known workaround for this?

YoonWatch
@JHWatch
Hello! Is Pythonnet not available yet with Python 3.9?
YoonWatch
@JHWatch
Help me I think it might be a version problem when I did Python 3.9 version, so I changed it to 3.8 version and executed the example code, but still TypeInitializationException exception treatment occurs
Runtime.dll has been referred to in "C:\Users\user\AppData\Local\Programs\Python\Python38\Lib\site-packages\pythonnet\runtime" in the Python installation path
chanyam
@chanyam:matrix.org
[m]

Hi! Using Pythonnet with Python 3.7 to load a .NET assembly, which seems to work just fine, but when I try to import an object from a namespace in that assembly, I get this error:

Traceback (most recent call last):
File "ForzaTextureExporter", line 10, in
File "E:\Tools\Scripts\Houdini\python\hdi\TextureExporter.py", line 38, in main
from MetaDataObjects import TextureSourceMetadataFactory
ModuleNotFoundError: No module named 'MetaDataObjects'

The assembly I'm loading has a bunch of external references to some of our other assemblies, but even copying those dlls into the same dir as python37.exe doesn't seem to get me past this.

the code I'm using is pretty straight forward:
assemblyPath = r"C:\python37" #moved all assemblies here, where python37.exe is
lib = clr.AddReference(os.path.join(assemblyPath, "ContentBrowserMetadataObjects"))
from MetaDataObjects import TextureSourceMetadataFactory # errors out here

Oh god, sorry about the formatting!
chanyam
@chanyam:matrix.org
[m]

:point_up: Edit: Hi! Using Pythonnet with Python 3.7 to load a .NET assembly, which seems to work just fine, but when I try to import an object from a namespace in that assembly, I get this error:

Traceback (most recent call last):
File "ForzaTextureExporter", line 10, in
File "E:\Tools\Scripts\Houdini\python\hdi\TextureExporter.py", line 38, in main
from MetaDataObjects import TextureSourceMetadataFactory
ModuleNotFoundError: No module named 'MetaDataObjects'

The assembly I'm loading has a bunch of external references to some of our other assemblies, but even copying those dlls into the same dir as python37.exe doesn't seem to get me past this.
The code I'm using is pretty straight forward:

assemblyPath = r"C:\python37" #moved all assemblies here, where python37.exe is
lib = clr.AddReference(os.path.join(assemblyPath, "ContentBrowserMetadataObjects"))
from MetaDataObjects import TextureSourceMetadataFactory # errors out here

slide-o-mix
@slide-o-mix:matrix.org
[m]
MetaDataObjects is the namespace?
chanyam
@chanyam:matrix.org
[m]
sorry, yes
chanyam
@chanyam:matrix.org
[m]
OMG - I just realized this looking at your question slide-o-mix
Its MetadataObjects 🤦‍♂️
thanks for pointing that out - for some reason my brain wasn't seeing it until just now
slide-o-mix
@slide-o-mix:matrix.org
[m]
It works with the correct namespace?
chanyam
@chanyam:matrix.org
[m]
yeah. i wouldn't call this a high point in my coding career, but hey, its working :D
slide-o-mix
@slide-o-mix:matrix.org
[m]
happens to everyone...
IamMusavaRibica
@IamMusavaRibica

How to write this method in pythonnet?

public override T[] ReadArray<T>(Func<T> func1)  {
     var count = ReadUInt32();
     var arr = new T[count];
     for (var i = 0; i < count; i++)  {
          arr[i] = (func1.Invoke());
     }
     return arr;
}

Its all happening in System.IO.BinaryReader and the func1 passed is System.IO.BinaryReader.ReadByte

chanyam
@chanyam:matrix.org
[m]
chanyam
@chanyam:matrix.org
[m]

OK, I'm getting the 'Module not found" errors again (and I've doubled checked my spelling :D)

It worked for a while on Friday and now after the weekend, its stopped. I haven't changed anything in my environment afaik. As a sanity check, I decided to print the assembly's ExportedType property to see what exactly was available from our assembly post-load. My code looks like this:

cblib = clr.AddReference(os.path.join(assemblyPath, "ContentBrowserMetadataObjects"))
    if cblib == None:
        print("failed to load ContentBrowserMetadataObjects.dll from " + assemblyPath)
    else:
        print("Successfully loaded ContentBrowserMetadataObjects.dll from " + assemblyPath)
    print(cblib.ImageRuntimeVersion)
    for t in cblib.ExportedTypes:
        print(t)

When I try calling cblib.ExportedTypes, I get the following exception message:

File "ForzaTextureExporter", line 9, in <module>
File "E:\P4\FMBase_Main\Tools\Scripts\Houdini\python\hdi\Forza_TextureExporter.py", line 26, in main
for t in cblib.ExportedTypes:
System.IO.FileNotFoundException: Could not load file or assembly 'Autofac, Version=4.0.1.0, Culture=neutral, PublicKeyToken=17863af14b0044da' or one of its dependencies. The system cannot find the file specified.
at System.Reflection.RuntimeAssembly.GetExportedTypes(RuntimeAssembly assembly, ObjectHandleOnStack retTypes)
at System.Reflection.RuntimeAssembly.GetExportedTypes()

So where is it looking for Autofac? I used Procmon to find all the events related to Houdini (the app calling Python3.7) and right after the event where it loads our assembly (ContentBrowserMetadataObjects.dll) I see the event in the image posted above. It looks like it took the Autofac assembly header and is using it for the name? If i copy Autofac.dll into that dir, it still complains about not finding the dll, but if I copy the name in the event (Autofac, Version=4. etc, etc) and rename the assembly to that, then it works - which is to say that it gets past the Autofac assembly reference but then dies on the next assembly reference, where it does the same thing (uses the header as the assembly name and not finding the dll). Does anyone know how pythonnet resolves assembly references?

chanyam
@chanyam:matrix.org
[m]
I assume this is why copying all of our assemblies into the same folder as the python3.7 exe didn't work - its looking for these modified named assemblies instead of the original assembly names.
chanyam
@chanyam:matrix.org
[m]

:point_up: Edit: OK, I'm getting the 'Module not found" errors again (and I've doubled checked my spelling :D)

It worked for a while on Friday and now after the weekend, its stopped. I haven't changed anything in my environment afaik. As a sanity check, I decided to print the assembly's ExportedType property to see what exactly was available from our assembly post-load. My code looks like this:

cblib = clr.AddReference(os.path.join(assemblyPath, "ContentBrowserMetadataObjects"))
    if cblib == None:
        print("failed to load ContentBrowserMetadataObjects.dll from " + assemblyPath)
    else:
        print("Successfully loaded ContentBrowserMetadataObjects.dll from " + assemblyPath)
    print(cblib.ImageRuntimeVersion)
    for t in cblib.ExportedTypes:
        print(t)

When I try calling cblib.ExportedTypes, I get the following exception message:

File "ForzaTextureExporter", line 9, in <module>
File "E:\P4\FMBase_Main\Tools\Scripts\Houdini\python\hdi\Forza_TextureExporter.py", line 26, in main
for t in cblib.ExportedTypes:
System.IO.FileNotFoundException: Could not load file or assembly 'Autofac, Version=4.0.1.0, Culture=neutral, PublicKeyToken=17863af14b0044da' or one of its dependencies. The system cannot find the file specified.
at System.Reflection.RuntimeAssembly.GetExportedTypes(RuntimeAssembly assembly, ObjectHandleOnStack retTypes)
at System.Reflection.RuntimeAssembly.GetExportedTypes()

So where is it looking for Autofac? I used Procmon to find all the events related to Houdini (the app calling Python3.7) and right after the event where it loads our assembly (ContentBrowserMetadataObjects.dll) I see the event in the image posted above. It looks like it took the Autofac assembly header and is using it for the name? If i copy Autofac.dll into any of the dozen paths that procmon tells me the assembly resolver is looking for Autofac in, it still complains about not finding the dll, but if I change the name of the assembly from 'Autofac.dll' to 'Autofac, Version=4.0.1.0, Culture=neutral, PublicKeyToken=17863af14b0044da.dll', then it works - which is to say that it gets past the Autofac assembly reference but then dies on the next assembly reference, where it does the same thing (uses the header as the assembly name and not finding the dll). Does anyone know how pythonnet resolves assembly references?

chrisquin
@chrisquin:matrix.org
[m]
hello, i try to use a .net dll and got an error:
System.TypeLoadException: Could not resolve type with token 010000c5 from typeref (expected class 'System.Diagnostics.Debug' in assembly 'System.Runtime, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a')
i am running a python script on linux that uses a dll which uses a simple Debug.WriteLine(...)
does somebody has an idea what is wrong? Perhaps install additional libs/packages? I installed Mono like mentioned here (https://www.mono-project.com/download/stable/)
chrisquin
@chrisquin:matrix.org
[m]
or how to install System.Diagnostics with gacutil
chrisquin
@chrisquin:matrix.org
[m]
dead chanel?
slide-o-mix
@slide-o-mix:matrix.org
[m]
System.Diagostics should be available as part of Mono
chrisquin
@chrisquin:matrix.org
[m]
it isn't. tried to install by my own: nuget install System.Diagnostics.Debug and then gacutil -i System.Diagnostics.Debug.dll but got the error:
Failure adding assembly System.Diagnostics.Debug.dll to the cache: Strong name cannot be verified for delay-signed assembly
chrisquin
@chrisquin:matrix.org
[m]

i tried to use dotnet under linux and installed the master pythonnet master into my virtual python 3.8 environment.
I exceuted the following code:

from clr_loader import get_coreclr
import pythonnet

rt = get_coreclr("runtimeconfig.json")
pythonnet.set_runtime(rt)
pythonnet.load()

import System
from System import String

s = String("Hello World from Python.NET for .NET 5!")
System.Console.WriteLine(s)

import clr

my_module = clr.AddReference("GWconfig")
from GWconfig import cls

with the runtimeconfig.json:

{
  "runtimeOptions": {
    "tfm": "net5.0",
    "framework": {
      "name": "Microsoft.NETCore.App",
      "version": "5.0.5"
    }
  }
}

with dotnet:

dotnet --list-runtimes
Microsoft.AspNetCore.App 5.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

Now i got the error:

ModuleNotFoundError: No module named 'GWconfig'

and:

my_module.DefinedTypes
*** System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types.
Could not load file or assembly 'System.Windows.Forms, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'. The system cannot find the file specified.

Could not load file or assembly 'System.Windows.Forms, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'. The system cannot find the file specified.

...

does somebody have an idea?

chendingqi
@chendingqi
ucrtbase.dll error???
how to slave
how to solve