Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 09:26
    DelazJ edited #6998
  • 09:25
    DelazJ edited #6998
  • 09:22
    domi4484 synchronize #45703
  • 08:24
    domi4484 synchronize #45703
  • 08:23
    github-actions[bot] milestoned #45703
  • 08:23
    domi4484 opened #45703
  • 08:22
    alexbruy commented #45685
  • 08:15
    DelazJ labeled #6992
  • 08:12
    DelazJ labeled #6999
  • 08:12
    DelazJ commented #6999
  • 08:10
    DelazJ commented #7001
  • 08:09
    DelazJ labeled #7001
  • 08:06
    DelazJ commented #7002
  • 08:06
    DelazJ labeled #7002
  • 08:05
    DelazJ labeled #7002
  • 08:02
    DelazJ labeled #7005
  • 08:02
    DelazJ commented #7005
  • 07:48

    transifex-integration[bot] on release_3.16

    Apply translations in it trans… (compare)

  • 07:34
    elpaso commented #45656
  • 06:49
    nicogodet commented #45674
matrixbot
@matrixbot
stef on Freenode Someone could help me?
matrixbot
@matrixbot
clara on Freenode someone knows if qgis latest versions work on Windows 2007?
Tom Kralidis
@tomkralidis
Hi all: I've merged qgis/QGIS#40785 to master. What is the current backport workflow? Should I open PRs against 3.18 and 3.16 ?
1 reply
matrixbot
@matrixbot
JohnAmsterdam2 on Freenode Hi - is anyone here? I had a question about QGIS raster calculator which is really driving me crazy but not sure if this is an appropriate place to ask?
Björn Harrtell
@bjornharrtell
Recently discovered that FlatGeobuf export dialog allows change of encoding to something else than UTF-8 which is wrong. I note that GeoPackage has that option disabled. Can't find where in the code this is capability is control, anyone know?
matrixbot
@matrixbot
@montgodb:matrix.org was kicked by @appservice-irc:matrix.org ("Idle for 30+ days").
matrixbot
@matrixbot
Virvis_ on Freenode is it possible to have different default attribute table views for different layers?
Virvis_ on Freenode like most "show all" but one layer "show visible"
matrixbot
@matrixbot
strk on Freenode is CI NOT building with ENABLE_PGTEST ? I don't see it under .github
strk on Freenode not that I understand how CI works
strk on Freenode but I see .ci/ogc/build.sh: -DENABLE_PGTEST=OFF \
strk on Freenode and .docker/docker-qgis-build.sh: -DENABLE_PGTEST=ON \
frippe12573
@frippe12573
do you know why when you use symbology-categorize no more than 13 categories are given? is it possible to have more than 13 categories when necessary?
matrixbot
@matrixbot
Ricardo45 on Freenode Hola
Ricardo45 on Freenode como desinstalo el programa qgis
Alexandre Neto
@SrNetoChan
@jef-n hi! Do we have any use for 3.10 and 3.14 translation resources? Can we just delete them? Thanks
saself
@saself
hi there people
i have some strange behaviour of qgis on my new machine -- every time i open plugin manager, it crashes
Charles Moulliard
@cmoulliard
Can QGIS calculate automatically the trace between 2 points added to a map and representing a segment ? This is something that we can do with ridewithgps, runkeeper, ...
Hi/Hello/Bonjour
kunickyd
@kunickyd
Hi everyone!
I have a question concerning translation. Does anyone know how to translate strings in html file?
I have some ideas, but none of them feels exactly right. Especially, when I take Transifex into account.
Any feedback appreciated.
paul van genuchten
@pvgenuchten
Hi, i have a question related to ogc api features in qgis server, No feature collections are shown at https://apitestbed.geonovum.nl/qgis/wfs3/collections, but they are displayed at https://apitestbed.geonovum.nl/qgis?request=getcapabilities&service=WMS, the log file doesn't indicate any problem, any hints on how to debug?
Andrew Annex
@AndrewAnnex
hey all, I am having a difficult time getting 3D Symbols to clamp to the altitude of my terrain (DEM). Basically, QGIS appears to either ignore the terrain entirely, or because my terrain is below the datum (all negative values) it seems to display symbols even further below the terrain than the terrain itself (only visible when zoomed out/rotated). I didn't see any related issues on the github page for QGIS at first glance, but are there known issues with the altitude clamping? I've even tried adding a vertical offset to the DEM using the raster calculator but so far no luck.
Navid Taheri
@navid.ta:matrix.org
[m]
Hi, everyone, I'm going to know is there any way I'll be able use whole QGIS and Grass GIS functions in python when QGIS is closed?
for example in ArcGIS I can use Arctoolbox(tools and functions) via ArcPy in python, when ArcMap and ArcCatalog are closed
it seems in QGIS I can use it functions when it is open and I can work with QGIS functions and even Grass GIS, SAGA ONLY when QGIS is open via python console in QGIS
Andrew Annex
@AndrewAnnex
@navid.ta:matrix.org I never tried it for anything real yet, but if you install QGIS using the conda-forge feedstock in an anaconda environment, you should have access to everything. A few months ago I was able to import various qgis functions into a jupyter notebook using that conda environment as the kernel, although as I said I didn't try anything other than importing things
Navid Taheri
@navid.ta:matrix.org
[m]
@AndrewAnnex thank you Andrew, based on your message I think It would be possible, however I should test that if I'll be able import entire QGIS function and even GRASS GIS also it would be awesome
Navid Taheri
@navid.ta:matrix.org
[m]
Hi, everyone,
I'm trying to install QGIS 3.20 on LMDE v4 (Linuxmint Debian Version) via QGIS installation instruction in qgis.org, However It seems, Debian repositories for QGIS 3.20 didn't update yet! .qgis.org officially announced qgis v3.20 released already and it must be available on entire supported platforms include Debian 10 (Buster)
1 reply
seranlop
@seranlop
Hello! if someone could help me please, i downloaded latest qgis, but i cant find the way to open it. the error that appears when i press the access icon is this: the element "qgis-bin.exe" wich this direct access refers to, has been move or change, thats why the direct acces wont work properly. ¿do you wish to eliminate direct acces?
Yves Moisan
@ymoisan
Quick question : I can read a gpkg through the web all right with QGIS. Provided I have directory perms well set on my server (or on S3), would it be possible to edit a GeoPackage file through the web ?
Guilhem Villemin
@gui2dev
Hi everyone !
I'm working on a custom application based on qgis.
I switched from qt 3.14 to 3.16, and I can't get wms layers to be painted.
I am using on a windows custom build from osgeo. Any idea where to look ?
Jürgen Fischer
@jef-n
custom build from osgeo?
Guilhem Villemin
@gui2dev
I use configonly.bat in ms-windows/osgeo directory to generate a visual studio solution
Guilhem Villemin
@gui2dev
Solved ! I was setting some flags on my QgsMapCanvas and somehow tiles were not rendered.
mMapCanvas->setMapSettingsFlags(QgsMapSettings::RenderPartialOutput | QgsMapSettings::Antialiasing | QgsMapSettings::RenderPreviewJob | QgsMapSettings::RenderMapTile | QgsMapSettings::UseAdvancedEffects | QgsMapSettings::UseRenderingOptimization | QgsMapSettings::DrawLabeling | QgsMapSettings::ForceVectorOutput);
maybe that was too much flags
Tom Kralidis
@tomkralidis
Hi QGIS devs: gentle callout for #44812 if anyone has a chance to review/suggest changes/approve. Thanks.
anitagraser
@anitagraser:osgeo.org
[m]
ping
Jürgen Fischer
@jef-n
ping
strk
@strk:osgeo.org
[m]
ping from gitter
Sandro Santilli
@strk_gitlab
ping from the real gitter (and yes, I can see the message from strk sent via matrix portal)
strk
@strk:osgeo.org
[m]
these messages don't get to #qgis:osgeo.org -- dunno why
Jürgen Fischer
@jef-n
ping
Sandro Santilli
@strk_gitlab
uhm
I don't see a Gitter widget that can possibly be added on the matrix room
I thought it was possible
Karl TAYOU
@TANK2003

Hello everyone!
if someone can help me, i have a script in pyqgis wich goal is to add new style to a vectorlayer with a new name.

newStyle:QgsMapLayerStyle = ....
newStyleName:str = ...

QGISProject = QgsProject()
QGISProject.read(pathToQgisProject)
layer = QGISProject.mapLayersByName(layerName)[0]
styleManager = layer.styleManager()
styleManager.addStyle(styleName,newStyle) // True
print(styleManager.styles()) // ['default',newStyleName]
QGISProject.write() // True


QGISProject = QgsProject()
QGISProject.read(pathToQgisProject)
layer = QGISProject.mapLayersByName(layerName)[0]
styleManager = layer.styleManager()
print(styleManager.styles()) // ['default']

Every thing work fine, but after write and reopen the project, the new style does not exist

Regards

Sandro Santilli
@strk_gitlab
@TANK2003 this channel is unsupported, please use matrix.to/#/#qgis:osgeo.org
Karl TAYOU
@TANK2003
Thanks @strk_gitlab , will post it there !