These are chat archives for quorrajs/quorrajs

17th
Jun 2016
Nate
@pitchinnate
Jun 17 2016 05:12
If you create a model and want to use Waterline for migrations, how do you tell the migration to run? Does it run automatically on server load or is there a cli command that needs to be ran?
Harish
@harishanchu
Jun 17 2016 05:13
migrations will run when you run the quorra application
Nate
@pitchinnate
Jun 17 2016 05:14
ok so if I don't see the table being created it must be a config issue I'm guessing
Harish
@harishanchu
Jun 17 2016 05:16
If you didn't configure your application environment for quorra, it will assume you are running application in production mode. In production mode migrate settings will fall back to safe mode even if you set it to something else.
Nate
@pitchinnate
Jun 17 2016 05:17
yeah was just looking at that
to set development mode or local, would that be something I do in the bootstrap/start.php or would I put an environment var in .env.js?
to do it quick, you can just pass your environment to ride command like this quorra ride --env development
Nate
@pitchinnate
Jun 17 2016 05:21
got it needed to setup my hostname, see the database table created now, thanks
Harish
@harishanchu
Jun 17 2016 05:21
:+1:
there are couple of ways you can do your environment configuration including nodes default way of setting environment to NODE_ENV
Nate
@pitchinnate
Jun 17 2016 05:52
just wondering @harishanchu are you part of the dev team or just a fan?
If you are part of the dev team might want to add to the Model & ORM page in the documentation the option for unique: true on an attribute, I found it in the waterline documentation but I know at least for me personally I use quite a bit
Harish
@harishanchu
Jun 17 2016 05:56
I'm the author of QuorraJS
Sure I will add, thanks for your suggestion :)
Harish
@harishanchu
Jun 17 2016 06:02
@pitchinnate Actually I have mentioned to refer waterline docs for attribute settings here: https://quorrajs.org/docs/v1/getting-started/models-&-orm.html#attributes
Unfortunately the link points to a 404. Needs to update