Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 26 2017 14:34
    @LefterisJP banned @poojasingh940_twitter
  • Dec 12 2017 13:36
    @LefterisJP banned @Nedu_Onyeanuna_twitter
  • Oct 10 2017 21:40
    @LefterisJP banned @etherchamp1_twitter
  • Aug 11 2016 13:48
    @heikoheiko banned @primehat23
Ryan Russell
@RyanRussell00

Hey all, I'm a Full-Stack Engineer/Software Engineer that's just graduated and currently interning at Microsoft.
I've spent some time learning more about the Blockchain ecosystem and I'm moving forward to specializing in this field.
I found the Raiden repo on up-for-grabs.net and saw there're a few issues labeled "good first issues".

Where would y'all recommend I get started to understand the system and to (hopefully) help contribute a bit?

1 reply
The Gouverneur
@MetaGouverneur_twitter

Hello everyone, glad to be here. I have a lot of questions about the Raiden network. First of all, I'd like to better understand how the tech works compared to the lightning network? Both use state channels, right? Is it more or less the same tech? What are the rough differences? The Raiden Network is solely focused on payments, right? Will it be cheaper than optimism for example?

Thanks in advance for any inputs :)

2 replies
Thecandypup
@thecandypup_twitter

Hi

I seem to be coming at this backwards. Any help would be good. I seem to be able to make these transactions for tokens for trade. How do I set up the process to transfer these tokens? Does anyone know the steps needed? Is there any step by step videos? Yep Iā€™m not an expert developer?
https://etherscan.io/tx/0x4a8baf6ba86dc1d78cc5144e77928e5479bf30fed814490f897e5f4e1e3cee90
https://etherscan.io/tx/0x6e40016d56e0d5ed4ded3d476aeb54b87afa92ea831e0e8891a055866f5ee5cf

Thanks

1 reply
vhcleite
@vhcleite
Hello guys! Is there any RSB server working in goerli network that is compatible with raiden 2.0.0? Looks that the servers presents in here https://github.com/raiden-network/raiden-service-bundle/blob/master/known_servers.test.yaml are not working...
Jacob Stenum Czepluch
@czepluch
So that would be without the /api/v1/info part
vhcleite
@vhcleite

Thanks for the reply @czepluch! I changed the pfs e matrix servers according to the command below:

./raiden-v2.0.0-linux-x86_64 --pathfinding-service-address=https://pfs.transport01.raiden.network --matrix-server=https://transport.transport01.raiden.network --eth-rpc-endpoint "https://goerli.infura.io:443/v3/xxxxxxxxxxxxxxxxx" --api-address "http://localhost:5001" --keystore-path ~/.ethereum/keystore --network-id goerli --environment-type development --log-config "raiden:debug" --accept-disclaimer

now I get this error:

1 reply
image.png
I created the accounts that I using for tests using raiden wizard... How can I change the token network registry from the accounts?
Aviv Eyal
@avive
hey, are there known issues with raiden software on macOS on ARM/M1 ? I've downloaded the wizard latest macOS release but I'm getting an OSError from ./raiden_wizard
12 replies
Also, I have an old Raiden account that was created using the raiden software. I have the account user-name and password combo. Anyone know how to retrieve the account private eth mainent key with this input?
The wizard if from latest release v1.3.0
Aviv Eyal
@avive
So regarding macOS/M1 - it is a possible bug with the wizard for raiden 2.0.0 - it works as expected on macOS/amd64
Aviv Eyal
@avive
Hi guys, I'm trying to use raiden again after a long time but I'm stuck on starting it up. I get this warning from the wizard:

`[warning ] Your Raiden database is version 26 and there is no compatible migration to version 27 available.
You need to either start a new Raiden node with a different account, or close and settle all channels, and start over with a fresh database.

More information on this topic at https://raiden-network.readthedocs.io/en/latest/other/known-issues.html#database-upgrades

If you are on mainnet and affected by this, please create an issue at https://github.com/raiden-network/raiden/issues/new?title=Mainnet%20Migration%2026%2027 [raiden.utils.upgrades]
Your Raiden database is version 26 and there is no compatible migration to version 27 available.
You need to either start a new Raiden node with a different account, or close and settle all channels, and start over with a fresh database.

More information on this topic at https://raiden-network.readthedocs.io/en/latest/other/known-issues.html#database-upgrades

If you are on mainnet and affected by this, please create an issue at https://github.com/raiden-network/raiden/issues/new?title=Mainnet%20Migration%2026%2027`

How can I access my existing funder account?
How can I settle all channels if I can't access the raiden app ?
Aviv Eyal
@avive
To be more specific, which release of raiden do I need to run in order to use db v26 ?
Jacob Stenum Czepluch
@czepluch
Hey @avive did you fix this?
iemwill
@iemwill
Hello šŸ‘‹šŸ½ are there stable releases and prototypes or even further?
Or in general, how is the status of the raiden-network :)?
titi
@alborz4048_titi_twitter
Hi i cant buy RDN.please help me how buy from pancakeswap???
Diego Ferrer
@Ferret-san
Hello, it's been a while since I last wrote something in here, but I saw this post and I was wondering if there's a place I can reference for how the team is adding Arbitrum to the MS and PFS so that I can do the same with my project.
5 replies
For reference, I worked on deploying Raiden to Optimism back in May but stopped working on it after I hit a blocker and had less time on my hands due to work and school, but I would like to finish what I started and my blocker was essentially the MS and PFS services not recognizing Optimism as a valid network even though I changed the code and built the images locally
Fraser Mackie
@WithoutWorries_twitter
tried loading the webpage but it seems odd, is it supposed to look like this?
1 reply
chao
@hackatoshi:matrix.org
[m]
Raiden wizard asks me to use infura. Is it possible to run with own node?
1 reply
Wyn Davies
@wynstrol
Hi guys. I am currently working on the Goerli network for my raiden node. However when starting my nodes I get the error Pathfinding Service is not operating on the same Token Network Registry (0x44c886653B536178831CF2Ca0724e0dd3f75FEd6) as your node (0x5a5CF4A63022F61F1506D1A2398490c2e8dfbb98). I am using https://pfs.transport01.raiden.network as my pathfinding service. I feel like I'm missing something here. There is not much information out there on the Token Network Registry. I have also tried not specifying a pfs so it gives me a random one but that service just says my nodes are offline (when I have 2 nodes running on my pc) so that doesnt seem to work either. Any help would be much appreciated.
Paul Lange
@palango
Hey @wynstrol , can you show me the command you use to start the raiden ndoe?
Paul Lange
@palango
And can you try adding a --development-environment unstable option if you didn't already? As we run integrations tests on those services we run them separate from the environment test users should use.
Wyn Davies
@wynstrol
Hey Paul. Here is the command I use: --eth-rpc-endpoint "${ETH_RPC_ENDPIONT}" --network-id goerli --environment-type development --api-address "0.0.0.0:5001" --pathfinding-service-address "https://pfs.transport01.raiden.network" --matrix-server "https://transport.transport01.raiden.network" --accept-disclaimer with the ETH_RPC_ENDPIONT being a infura address.
I tried adding --development-environment unstable but I get Error: no such option: --development-environment
Paul Lange
@palango
Which raiden version do you use?
Paul Lange
@palango
For this and for the interaction with the transport0X servers you should use the latest RC
7 replies
Wyn Davies
@wynstrol
raidennetwork/raiden:latest is what I have recently changed to. Before I used raidennetwork/raiden:develop but thought it was time for a change. Is this what you mean by the "latest RC"?
Paul Lange
@palango
if you need a docker image, please build it in the develop branch
We need to update the automatic docker builds after their changes to dockerhub
atomicdomb
@atomicdomb
Does one require SVT tokens in order to make payments even on Goerli Testnet?
atomicdomb
@atomicdomb

I keep getting this error when trying to make a transfer:
Payment couldn't be completed because: PFS returned an error while trying to fetch user information: ('There is no user found online for given address. (PFS error code: 2203)', {'address': '0xF447919A55CE3415077655E330a92fC0205fe823', 'seen_offline_since': 1391063.807376})

I'm on Goerli testnet.

Paul Lange
@palango
Depends on the PFS. If it requires payment, then you need SVT
But on testnets the service tokens are mintable
Is 0xF447919A55CE3415077655E330a92fC0205fe823 the target of your payment?
atomicdomb
@atomicdomb
@palango Yes 0xF447919A55CE3415077655E330a92fC0205fe823 is the target. I minted some SVT and tried again with some to no avail. The target payment is just another node I'm running, I'm basically just trying to get a test payment working between two of my own nodes. I've already set up a channel between them and the whole process of opening the channels and everything else went smoothly. This is the address of Node 1 "0x446ef514245D0Ba90f6f32F621498172d7ce0800" (The node trying to make the transfer). I didn't specify a PFS. I consistently get this error weather I attempt to send to a node that is offline or online...
Paul Lange
@palango
which PFS's are the nodes using and are you using the light client or python client?
Can you try shutting both nodes down, and leaving them shut down for at least 30s before restarting them
This usually helps if the PFS for some reason cached a wrong presence
YC Cap
@YesCapCapital_twitter
Where does one buy RDN? Looking for somewhere not binance preferably a DEX. Not seeing much liquidity for someone in the US?
3 replies
atomicdomb
@atomicdomb
@palango The PFS has been different when I've launched the node at different times. The last one I used was "https://pfs.transport01.raiden.network" which was automatically selected. I'm running things through Docker not the light client or the python client. I recently tried to run the raiden wizard on goerli and that ALSO failed. With the wizard it just gets to the end and says my node is funded with 0.1 Geth, 0 SVT and 1000 Test Tokens. It then has a button that says "Add Funds" instead of "Launch Raiden", when I click add funds it errors out and crashes. It shouldn't be this difficult to get a node up and running.
atomicdomb
@atomicdomb
So through using the Raiden_Wizard I got to the point where it let me click Launch Raiden and then after downloading and installing Raiden 1.1.1 I get this error in terminal "FATAL: An unexpected exception occurred. A traceback has been written to /tmp/raiden-exception-2021-10-07T12-138qi7u3p6.txt
You need a Byzantium enabled ethereum node. Parity >= 1.7.6 <= 2.7.2 or Geth >= 1.9.7 <= 1.9.11 but you have 1.10.8 EthClient.GETH". Do I need to change my ETH end point? I'm currently using on on infura.
6 replies
atomicdomb
@atomicdomb
Still getting this error "Unsupported Ethereum client version "Geth/v1.10.8-omnibus-aef5bfb3/linux-amd64/go1.16.7" [raiden.network.rpc.client] " on 2.0.0rc4 despite version 2.0.0rc4 stating that they added support for Geth 1.10, am I missing something?