These are chat archives for rails-sqlserver/activerecord-sqlserver-adapter

28th
Jan 2017
Steven Lumos
@slumos
Jan 28 2017 00:16
Has anyone managed to build a static tiny_tds gem for Linux?
Joe Bauser
@coderjoe
Jan 28 2017 00:18
To be honest I haven't heard of anybody trying yet.
CCH4GITHUB
@CCH4GITHUB
Jan 28 2017 10:05
Error:[rake --tasks] rake aborted!
LoadError: cannot load such file -- tiny_tds/tiny_tds
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:293:in require' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:293:inblock in require'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:259:in load_dependency' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:293:inrequire'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/tiny_tds-1.1.0-x86-mingw32/lib/tiny_tds.rb:22:in rescue in <top (required)>' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/tiny_tds-1.1.0-x86-mingw32/lib/tiny_tds.rb:25:in<top (required)>'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:in require' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:inblock (2 levels) in require'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:in each' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:inblock in require'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:75:in each' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:75:inrequire'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler.rb:106:in require' C:/RubymineProjects/pms4sql/config/application.rb:7:in<top (required)>'
C:/RubymineProjects/pms4sql/Rakefile:4:in require_relative' C:/RubymineProjects/pms4sql/Rakefile:4:in<top (required)>'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/rake_module.rb:28:in load' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/rake_module.rb:28:inload_rakefile'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:687:in raw_load_rakefile' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:96:inblock in load_rakefile'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:178:in standard_exception_handling' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:95:inload_rakefile'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:79:in block in run' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:178:instandard_exception_handling'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/rake-12.0.0/lib/rake/application.rb:77:in run' C:/RubymineProjects/pms4sql/bin/rake:4:in<main>'
LoadError: 126: The specified module could not be found. - C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/tiny_tds-1.1.0-x86-mingw32/lib/tiny_tds/2.2/tiny_tds.so
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:293:in require' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:293:inblock in require'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:259:in load_dependency' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activesupport-5.0.1/lib/active_support/dependencies.rb:293:inrequire'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/tiny_tds-1.1.0-x86-mingw32/lib/tiny_tds.rb:20:in <top (required)>' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:inrequire'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:in block (2 levels) in require' C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:ineach'
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/bund
I am using Ruby 226+Rails 5.01
CCH4GITHUB
@CCH4GITHUB
Jan 28 2017 10:47
Downgraded to Rails 4.2.7.1 but still unable to load tiny_tds :-(
Any guidance is appreciated.
Environment: Windows 8.1 Pro
Joe Bauser
@coderjoe
Jan 28 2017 16:50
@CCH4GITHUB we have a pretty long thread going on issue #330 up on the tiny_tds repository rails-sqlserver/tiny_tds#330
Would you mind adding a comment listing your OS, your achitecture, how you installed rails/ruby and the architecture of your ruby install?
an example would be: Windows 7, i686-pc-mingw32, installed via railsinstaller using 32 bit installer.