These are chat archives for ramda/ramda

Oct 2017
Oct 01 2017 04:59
Ive tried deep merge, and pipe(
zipObj(['name', 'typechild']),
x => ({ ...x, color: x.typechild[0], level: 1 }),
But no luck either
Julio Borja Barra
Oct 01 2017 10:06
@yarnball I would suggest putting names on partial functions so you get a more declarative/readable code
Oct 01 2017 12:05
@juboba I tried, but had no success with my real data. Could you show me an example?
Scott Sauyet
Oct 01 2017 16:47
@yarnball: I posted an answer on StackOverflow to a very similar question, and in it I used meaningful names on the intermediate functions as suggested by @juboba. I can't quite tell what it is you're looking for, but will that get you started?
Julio Borja Barra
Oct 01 2017 18:05
Sorry @yarnball for my late reply. Please check out @CrossEye 's answer.
And yes, this is exactly what I meant.