These are chat archives for reactioncommerce/reaction

22nd
Sep 2015
hrath2015
@hrath2015
Sep 22 2015 09:41
Getting the error while submitting Exception while invoking method 'cart/submitPayment' TypeError: Cannot read property '_id' of undefined
at [object Object].doValidate (packages/aldeed:collection2/collection2.js:290:1)
at [object Object].Mongo.Collection.(anonymous function) [as update] (packages/aldeed:collection2/collection2.js:169:1)
at packages/reactioncommerce:core/server/methods/cart.js:158:1
at [object Object]._.extend.forEach (packages/mongo/mongo_driver.js:965:1)
at [object Object].Cursor.(anonymous function) [as forEach] (packages/mongo/mongo_driver.js:812:1)
at [object Object].Meteor.methods.createCart (packages/reactioncommerce:core/server/methods/cart.js:137:1)
at packages/check/match.js:109:1
at [object Object]._.extend.withValue (packages/meteor/dynamics_nodejs.js:56:1)
at Object.Match._failIfArgumentsAreNotAllChecked (packages/check/match.js:108:1)
at maybeAuditArgumentChecks (packages/ddp/livedata_server.js:1614:1)
This message was deleted
Not sure why?
Bogi
@boboci9
Sep 22 2015 12:16
Hi all, I tried starting the app after a simple clone-packages.sh and I got
While selecting package versions:
   error: unknown package: isobuild:minifier-plugin
   Required by: standard-minifiers 1.0.0
Aaron Judd
@aaronjudd
Sep 22 2015 13:46
@hrath2015 bug.
@boboci9 Meteor 1.2 was released last night, causing some issues I think.
Bogi
@boboci9
Sep 22 2015 13:51
I think so too, I managed to start it for now with allow-incompatible-updates, but I though you should know
Aaron Judd
@aaronjudd
Sep 22 2015 13:56
thanks, I think I got 1.2 updates mixed into the dev branch, on analytics, fixing now, that’s probably the issue
Goutham Veeramachaneni
@gouthamve
Sep 22 2015 14:02
I dont think 1.2 might be the issue. On a fresh install, I get this Update to release METEOR@1.2.0.1 is impossible: followed by the incompatibilites.
even with --allow-incompatible-update
Aaron Judd
@aaronjudd
Sep 22 2015 14:03
you'd need to pick all our meteor-one-two branches, for all our packages, to use meteor 1.2.x
not ready just yet, there's a few communities packages we'll need to wait on
it's not a update and go, kind of update :-1:
Goutham Veeramachaneni
@gouthamve
Sep 22 2015 14:05
Oh, okay. Damn! I will check into one-two branches now.
Aaron Judd
@aaronjudd
Sep 22 2015 14:06
I think the only remaining (or at least current) roadblock is @mquandalle bower isn't working.
Bryan Wu
@cooloney
Sep 22 2015 16:46
@aaronjudd will beta release use meteor 1.2.x?
Aaron Judd
@aaronjudd
Sep 22 2015 16:46
yes
Bryan Wu
@cooloney
Sep 22 2015 16:48
cool. and will reaction replace coffeescript or ES5 to ES6 ECMAScript?
Aaron Judd
@aaronjudd
Sep 22 2015 16:49
coffeescript is already gone, but yes ES6 (with 1.2)
Bryan Wu
@cooloney
Sep 22 2015 16:53
Cool, thanks for letting me know