These are chat archives for reactioncommerce/reaction

31st
Dec 2015
Michael Jenny
@prinzdezibel
Dec 31 2015 17:41
Hi. is it possible to override values in variables.less in reaction-core-theme/default when using a custom theming package?
Owen Hoskins
@owenhoskins
Dec 31 2015 17:48
Hey all, I am looking for some info on how reaction is using git subtree with the packages folder. I found some mentions in the gitter history -- is there somewhere else to look?
Aaron Judd
@aaronjudd
Dec 31 2015 17:49
the packages folders are now just “regular” folders.. we used subtree to move some other (deprecated package) repos into the folder
Michael Jenny
@prinzdezibel
Dec 31 2015 17:51
@owenhoskins: Please check your PMs
Owen Hoskins
@owenhoskins
Dec 31 2015 17:53
@aaronjudd: thanks for the clarification. I now thought to inspect the .gitignore file in the packages directory and see why my package wasn't showing up
@prinzdezibel looking
Michael Jenny
@prinzdezibel
Dec 31 2015 17:53
I'm asking, because I can't figure out how to override @navbar-default-bg variable when using a custom theme.
Aaron Judd
@aaronjudd
Dec 31 2015 17:54
@prinzdezibel to be honest, not sure myself - I’d have to dig into it. @mikemurray probably knows..
Michael Jenny
@prinzdezibel
Dec 31 2015 17:55
(without re-defining the CSS rules where this variable gets used)
Owen Hoskins
@owenhoskins
Dec 31 2015 18:17
This message was deleted
Michael Jenny
@prinzdezibel
Dec 31 2015 18:52
@mikemurray: Concerning overriding less variables (e.g.) @navbar-default-bg. It works, when disabling the package reaction-default-theme altogether and instead copy over the content from main.less into my my:custom-theme/main.less. Wouldn't it make sense to communicate this as default way (https://reactioncommerce.com/docs/development/themes) and adapt main.less of package my-custom-theme-template accordingly?
New Years Eve Dinner here :wine_glass: HAPPY NEW YEAR !! :)
Jesus Millan
@JsusMillan
Dec 31 2015 19:54
Hello
i have problem
While selecting package versions:
error: unknown package: scss
Required by: my:bjbaby-theme 0.1.0
I want to use sass
i am install meteor add fourseven:scss
Owen Hoskins
@owenhoskins
Dec 31 2015 20:35
@JsusMillan in your packages.js you api.use("fourseven:scss");
Jesus Millan
@JsusMillan
Dec 31 2015 20:59
aaah good thanks =)
Hapṕy new years