These are chat archives for reactioncommerce/reaction

2nd
May 2016
Brent Hoover
@zenweasel
May 02 2016 02:40
I just went through and double-checked from a fresh checkout and was able to process orders using Braintree using master
Lukas Sägesser
@ScyDev
May 02 2016 09:13
@zenweasel Yes, I can process orders, but the Braintree settings in the admin backend are not displayed if reaction-paymentmethod is not enabled.
mind you, my fork is based on 0.12, so maybe this was fixed already.
Brent Hoover
@zenweasel
May 02 2016 09:13
That’s what I tested with
You have something else going on
do you have a local checkout of reaction-braintree?
Brent Hoover
@zenweasel
May 02 2016 09:22
Dashboard.png
Lukas Sägesser
@ScyDev
May 02 2016 09:22
Yes I do.
Brent Hoover
@zenweasel
May 02 2016 09:23
that’s running from a fresh checkout of the master branch with only Braintree package installed
can you verify that that package is on the development branch?
Lukas Sägesser
@ScyDev
May 02 2016 09:26
Ok then. I'll see how it works once I catch up. I don't use the latest official code on any of the packages because I couldn't afford the time to deal with things breaking when I merged.
Thanks anyway!
Brent Hoover
@zenweasel
May 02 2016 09:26
master is not the latest
It’s v0.12.3
can you verify that you are running reaction-braintree on the development branch.
There are no breaking changes there
useralive003
@useralive003
May 02 2016 09:28
hai help me out i am fresher i want to learn reactioncommerce help me out how can i start .give some tutorial
Lukas Sägesser
@ScyDev
May 02 2016 09:31
@zenweasel I really can't do that right now, we're going live. Can't risk any change that wasn't introduced by myself. Sorry for reporting a problem with an old code base ;)
arijit roy
@babin78
May 02 2016 13:27
hi i have already installed reaction on windows but getting black page without any error when running http://localhost:3000
pls help
hrath2015
@hrath2015
May 02 2016 15:06
@babin78 I am assuming u have take latest from Dev branch. Try commenting below in reaction logger folder package.js.
Npm.depends({
// "bunyan": "1.8.0",
// "bunyan-format": "0.2.1",
// "bunyan-loggly": "0.0.5"
});
see if that helps
icaruslee
@icaruslee
May 02 2016 20:12
hey @hrath2015. Run meteor update
Tom De Caluwé
@tdecaluwe
May 02 2016 20:55

Since upgrading to meteor 1.3 I'm running into:

While selecting package versions:
error: Conflict: Constraint aldeed:collection2@2.9.0 is not satisfied by aldeed:collection2 2.8.0.
Constraints on package "aldeed:collection2":
* aldeed:collection2@=2.8.0 <- top level
* aldeed:collection2@2.9.0 <- reactioncommerce:reaction-schemas 2.0.5 <- reactioncommerce:reaction-collections 2.2.0 <-
reactioncommerce:core 0.13.0
* aldeed:collection2@2.9.0 <- reactioncommerce:reaction-schemas 2.0.5 <- reactioncommerce:reaction-ui 0.7.0
* aldeed:collection2@2.0.0 <- aldeed:autoform 5.8.1 <- reactioncommerce:core 0.13.0

But top-level hasn't a direct aldeed:collection2 dependency... Any thoughts?

Aaron Judd
@aaronjudd
May 02 2016 21:58
I think the only place is in reaction-collections.. but that’s strange.. any packages customized?
Tom De Caluwé
@tdecaluwe
May 02 2016 22:28
I did, however, I also checked with a standard development branch checkout and the error persists. Currently checking with a fresh clone...
Tom De Caluwé
@tdecaluwe
May 02 2016 22:36
Removing anything meteor and a fresh clone on another machine seems to fix it :) Doesn't help much in identifying the problem...