These are chat archives for reactioncommerce/reaction

28th
May 2016
@motoxuz
@motoxuz_twitter
May 28 2016 09:18
I run "meteor npm install" it is stuck at Fetching package details....
@motoxuz
@motoxuz_twitter
May 28 2016 09:34
I tried with powershell and it works, git bash was giving problems
Brent Hoover
@zenweasel
May 28 2016 09:35
I am not sure, because that’s just a meteor function and as long as you have connectivity it should work
did you run ./reaction pull?
@motoxuz
@motoxuz_twitter
May 28 2016 09:36
no, but it is pulling
Brent Hoover
@zenweasel
May 28 2016 09:36
what is pulling?
@motoxuz
@motoxuz_twitter
May 28 2016 09:37
I mean it is updating stuff and adding missing bits
Brent Hoover
@zenweasel
May 28 2016 09:37
Can you cancel out of it?
Or is it hard frozen?
@motoxuz
@motoxuz_twitter
May 28 2016 09:37
I see you mean the fetching package.. yep that is resolved
thanks
Brent Hoover
@zenweasel
May 28 2016 09:38
Ah ok
@motoxuz
@motoxuz_twitter
May 28 2016 09:43
@zenweasel now it tried starting application and it says %1 is not a valid win32 application
@zenweasel your application is crashing waiting for file change
Brent Hoover
@zenweasel
May 28 2016 09:48
It sounds like something has become corrupted
can you create another meteor application by doing meteor create xxxx and see if you can start that application?
hrath2015
@hrath2015
May 28 2016 09:50
also u can refer to reactioncommerce/reaction#404
I guess this is problem because of node-aes-gcm package
@motoxuz
@motoxuz_twitter
May 28 2016 09:51
@hrath2015 yes correct
hrath2015
@hrath2015
May 28 2016 09:51
on Windows u have to do the intial set up as per installation doc
@motoxuz
@motoxuz_twitter
May 28 2016 09:51
@zenweasel it worked, the test app runs "Welcome to meteor"
@hrath2015 yes i followed that and i had openssl already installed
hrath2015
@hrath2015
May 28 2016 09:52
window 7?
@motoxuz
@motoxuz_twitter
May 28 2016 09:52
@hrath2015 it complains about fibers\future.js:245, is not a valid win32 application
hrath2015
@hrath2015
May 28 2016 09:53
I know the problem
do this "meteor remove oauth-encryption"
from app directory
@motoxuz
@motoxuz_twitter
May 28 2016 09:56
@hrath2015 it says oauth-encryption is not a direct dependency in this project
hrath2015
@hrath2015
May 28 2016 09:56
and comment the this line api.use("oauth-encryption") in package.js in reaction-accounts and reaction-core pakcage
then try this meteor remove node-aes-gcm
@motoxuz
@motoxuz_twitter
May 28 2016 09:59
@hrath2015 ok, it is trying to launch... waiting
hrath2015
@hrath2015
May 28 2016 10:00
keep an eye on console u will get admin password printed on it
@motoxuz
@motoxuz_twitter
May 28 2016 10:01
@hrath2015 ok, it is working, I am thinking of setting it up with my products and run it on ibm bluemix
hrath2015
@hrath2015
May 28 2016 10:02
in case u have not used the settings file
:+1:
@motoxuz
@motoxuz_twitter
May 28 2016 10:02
@hrath2015 I think I should be able to reactivate oauth when pushing to ibm, there environement can build anything :)
hrath2015
@hrath2015
May 28 2016 10:02
Yes u can
as long it is not windows env
@motoxuz
@motoxuz_twitter
May 28 2016 10:03
@hrath2015 I see, tks
Valery Orloff
@valorloff
May 28 2016 10:57
if i insert image to media collection by REST, with corresponding metadata.productId and metadata.shopId, is it enough it has been automatically linked to product and displayed in product detail?
or relation to the product has additional another way ?
Brent Hoover
@zenweasel
May 28 2016 11:33
@hrath2015 Thanks for helping. I would not have known that at all
xiaoc li
@brianxcli
May 28 2016 11:36
I have the issue but when I run Reaction in Docker
I've tried several nodejs version, but still the same
Brent Hoover
@zenweasel
May 28 2016 11:37
@brianxcli The issue with oauth-encryption?
xiaoc li
@brianxcli
May 28 2016 11:37
Oh, no. The issue of node-aes-gcm
blob
Brent Hoover
@zenweasel
May 28 2016 11:40
Ok, well that’s super confusing :worried:
xiaoc li
@brianxcli
May 28 2016 11:43
No reason for that online. Someone said it is nodejs version problem. I changed the version from 0.10.40 to 4.4.3 and 4.4.5, but the same
Brent Hoover
@zenweasel
May 28 2016 11:43
Have you tried 1.3.3? Meteor I mean.
Not sure why that would help. Shot in the dark.
xiaoc li
@brianxcli
May 28 2016 11:44
The latest Meteor I can download is 1.3.2.4
Brent Hoover
@zenweasel
May 28 2016 11:45
meteor update --release 1.3.3-beta.1
xiaoc li
@brianxcli
May 28 2016 11:53
I am building the image
developergrizzly
@developergrizzly
May 28 2016 11:56
Hello All,
I am new in reaction commerce.
I need to help for installation of reaction in windows.
Is any here who can help me on that ?
xiaoc li
@brianxcli
May 28 2016 11:56
I remember I got the same error when I deployed the project to AWS
Brent Hoover
@zenweasel
May 28 2016 11:56
@developergrizzly Have you run through the steps in the docs?
developergrizzly
@developergrizzly
May 28 2016 11:58
Yes, i have go through with steps and when try to run ./reaction command it will go for downloading meteor tool
but that tool takes long time and at end it will give error and not install
Brent Hoover
@zenweasel
May 28 2016 12:01
That is just meteor starting up for the first time. Does it actually error out?
hrath2015
@hrath2015
May 28 2016 12:01
@developergrizzly try what @zenweasel suggested. Create another app and run first. Just to isolate the problem. meteor create xxxx
developergrizzly
@developergrizzly
May 28 2016 12:01
no, it go for download and never end
hrath2015
@hrath2015
May 28 2016 12:01
It could be slow internet connection
Brent Hoover
@zenweasel
May 28 2016 12:01
Yeah, what @hrath2015 said I said
Yeah, where are you? It’s slow for me here in Southeast Asia
developergrizzly
@developergrizzly
May 28 2016 12:02
it downloading and downloading
i am from India
i have 10mbps plan at my office
hrath2015
@hrath2015
May 28 2016 12:03
try a plain meteor create xxxx first and run it
@motoxuz
@motoxuz_twitter
May 28 2016 12:03
@hrath2015 hi, I have a problem with settings, I have created a mongodb at mongolab I put mongourl in settings file but it is not using the online mongodb
J T
@wytanj
May 28 2016 12:04
@zenweasel which part of SEA are you at?
Brent Hoover
@zenweasel
May 28 2016 12:04
I am in the Philippines
J T
@wytanj
May 28 2016 12:04
:D slowest internet of the entire SEA indeed
developergrizzly
@developergrizzly
May 28 2016 12:04
@hrath2015 and @zenweasel Thanks for help i am trying to plain meteor create
Brent Hoover
@zenweasel
May 28 2016 12:05
@wytanj True. I think in all of Asia
hrath2015
@hrath2015
May 28 2016 12:10
@motoxuz_twitter I have worked so far with local mongo db instance only. so can't say much
may be others can help.
xiaoc li
@brianxcli
May 28 2016 12:19
@zenweasel meteor 1.3.3 does fix the issue
@motoxuz
@motoxuz_twitter
May 28 2016 12:20
I am pushing to ibm bluemix as meteor app it is trying to upload 300MB
@motoxuz
@motoxuz_twitter
May 28 2016 12:38
I see
Brent Hoover
@zenweasel
May 28 2016 12:44
@motoxuz_twitter Are you having the problems using the Mongolab instance from your local machine or a deployed instance?
@motoxuz
@motoxuz_twitter
May 28 2016 17:40
@zenweasel hi, i have added settings.json with mongodburl in it but it is not using my mongodb from mongolab it is still using some local it generated itself
@zenweasel it says: Starting Reaction using '/c/Users/Ario/Documents/reaction/settings/settings.json', but when i look in mongolab the database is empty
@motoxuz
@motoxuz_twitter
May 28 2016 17:47
what if I do a ./reaction reset, does it start using my mongolab db?
hrath2015
@hrath2015
May 28 2016 17:57
@motoxuz_twitter is mongolab free. I can try from machine and see if it works for me.
@motoxuz
@motoxuz_twitter
May 28 2016 17:57
@hrath2015 , yes you can get 500MB for free
@motoxuz
@motoxuz_twitter
May 28 2016 18:10
@hrath2015 , I am gonna try reaction on a mac, see if I get same results, hopefully it will all be easier :)
hrath2015
@hrath2015
May 28 2016 18:25
OK
developergrizzly
@developergrizzly
May 28 2016 21:45
Hello I am new in reaction commerce.
I am facing this error while running reaction this command on git bash
bin/clone-packages.sh
error.png
is any one here who can help me on that
?
@motoxuz
@motoxuz_twitter
May 28 2016 22:03
Did a new try: I deployed with Docker to Digital Ocean, but when I try with browser it says connection refused
@motoxuz
@motoxuz_twitter
May 28 2016 22:13
got the logs, ERROR: Mongo not installed inside container. Rebuild with INSTALL_MONGO=true
please help
xiaoc li
@brianxcli
May 28 2016 22:57
@motoxuz_twitter If you would like to know the reason, please refer to Dockerfile and ./docker/scripts
If you want to run Mongo with you docker image, change INSTALL_MONGO to "true", in Dockerfile
This message was deleted
This message was deleted
xiaoc li
@brianxcli
May 28 2016 23:03
If you want to run Mongo in a separate container, change mongo url to the real ip address of your host rather than localhost or 127.0.0.1
@motoxuz
@motoxuz_twitter
May 28 2016 23:10
@brianxcli , my mongodb is on www.mongolab.com I have a url for it but the db is empty, so you mean if I change INSTALL_MONGO to true it will initialize my mongolab db?
xiaoc li
@brianxcli
May 28 2016 23:11
Have you changed your Mongo url in the Dockerfile?
I think you may forget the change or you changed a wrong value
@motoxuz
@motoxuz_twitter
May 28 2016 23:12
nope it is specified as a environement variable, docker run -e MONGO_URL
xiaoc li
@brianxcli
May 28 2016 23:16
Then the url is not set properly in some way. The code is
blob
For me, I just comment out this code
@motoxuz
@motoxuz_twitter
May 28 2016 23:18
but if you look at digitalocean comments other people mention same problem as I had check this link https://hub.docker.com/r/reactioncommerce/reaction/
see comments below on that page, everybody have same problem as i have
xiaoc li
@brianxcli
May 28 2016 23:21
The -e options are not used in the case? I don't know that, because I change it in Dockerfile
@motoxuz
@motoxuz_twitter
May 28 2016 23:21
i can give you access to my pc with teamviewer can you help me get it running
or i can send my digitalocean_access_token
xiaoc li
@brianxcli
May 28 2016 23:25
Well, can you please try to comment out these lines of code? It's in project-path/docker/scripts/entrypoint.sh, or you can change you mongo url in project-path/Dockerfile.
And then build the image again
@motoxuz
@motoxuz_twitter
May 28 2016 23:27
i dont know how to use dockerfile, I am new to dockers, I can just run the command to get latest stable build
xiaoc li
@brianxcli
May 28 2016 23:27
This message was deleted
blob
Change this line to your mongo url
@motoxuz
@motoxuz_twitter
May 28 2016 23:34
ok, I am trying to shell to the container and then I will edit it with vi
xiaoc li
@brianxcli
May 28 2016 23:35
In your project, not docker I guess?
@motoxuz
@motoxuz_twitter
May 28 2016 23:46
are you developing locally and then you push it via docker?
what is the command for that