These are chat archives for reactioncommerce/reaction

25th
Jul 2016
3Maestros
@3Maestros
Jul 25 2016 00:16
@zenweasel thank you, shouldn't reaction/beesknees/client/templates/products/productsLanding.js and productList.js import their respective HTML files? Just like review.js importing review.html, Is this a miss?
Brent Hoover
@zenweasel
Jul 25 2016 00:19
Let me look at it
No, those are all imported in the index file
review.js should probably be changed to be consistent with the rest
It’s 6 of one, half-dozen of the other, but we are trying to be consistent with putting things in index.js
3Maestros
@3Maestros
Jul 25 2016 00:25
got it thank you !
3Maestros
@3Maestros
Jul 25 2016 00:58
Anyone seen following error when you run beesknees plugin While processing files with less (for target web.browser):
beesknees/client/styles/main.less:62: Unknown import:
It is failing at this line @import "/imports/themes/default/styles/alerts.less"; I dont see any themes folder under imports.
Brent Hoover
@zenweasel
Jul 25 2016 01:00
Hmmm, the theme may have been moved
I think it got moved to plugins/included/default-theme
3Maestros
@3Maestros
Jul 25 2016 01:05
yeah...
do you want me to fix it commit?
Brent Hoover
@zenweasel
Jul 25 2016 01:07
I just pushed the fixed version
3Maestros
@3Maestros
Jul 25 2016 01:08
ok thank you !
3Maestros
@3Maestros
Jul 25 2016 03:52
I get following error when I run beesknees "install.js:101Uncaught Error: Cannot find module '/server/api'" I have beesnees folder at same level as "imports". I dont see anything wrong in the line "import { Reaction } from "/server/api";" in Register.js . Is anyone seeing this error?
Brent Hoover
@zenweasel
Jul 25 2016 03:53
Are you trying to import that from a file on the client-side?
I’m running that repo here locally and not seeing the issue
3Maestros
@3Maestros
Jul 25 2016 03:54
where do you have the folder beesknees in the hierarchy?
Brent Hoover
@zenweasel
Jul 25 2016 03:55
imports/plugins/custom/beesknees
3Maestros
@3Maestros
Jul 25 2016 03:55
guess this is the issue ...
I have it as peer of imports ..
Brent Hoover
@zenweasel
Jul 25 2016 03:56
If it’s not in an imports directory Meteor will autoload it
3Maestros
@3Maestros
Jul 25 2016 03:57
I am still learning new import/export concepts , thank you ...
Brent Hoover
@zenweasel
Jul 25 2016 03:58
Yeah, me too. No worries.
3Maestros
@3Maestros
Jul 25 2016 04:17
I see error "Cannot read property 'onRendered' in review.js line 9 in console but went away when I added "import "./review.html"; in review.js. I see that you imported review in template/index.js , this is wierd ...
now the app is starting clean ..
Brent Hoover
@zenweasel
Jul 25 2016 04:17
I’m not seeing that
3Maestros
@3Maestros
Jul 25 2016 04:19
I guess I need delete and do a clean pull, let me try that .
fesh pull I mean
Brent Hoover
@zenweasel
Jul 25 2016 04:19
I feel like I saw that error as well and that was why I added the import, but it shouldn’t actually matter
3Maestros
@3Maestros
Jul 25 2016 04:31
did a fresh pull saw same error again , added line "import "./review.html";" to get rid of it ...
Brent Hoover
@zenweasel
Jul 25 2016 04:31
Hmmm
I don’t have that and I’m not seeing the error. What version of Meteor?
Maybe try swapping the order of the imports in the index.js? Put the HTML file first?
3Maestros
@3Maestros
Jul 25 2016 04:35
meteor is same as you have in release 14 1.3.5.1
let try swapping the order ...
also ever attempt to view the page first time after login results in "This page was not found." , second attempt is fine.
Brent Hoover
@zenweasel
Jul 25 2016 04:37
Yeah, that’s a known issue. reactioncommerce/reaction#1122
3Maestros
@3Maestros
Jul 25 2016 04:39
changing the order fixed it ..:)
Brent Hoover
@zenweasel
Jul 25 2016 04:39
This message was deleted
weird
3Maestros
@3Maestros
Jul 25 2016 04:40
yup
Brent Hoover
@zenweasel
Jul 25 2016 04:40
I mean, it does sort of make sense
just don’t know why I am not seeing it
3Maestros
@3Maestros
Jul 25 2016 04:40
same meteor verion?
Brent Hoover
@zenweasel
Jul 25 2016 04:41
Yep, what version of node?
3Maestros
@3Maestros
Jul 25 2016 04:41
v6.2.2
Brent Hoover
@zenweasel
Jul 25 2016 04:41
same
well, I will make that change in the repo anyway so that no one else runs into it
3Maestros
@3Maestros
Jul 25 2016 04:42
thanks for your help!
Brent Hoover
@zenweasel
Jul 25 2016 04:42
No problem
3Maestros
@3Maestros
Jul 25 2016 04:53
And I believe "Template.productGridItems.helpers({" in file productGrid/item.js line 19 should be "productGridItemsBeesknees" instead?
Brent Hoover
@zenweasel
Jul 25 2016 04:54
Probably
hrath2015
@hrath2015
Jul 25 2016 17:34
Need 1 help. So far I was using local MongoDB. Today I setup an account @ mlab and updated mongo_url in settings.json. Did meteor reset. Still meteor is using 3001 on local. No collection created on mlab instance. Thanks in advance
Jeremy Shimko
@jshimko
Jul 25 2016 17:52
The MONGO_URL is settings.json is not actually implemented. The docs need to be updated.
Just prepend the reaction command with your new URL.
MONGO_URL='mongodb://url:port' reaction
othmaan
@othmaan
Jul 25 2016 18:41
I can't find client/main.js

from Reaction documentation...

So since we are going to inherit styles into our plugin we don’t want them inserted twice so we will comment-out the import in client/main.js

// import "/imports/themes/default";

Jeremy Shimko
@jshimko
Jul 25 2016 18:44
the default theme has been moved to /imports/plugins/included/default-theme and gets loaded by the plugin loader
othmaan
@othmaan
Jul 25 2016 18:48
Thanks a lot. Is there any updated guide to customize ReactionCommerce?
hrath2015
@hrath2015
Jul 25 2016 18:54
@jshimko that worked great. thanks
Mike Murray
@mikemurray
Jul 25 2016 18:58
@othmaan theming guide will be updated today
othmaan
@othmaan
Jul 25 2016 19:01
@mikemurray 👍🏼
hrath2015
@hrath2015
Jul 25 2016 19:19
@jshimko timing issue is still there. Seen in 2 scenarios: First using Dev build where mongo is remote (free instance in US east coast) Second prod deploy using mupx where app and mongodb both are local. ShopId is null for translation and shipping in mupx deploy. In Dev build shipping collection has shopid as null. Only case where it is working fine is local-local dev build.
Jeremy Shimko
@jshimko
Jul 25 2016 21:34
Thanks for reporting @hrath2015. That problem just doesn’t want to die. I’ll take a look and see what we can do.