These are chat archives for reactioncommerce/reaction

25th
Jul 2016
3Maestros
@3Maestros
Jul 25 2016 00:16 UTC
@zenweasel thank you, shouldn't reaction/beesknees/client/templates/products/productsLanding.js and productList.js import their respective HTML files? Just like review.js importing review.html, Is this a miss?
Brent Hoover
@zenweasel
Jul 25 2016 00:19 UTC
Let me look at it
No, those are all imported in the index file
review.js should probably be changed to be consistent with the rest
It’s 6 of one, half-dozen of the other, but we are trying to be consistent with putting things in index.js
3Maestros
@3Maestros
Jul 25 2016 00:25 UTC
got it thank you !
3Maestros
@3Maestros
Jul 25 2016 00:58 UTC
Anyone seen following error when you run beesknees plugin While processing files with less (for target web.browser):
beesknees/client/styles/main.less:62: Unknown import:
It is failing at this line @import "/imports/themes/default/styles/alerts.less"; I dont see any themes folder under imports.
Brent Hoover
@zenweasel
Jul 25 2016 01:00 UTC
Hmmm, the theme may have been moved
I think it got moved to plugins/included/default-theme
3Maestros
@3Maestros
Jul 25 2016 01:05 UTC
yeah...
do you want me to fix it commit?
Brent Hoover
@zenweasel
Jul 25 2016 01:07 UTC
I just pushed the fixed version
3Maestros
@3Maestros
Jul 25 2016 01:08 UTC
ok thank you !
3Maestros
@3Maestros
Jul 25 2016 03:52 UTC
I get following error when I run beesknees "install.js:101Uncaught Error: Cannot find module '/server/api'" I have beesnees folder at same level as "imports". I dont see anything wrong in the line "import { Reaction } from "/server/api";" in Register.js . Is anyone seeing this error?
Brent Hoover
@zenweasel
Jul 25 2016 03:53 UTC
Are you trying to import that from a file on the client-side?
I’m running that repo here locally and not seeing the issue
3Maestros
@3Maestros
Jul 25 2016 03:54 UTC
where do you have the folder beesknees in the hierarchy?
Brent Hoover
@zenweasel
Jul 25 2016 03:55 UTC
imports/plugins/custom/beesknees
3Maestros
@3Maestros
Jul 25 2016 03:55 UTC
guess this is the issue ...
I have it as peer of imports ..
Brent Hoover
@zenweasel
Jul 25 2016 03:56 UTC
If it’s not in an imports directory Meteor will autoload it
3Maestros
@3Maestros
Jul 25 2016 03:57 UTC
I am still learning new import/export concepts , thank you ...
Brent Hoover
@zenweasel
Jul 25 2016 03:58 UTC
Yeah, me too. No worries.
3Maestros
@3Maestros
Jul 25 2016 04:17 UTC
I see error "Cannot read property 'onRendered' in review.js line 9 in console but went away when I added "import "./review.html"; in review.js. I see that you imported review in template/index.js , this is wierd ...
now the app is starting clean ..
Brent Hoover
@zenweasel
Jul 25 2016 04:17 UTC
I’m not seeing that
3Maestros
@3Maestros
Jul 25 2016 04:19 UTC
I guess I need delete and do a clean pull, let me try that .
fesh pull I mean
Brent Hoover
@zenweasel
Jul 25 2016 04:19 UTC
I feel like I saw that error as well and that was why I added the import, but it shouldn’t actually matter
3Maestros
@3Maestros
Jul 25 2016 04:31 UTC
did a fresh pull saw same error again , added line "import "./review.html";" to get rid of it ...
Brent Hoover
@zenweasel
Jul 25 2016 04:31 UTC
Hmmm
I don’t have that and I’m not seeing the error. What version of Meteor?
Maybe try swapping the order of the imports in the index.js? Put the HTML file first?
3Maestros
@3Maestros
Jul 25 2016 04:35 UTC
meteor is same as you have in release 14 1.3.5.1
let try swapping the order ...
also ever attempt to view the page first time after login results in "This page was not found." , second attempt is fine.
Brent Hoover
@zenweasel
Jul 25 2016 04:37 UTC
Yeah, that’s a known issue. reactioncommerce/reaction#1122
3Maestros
@3Maestros
Jul 25 2016 04:39 UTC
changing the order fixed it ..:)
Brent Hoover
@zenweasel
Jul 25 2016 04:39 UTC
This message was deleted
weird
3Maestros
@3Maestros
Jul 25 2016 04:40 UTC
yup
Brent Hoover
@zenweasel
Jul 25 2016 04:40 UTC
I mean, it does sort of make sense
just don’t know why I am not seeing it
3Maestros
@3Maestros
Jul 25 2016 04:40 UTC
same meteor verion?
Brent Hoover
@zenweasel
Jul 25 2016 04:41 UTC
Yep, what version of node?
3Maestros
@3Maestros
Jul 25 2016 04:41 UTC
v6.2.2
Brent Hoover
@zenweasel
Jul 25 2016 04:41 UTC
same
well, I will make that change in the repo anyway so that no one else runs into it
3Maestros
@3Maestros
Jul 25 2016 04:42 UTC
thanks for your help!
Brent Hoover
@zenweasel
Jul 25 2016 04:42 UTC
No problem
3Maestros
@3Maestros
Jul 25 2016 04:53 UTC
And I believe "Template.productGridItems.helpers({" in file productGrid/item.js line 19 should be "productGridItemsBeesknees" instead?
Brent Hoover
@zenweasel
Jul 25 2016 04:54 UTC
Probably
hrath2015
@hrath2015
Jul 25 2016 17:34 UTC
Need 1 help. So far I was using local MongoDB. Today I setup an account @ mlab and updated mongo_url in settings.json. Did meteor reset. Still meteor is using 3001 on local. No collection created on mlab instance. Thanks in advance
Jeremy Shimko
@jshimko
Jul 25 2016 17:52 UTC
The MONGO_URL is settings.json is not actually implemented. The docs need to be updated.
Just prepend the reaction command with your new URL.
MONGO_URL='mongodb://url:port' reaction
othmaan
@othmaan
Jul 25 2016 18:41 UTC
I can't find client/main.js

from Reaction documentation...

So since we are going to inherit styles into our plugin we don’t want them inserted twice so we will comment-out the import in client/main.js

// import "/imports/themes/default";

Jeremy Shimko
@jshimko
Jul 25 2016 18:44 UTC
the default theme has been moved to /imports/plugins/included/default-theme and gets loaded by the plugin loader
othmaan
@othmaan
Jul 25 2016 18:48 UTC
Thanks a lot. Is there any updated guide to customize ReactionCommerce?
hrath2015
@hrath2015
Jul 25 2016 18:54 UTC
@jshimko that worked great. thanks
Mike Murray
@mikemurray
Jul 25 2016 18:58 UTC
@othmaan theming guide will be updated today
othmaan
@othmaan
Jul 25 2016 19:01 UTC
@mikemurray 👍🏼
hrath2015
@hrath2015
Jul 25 2016 19:19 UTC
@jshimko timing issue is still there. Seen in 2 scenarios: First using Dev build where mongo is remote (free instance in US east coast) Second prod deploy using mupx where app and mongodb both are local. ShopId is null for translation and shipping in mupx deploy. In Dev build shipping collection has shopid as null. Only case where it is working fine is local-local dev build.
Jeremy Shimko
@jshimko
Jul 25 2016 21:34 UTC
Thanks for reporting @hrath2015. That problem just doesn’t want to die. I’ll take a look and see what we can do.