These are chat archives for reactioncommerce/reaction

12th
Aug 2016
RefactorMan
@RefactorMan
Aug 12 2016 00:05
@zenweasel reaction init OR npm install
Brent Hoover
@zenweasel
Aug 12 2016 00:05
You should be doing meteor npm install
but that’s what reaction init is running
RefactorMan
@RefactorMan
Aug 12 2016 00:05
the problem is the postinstall script
I tried execute the command by myself
".reaction/scripts/postinstall.sh"
but i get:
'.reaction' is not recognized as an internal or external command,
operable program or batch file.
Brent Hoover
@zenweasel
Aug 12 2016 00:09
Yeah, bash scripts don’t work under Windows
Try commenting out that line in the package.json
RefactorMan
@RefactorMan
Aug 12 2016 00:10
okay thanks
RefactorMan
@RefactorMan
Aug 12 2016 00:20
@zenweasel now there is other error :(

=> Started proxy.
=> Started MongoDB.
=> Errors prevented startup:

While checking for npm-node-aes-gcm@0.1.7_4:
error: No compatible binary build found for this package. Contact the
package author and ask them to publish it for your platform.

=> Your application has errors. Waiting for file change.

Brent Hoover
@zenweasel
Aug 12 2016 00:21
Do you have the MS Build Tools installed?
RefactorMan
@RefactorMan
Aug 12 2016 00:21
yes ..
Brent Hoover
@zenweasel
Aug 12 2016 00:46
Every reference I see to that error references the build tools not being installed or misconfigured
what happens if you do msbuild?
3Maestros
@3Maestros
Aug 12 2016 02:50
is there any explaination around "Reaction.registerPackage" , I have read the "Routing" chapter in customization guide but it does not talk about all the attributes used here, just few selected attributes.
No, the customization guide would not be for going over every attribute of registerPackage
3Maestros
@3Maestros
Aug 12 2016 02:54
no I haven't, thank you @zenweasel
3Maestros
@3Maestros
Aug 12 2016 03:24
I read this statement Layouts defined here need to also exist in the Shops.layout collection to enable them.
where is Shops.layout?
Brent Hoover
@zenweasel
Aug 12 2016 03:24
the Shops collection
Robomongo_0_9_0-RC9.png
3Maestros
@3Maestros
Aug 12 2016 03:26
how is this populated?
Brent Hoover
@zenweasel
Aug 12 2016 03:26
layout records in packages
3Maestros
@3Maestros
Aug 12 2016 03:27
ok
do you have a example?
3Maestros
@3Maestros
Aug 12 2016 04:07
what is a structure inside a layout?
structure: { template: "cartCheckout", layoutHeader: "checkoutHeader", layoutFooter: "", notFound: "notFound", dashboardHeader: "", dashboardControls: "dashboardControls", dashboardHeaderControls: "", adminControlsFooter: "adminControlsFooter" }
3Maestros
@3Maestros
Aug 12 2016 04:13
This message was deleted
3Maestros
@3Maestros
Aug 12 2016 04:22
is this like general layout settings?
Brent Hoover
@zenweasel
Aug 12 2016 04:23
no, different workflows may render different templates in there
RefactorMan
@RefactorMan
Aug 12 2016 09:16

@zenweasel

Every reference I see to that error references the build tools not being installed or misconfigured

hey, I added to PATH the msbuild directory of .NET 4 "C:\Windows\Microsoft.NET\Framework\v4.0.30319"

now the msbuild command exists
but now the error is different

=> Started proxy.
=> Started MongoDB.
=> Errors prevented startup:

While checking for npm-node-aes-gcm@0.1.7_4:
error: No compatible binary build found for this package. Contact the
package author and ask them to publish it for your platform.

=> Your application has errors. Waiting for file change.

RefactorMan
@RefactorMan
Aug 12 2016 09:23
Sorry I made a mistake, the same error appears.
Lukas Sägesser
@ScyDev
Aug 12 2016 09:54
Hay anyone done a voucher package for Reaction, giving customers a discount during checkout if they enter a code?
Brent Hoover
@zenweasel
Aug 12 2016 10:07
No, but it’s on the schedule for September
aaronmann613348
@aaronmann613348
Aug 12 2016 10:08
Hey I just started installing reaction. The installation instructions were working fine until I had to run it. Then I got " While loading package npm-bcrypt@0.8.7:
error: Command failed:
Brent Hoover
@zenweasel
Aug 12 2016 10:08
what platform are you on?
aaronmann613348
@aaronmann613348
Aug 12 2016 10:09
Mac OS
Brent Hoover
@zenweasel
Aug 12 2016 10:09
how did you install?
aaronmann613348
@aaronmann613348
Aug 12 2016 10:09
and wow quick answer thanks
basic instructions, followed npm install -g reaction-cli
reaction init
used sudo to execute npm install
Brent Hoover
@zenweasel
Aug 12 2016 10:11
what happens in you run meteor npm install
I’m running OSX here and have never seen that error
aaronmann613348
@aaronmann613348
Aug 12 2016 10:12
reaction@0.14.2 postinstall /Users/Aaron/reaction
.reaction/scripts/postinstall.sh
Brent Hoover
@zenweasel
Aug 12 2016 10:13
do you have XCode installed?
aaronmann613348
@aaronmann613348
Aug 12 2016 10:13
I do
Brent Hoover
@zenweasel
Aug 12 2016 10:14
Hmmm, I don’t know. That’s a new one
aaronmann613348
@aaronmann613348
Aug 12 2016 10:14
tho I haven't check it in a while but idk
yay
Brent Hoover
@zenweasel
Aug 12 2016 10:14
Meteor requires XCode installed and working to build all binary dependencies, one of which is BCrypt
aaronmann613348
@aaronmann613348
Aug 12 2016 10:15
Is the install supposed to work in a vacuum or is there a list of things to have before hand?
I should check my xcode status
never know
Brent Hoover
@zenweasel
Aug 12 2016 10:16
xcode-select —install
You need Node.js >=4.x.x (with NPM)
aaronmann613348
@aaronmann613348
Aug 12 2016 10:18
thanks, ive been in traveling for a few months im in need of an os update lemme try that and get back to you
Brent Hoover
@zenweasel
Aug 12 2016 10:19
kk
aaronmann613348
@aaronmann613348
Aug 12 2016 10:31
nope still stuck on BCrypt not being loaded
any suggestions for update BCrypt
updating*
Brent Hoover
@zenweasel
Aug 12 2016 10:34
if everything is installed correctly, it should just build it when you do meteor npm install
aaronmann613348
@aaronmann613348
Aug 12 2016 10:37

yea the line executes but just produces

reaction@0.14.2 postinstall /Users/Aaron/reaction
.reaction/scripts/postinstall.sh

Brent Hoover
@zenweasel
Aug 12 2016 11:09
I just ran the process from scratch on my machine and it worked fine, so I don’t know what else to tell you
dileep kushwaha
@dileepkush_twitter
Aug 12 2016 13:48
I'm unable to upload images.
Brent Hoover
@zenweasel
Aug 12 2016 13:53
Did you install imagemagick?
dileep kushwaha
@dileepkush_twitter
Aug 12 2016 13:53
yes i did
dp@dp-vault:~/play/reaction-master$ convert -version
Version: ImageMagick 7.0.2-7 Q16 i686 2016-08-08 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2016 ImageMagick Studio LLC
License: http://www.imagemagick.org/script/license.php
Features: Cipher DPC HDRI OpenMP
Delegates (built-in): zlib
Brent Hoover
@zenweasel
Aug 12 2016 13:56
are you getting an error or?
dileep kushwaha
@dileepkush_twitter
Aug 12 2016 13:59
no...but the image source is src="/assets/files/Media/QW8ofyKifDF3Httc5/images.jpg?token=eyJhdXRoVG9rZW4iOiItcnRhSllHTU8yM3JoZUVfUVBlVFdfVVl4ckFqX0MwY2daNE9Lc3kwWE9sIn0%3D&store=large"
some package responsible for displaying image isn't working. The image is being uploaded.
Brent Hoover
@zenweasel
Aug 12 2016 14:01
I just double-checked it now and image upload does seem to be working
dileep kushwaha
@dileepkush_twitter
Aug 12 2016 14:01
blob
Brent Hoover
@zenweasel
Aug 12 2016 14:02
sorry, I don’t really know what could be going on
dileep kushwaha
@dileepkush_twitter
Aug 12 2016 14:03
Alright...i guess i'll try reinstalling it....
i'm on 32 bit machine.....that could be a problem with some of the packages
Lukas Sägesser
@ScyDev
Aug 12 2016 16:09
@zenweasel Ok, in that case, we will create a voucher package next week that can be ported to Reaction HEAD later.
aaronmann613348
@aaronmann613348
Aug 12 2016 16:10
hey brent I went thru and found some installation errors with xcode (idk goofy stuff happened) and thankfully its working now, thanks for the help last night
@zenweasel hey brent I went thru and found some installation errors with xcode (idk goofy stuff happened) and thankfully its working now, thanks for the help last night
RefactorMan
@RefactorMan
Aug 12 2016 16:28
@zenweasel hey Brent, I installed ubuntu and now it seems to work fine
Although it run I have a strange error
=> Started proxy.
=> Started MongoDB.
{ [Error: Cannot find module '../build/Release/bson'] code: 'MODULE_NOT_FOUND' }
js-bson: Failed to load c++ bson extension, using pure JS version
Do I need to do somthing about it?
aaronmann613348
@aaronmann613348
Aug 12 2016 16:33
@RefactorMan I have the same error, the local host is kind of running tho
Antonin Hackenberg
@TondaHack
Aug 12 2016 16:39
Hi, Did you test reaction with a large number of products? I mean until a few millions.