These are chat archives for reactioncommerce/reaction

21st
Aug 2016
3Maestros
@3Maestros
Aug 21 2016 01:36
Nothing happens clicking on "Email Templates", anyone?
I dont see any error in browser/server console either
Brent Hoover
@zenweasel
Aug 21 2016 01:40
Yes, that’s just a placeholder for work we are doing in the next release
3Maestros
@3Maestros
Aug 21 2016 01:44
where do I configure the email ?
I see following error in the server ...
Brent Hoover
@zenweasel
Aug 21 2016 01:45
what specifically about email?
3Maestros
@3Maestros
Aug 21 2016 01:46
I20160820-18:34:16.396(-7)? 01:34:16.395Z ERROR Reaction: Email job failed
I20160820-18:34:16.396(-7)?   Error: connect ETIMEDOUT 216.58.194.101:25
I20160820-18:34:16.397(-7)?       at Object.Future.wait (/Users/Aquaboi/.meteor/packages/meteor-tool/.1.4.0-1.am5k5c++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:449:15)
I20160820-18:34:16.398(-7)?       at smtpSend (packages/email/email.js:89:1)
I20160820-18:34:16.399(-7)?       at Object.Email.send (packages/email/email.js:192:1)
I20160820-18:34:16.399(-7)?       at server/jobs/email.js:32:15
I20160820-18:34:16.400(-7)?       at Array.forEach (native)
I20160820-18:34:16.401(-7)?       at JobQueue.worker (server/jobs/email.js:18:10)
I20160820-18:34:16.401(-7)?       at JobQueue._process (packages/vsivsi_job-collection/job/src/job_class.coffee:191:8)
I20160820-18:34:16.402(-7)?       at [object Object]._.extend.withValue (packages/meteor/dynamics_nodejs.js:56:1)
I20160820-18:34:16.403(-7)?       at packages/meteor/timers.js:6:1
I20160820-18:34:16.403(-7)?       at runWithEnvironment (packages/meteor/dynamics_nodejs.js:110:1)
I20160820-18:34:16.403(-7)?       - - - - -
I20160820-18:34:16.409(-7)?       at Object.exports._errnoException (util.js:873:11)
I20160820-18:34:16.409(-7)?       at exports._exceptionWithHostPort (util.js:896:20)
I20160820-18:34:16.410(-7)?       at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1077:14)
W20160820-18:34:16.424(-7)? (STDERR) Running job not found JMBGCXjLe6iTh392w mP9NeD2n9HwAzrSsJ
Brent Hoover
@zenweasel
Aug 21 2016 01:46
that looks like something about the EMAIL_URL is misconfigured
3Maestros
@3Maestros
Aug 21 2016 01:46
I configure the email from Dashboard store core settings...
can you tell me where to conigure this?
Brent Hoover
@zenweasel
Aug 21 2016 01:47
If you are getting the ETIMEDOUTerror than your email URL is misconfigured
3Maestros
@3Maestros
Aug 21 2016 01:48
is core settings right place where you configure email?
ok
oh..
Brent Hoover
@zenweasel
Aug 21 2016 01:49
Doing it through the dashboard does the same thing but it isn’t persistent if you reset your db
3Maestros
@3Maestros
Aug 21 2016 01:49
what is the email settings in core settings from dashboard for?
ok ..
Brent Hoover
@zenweasel
Aug 21 2016 01:50
we try to make everything in the dashboard settable from either settings.json or reaction.json so you can have a repeatable configuration
3Maestros
@3Maestros
Aug 21 2016 01:56
example of a root url please?
Brent Hoover
@zenweasel
Aug 21 2016 01:57
an example?
it’s what you want your URL to be instead of “localhost"
so if your site is “brenthoover.com” you would set it to “brenthoover.com”
Jeremy Shimko
@jshimko
Aug 21 2016 02:06
With the protocol too. (http/https)
Jeremy Shimko
@jshimko
Aug 21 2016 03:03
@3Maestros, sorry for the confusion… those docs are out of date. You can’t set the MAIL_URL in the settings.json. You need to either use the “core” settings from the dashboard (see following pics) or set the MAIL_URL environment variable.
reaction-mail1.jpg
reaction-mail2.jpg
Brent Hoover
@zenweasel
Aug 21 2016 03:04
You can’t?
Jeremy Shimko
@jshimko
Aug 21 2016 03:04
Nope
Brent Hoover
@zenweasel
Aug 21 2016 03:04
Seems to be working for me right at this moment?
Jeremy Shimko
@jshimko
Aug 21 2016 03:05
Probably because you used the internal reaction.json we all share, no?
That imports the core settings
Took me a long time to figure out that’s why that magically worked. :)
Brent Hoover
@zenweasel
Aug 21 2016 03:05
I don’t use the shared one but yes, it’s reaction.json I am thinking of
not settings.json
Jeremy Shimko
@jshimko
Aug 21 2016 03:06
but yeah, the docs still have that (which is definitely wrong)
One more good topic for the tutorial videos. :)
I think the whole mail setup could probably be a little less technically demanding. Most people find it unclear, but I bet non-developers probably find it quite complicated.
Brent Hoover
@zenweasel
Aug 21 2016 03:10
I think there is more confusion over the settings.json and reaction.json and things in the settings panel imho
Jeremy Shimko
@jshimko
Aug 21 2016 03:10
yeah, definitely that too
Brent Hoover
@zenweasel
Aug 21 2016 03:11
I’m never sure if it’s actually confusing or we just don’t explain it well
Jeremy Shimko
@jshimko
Aug 21 2016 03:11
probably a little of both
Jeremy Shimko
@jshimko
Aug 21 2016 03:26

@3Maestros Here’s a great explanation of using Meteor’s email package…
https://themeteorchef.com/snippets/using-the-email-package/
The only difference you need to care about in Reaction is this:

Email.send();

is converted to:

Reaction.Email.send();

Same exact arguments though (to/from/subject/html). All of the rest of the differences are under the hood and don’t effect the API. The biggest difference is that our implementation uses a job queue which will retry failed attempts and keeps a log of all emails sent in the jobs collection.

You should also note that to/from/subject/html are the only supported options right now. You don’t need to pass html to the html argument though. You can send plain text without html tags and it should still work.
3Maestros
@3Maestros
Aug 21 2016 03:44
@jshimko thank you , I guess I have been trying too many ways to get this working . I have tried from Dasthboard settings , the settings.json and also try to set it explicitly calling process.env.MAIL_URL in init.js . But nothing seems to work , I think I have everything configured right from Dashboard core settings but I still get "ETIMEDOUT 216.58.195.37:25" . Let me back out all my changes and just retain Dashboard core settings and give it a try.
Jeremy Shimko
@jshimko
Aug 21 2016 03:46
you can always set environment variables right in the command that starts the app too…
MAIL_URL="smtp://user:password@url:port" reaction
you can prepend any amount of them before the command
but the dashboard is probably easiest because it persists to the database
3Maestros
@3Maestros
Aug 21 2016 03:47
ok
I will stick to dashboard
Jeremy Shimko
@jshimko
Aug 21 2016 03:48
but it it doesn’t work for some reason, certainly try the other options
one of the last lines in your error above…
exports._exceptionWithHostPort (util.js:896:20)
3Maestros
@3Maestros
Aug 21 2016 04:17
I consistently get error "connect ETIMEDOUT 216.58.195.37:25" , here 216.58.X.X is gmail but nut sure from where it is getting port as 25 while in Dashboard core settings I have set the port to be "465".
has any of one confirmed e-mail works in version 15 ?
Brent Hoover
@zenweasel
Aug 21 2016 04:19
Yep. I tested it with my Mailgun configuration and it works fine
and it’s using port 587 so it seems to be passing in the port correctly
3Maestros
@3Maestros
Aug 21 2016 04:20
not sure from where it is picking port 25 in my setup , I have not modified any of the code ...
Brent Hoover
@zenweasel
Aug 21 2016 04:22
Let me try not setting it via reaction.json and setting it via the dashboard to see if I get any different results
3Maestros
@3Maestros
Aug 21 2016 04:22
ok, thanks ..
Brent Hoover
@zenweasel
Aug 21 2016 04:23
because it’s something I inadvertently test all day ever day every time I put in an order locally
3Maestros
@3Maestros
Aug 21 2016 04:24
I did a fresh pull , only customization I have is reaction user in settings.json
Brent Hoover
@zenweasel
Aug 21 2016 04:25
Ok, may take me a second to switch out of what I was doing
3Maestros
@3Maestros
Aug 21 2016 04:26
no problem, whenever you get a chance ...
Brent Hoover
@zenweasel
Aug 21 2016 04:30
This message was deleted
This message was deleted
3Maestros
@3Maestros
Aug 21 2016 04:30
Yup!
Brent Hoover
@zenweasel
Aug 21 2016 04:30
Sorry, bad results. I had two periods in the url
Jeremy Shimko
@jshimko
Aug 21 2016 04:31
yep
3Maestros
@3Maestros
Aug 21 2016 04:31
:)
Brent Hoover
@zenweasel
Aug 21 2016 04:31
I20160821-12:33:03.386(8)? 04:33:03.385Z  INFO Reaction: setting default mail url to: smtp.mailgun.org
I20160821-12:33:08.690(8)? 04:33:08.690Z  INFO Reaction: Successfully sent email to hoover.net
Jeremy Shimko
@jshimko
Aug 21 2016 04:32
Yeah, it’s extensively used. I’m thinking you have bad credentials @3Maestros
Brent Hoover
@zenweasel
Aug 21 2016 04:32
well, it’s using the wrong port, we can see that
it’s just why it’s using the wrong port… :worried:
3Maestros
@3Maestros
Aug 21 2016 04:33
yes it is failing because of wrong port 25 while I have it set to 465 in Dashboard Core settings
dont know where it is picking 25 from
Jeremy Shimko
@jshimko
Aug 21 2016 04:33
you can hop into meteor shell and run Reaction.configureMailUrl() and it should output the MAIL_URL that’s being used.
And you can look here to see how the MAIL_URL is assembled from the various possible settings…
https://github.com/reactioncommerce/reaction/blob/master/server/api/core/core.js#L124-L161
3Maestros
@3Maestros
Aug 21 2016 04:34
yeah I was looking at that ..
a while ago
meteor shell you mean browser?
Jeremy Shimko
@jshimko
Aug 21 2016 04:37
No. Start the app and then open another terminal window in the same directory and run
meteor shell
3Maestros
@3Maestros
Aug 21 2016 04:37
ok
It’s pretty much the same idea as the browser console, but for the server side environment
Which is handy for manually calling server-only methods
or checking environment variables
like process.env.MAIL_URL
3Maestros
@3Maestros
Aug 21 2016 04:40
I get folowing error when I try that
Brent Hoover
@zenweasel
Aug 21 2016 04:41
> import { Reaction } from "/server/api";
> Reaction.configureMailUrl()
Jeremy Shimko
@jshimko
Aug 21 2016 04:41
oh yeah, sorry. forgot that stuff isn’t global. You can use the legacy ReactionCore global.
ReactionCore.configureMailUrl()
(in meteor shell)
3Maestros
@3Maestros
Aug 21 2016 04:42
it shows the right port 465
Brent Hoover
@zenweasel
Aug 21 2016 04:42
well that’s a puzzler
Jeremy Shimko
@jshimko
Aug 21 2016 04:43
then I can’t see any reason why that would fail other than if it’s not the right port
on the Google side
Brent Hoover
@zenweasel
Aug 21 2016 04:43
Oh you know, I think GMail has some weird stuff besides the non-standard port
3Maestros
@3Maestros
Aug 21 2016 04:44
hmm...
Brent Hoover
@zenweasel
Aug 21 2016 04:45
it may need to be a TLS connection or something like that?
Jeremy Shimko
@jshimko
Aug 21 2016 04:45
You could also just use mailgun. It’s free for 10000 emails a month
and a bit more robust than gmail for this use case.
3Maestros
@3Maestros
Aug 21 2016 04:46
let me try mail gun ..
Brent Hoover
@zenweasel
Aug 21 2016 04:48
this would seem to imply there is nothing special with setting up Gmail
Jeremy Shimko
@jshimko
Aug 21 2016 04:48
also note that you can set those values in private/settings/reaction.json and it will populate the shop settings.
https://github.com/reactioncommerce/reaction/blob/master/private/settings/reaction.json.example#L17-L22
3Maestros
@3Maestros
Aug 21 2016 05:17
what port do you use on maingun, for not I want to stick to your configuration and get it working
Jeremy Shimko
@jshimko
Aug 21 2016 05:18
it should say it right in the same place you get your credentials
but one of mine that I just checked is 587
Brent Hoover
@zenweasel
Aug 21 2016 05:19
yeah, 587 here as well
3Maestros
@3Maestros
Aug 21 2016 05:19
ok
3Maestros
@3Maestros
Aug 21 2016 05:45
I am still getting following error , not sure why it is still trying to reach gmail while I have pointed it to mailgun. I did a fresh pull and configured dashboard core settings. I am puzzled
I20160820-22:42:29.903(-7)? 05:42:29.902Z ERROR Reaction: Email job failed
I20160820-22:42:29.904(-7)?   Error: connect ETIMEDOUT 216.58.195.37:25
I20160820-22:42:29.905(-7)?       at Object.Future.wait (/Users/Aquaboi/.meteor/packages/meteor-tool/.1.4.0-1.am5k5c++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:449:15)
I20160820-22:42:29.905(-7)?       at smtpSend (packages/email/email.js:89:1)
I20160820-22:42:29.906(-7)?       at Object.Email.send (packages/email/email.js:192:1)
I20160820-22:42:29.906(-7)?       at server/jobs/email.js:32:15
I20160820-22:42:29.907(-7)?       at Array.forEach (native)
I20160820-22:42:29.908(-7)?       at JobQueue.worker (server/jobs/email.js:18:10)
I20160820-22:42:29.908(-7)?       at JobQueue._process (packages/vsivsi_job-collection/job/src/job_class.coffee:191:8)
I20160820-22:42:29.909(-7)?       at [object Object]._.extend.withValue (packages/meteor/dynamics_nodejs.js:56:1)
I20160820-22:42:29.909(-7)?       at packages/meteor/timers.js:6:1
I20160820-22:42:29.909(-7)?       at runWithEnvironment (packages/meteor/dynamics_nodejs.js:110:1)
I20160820-22:42:29.910(-7)?       - - - - -
I20160820-22:42:29.910(-7)?       at Object.exports._errnoException (util.js:873:11)
I20160820-22:42:29.911(-7)?       at exports._exceptionWithHostPort (util.js:896:20)
I20160820-22:42:29.911(-7)?       at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1077:14)
W20160820-22:42:29.927(-7)? (STDERR) Running job not found n7QWEoFN4tktP3vR5 28qQ4WAMDxaW4PBm2
I20160820-22:43:29.369(-7)? 05:43:29.368Z  INFO Reaction: setting default mail url to: smtp.mailgun.org
Jeremy Shimko
@jshimko
Aug 21 2016 05:48
It looks like settings.json is actually used after all. You have settings there?
3Maestros
@3Maestros
Aug 21 2016 05:48
yes I have set reaction user only, rest are default
you want me to try to run settings.json to default and try ?
Jeremy Shimko
@jshimko
Aug 21 2016 05:50
So the MAIL_URL is not in settings.json or reaction.json and it’s only set in the database? And Reaction.configureMailUrl() returns the right url?
3Maestros
@3Maestros
Aug 21 2016 05:50
yes
yes
Jeremy Shimko
@jshimko
Aug 21 2016 05:50
that makes no sense. Actually, it should be impossible
3Maestros
@3Maestros
Aug 21 2016 05:50
url and port also
Jeremy Shimko
@jshimko
Aug 21 2016 05:51
throw some console.logs in that configureMailUrl method
3Maestros
@3Maestros
Aug 21 2016 05:51
yeah ...I am reverting settings.json to default and give it a try
ok
Jeremy Shimko
@jshimko
Aug 21 2016 05:51
you don’t need to revert it if the MAIL_URL isn’t set
Brent Hoover
@zenweasel
Aug 21 2016 05:51
could an environment variable be overriding it?
Jeremy Shimko
@jshimko
Aug 21 2016 05:51
yes, definitely.
Pretty sure that’s the ultimate override
it overrides every other possible place to set it
Brent Hoover
@zenweasel
Aug 21 2016 05:53
right, that was my point
3Maestros
@3Maestros
Aug 21 2016 05:53
That may be a possiblity , I has try setting with process.env in the init.js before when none of these worked
but I have the same shell session since then, let me try opening a new shell and give it a spin
Brent Hoover
@zenweasel
Aug 21 2016 05:54
printenv | grep -i mail_url
Jeremy Shimko
@jshimko
Aug 21 2016 05:55
restart the app
if you manually set the MAIL_URL in the shell, it will still be that value
MAIL_URL only gets reset if it wasn’t already set
3Maestros
@3Maestros
Aug 21 2016 05:55
it's empty
printenv | grep -i mail_url is returning empty
Jeremy Shimko
@jshimko
Aug 21 2016 05:56
probably caps
MAIL_URL
Brent Hoover
@zenweasel
Aug 21 2016 05:57
-i makes it case insensitive
Jeremy Shimko
@jshimko
Aug 21 2016 05:58
that doesn’t return anything for me either and I have an app running with that env var set
Brent Hoover
@zenweasel
Aug 21 2016 05:59
strange, working for me literally right now
man grep
     -i, --ignore-case
             Perform case insensitive matching.  By default, grep is case sensitive.
Jeremy Shimko
@jshimko
Aug 21 2016 05:59
oh, I believe you. I can do it with plenty of other env vars
just not MAIL_URL
Brent Hoover
@zenweasel
Aug 21 2016 05:59
but either way, try it with all caps
Jeremy Shimko
@jshimko
Aug 21 2016 06:00
you can also just run echo $MAIL_URL
Nathan Yeung
@n8yeung
Aug 21 2016 06:33
Does reaction work with Angularjs?
3Maestros
@3Maestros
Aug 21 2016 06:44
@jshimko It looks like it following the domain in the user name instead of specified in host , so for example you have user name with gmail login with mailgun. It is trying to reach gmail:25 , if you change username@mailgun , then it tries mailgun:25. Not sure why you are not seeing this behavior.
and it is always trying port 25 not what is configured in dashboard settings
3Maestros
@3Maestros
Aug 21 2016 07:53
I believe in your case also it is always using port 25 regardless of what you have configured in dashboard settings, the fact that my ISP has blocked port 25 it is causing failure my end but it may not be blocked at your end . Can you try "telnet smtp.mailgun.org 25" as see if you are able to connect
Brent Hoover
@zenweasel
Aug 21 2016 08:03
I am sure that’s blocked
Yep
I know it’s using the port as I had it wrong for a while and was getting the same error
I had port 5877 and got that timeout error
jussiahtikari
@jussiahtikari
Aug 21 2016 11:51
Hi, does anyone know if it is possible to make subscription based pricing with Reaction Commerce? For example putting a price like "$10 / month" for a product?
3Maestros
@3Maestros
Aug 21 2016 13:20
I am observing two issues
1 It is using port 25 not the one I specified in the Dashboard core settings
2 . It is trying to reach gmail.com while my host settings says "smtp.mailgun.org", it is building the host using the domain in the user name "username@gmail.com".
Error: getaddrinfo ENOTFOUND gmail.com gmail.com:25
3Maestros
@3Maestros
Aug 21 2016 13:25
 INFO Reaction: setting default mailUrl tosmtp://booksmaestro@gmail.com:XXXXX@smtp.mailgun.org:587/
Jeremy Shimko
@jshimko
Aug 21 2016 13:29
is that last log exactly how it came out?
3Maestros
@3Maestros
Aug 21 2016 13:30
I replaced the password with "XXXX" , rest are the same as in the logs
I added these log statements ..
Jeremy Shimko
@jshimko
Aug 21 2016 13:32
Can you try a completely fresh clone and then set it in the dashboard?
reaction init mailtest
cd mailtest
reaction
If it’s still getting your gmail, then it’s still set somewhere
3Maestros
@3Maestros
Aug 21 2016 13:33
what does "reaction init mailtest" do ?
Jeremy Shimko
@jshimko
Aug 21 2016 13:33
git clone reaction -> a directory called mailtest
3Maestros
@3Maestros
Aug 21 2016 13:33
Ahh..
Jeremy Shimko
@jshimko
Aug 21 2016 13:34
the mailtest part is optional. just a directory for clarity
otherwise, it would always be called reaction
3Maestros
@3Maestros
Aug 21 2016 13:34
got , I have tried with a fresh clone numbe of times yesterday ...
but no luck, it's the same result
Jeremy Shimko
@jshimko
Aug 21 2016 13:35
and what do you get if you have no Reaction instances running and you run...
echo $MAIL_URL
(should be nothing)
3Maestros
@3Maestros
Aug 21 2016 13:36
from another shell?
Jeremy Shimko
@jshimko
Aug 21 2016 13:36
from any open terminal, but specifically when Reaction is not running
3Maestros
@3Maestros
Aug 21 2016 13:37
ok didn't see "not" , let me try
returns empty ..
Jeremy Shimko
@jshimko
Aug 21 2016 13:38
ok, good. Then it’s definitely contained in the app
3Maestros
@3Maestros
Aug 21 2016 13:38
Yeah, I have tried numerous times with fresh pull
can you tell how calls this " expect(err.message).to.contain('getaddrinfo');" which is in file node_modules/sntp/test/index.js ?
how = who ?
Jeremy Shimko
@jshimko
Aug 21 2016 13:41
that’s a test
3Maestros
@3Maestros
Aug 21 2016 13:42
trying to chase where is this coming form
Error: getaddrinfo ENOTFOUND gmail.com gmail.com:25
Jeremy Shimko
@jshimko
Aug 21 2016 13:43
a new clone gets that?
3Maestros
@3Maestros
Aug 21 2016 13:44
yes ..
Jeremy Shimko
@jshimko
Aug 21 2016 13:44
there’s not a single instance of the word gmail in the entire code base
it’s something happening in your environment somehow
3Maestros
@3Maestros
Aug 21 2016 13:45
this is a variable I believe ..
my user name is "booksmaestro@gmail.com"
Jeremy Shimko
@jshimko
Aug 21 2016 13:45
I did a fresh clone and nothing is set
3Maestros
@3Maestros
Aug 21 2016 13:46
what is your username in the core settings?
It is deriving the host from username it seems
yes fresh clone nothing is set but I go to dashboard clone settings and configure my e-mail settings
3Maestros
@3Maestros
Aug 21 2016 13:52
I am trying with a fresh install again for the 'N' time...let's see
Jeremy Shimko
@jshimko
Aug 21 2016 13:55
I just did a fresh clone, added email details (in the dashboard), and invited a user. Everything worked as expected. Email sent and received.
note that the full username for mailgun should look something like postmaster@yourdomain.com
that’s only the username. not the host
the host is always smtp.mailgun.org
Jeremy Shimko
@jshimko
Aug 21 2016 14:00
oh damn. hold on. several mins later the job failed for me too
3Maestros
@3Maestros
Aug 21 2016 14:04
what is the error message you are seeing?
in your case "postmaster@yourdomain.com" what is your "yourdomain" ?
Jeremy Shimko
@jshimko
Aug 21 2016 14:09
reactioncommerce.com
I know what the problem is though (at least in my case).
3Maestros
@3Maestros
Aug 21 2016 14:09
I am trying now with fresh pull
Jeremy Shimko
@jshimko
Aug 21 2016 14:09
you can’t have two @’s
3Maestros
@3Maestros
Aug 21 2016 14:10
ok you had two @..
Jeremy Shimko
@jshimko
Aug 21 2016 14:10
yeah, and you should too
if you’re using mailgun
3Maestros
@3Maestros
Aug 21 2016 14:11
my user name is from gmail ...
I have only one @ ..
Jeremy Shimko
@jshimko
Aug 21 2016 14:11
so you’re not using mailgun?
3Maestros
@3Maestros
Aug 21 2016 14:11
mail gun is my host ..
Jeremy Shimko
@jshimko
Aug 21 2016 14:11
your gmail address is not your mailgun MAIL_URL user
3Maestros
@3Maestros
Aug 21 2016 14:11
smtp.mailgun.org
Jeremy Shimko
@jshimko
Aug 21 2016 14:12
Window_and_reactioncommerce_com_-_Mailgun.jpg
3Maestros
@3Maestros
Aug 21 2016 14:13
that's how I login to my mailgun acount...
Jeremy Shimko
@jshimko
Aug 21 2016 14:14
every domain you have set in mailgun will have another username like that
it won’t ever be your personal login
the issue I’m having is the character encoding of the extra @. The one in the username needs to be %40 instead
3Maestros
@3Maestros
Aug 21 2016 14:16
WOW ...that's how I used it when I worked with google smtp ..
Jeremy Shimko
@jshimko
Aug 21 2016 14:16
yeah, this process sucks
this is way too much of a hassle for most people
we were all spoiled back when PHP sent emails for us with little/no configuration
3Maestros
@3Maestros
Aug 21 2016 14:18
how does your new user name looks now , you took out "@"?
Jeremy Shimko
@jshimko
Aug 21 2016 14:19
postmaster%40yourdomain.com
3Maestros
@3Maestros
Aug 21 2016 14:19
ok
does this work for you ?
telnet smtp.mailgun.org 25
Jeremy Shimko
@jshimko
Aug 21 2016 14:24
pretty sure your port is supposed to be 465
3Maestros
@3Maestros
Aug 21 2016 14:25
its always going to 25 and my 25 is blocked by ISP , it doesn't seem to take what I have in the settings ...
does telnet to port 25 with mailgun work for you?
Jeremy Shimko
@jshimko
Aug 21 2016 14:39
$ telnet smtp.mailgun.org 465
Trying 104.130.177.23...
Connected to smtp.mailgun.org.
why is always going to be 25?
Jeremy Shimko
@jshimko
Aug 21 2016 15:46
@3Maestros Still working on it… I’m having different issues than you, but I’m also having issues with the email package. I might be taking a deep dive to tear this stuff apart today. We’ve been meaning to improve a bunch of email stuff anyway.
3Maestros
@3Maestros
Aug 21 2016 18:59
@jshimko sorry I was away, I am trying to add the DNS text records and rest of the things ...
Jeremy Shimko
@jshimko
Aug 21 2016 19:11
Yeah, definitely won’t work without those