These are chat archives for reactioncommerce/reaction

25th
Oct 2016
James Scaggs
@jamesscaggs
Oct 25 2016 00:00
I'll post back on this tomorrow with an update, thank you!
Spencer Norman
@spencern
Oct 25 2016 00:00
:+1:
Donovan Adams - Hydrotik
@hydrotik
Oct 25 2016 03:00
@zenweasel Hi Brent, i took a stab at creating a separate layout for index and core, but I seem to get getting the 404 page. thought I had covered everything and was hoping you could take a peek? https://github.com/hydrotik/reaction-hydrotik-plugin
Brent Hoover
@zenweasel
Oct 25 2016 03:03
@hydrotik I’ll try to take a look after lunch
Donovan Adams - Hydrotik
@hydrotik
Oct 25 2016 03:05
Thanks no rush, I need to get some sleep tonight lol Maybe I will catch you in the evening.. also it seems that Package.js is the best way to install a plugin and have the deps loaded into the root?
Brent Hoover
@zenweasel
Oct 25 2016 03:05
do you mean package.json?
Brent Hoover
@zenweasel
Oct 25 2016 03:06
that’s from the old Meteor package system
Donovan Adams - Hydrotik
@hydrotik
Oct 25 2016 03:06
ah
Brent Hoover
@zenweasel
Oct 25 2016 03:07
that’s deprecated and will break eventually
Donovan Adams - Hydrotik
@hydrotik
Oct 25 2016 03:07
ok.. I started brainstorming something like this in register.js https://github.com/hydrotik/reaction-hydrotik-plugin/blob/master/register.js
but I don't want to reinvent the wheel if there is an existing process in place
Brent Hoover
@zenweasel
Oct 25 2016 03:08
I know @jshimko had some ideas about the plugin loader being able to recursively find package.json files in plugins and install them
Donovan Adams - Hydrotik
@hydrotik
Oct 25 2016 03:08
cool, that sounds like a good solution
if there's a ticket for that I'd love to subscribe
Brent Hoover
@zenweasel
Oct 25 2016 03:10
I don’t think there is a ticket, just something we have talked about
you are the first person to ask about it. We just spoke about it in the theoretical
Brent Hoover
@zenweasel
Oct 25 2016 03:22
Just added it: reactioncommerce/reaction-cli#17
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:33
my reaction install is complaining after I renamed some parent directories. Is there a process I must follow? Is it possible to relocate a reaction app?
Brent Hoover
@zenweasel
Oct 25 2016 03:34
it should be self-contained. what’s the error you are receiving?
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:35
when trying to debug the server side I see
Network.loadResourceForFrontend failed.
some/old/path/that/has/since/been/renamed
This is in the node-inspector console
Brent Hoover
@zenweasel
Oct 25 2016 03:36
Sorry, I have not seen that
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:36
Error: ENOENT: no such file or directory, open '/Users/frankg/dev/code/...
there are like 40 lines like this in the console
they seem to all have the word braintree in the path
Error: ENOENT: no such file or directory, open '/Users/frankg/dev/code/projects/cart-project/reaction/node_modules/braintree/lib/braintree/disbursement_gateway.map'
Network.loadResourceForFrontend failed.
Error: ENOENT: no such file or directory, open '/Users/frankg/dev/code/projects/cart-project/reaction/node_modules/braintree/lib/braintree/subscription_gateway.map'
Brent Hoover
@zenweasel
Oct 25 2016 03:38
trying it now
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:41
ok
Brent Hoover
@zenweasel
Oct 25 2016 03:41
actually hold on
I didn’t mean to send that yet
let me try it here first, almost done
I do get an error when I renamed the parent directory
so yeah, I did reaction reset -y and then meteor npm install
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:44
ok - I'll try that now
Brent Hoover
@zenweasel
Oct 25 2016 03:44
if you don’t want to reset your db you could probably just delete the node_modules directory
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:45
ok
Brent Hoover
@zenweasel
Oct 25 2016 03:45
it must freeze the location of those files somewhere
Frank Gutierrez
@dearfrankg
Oct 25 2016 03:45
good to be aware of this
Brent Hoover
@zenweasel
Oct 25 2016 03:46
must be a Meteor thing as we are not doing that anywhere
samgitre
@samgitre
Oct 25 2016 04:21
hi, good day, bro!
please I'm have a problem with products details
when I click a product on the home page it suppose to take me to the product details page, but is not working that way
when I click a product it goes to the details page but is not showing me any thing, I can't see the image and its details
please, any help is appreciated, thanks!
Brent Hoover
@zenweasel
Oct 25 2016 04:26
the first question would be, what have you changed?
samgitre
@samgitre
Oct 25 2016 04:38
I'm trying to cusstomise the templates
I change the product details template name and some of them to mine
But the workflow and collections remain the same
Frank Gutierrez
@dearfrankg
Oct 25 2016 04:41
@zenweasel FYI,
  1. the earlier problem related to changing parent path was my bad for using symlinks (since removed)
  2. I am getting console error with a clean reaction install when debugging the server using reaction debug
    The errors are braintree related it's looking for .map files when there isn't any.
    example: no such file .....disbursement_gateway.map
  3. it's taking me almost 3.5 minutes to get to a debugger line when debugging. Is that normal?
samgitre
@samgitre
Oct 25 2016 04:43
@zenweasel : workflow: "coreProductWorkflow collection: "Products"
Brent Hoover
@zenweasel
Oct 25 2016 04:45
ok guys, it’s lunchtime here so I will try to answer your questions in about 30-45 minutes
samgitre
@samgitre
Oct 25 2016 04:47
cool!
Brent Hoover
@zenweasel
Oct 25 2016 05:40
@samgitre Is your code somewhere I can take a look at it?
samgitre
@samgitre
Oct 25 2016 06:00
Ok, I will keep it organised later and send you the link
Brent Hoover
@zenweasel
Oct 25 2016 06:02
@dearfrankg I am testing out your scenario now
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:02
@zenweasel nice
Brent Hoover
@zenweasel
Oct 25 2016 06:03
just a reaction init and then running reaction debug?
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:03
yep
Brent Hoover
@zenweasel
Oct 25 2016 06:05
not seeing any issue here
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:06
wondering what it could be?
Brent Hoover
@zenweasel
Oct 25 2016 06:06
is there something more I should be trying?
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:06
no, that was it.
I can try again on my end
Brent Hoover
@zenweasel
Oct 25 2016 06:07
I don’t really use the debugger so I don’t know what to look for but no console errors. Everything looks to be solid.
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:07
ok trying again on my side
Brent Hoover
@zenweasel
Oct 25 2016 06:08
kk
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:08
does it take you 3.5 minutes to get the debugger up?
Brent Hoover
@zenweasel
Oct 25 2016 06:08
nothing beyond the usual build time
not sure what that is, maybe 60-90 seconds
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:09
it takes me 3.5 minutes before the debugger is ready -- when you start the debugger you have to hit the pause button to continue - maybe that's the missing step
Brent Hoover
@zenweasel
Oct 25 2016 06:09
let me start it again
~40 seconds to start up and no errors in the debugger
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:14
did you hit the pause button to continue
Brent Hoover
@zenweasel
Oct 25 2016 06:14
I don’t have a breakpoint set
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:14
neither do I
it auto breaks I think
Brent Hoover
@zenweasel
Oct 25 2016 06:15
not seeing that
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:15
I just reproduced the error with a fresh install
maybe I can make a video and post online
Brent Hoover
@zenweasel
Oct 25 2016 06:15
Your application is now ready for debugging!

To debug the server process using a graphical debugging interface,
visit this URL in your web browser:

  http://localhost:8080/?port=5858

If your application is paused on a breakpoint but the code is not
visible in the debugger, press the pause (||) button.

Debugger listening on port 5959
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:16
see that message - press the pause button
Brent Hoover
@zenweasel
Oct 25 2016 06:18
just to clarify, we’re talking about this pause button?
Node_Inspector_-_file____Users_brenthoover_Projects_js_reaction-debug-test__meteor_local_build_main_js_and_media_js_-_reaction_-____Projects_js_reaction_.png
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:18
yeah - first button on the left
Brent Hoover
@zenweasel
Oct 25 2016 06:19
right. nothing
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:19
ok - I'll make a video and get it to you
Brent Hoover
@zenweasel
Oct 25 2016 06:19
I don’t know how much help I can be if I can’t replicate it
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:20
I don't need help - just making the info available to the team
Brent Hoover
@zenweasel
Oct 25 2016 06:20
ah, ok
I still feel like there’s something I’m not doing
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:22
hopefully the video will clarify
Brent Hoover
@zenweasel
Oct 25 2016 06:22
did this all start after renaming the directory?
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:23
no this happend on a clean install
Brent Hoover
@zenweasel
Oct 25 2016 06:23
understood, but it wasn’t happening before right?
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:23
it seems that it has always been happening for me
Brent Hoover
@zenweasel
Oct 25 2016 06:24
I see
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:50
@zenweasel check it out: http://screencast.com/t/UTQFvWoqui
I hope the video doesn't take a long time to download to you
Brent Hoover
@zenweasel
Oct 25 2016 06:54
so you click pause and then you are waiting for a while?
Frank Gutierrez
@dearfrankg
Oct 25 2016 06:54
yes, like 3 - 4 minutes
Brent Hoover
@zenweasel
Oct 25 2016 06:58
paused, waiting
or unpaused I mean
still no excitement
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:01
lol
did you see the video I made?
Brent Hoover
@zenweasel
Oct 25 2016 07:01
yep
I was following along
I wonder if that .temp is messing with something
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:03
what kind of laptop do you have?
Brent Hoover
@zenweasel
Oct 25 2016 07:03
OSX
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:03
I have a 2013 macbook pro
Brent Hoover
@zenweasel
Oct 25 2016 07:03
mines 2014
practically vintage
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:03
and it takes a long time for that debugger to show up
oh mine is actually 2014
Brent Hoover
@zenweasel
Oct 25 2016 07:04
Node_Inspector_-_file____Users_brenthoover_Projects_js_reaction__meteor_local_build_main_js.png
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:05
der it is!
Brent Hoover
@zenweasel
Oct 25 2016 07:05
success. of a dubious type
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:05
well, I hope it helps somebody
Brent Hoover
@zenweasel
Oct 25 2016 07:06
at least we know it’s not your environment
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:06
yes!
Brent Hoover
@zenweasel
Oct 25 2016 07:06
I would have bet $10 right up until it happened that it was
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:07
I know what you mean
Brent Hoover
@zenweasel
Oct 25 2016 07:07
not sure what is up with those BT map files
stupid BrainTree
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:07
wondering what's up with that 3 - 4 minutes to get a debugger going
Brent Hoover
@zenweasel
Oct 25 2016 07:08
that part I am not seeing
unless you mean the time from the un-pause until the error
you mean from when you type reaction debug until you get the “debugger ready” message?
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:08
yes, you can add a debugger line to server/main.js for it to pause there
or just create a break point
Brent Hoover
@zenweasel
Oct 25 2016 07:09
what happens if you delete the BT plugin?
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:09
well, now that I have you here can you tell me a little about this workflow thing I've been seeing here and there
Brent Hoover
@zenweasel
Oct 25 2016 07:10
honestly there’s not a lot to tell right now
which kind of workflows are you talking about?
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:10
also how to the plugins get loaded - been going over the server startup process
Brent Hoover
@zenweasel
Oct 25 2016 07:11
the reaction-cli scans the code for plugins and adds them to the imports
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:11
let me find those workflow names
In the registry directories: one example: workflow: "coreAccountsWorkflow",
and workflow: "coreCartWorkflow",
Brent Hoover
@zenweasel
Oct 25 2016 07:15
well, the coreCartWorkflow is a good example
I talk about it in the customization guide
it’s basically just an array of template names
start on one template, go to the next template etc
if you want to remove a step, you just modify that array
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:16
I see, I'll go dive into those docs again
so you need to start with reaction-cli to get plugins correct?
Brent Hoover
@zenweasel
Oct 25 2016 07:17
if you run reaction you are using the CLI
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:17
right
Brent Hoover
@zenweasel
Oct 25 2016 07:17
you should see that “setting up plugin imports” message
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:17
ok
Brent Hoover
@zenweasel
Oct 25 2016 07:17
yeah, that’s why you have to start reaction with the reaction command
at least once
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:17
I'm learning
Brent Hoover
@zenweasel
Oct 25 2016 07:17
lol
our plugin standard is still evolving. We had to come up with something quickly when MDG deprecated packages
mostly it works, but there’s still some holes like disabling plugins
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:19
are you in the know regarding how the project is doing
like the milestones
etc.
Brent Hoover
@zenweasel
Oct 25 2016 07:19
i feel like I am, yes
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:19
are you an employee?
Brent Hoover
@zenweasel
Oct 25 2016 07:19
I am
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:19
ok, that makes sense
Brent Hoover
@zenweasel
Oct 25 2016 07:19
though this part is not technically my job
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:20
I understand
Brent Hoover
@zenweasel
Oct 25 2016 07:20
what do you want to know?
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:20
I think you fed me a lot of info today
but I will let you know if I get stuck
Brent Hoover
@zenweasel
Oct 25 2016 07:21
I am trying this debug thing w/o the braintree plugin
if I know BT code it’s a terrible, complicated mess
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:21
I bet you get no errors now
Brent Hoover
@zenweasel
Oct 25 2016 07:22
yep. but less me guess. BT is your payment processor?
I can’t remember how long I had to wait last time
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:22
no, I'm just liking the reaction app
it's a learning experience for me
what time is it there?
Brent Hoover
@zenweasel
Oct 25 2016 07:23
3:30 in the afternoon abouts
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:24
ok Beijing Time
12:30am here
Brent Hoover
@zenweasel
Oct 25 2016 07:24
west coast?
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:24
San Francisco
Brent Hoover
@zenweasel
Oct 25 2016 07:25
most of the team is in Santa Monica
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:25
too bad they don't have an office here
Brent Hoover
@zenweasel
Oct 25 2016 07:25
Node_Inspector_-_file____Users_brenthoover_Projects_js_reaction__meteor_local_build_main_js.png
one error still
an external package still
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:25
hmm, not braintree related
Brent Hoover
@zenweasel
Oct 25 2016 07:25
ah, must be source map files
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:25
that makes sense
Brent Hoover
@zenweasel
Oct 25 2016 07:26
shouldn’t really affect anything unless you needed to debug that stuff then
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:26
right
well, time for me to crash
Thanks a lot for helping me out
Brent Hoover
@zenweasel
Oct 25 2016 07:27
:+1:
Frank Gutierrez
@dearfrankg
Oct 25 2016 07:27
Seeya tomorrow
Brent Hoover
@zenweasel
Oct 25 2016 07:27
g'night
Philip Nuzhnyi
@callmephilip
Oct 25 2016 10:43
hello guys. i am seeing some odd exceptions all over the place in tests after updating to 0.17 (i think the same is happening on development in CI):
I20161025-11:35:41.162(1)? Exception in queued task: TypeError: Cannot set property 'type' of undefined
I20161025-11:35:41.162(1)?     at packages/underscore/underscore.js:848:1
I20161025-11:35:41.162(1)?     at Array.forEach (native)
I20161025-11:35:41.162(1)?     at _.each._.forEach (packages/underscore/underscore.js:105:1)
I20161025-11:35:41.162(1)?     at Function._.extend (packages/underscore/underscore.js:845:1)
I20161025-11:35:41.162(1)?     at PublicationCollector.changed (packages/johanbrook:publication-collector/publication-collector.js:70:7)
I20161025-11:35:41.162(1)?     at changed (server/publications/collections/products.js:335:20)
I20161025-11:35:41.162(1)?     at packages/mongo/observe_multiplex.js:183:30
I20161025-11:35:41.162(1)?     at Array.forEach (native)
I20161025-11:35:41.163(1)?     at Function._.each._.forEach (packages/underscore/underscore.js:105:1)
I20161025-11:35:41.163(1)?     at Object.task (packages/mongo/observe_multiplex.js:177:9)
I20161025-11:35:41.163(1)?     at [object Object]._.extend._run (packages/meteor/fiber_helpers.js:147:1)
I20161025-11:35:41.163(1)?     at packages/meteor/fiber_helpers.js:125:1
the majority of tests seem to run ok but a few seem to be impacted by this
Brent Hoover
@zenweasel
Oct 25 2016 10:58
I have seen those errors for a while. They don’t seem to be affecting tests. Tests are passing in CI
apparently it’s from a package we use, not from our code directly
Philip Nuzhnyi
@callmephilip
Oct 25 2016 11:00
i see. gonna dig deeper on this. thanks
tdmoneybanks
@tdmoneybanks
Oct 25 2016 15:02
hey guys quick question
it seems like right now, each dashboard is tied to a specific shop and then permissions are grouped by shopid
so, im working on building out the additions necessary to make reaction commerce support multiple shops
one requirement of that is to have an "overall" admin who is able to manage the shops on the site as well as invite new shops (admin controlled invite/onboarding). I'm wondering what your guys thoughts are on how to approach an admin dashboard that would live outside any shop and would have a global permission as opposed to a shopId based permission
Aaron Judd
@aaronjudd
Oct 25 2016 16:10
that’s what “owner” is versus “admin” in the roles, and you can also use GLOBAL_ROLES
tdmoneybanks
@tdmoneybanks
Oct 25 2016 16:11
@aaronjudd thanks, is the owner role added to the original admin created with an empty db? also, as far as the registry (sorry still trying to fully grasp how it works), what is the correct process for creating a route directly off the route where i would put dashboard/etc for the owner
sorry
directly off the root route
i mean creating a route such as reactionapp.com/dashboard
Aaron Judd
@aaronjudd
Oct 25 2016 18:38
@tdmoneybanks yes, it’s added by default. the original admin is the owner, and gets a GLOBAL_ROLE in addition to the roles that every user gets.
see this for the routing: https://docs.reactioncommerce.com/reaction-docs/master/routing under "Multi-shop prefixed urls structure"
tdmoneybanks
@tdmoneybanks
Oct 25 2016 18:40
ah i dont know how i missed that. thanks a lot! @aaronjudd
Aaron Judd
@aaronjudd
Oct 25 2016 18:40
:thumbsup:
tdmoneybanks
@tdmoneybanks
Oct 25 2016 18:40
one other thing i noticed
is that in the Accounts collection
users are tied to shops
would this be entering a new accounts entry for each user when they visit a new shop? or are users signed up to only one shop at a time?
Aaron Judd
@aaronjudd
Oct 25 2016 18:41
it’s their initial shop, but that doesn’t limit their viewing additional shops, that’s all in the roles
tdmoneybanks
@tdmoneybanks
Oct 25 2016 18:41
ah alright thats what i tought
thought
thanks again
just one last ? so since the routes and actions are handled by permissions that are shopId grouped, what process do you have in mind when a new shop registers
would you extend the roles array of each user
to include permissions for the new shopId
Ivanthadev
@ivanthemeh
Oct 25 2016 19:02
Anyone here goood with devops mind giving me a hand? Im having an emergency with a meteor app and could really use a helping hand please
Jeremy Shimko
@jshimko
Oct 25 2016 19:02
what’s the issue?
Ivanthadev
@ivanthemeh
Oct 25 2016 19:04
Im getting this error in the client
Failed to load resource: the server responded with a status of 502 (Bad Gateway) aff4835….js?meteor_js_resource=true:50 GET https://schiller.ivanthemeh.com/sockjs/info?cb=h3up1odswz 502 (Bad Gateway)y._start @ aff4835….js?meteor_js_resource=true:50(anonymous function) @ aff4835….js?meteor_js_resource=true:50
as well as a 502 bad gateway page too! :worried: the app in questions is supposed to be live and IM at my wits end figuring this out. I have a custom nginx config with a proxy setup and Im new to devops so IM having a hard time figuring it out not to mention the tons of info online about this and I just dont know where to go or start. Ive been copying and psting and reading for the last 4 hours and havent gotten anywhere
Jeremy Shimko
@jshimko
Oct 25 2016 19:05
what do your nginx logs say?
Ivanthadev
@ivanthemeh
Oct 25 2016 19:05
I can give you any logs you want or anything I can get you to help me.. Please , I feel like this issue has a quick or fairly easy solution Im just messing up cuz Im stressing out!
2016/10/25 18:59:13 [error] 2176#0: *2 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 162.246.143.6, server: schiller.ivanthemeh.com, request: "GET /so$
Ivanthadev
@ivanthemeh
Oct 25 2016 19:11
aff4835….js?meteor_js_resource=true:50 GET https://schiller.ivanthemeh.com/sockjs/info?cb=s5lc056f3k 502 (Bad Gateway)
Jeremy Shimko
@jshimko
Oct 25 2016 19:11
One line is it?
Ivanthadev
@ivanthemeh
Oct 25 2016 19:12
what do you mean?
the error logs I just gave you the last line
they are all the same
Jeremy Shimko
@jshimko
Oct 25 2016 19:12
I mean you only have one line in all of your logs?
Ivanthadev
@ivanthemeh
Oct 25 2016 19:13
no .. there are a ton
Jeremy Shimko
@jshimko
Oct 25 2016 19:13
Have you tried skipping the proxy and just going straight to Node?
That’s probably not ideal, but it’s at least a solution until you figure out how to configure Nginx properly.
Ivanthadev
@ivanthemeh
Oct 25 2016 19:16
how do I do that?
Jeremy Shimko
@jshimko
Oct 25 2016 19:17
you don’t put nginx in front of it
Ivanthadev
@ivanthemeh
Oct 25 2016 19:17
Ive tried turning of the profxy buffer but I so new to this stuff Im not sure If im putting it in the right place
you mean like starting the app in local?
Jeremy Shimko
@jshimko
Oct 25 2016 19:17
How did you deploy the app?
Ivanthadev
@ivanthemeh
Oct 25 2016 19:17
mupx
Jeremy Shimko
@jshimko
Oct 25 2016 19:18
configure the app to use port 80 and don’t use nginx
Ivanthadev
@ivanthemeh
Oct 25 2016 19:24
working on that now.
Ill let ya know in a few
Ivanthadev
@ivanthemeh
Oct 25 2016 19:31
so know Im getting this instead of bad gateway
aff4835….js?meteor_js_resource=true:50 GET http://schiller.ivanthemeh.com/sockjs/info?cb=67xkvz2iwe net::ERR_CONNECTION_REFUSED
mupx uses nginx either way, the reason IM using a custom config is so I can edit the proxy_buffer size which I cant do in a regular mupx setup like you suggested. IM at my wits end...
Jeremy Shimko
@jshimko
Oct 25 2016 19:49
Not sure. I don’t use mup/mupx anymore. They have a bit of a reputation for abandoning projects, so I don’t use or recommend them anymore. You can try creating an issue and posting your details over in their repo.
Sorry I don’t have a better answer. If you can’t figure out the mupx issues, you can try following the officially supported Docker deployment methods.
Donovan Adams - Hydrotik
@hydrotik
Oct 25 2016 23:15
any reason why using this would break the page?
Session.set("DEFAULT_LAYOUT", "coreLayoutHydrotik");

Session.set("INDEX_OPTIONS", {
  template: "indexLayoutHydrotik",
  layoutHeader: "layoutHeaderHydrotik",
  layoutFooter: "layoutFooterHydrotik",
  notFound: "notFound",
  dashboardControls: "dashboardControls",
  adminControlsFooter: "adminControlsFooter"
});
I'm trying to set a default layout in my plugin but a different for index. maybe there is a better way?
Brent Hoover
@zenweasel
Oct 25 2016 23:16
no, that’s the way you would do it
what does “break the page” mean here?