These are chat archives for reactioncommerce/reaction

28th
Oct 2016
alai6039
@alai6039
Oct 28 2016 00:02
does anyone know when the multi-vendor product is coming out?
Brent Hoover
@zenweasel
Oct 28 2016 00:02
multi-vendor product?
alai6039
@alai6039
Oct 28 2016 00:03
reaction said that they are coming out with a multiple vendor solution, which can support multiple sellers
Brent Hoover
@zenweasel
Oct 28 2016 00:04
we don’t have a specific release date for that yet, but several people have already implemented it.
alai6039
@alai6039
Oct 28 2016 00:05
can we possibly implement that as well?
Enny Isambert
@ennysantana
Oct 28 2016 00:06
brent, after database reset says: Sorry, this project uses Meteor 1.4.1.2, which is not installated and could not be downloaded. Please check to make sure that you are online.
Done!
Brent Hoover
@zenweasel
Oct 28 2016 00:06
@alai6039 multi-shop is built into the schema on the backend, there just doesn’t exist a front-end for it. So you could implement that without having to modify Reaction code
@ennysantana It looks like your internet connection is having problems
Enny Isambert
@ennysantana
Oct 28 2016 00:08

and then deleting node_modules...

Reinstalling node_modules...
and npm ERR! fetch failed

Brent Hoover
@zenweasel
Oct 28 2016 00:08
yeah, it can’t reach the Meteor/NPM servers
you’ve got an issue with your network connection
Enny Isambert
@ennysantana
Oct 28 2016 00:09
npm ERR! is because my conection failed
Brent Hoover
@zenweasel
Oct 28 2016 00:09
Yes
Enny Isambert
@ennysantana
Oct 28 2016 00:10
npm ERR! is because my conection failed
and now cmd is thinking ...
Brent Hoover
@zenweasel
Oct 28 2016 00:11
Both the errors you received are because your connection failed
Enny Isambert
@ennysantana
Oct 28 2016 00:11
what can i do?
Brent Hoover
@zenweasel
Oct 28 2016 00:11
what country are you in?
Enny Isambert
@ennysantana
Oct 28 2016 00:11
again reaction reset or meteor npm install?
Brent Hoover
@zenweasel
Oct 28 2016 00:12
No, your core problem is that your connection is not working well
You cannot run Meteor or Reaction until you fix the issues with your network connection
obviously you’re connected to the internet, but for some reason you can’t download NPM modules
Enny Isambert
@ennysantana
Oct 28 2016 00:20
i'm from venezuela
IPS sucks!
ISP*
Brent Hoover
@zenweasel
Oct 28 2016 00:22
NPM is blocked for certain countries but I don’t think Venezuela is one of them
Yeah, your going to need to work that out with your ISP. It could be just a temporary thing
Aaron Judd
@aaronjudd
Oct 28 2016 01:12
@dearfrankg re: yarn, I saw that Meteor 1.4.2 had an issue resolved for supporting yarn, we’ve updated to 1.4.2 in development. other than that, haven’t done much investigation, but it’s on the radar for sure.
Frank Gutierrez
@dearfrankg
Oct 28 2016 01:12
just wondering, thanks
Ankit
@ankit-tj
Oct 28 2016 01:30
hi, i m new for reactioncommerce : can some one guide me, how can we created different products for each vendor ?
i want to do like : each admin can manage their own products and not able to see other's. Also, if possible superadmin can see each admin's products
Brent Hoover
@zenweasel
Oct 28 2016 01:32
I think what you are talking about is multi-shop or what we call a “marketplace"
Ankit
@ankit-tj
Oct 28 2016 01:32
ok.. can you please guide me, how can i achieve that ?
Brent Hoover
@zenweasel
Oct 28 2016 01:32
multi-shop is implemented in the API, but there currently is no existing UI
Ankit
@ankit-tj
Oct 28 2016 01:32
yes, multi-shop where each shop admin can manage their own products and users
Brent Hoover
@zenweasel
Oct 28 2016 01:33
you would need to implement it
@ScyDev Has already implemented a version of this and has it in product. You may want to take a look at that
Ankit
@ankit-tj
Oct 28 2016 01:33
ohh ok, is there any way..(like any git branch) from where i can get it ?
Brent Hoover
@zenweasel
Oct 28 2016 01:34
You can take a look at his fork here: https://github.com/ScyDev/reaction
Ankit
@ankit-tj
Oct 28 2016 01:35
ok, thank you. I will take a look and try it. !!
Ankit
@ankit-tj
Oct 28 2016 02:04
it gives me : error: unknown package: scydev:reaction-search
Brent Hoover
@zenweasel
Oct 28 2016 02:05
I don’t think all of his packages are public. You really would need to look at this code
Ankit
@ankit-tj
Oct 28 2016 02:05
oh ok, thanks.
Ankit
@ankit-tj
Oct 28 2016 02:12
@aaronjudd
sorry by mistake done
Aaron Judd
@aaronjudd
Oct 28 2016 02:12
:smile:
samgitre
@samgitre
Oct 28 2016 02:16
Hello, brothers
yesterday I upgraded my reaction project from my previous meteor version to version 1.4.2, after that my project could not run again.
Brent Hoover
@zenweasel
Oct 28 2016 02:19
and sisters, and those who don’t wish their gender enumerated. ;)
samgitre
@samgitre
Oct 28 2016 02:20
i'm working on Ubuntu 16
Brent Hoover
@zenweasel
Oct 28 2016 02:20
we’re all working on 1.4.2 so pretty sure reaction works with it
how did you upgrade?
samgitre
@samgitre
Oct 28 2016 02:21
it works with my other team members
Aaron Judd
@aaronjudd
Oct 28 2016 02:22
@samgitre if you have an issue with _browser module not found, you’ll need to delete node_modules and reinstall, that’s the only update error I’ve seen... the usual answer here is reaction reset.
samgitre
@samgitre
Oct 28 2016 02:23
@aaronjudd : _browser not found is the problem
ok, let me delete the node_modules and reinstall
Aaron Judd
@aaronjudd
Oct 28 2016 02:25
oh, also, I saw that someone with an older development branch had a conflict in package.json, just make sure that’s the not the case as well.
samgitre
@samgitre
Oct 28 2016 02:29
ok
@zenweasel : I forgot to include sisters and others to my greetings, now I extend my greetings to them as well
:smile:
Brent Hoover
@zenweasel
Oct 28 2016 02:32
:) :+1:
samgitre
@samgitre
Oct 28 2016 02:37
:+1:
samgitre
@samgitre
Oct 28 2016 02:50
Error: Cannot find module './browsers'
at require (packages/modules-runtime.js:109:19)
at packages/modules.js:18809:14
at meteorInstall.node_modules.autoprefixer.lib.autoprefixer.js (packages/modules.js:18888:4)
at fileEvaluate (packages/modules-runtime.js:181:9)
at Module.require (packages/modules-runtime.js:106:16)
at Module.Mp.import (/home/samgitre/.meteor/packages/modules/.0.7.7.dqdz95++os+web.browser+web.cordova/npm/node_modules/reify/lib/runtime.js:70:16)
at meteorInstall.server.api.core.ui.js (server/api/core/ui.js:1:1)
at fileEvaluate (packages/modules-runtime.js:181:9)
at Module.require (packages/modules-runtime.js:106:16)
at Module.Mp.import (/home/samgitre/.meteor/packages/modules/.0.7.7.dqdz95++os+web.browser+web.cordova/npm/node_modules/reify/lib/runtime.js:70:16)
at meteorInstall.server.api.core.index.js (server/api/core/index.js:1:1)
at fileEvaluate (packages/modules-runtime.js:181:9)
at Module.require (packages/modules-runtime.js:106:16)
at Module.Mp.import (/home/samgitre/.meteor/packages/modules/.0.7.7.dqdz95++os+web.browser+web.cordova/npm/node_modules/reify/lib/runtime.js:70:16)
at meteorInstall.server.api.index.js (server/api/index.js:1:1)
at fileEvaluate (packages/modules-runtime.js:181:9)
I still got the error after deleting and reinstalling the node_modules.
Brent Hoover
@zenweasel
Oct 28 2016 07:53
Have you tried with a fresh install?
Dennis Rankin
@derankin
Oct 28 2016 19:40
I am also having the same problem as @samgitre after upgrading meteor to 1.4.2
Jeremy Shimko
@jshimko
Oct 28 2016 20:52
I just did a fresh clone and didn’t have any issues.
reaction init -b development onefourtwo
cd onefourtwo
reaction
I suspect it’s a node_module dir that needs to be deleted. Try…
reaction reset -y
Frank Gutierrez
@dearfrankg
Oct 28 2016 22:40
I set the ROOT_URL to my http://mydomain.com
reaction starts up saying running at http://mydomain.com
But I can only get to it at http://localhost:3000
What's up with that?
Spencer Norman
@spencern
Oct 28 2016 22:44
has your DNS propogated?
Frank Gutierrez
@dearfrankg
Oct 28 2016 22:45
my domain is pointing to my laptop
I can access nginx on my laptop with my domain
Spencer Norman
@spencern
Oct 28 2016 22:46
hmm, I think there’s also a setting in the Shops.json / Shops collection that specifies domain
not sure if that’s necessary for this or not
I’ve never run a domain pointed at local honestly
your nginx config is correct I’m assuming?
Frank Gutierrez
@dearfrankg
Oct 28 2016 22:47
it' strange that it serves at http:localhost:3000
yes, again nginx is accessible
Spencer Norman
@spencern
Oct 28 2016 22:48
is nginx acting as a rev proxy to port 3000?
Frank Gutierrez
@dearfrankg
Oct 28 2016 22:48
I just turned on nginx as a proof of concept
I was wondering if I need nginx as a proxy to 3000
Spencer Norman
@spencern
Oct 28 2016 22:49
I think you do if you want to use nginx - otherwise just launch reaction on port 80 and see if it works
Frank Gutierrez
@dearfrankg
Oct 28 2016 22:49
I was wondering if that's the typical reaction way
Spencer Norman
@spencern
Oct 28 2016 22:49
that’s how we do it
nginx:80 -> reaction:3000
Frank Gutierrez
@dearfrankg
Oct 28 2016 22:49
ok I will give that a try - thanks