These are chat archives for reactioncommerce/reaction

15th
Mar 2017
Vigy
@vigyano
Mar 15 2017 08:33
getting following error when adding shipping info. I have a custom plugin enabled to override layouts/templates, is there anything specific I need to do if I have custom plugin?
Exception while invoking method 'shipping/rates/add' Error: Match error: Match error: Shipment Method Id is required
Brent Hoover
@zenweasel
Mar 15 2017 08:35
I need a little more info about the context of that error to know what’s going on
@vigyano To answer your question, no there is nothing extra you need to know about running a custom plug-in. It’s just more code.
Vigy
@vigyano
Mar 15 2017 08:36
blob
I get this error when adding flat rate item.
Exception while invoking method 'shipping/rates/add' Error: Match error: Match error: Shipment Method Id is required
    at exports.check (packages/check.js:57:15)
    at [object Object].methods.shipping/rates/add (imports/plugins/included/shipping-rates/server/methods/rates.js:17:5)
    at packages/check.js:130:16
    at [object Object]._.extend.withValue (packages/meteor.js:1122:17)
    at Object.exports.Match._failIfArgumentsAreNotAllChecked (packages/check.js:129:41)
    at maybeAuditArgumentChecks (packages/ddp-server/livedata_server.js:1734:18)
    at packages/ddp-server/livedata_server.js:719:19
    at [object Object]._.extend.withValue (packages/meteor.js:1122:17)
    at packages/ddp-server/livedata_server.js:717:40
    at [object Object]._.extend.withValue (packages/meteor.js:1122:17)
    at packages/ddp-server/livedata_server.js:715:46
    at [object Object]._.extend.protocol_handlers.method (packages/ddp-server/livedata_server.js:689:23)
    at packages/ddp-server/livedata_server.js:559:43
Sanitized and reported to the client as: Match failed [400]
Brent Hoover
@zenweasel
Mar 15 2017 08:37
Could you give me some steps to get there?
Vigy
@vigyano
Mar 15 2017 08:40
Steps:
1) Clicked Dashboard -> Shipping -> '+' to add new item
2) Filled :
MethodName: Standard
Cost : <empty>
Public Label: Standard
Handling: 1.50
Group : Ground
Rate: 2.99
3) Checked "Enabled"
4) Click "Save Changes"
Brent Hoover
@zenweasel
Mar 15 2017 08:41
Ok, give me a minute and I will try that
Vigy
@vigyano
Mar 15 2017 08:42
Tried both in master and development branch, same issue.
Brent Hoover
@zenweasel
Mar 15 2017 08:46
I just did that without getting an error
Vigy
@vigyano
Mar 15 2017 08:46
did you have a plugin that is enabled in custom?
I have a custom plugin enabled
Brent Hoover
@zenweasel
Mar 15 2017 08:47
No, but I suppose I could try that
Vigy
@vigyano
Mar 15 2017 08:47
I think if we have custom plugin this error occurs
Brent Hoover
@zenweasel
Mar 15 2017 08:48
Hmmm, I don’t know how that would be true, but I will test
Brent Hoover
@zenweasel
Mar 15 2017 08:59
Same deal with custom plugin installed. No error
Vigy
@vigyano
Mar 15 2017 09:00
hmm, thanks for checking. Not sure what issue in my end. any idea what "shipment method id is required" mean?
Have you modified any of the shipping code?
Vigy
@vigyano
Mar 15 2017 09:04
no, I didn't
Brent Hoover
@zenweasel
Mar 15 2017 09:04
This is code that’s been working since, well a long, long time
so unless you are adding hooks or changing schemas I don’t see how a plugin would even affect it
Vigy
@vigyano
Mar 15 2017 09:08
I just used the reaction example plugin and customized it further to include our templates
no hooks or schema changes
Brent Hoover
@zenweasel
Mar 15 2017 09:08
Yeah, that’s what I just tested with
Vigy
@vigyano
Mar 15 2017 09:10
maybe I will do the same and use the reaction example plugin and test so that I can corner the issue if it is related to my custom plugin
Brent Hoover
@zenweasel
Mar 15 2017 09:15
yeah, that’s a good idea. Do you have your plug up on GH?
Vigy
@vigyano
Mar 15 2017 09:20
not in GH, its private repo in bitbucket. If you have login to bitbucket I can share the plugin
Brent Hoover
@zenweasel
Mar 15 2017 09:21
Hmmm, I used to. It’s been a loooong time
Vigy
@vigyano
Mar 15 2017 10:11
on another issue, on many products it shows "sold out" even if the quantity is more than 1.
Kolawole Michael Alade
@michael-alade
Mar 15 2017 10:11
@vigyano Does it show any error?
Vigy
@vigyano
Mar 15 2017 10:12
no just "sold out" tag on top of each product even if the variant quantity is greater than 1
Kolawole Michael Alade
@michael-alade
Mar 15 2017 10:12
Could you share a screenshot of the edit variant sidebar?
@vigyano
Vigy
@vigyano
Mar 15 2017 10:17
blob
Brent Hoover
@zenweasel
Mar 15 2017 10:22
Are you using the current version?
Vigy
@vigyano
Mar 15 2017 10:22
development branch
also tried master and same issue
Brent Hoover
@zenweasel
Mar 15 2017 10:23
v0.20?
Vigy
@vigyano
Mar 15 2017 10:24
yes, i tried 0.19 and 0.20 and same issue
Brent Hoover
@zenweasel
Mar 15 2017 10:24
can you give me some more detailed steps to replicate? Because I am not seeing that here
Vigy
@vigyano
Mar 15 2017 10:29
blob
Brent Hoover
@zenweasel
Mar 15 2017 10:30
yeah, something is funky with your installation
Vigy
@vigyano
Mar 15 2017 10:30
@zenweasel - regarding shipping error, I used latest reaction example plugin and got the same error while adding the shipping.
Also, noticed "sold out" tag that I mentioned in second issue.
Brent Hoover
@zenweasel
Mar 15 2017 10:30
Yeah, but I am using the same code and I can’t replicate it
Vigy
@vigyano
Mar 15 2017 10:31
but I built docker in my mac and deployed, but same issue with my custom plugin
Brent Hoover
@zenweasel
Mar 15 2017 10:31
and there’s just no way the example-plugin is causing that error with flat rate shipping
I notice you are using the sample data too?
let me try that
Vigy
@vigyano
Mar 15 2017 10:33
yeah, i copied the private data to reaction root
i did reaction reset before switching the plugin
Brent Hoover
@zenweasel
Mar 15 2017 10:33
Yeah, maybe something needs to be updated in the sample data
Could you try it just using the built-in data?
Vigy
@vigyano
Mar 15 2017 10:35
without moving the private data from example plugin?
Brent Hoover
@zenweasel
Mar 15 2017 10:35
correct
Vigy
@vigyano
Mar 15 2017 10:35
k, let me try that
Brent Hoover
@zenweasel
Mar 15 2017 10:36
Yeah, I think that’s the ticket
Bee_s_Knees.png
Vigy
@vigyano
Mar 15 2017 10:37
I see, can you also try adding shipping flat rate?
Brent Hoover
@zenweasel
Mar 15 2017 10:37
yep, doing that
Bee_s_Knees.png
Vigy
@vigyano
Mar 15 2017 10:38
ah!
Brent Hoover
@zenweasel
Mar 15 2017 10:39
so there’s something about that sample data that’s in an incorrect format
You don’t really need that Shipping.json anyway
I should just remove that from the plugin
Vigy
@vigyano
Mar 15 2017 10:41
not only sample data. with my custom plugin, I loaded empty products and then started adding products to it through the interface. Even this way, I am not able to update the shipping.
maybe something to do with private/data/Shops.json, do you think?
Brent Hoover
@zenweasel
Mar 15 2017 10:42
what if you don’t copy the sameple data and use the included data only?
revert all those files to the originals
Vigy
@vigyano
Mar 15 2017 10:42
doing thatnow
Brent Hoover
@zenweasel
Mar 15 2017 10:42
yeah either Shops.json or Shipping.json or both
I would bet $10 that’s what it is, because I wasn’t doing that and everything worked
Vigy
@vigyano
Mar 15 2017 10:44
yup, able to add Shipping flat rate with default data.
Brent Hoover
@zenweasel
Mar 15 2017 10:44
:clap:
there’s no real reason to use that sample data. It’s just for the tutorial
Vigy
@vigyano
Mar 15 2017 10:47
but I am not using that sample data in my custom plugin. I created an empty site and added the products through interface. Then exported the products.json and using in docker image to deploy
Brent Hoover
@zenweasel
Mar 15 2017 10:48
you're not using any of the sample files?
Vigy
@vigyano
Mar 15 2017 10:48
no, I overwrote those sample data with my exported json
Brent Hoover
@zenweasel
Mar 15 2017 10:48
including Shops.json?
Vigy
@vigyano
Mar 15 2017 10:49
yes, including shops.json
Brent Hoover
@zenweasel
Mar 15 2017 10:49
what files did you export?
Vigy
@vigyano
Mar 15 2017 10:51
  • Products.json
  • Shipping.json
  • Shops.json
  • Tags.json
Brent Hoover
@zenweasel
Mar 15 2017 10:52
and if you import those files into your local install it works?
Vigy
@vigyano
Mar 15 2017 10:53
I didn't import them in my local install
just exported
probably can try that
Brent Hoover
@zenweasel
Mar 15 2017 10:55
ok, dinner break. :chicken:
Vigy
@vigyano
Mar 15 2017 10:55
ok, got to catch some sleep
will try in the morning
Brent Hoover
@zenweasel
Mar 15 2017 10:56
kk
Ivanthadev
@ivanthemeh
Mar 15 2017 14:25
anyone around? IM having a few issues with my deploy and site.
alexhfch
@alexhfch
Mar 15 2017 20:34
Hello Guys, I have successfully deployed Reaction onto Ubuntu Docker 17.03.0-ce on 14.04 using this guide https://hub.docker.com/r/reactioncommerce/reaction/, frontend is all up and running, however I have never received verification email and I cannot log into the backend, while trying to sign in using my user and pass, it shows "oops please validate your email first", please advise
Brent Hoover
@zenweasel
Mar 15 2017 21:53
DId you pass in your mail server info?
alexhfch
@alexhfch
Mar 15 2017 21:53
No, how and where do I do that?
Brent Hoover
@zenweasel
Mar 15 2017 21:55
as en environment variable: MAIL_URL
alexhfch
@alexhfch
Mar 15 2017 21:58
10-4, thanks Brent