These are chat archives for reactioncommerce/reaction

28th
Aug 2017
Vinay
@vip20
Aug 28 2017 11:39
Is there anything similar to RC?
Brent Hoover
@zenweasel
Aug 28 2017 11:48
Nope. Nothing like it.
@patmir Just trying editing and resaving your address and see if it updates. Updates to shipping methods are not reactive. This only affects the first time you check out as an admin.
patmir
@patmir
Aug 28 2017 12:10
@zenweasel The log shows errors with retrieving tax calculation from alavara. I would often see an errors such as "Cannot save address", or "no shipping options configured", then in logs I see the shipping rates being retrieved, shipping address being saved in database record and alavara errors.
Patrick Tavares
@patrick-tavares
Aug 28 2017 12:21
speaking of reactive... what's being used to drive that? I don't see any react-komposer references anywhere in the code :P
Alihan
@mursalal
Aug 28 2017 12:39
Hello! How enter in Admin Dashboard?
patmir
@patmir
Aug 28 2017 12:40
Default login is admin@localhost/r3@cti0n
Brent Hoover
@zenweasel
Aug 28 2017 12:43
@patrick-tavares We are using recompose and our own composeWithTracker
patmir
@patmir
Aug 28 2017 12:43
@zenweasel It would also seem that if I set the shop address to something else, I'm getting empty response from Shippo API
Brent Hoover
@zenweasel
Aug 28 2017 12:44
@patmir Not sure what could be going on there
Have you enabled address validation in Shippo?
patmir
@patmir
Aug 28 2017 12:45
@zenweasel I haven't noticed any address validation option
@zenweasel Is it in Shippo dashboard or reaction dashboard?
Brent Hoover
@zenweasel
Aug 28 2017 12:47
It’s not something we support. I imagine it would be somewhere in the Shippo dashboard
patmir
@patmir
Aug 28 2017 12:47
@zenweasel It's not, it's in the API call -> https://goshippo.com/docs/address-validation
Brent Hoover
@zenweasel
Aug 28 2017 12:48
Do you have address validation turned on for Avalara?
patmir
@patmir
Aug 28 2017 12:49
Currently on fresh install with disabled Avalara
Brent Hoover
@zenweasel
Aug 28 2017 12:49
then that makes no sense. Avalara certainly has nothing to do with a no shipping options configured error
Are you sure you aren’t having connectivity problems?
patmir
@patmir
Aug 28 2017 12:50
It might be that I was getting empty rates due to that address validation, causing this error. Since alavara tax calculation is triggered more-less at the same time, it also produced an error
If i use default shop address Shippo works
Brent Hoover
@zenweasel
Aug 28 2017 12:51
Avalara and Shippo are not connected in any way
failure of Avalara address validation (if it was turned on) would block you from moving to the Shipping step
not sure what would happen if you entered an invalid address for Shippo
it might just give you a “no rates” message
patmir
@patmir
Aug 28 2017 12:56
I guess so. So I have two issues -> empty rates return with address located in Poland or Austria, and Avalara tax calucation. Currently I have disabled Avalara completely, getting no shipping rates error
Brent Hoover
@zenweasel
Aug 28 2017 12:57
I don’ t know how it would be possible for Avalara to have anything to do with Shipping Rates
patmir
@patmir
Aug 28 2017 12:58
It doesn't. I'm trying to point out that those are the two errors I got. I missed the empty return of Shippo rates and saw Avalara error message, saw "no shipping configured". So the "no shipping" is caused by empty Shippo rates, avalara error is another, separate issue.
Brent Hoover
@zenweasel
Aug 28 2017 13:00
I would expect that the empty rates is because the carriers you have enabled don’t operate at those locations or can’t recorgnize the address.
patmir
@patmir
Aug 28 2017 13:01
I would assume since I can get shipping rates correctly for USPS and DHL for shippments from US to PL, i should also get PL to PL
Brent Hoover
@zenweasel
Aug 28 2017 13:02
Can you manually get quotes for those exact addresses for those carriers?
patmir
@patmir
Aug 28 2017 13:04
I will try
Brent Hoover
@zenweasel
Aug 28 2017 13:04
Not sure if Shppo allows you to get quotes via their site
Looking
patmir
@patmir
Aug 28 2017 13:05
No, the API Test Drive sets the default "from" address
Brent Hoover
@zenweasel
Aug 28 2017 13:05
Bummer
patmir
@patmir
Aug 28 2017 13:06
Tough they provide curl call example
Brent Hoover
@zenweasel
Aug 28 2017 13:06
DId you try just using curl?
patmir
@patmir
Aug 28 2017 13:06
I'm on it
Brent Hoover
@zenweasel
Aug 28 2017 13:11
Ok, I need to head to bed, but that should at least show you if Shippo should be returning rates for those addresses and then we can go from there
patmir
@patmir
Aug 28 2017 13:11
Thanks for the clues
Brent Hoover
@zenweasel
Aug 28 2017 13:11
:+1:
Mateo Morrison
@mateomorrison
Aug 28 2017 13:18
Hello guys
I got this showing up
WhatsApp Image 2017-08-27 at 7.55.04 PM.jpeg
How do I fix it
patmir
@patmir
Aug 28 2017 13:21
Where are you getting this error?
Mateo Morrison
@mateomorrison
Aug 28 2017 13:21
When I search for my website
on Google
Loan Laux
@loanlaux
Aug 28 2017 13:21
That's intersting
Mateo Morrison
@mateomorrison
Aug 28 2017 13:21
Huh?
Loan Laux
@loanlaux
Aug 28 2017 13:22
My Reaction Commerce website isn't in production yet so I obviously can't relate
patmir
@patmir
Aug 28 2017 13:22
It's weird, google crawler should support JS websites
You can use it to test what sort of data the crawler gets from your website
Vinay
@vip20
Aug 28 2017 13:24
If I update code in prod will there be any affect to the existing DB?
Mateo Morrison
@mateomorrison
Aug 28 2017 13:38
I heard something about Spiderable. Does it have something to do with it
Alihan
@mursalal
Aug 28 2017 13:39
Can anyone share settings.json example?
settings.json need to fill on deploy in production?
patmir
@patmir
Aug 28 2017 13:46
@zenweasel It appears that default Shippo carriers don't support shipments originating from countries other than US, Canada or Germany.
Mateo Morrison
@mateomorrison
Aug 28 2017 14:14
Hello guys can you help with this:
WhatsApp Image 2017-08-27 at 7.55.04 PM.jpeg
Alihan
@mursalal
Aug 28 2017 15:22
Hi, please link me to AWS Deploy guide.
Lorenzo Campanis
@lcampanis
Aug 28 2017 17:10
@mateomorrison Spiderable should be enabled in your plugins in order for the render to happen. Enable it in .meteor/packages.
@mursalal It's best to have your settings in environment variables instead. Those keys in settings.json correspond to environment variables. See https://docs.reactioncommerce.com/reaction-docs/v1.4.1/installation You can use settings.json for local development, as dev.settings.json is not ignored by git and will be available to everyone with access to your repository.
@vip20 updating code will always have some effect if you change register.js files, add new packages, new translations, etc.. Any settings you have set through the admin though will not be overridden, unless you reset reaction, in which case everything will be affected.
@patmir Shippo offers those carriers by default in the US as Shippo is based in the US. You will have to open business accounts with the rest of the carriers in order to use them with Shippo.
NemesisMate
@NemesisMate
Aug 28 2017 17:20
Hi, I've just installed reaction with docker and it is working, but I'm having troubles when trying to "override" the reaction folder with a "host reaction folder", so I can easily develop it under docker. Is there any consideration I have to take into account?
Sophie He
@sophiehe
Aug 28 2017 18:12
Hi everyone. Just a reminder that our Reaction Action livestream and Q&A is taking place tmrw at 7am PT/ 10 am ET. RSVP here: getrxn.io/reaction-action-august
Josh Cox
@joshuacox
Aug 28 2017 19:17
@NemesisMate perhaps share how you are doing this? I could envision a dockerized reaction dev environment, something like this --> https://github.com/joshuacox/reactiondev make to build it, run it, and follow the logs, ctrl-C to stop watching the logs, and make enter to go into the dev environment, which should also be on http://localhost:3000 while inside you should have your ssh keys, so you can do things like git remote add mycustomreaction git@github.com:githhubuser/mycustomreaction so you can push any changes you make.
Josh Cox
@joshuacox
Aug 28 2017 23:18
something is an issue in alpine, probably missing something still, I made a debian branch and merged that into master once I got it functioning, I'll poke at the alpine branch more as curiosity gets the best of me. https://hub.docker.com/r/joshuacox/reactiondev/ <-- not sure if anyone plans on dev'ing in a container aside from @NemesisMate and myself, but this is interesting as I multiboot between many different linux flavors and occasionally even windoze and mac, abstracting dev away from all the differences between those is not a bad thing imho. And just might be another avenue for people struggling to get their node environment setup correctly