These are chat archives for reactioncommerce/reaction

29th
Oct 2017
Emem Umoh
@ememumoh
Oct 29 2017 10:52
I keep having this error: "FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - process out of memory" please help

D:\reactioncommerceprojects\reaction>reaction

Using settings file at settings/dev.settings.json

Setting up plugin imports...

Installing dependencies for connectors-shopify...

Setting up style imports...

[[[[[ ~\D\reactioncommerceprojects\reaction ]]]]]

=> Started proxy.
FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - process out of memory

D:\reactioncommerceprojects\reaction>

Can anyone help on the above error please
I have enough memory!
Emem Umoh
@ememumoh
Oct 29 2017 12:16
Hello? Any help on: "FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - process out of memory"
@jshimko please help
@zenweasel please help
Emem Umoh
@ememumoh
Oct 29 2017 12:30
@aaronjudd Please help on: "FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - process out of memory"
Emem Umoh
@ememumoh
Oct 29 2017 12:49
I am stuck on this.
Stevaras
@stevaras
Oct 29 2017 15:18
@ememumoh You could try as a temporary solution to change Meteor version from 1.5.2.2 to 1.5.1.
You can do that by going inside your Reaction's project folder, then inside .meteor (which is a hidden folder) and from there open the "release" file.
There you'll see "METEOR@1.5.2.2". Change it to "METEOR@1.5.1". It's not that you won't see this allocation error again but at least this way it's less frequently.
Emem Umoh
@ememumoh
Oct 29 2017 16:36
@stevaras got stuck at "setting up style imports ..."
This is really frustrating
Stevaras
@stevaras
Oct 29 2017 17:27
@ememumoh Usually it takes me about 2-3 tries to actually run it.
That's really bad. If you tried at least 3 times and still nothing I'm not sure what you can do.
For sure try closing all other windows, browsers and stuff. Maybe even add some swap memory?
I suppose you could try an older version of Meteor although from what I understood from the comments above, Meteor 1.6 is almost here.
Hopefully this could solve this frustrating indeed issue :)
Jeremy Shimko
@jshimko
Oct 29 2017 18:53
@ememumoh perhaps try adding this before the reaction command…
TOOL_NODE_FLAGS="--max-old-space-size=2048" reaction
Emem Umoh
@ememumoh
Oct 29 2017 19:27
@jshimko in windows?
Jeremy Shimko
@jshimko
Oct 29 2017 19:27
yes
Emem Umoh
@ememumoh
Oct 29 2017 19:28
@jshimko I got this error: "'TOOL_NODE_FLAGS' is not recognized as an internal or external command,
operable program or batch file."
Can I do with the Git Bash?
Jeremy Shimko
@jshimko
Oct 29 2017 19:29
yes
Emem Umoh
@ememumoh
Oct 29 2017 19:29
Okay let me try then
Jeremy Shimko
@jshimko
Oct 29 2017 19:29
the Windows cmd prompt is extremely inflexible. use a bash terminal any time you can
Emem Umoh
@ememumoh
Oct 29 2017 19:30
Okay
Emem Umoh
@ememumoh
Oct 29 2017 19:36
TOOL_NODE_FLAGS="--max-old-space-size=2048" reaction flags process out of memory error
I change 2048 to 1024, it is running now but has not concluded yet
@jshimko are you there?
Jeremy Shimko
@jshimko
Oct 29 2017 19:38
yes
Emem Umoh
@ememumoh
Oct 29 2017 19:39
@jshimko @ememumoh
TOOL_NODE_FLAGS="--max-old-space-size=2048" reaction flags process out of memory error
I change 2048 to 1024, it is running now but has not concluded yet
Michael Duane Mooring
@mikeumus
Oct 29 2017 19:53

Hey Team, after upgrading from 1.4.x to 1.5.x and after rc run I'm getting this in the browser:

TypeError: require(...).__SECRET_INTERNALS_DO_NOT_USE_OR_YOU_WILL_BE_FIRED is undefined

This Stack Overflow says react isn't loading correctly: https://stackoverflow.com/a/34439712/1762493
I found imports/plugins/core/ui/client/helpers/react-template-helper.js where React is mainly being loaded I think. Any ideas what could be missing here?

Emem Umoh
@ememumoh
Oct 29 2017 20:10

how can I resolve this: cfs:graphicsmagick could not find "graphicsMagic" or "imageMagic" on the
system.

I just checked PATH to see if I could find the GraphicsMagick or ImageMagic
unix/mac os/windows binaries on your system, I failed.

Why:

  1. I may be blind or naive, help making me smarter
  2. You havent added the path to the binaries
  3. You havent actually installed GraphicsMagick or ImageMagick

Make sure "$PATH" environment is configured "PATH:/path/to/binaries"

I have GraphicsMagick installed and it on the path
Because the site rendering is blank!!!
Michael Duane Mooring
@mikeumus
Oct 29 2017 20:45
What happened to the development branch from CONTRIBUTING.md here?
https://github.com/reactioncommerce/reaction/blob/master/CONTRIBUTING.md#pull-requests
Jeremy Shimko
@jshimko
Oct 29 2017 21:14
@mikeumus Looks like we missed that when the development branch got deprecated. Pull requests should go to master now.
@ememumoh try installing imagemagick
https://www.imagemagick.org/script/download.php#windows
Emem Umoh
@ememumoh
Oct 29 2017 21:19
@jshimko I have done that to no avail
Jeremy Shimko
@jshimko
Oct 29 2017 21:31
what version of Windows?
Emem Umoh
@ememumoh
Oct 29 2017 21:32
@jshimko windows 10 professional
Jeremy Shimko
@jshimko
Oct 29 2017 21:34
Ok. I don’t have a Windows machine, but I'll try setting up a VM and see if I can reproduce it. Sorry you’re having such a hard time. Windows development environments can be pretty hard to set up sometimes.
Emem Umoh
@ememumoh
Oct 29 2017 21:35
@jshimko hmmmmm.........I cannot afford a mac
Jeremy Shimko
@jshimko
Oct 29 2017 21:39
I don’t think you need to buy another computer. A lot of people use Windows without issues. There is probably just a setup step we’re missing.
Install/setup problems are unfortunately not uncommon on Windows. We are trying to make installs easier for Windows user though. It’s absolutely a priority for the near term.
Emem Umoh
@ememumoh
Oct 29 2017 21:44
Hello @jshimko TOOL_NODE_FLAGS="--max-old-space-size=2048" command actually works but rendered blank page on the browser and flag the "cfs:graphicsmagick could not find "graphicsMagic" or "imageMagic" on the
system." on the console. Is the blank rendering on the browser, due to the graphicsmagick or imagemagic issue?
Jeremy Shimko
@jshimko
Oct 29 2017 21:45
I don’t think so. I haven’t seen that before. Are there any errors in the browser console?
Emem Umoh
@ememumoh
Oct 29 2017 21:49
alot of errors like:
ejson.js?hash=3af8c8d…:21 Uncaught TypeError: Cannot read property 'Symbol' of undefined
at ejson.js?hash=3af8c8d…:21
at ejson.js?hash=3af8c8d…:861
(anonymous) @ ejson.js?hash=3af8c8d…:21
(anonymous) @ ejson.js?hash=3af8c8d…:861
diff-sequence.js?hash=15014d7…:18 Uncaught TypeError: Cannot read property 'EJSON' of undefined
at diff-sequence.js?hash=15014d7…:18
at diff-sequence.js?hash=15014d7…:297
(anonymous) @ diff-sequence.js?hash=15014d7…:18
(anonymous) @ diff-sequence.js?hash=15014d7…:297
id-map.js?hash=c7aea8d…:18 Uncaught TypeError: Cannot read property 'EJSON' of undefined
at id-map.js?hash=c7aea8d…:18
at id-map.js?hash=c7aea8d…:123
there are so many!
@jshimko I do really have a problem so many errors
Emem Umoh
@ememumoh
Oct 29 2017 22:24
@jshimko this: -- core-js@2.5.1 dependence was lacking, when I install it, the rendering on the browser is fine now, just that grahics sizes cannot be adjusted due to the images issues (that is ...magicks are not found).