These are chat archives for reactioncommerce/reaction

6th
Aug 2018
rohit-elevar
@rohit-elevar
Aug 06 2018 08:38
My issue is resolved. I removed and re-installed docker, and It's working now
Enny Isambert
@ennysantana
Aug 06 2018 13:52
Hey dudes!!
Nodejs 8.x is recommended to use reaction? or is better use 6.x?
Loan Laux
@loanlaux
Aug 06 2018 13:56
@ennysantana 8.11 afaik
Enny Isambert
@ennysantana
Aug 06 2018 14:06
Captura de pantalla de 2018-08-06 11-05-06.png
i'm asking because i'm getting npm ERR! and i dont know why
i have all the prerequirements, node 8.11, meteor, development tools...
Help please guys!!
and excuse me by the bad english, im from Venezuela
Enny Isambert
@ennysantana
Aug 06 2018 14:15
@loanlaux could you help me bro?
ramin
@rmros
Aug 06 2018 14:16
@ennysantana اه
hi
i saw your error
use docker composer
Enny Isambert
@ennysantana
Aug 06 2018 14:59
@rmros thanks bro! i installed docker compose but i'm getting error when reaction-cli is trying to install sharp

```Installing NPM packages...

[ .......] | extract:@babel/helper-annotate-as-pure: sill extract leven@2.1.0 extracted to /home/enny/Javasc

dtrace-provider@0.8.5 install /home/enny/Javascript/reaction/node_modules/dtrace-provider
node scripts/install.js

fibers@2.0.0 install /home/enny/Javascript/reaction/node_modules/fibers
node build.js || nodejs build.js

linux-x64-57 exists; testing
Binary is fine; exiting

sharp@0.19.0 install /home/enny/Javascript/reaction/node_modules/sharp
node-gyp rebuild

gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir '/home/enny/Javascript/reaction/node_modules/sharp/build'
gyp ERR! System Linux 4.15.0-20-generic
gyp ERR! command "/home/enny/.meteor/packages/meteor-tool/.1.7.0_3.u9lhms.hf7k++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node" "/home/enny/.meteor/packages/meteor-tool/.1.7.0_3.u9lhms.hf7k++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/enny/Javascript/reaction/node_modules/sharp
gyp ERR! node -v v8.11.3
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sharp@0.19.0 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sharp@0.19.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/enny/.npm/_logs/2018-08-06T14_55_52_217Z-debug.log

Error: Node modules were not successfully installed. Exiting.
´´´

Sorry!!

Again: ```Installing NPM packages...

[ .......] | extract:@babel/helper-annotate-as-pure: sill extract leven@2.1.0 extracted to /home/enny/Javasc

dtrace-provider@0.8.5 install /home/enny/Javascript/reaction/node_modules/dtrace-provider
node scripts/install.js

fibers@2.0.0 install /home/enny/Javascript/reaction/node_modules/fibers
node build.js || nodejs build.js

linux-x64-57 exists; testing
Binary is fine; exiting

sharp@0.19.0 install /home/enny/Javascript/reaction/node_modules/sharp
node-gyp rebuild

gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir '/home/enny/Javascript/reaction/node_modules/sharp/build'
gyp ERR! System Linux 4.15.0-20-generic
gyp ERR! command "/home/enny/.meteor/packages/meteor-tool/.1.7.0_3.u9lhms.hf7k++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node" "/home/enny/.meteor/packages/meteor-tool/.1.7.0_3.u9lhms.hf7k++os.linux.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/enny/Javascript/reaction/node_modules/sharp
gyp ERR! node -v v8.11.3
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sharp@0.19.0 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sharp@0.19.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/enny/.npm/_logs/2018-08-06T14_55_52_217Z-debug.log

Error: Node modules were not successfully installed. Exiting.
```

Enny Isambert
@ennysantana
Aug 06 2018 15:05
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sharp@0.19.0 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sharp@0.19.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/enny/.npm/_logs/2018-08-06T14_55_52_217Z-debug.log

Error: Node modules were not successfully installed. Exiting.
Brent Hoover
@zenweasel
Aug 06 2018 20:46
Are you on Node 9? Node 9 is not supported and Sharp does not have a binary for it