by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 18 07:45
    loan-laux closed #6280
  • Sep 18 05:13
    snyk-bot opened #6287
  • Sep 18 05:13

    chrispotter on snyk-upgrade-35ade7f199b5da3e048ea6a8a834d667

    fix: upgrade react-animate-heig… (compare)

  • Sep 18 05:13

    chrispotter on snyk-upgrade-35ade7f199b5da3e048ea6a8a834d667

    (compare)

  • Sep 18 05:13
    snyk-bot opened #6286
  • Sep 18 05:13

    chrispotter on snyk-upgrade-b189f6d8e1a18ea3b7fa87e81109530b

    fix: upgrade csv-parse from 4.4… (compare)

  • Sep 18 05:13

    chrispotter on snyk-upgrade-b189f6d8e1a18ea3b7fa87e81109530b

    (compare)

  • Sep 18 05:13
    snyk-bot opened #6285
  • Sep 18 05:13

    chrispotter on snyk-upgrade-6a07602fe850958edaed9e8e067dcfc6

    fix: upgrade multiple dependenc… (compare)

  • Sep 18 05:13

    chrispotter on snyk-upgrade-6a07602fe850958edaed9e8e067dcfc6

    (compare)

  • Sep 18 05:13
    snyk-bot opened #6284
  • Sep 18 05:13

    chrispotter on snyk-upgrade-dda97971d04dca5e0ea8581df7a452ef

    fix: upgrade @babel/runtime fro… (compare)

  • Sep 18 05:13

    chrispotter on snyk-upgrade-dda97971d04dca5e0ea8581df7a452ef

    (compare)

  • Sep 17 21:58
    kieckhafer edited #6282
  • Sep 17 21:57
    kieckhafer synchronize #6282
  • Sep 17 21:57

    kieckhafer on release-next-v2.9.3

    update EOL copy Signed-off-by:… (compare)

  • Sep 17 21:43
    kieckhafer synchronize #6282
  • Sep 17 21:43

    kieckhafer on release-next-v2.9.3

    trigger snyk Signed-off-by: Er… (compare)

  • Sep 17 21:41
    snyk-bot opened #6283
  • Sep 17 21:41

    kieckhafer on snyk-fix-5ab614f4014f8fcc02bdf6af2553fd63

    fix: package.json, package-lock… (compare)

incapsulatesshamala
@incapsulatesshamala

@HarisSpahijaPon also my identity app not showing up at http://localhost:4100/

i dont see any errors, no network calls on load of http://localhost:4100/

HarisSpahijaPon
@HarisSpahijaPon
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES ef86ec696434 reactioncommerce/admin:3.0.0-beta.5 "docker-entrypoint.s…" 6 minutes ago Up 5 minutes 0.0.0.0:4080->4080/tcp, 0.0.0.0:9231->9229/tcp reaction-admin_reaction-admin_1 c9237d3cec17 reactioncommerce/identity:3.0.0 "docker-entrypoint.s…" 18 hours ago Up 5 minutes 0.0.0.0:4100->4100/tcp reaction-identity_identity_1 d783b4daa651 reactioncommerce/example-storefront:3.0.0 "docker-entrypoint.s…" 19 hours ago Up 5 minutes 0.0.0.0:4000->4000/tcp example-storefront_web_1 01130c0a7793 reactioncommerce/reaction:3.0.0 "docker-entrypoint.s…" 19 hours ago Up 5 minutes 0.0.0.0:3000->3000/tcp reaction_api_1 a46a288ee669 mongo:4.2.0 "docker-entrypoint.s…" 19 hours ago Up 5 minutes 0.0.0.0:27017->27017/tcp reaction_mongo_1 441081dde269 oryd/hydra:v1.0.8 "hydra serve all --d…" 19 hours ago Up 5 minutes 0.0.0.0:4444-4445->4444-4445/tcp, 0.0.0.0:5555->5555/tcp reaction-hydra_hydra_1 65ff354ada04 postgres:10.3 "docker-entrypoint.s…" 19 hours ago Up 5 minutes 0.0.0.0:32772->5432/tcp reaction-hydra_postgres_1
Sorry just formatting so I can see better
can you maybe log your identity
Its weird cause it does show up in the docker containers
You can find the logs by navigating to the identity folder and using docker-compose up
you should be able to see logs in your terminal
incapsulatesshamala
@incapsulatesshamala

all good here

reaction-identity_identity_1 is up-to-date Attaching to reaction-identity_identity_1 identity_1 | Waiting for MongoDB... identity_1 | MongoDB ready. identity_1 | Waiting for MongoDB replica set... identity_1 | MongoDB replica set ready. identity_1 | 18:26:15.365Z INFO Reaction: Serving Reaction Identity at http://localhost:4100 identity_1 | Waiting for MongoDB... identity_1 | MongoDB ready. identity_1 | Waiting for MongoDB replica set... identity_1 | MongoDB replica set ready. identity_1 | 12:31:03.179Z INFO Reaction: Serving Reaction Identity at http://localhost:4100

HarisSpahijaPon
@HarisSpahijaPon
but its not getting any connection?
incapsulatesshamala
@incapsulatesshamala

yes when i open http://localhost:4100, i see this

`

<!DOCTYPE html>

<html>

<head>
<link rel="stylesheet" type="text/css" class="__meteor-css__" href="/37e42b737262b860c4904c46dd85cf833511dc77.css?meteor_css_resource=true">

<link href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:200,400,600,700" rel="stylesheet">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=0">

</head>

<body><div id="react-root"><div class="jss1"><div class="jss2"></div></div></div>
<script type="text/javascript">meteor_runtime_config = JSON.parse(decodeURIComponent("%7B%22meteorRelease%22%3A%22METEOR%401.9%22%2C%22gitCommitHash%22%3A%22999098e1900b1d71ce2ec5f68f809d710b7f336c%22%2C%22meteorEnv%22%3A%7B%22NODE_ENV%22%3A%22production%22%2C%22TEST_METADATA%22%3A%22%7B%7D%22%7D%2C%22PUBLIC_SETTINGS%22%3A%7B%7D%2C%22ROOT_URL%22%3A%22http%3A%2F%2Flocalhost%3A4100%22%2C%22ROOT_URL_PATH_PREFIX%22%3A%22%22%2C%22isModern%22%3Atrue%7D"))</script>

<script type="text/javascript" src="/dd941fbe856beda43dc812683f609b928148a662.js?meteor_js_resource=true"></script>

</body>
</html>`

@HarisSpahijaPon looks like issue is in hydra
Could this help?

time="2020-02-12T17:47:05Z" level=error msg="Unable to connect to database, retrying..." error="could not ping SQL connection: dial tcp: lookup postgres.reaction.localhost on 127.0.0.11:53: no such host" hydra_1 | time="2020-02-12T17:47:05Z" level=info msg="Retrying in 0.800000 seconds..." hydra_1 | time="2020-02-12T17:47:06Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable" hydra_1 | time="2020-02-12T17:47:06Z" level=error msg="Unable to ping SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable" error="dial tcp: lookup postgres.reaction.localhost on 127.0.0.11:53: no such host"

HarisSpahijaPon
@HarisSpahijaPon
your hydra is not running though
it cannot find its backend
you can reboot hydra, maybe that will help?
incapsulatesshamala
@incapsulatesshamala
ok, can you help me how to reboot?
HarisSpahijaPon
@HarisSpahijaPon
docker-compose down and then docker-compose up --build -d
if that doesnt work you should try to remove the container aswell
incapsulatesshamala
@incapsulatesshamala
Here is the new stack trace
Attaching to reaction-hydra_postgres_1, reaction-hydra_hydra-migrate_1, reaction-hydra_hydra_1
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="No tracer configured - skipping tracing setup"
hydra_1          | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | Thank you for using ORY Hydra v1.0.8+oryOS.12!
hydra_1          |
hydra_1          | Take security seriously and subscribe to the ORY Security Newsletter. Stay on top of new patches and security insights.
hydra_1          |
hydra_1          | >> Subscribe now: http://eepurl.com/di390P <<
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Software quality assurance features are enabled. Learn more at: https://www.ory.sh/docs/ecosystem/sqa"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4445"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4444"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
postgres_1       | 2020-02-13 12:56:18.831 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
postgres_1       | 2020-02-13 12:56:18.832 UTC [1] LOG:  listening on IPv6 address "::", port 5432
postgres_1       | 2020-02-13 12:56:18.837 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
postgres_1       | 2020-02-13 12:56:18.856 UTC [23] LOG:  database system was shut down at 2020-02-13 12:55:53 UTC
postgres_1       | 2020-02-13 12:56:18.866 UTC [1] LOG:  database system is ready to accept connections
hydra-migrate_1  | time="2020-02-13T12:57:01Z" level=info msg="No tracer configured - skipping tracing setup"
hydra-migrate_1  | time="2020-02-13T12:57:01Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra-migrate_1  | time="2020-02-13T12:57:01Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
HarisSpahijaPon
@HarisSpahijaPon
And if you try again now?
incapsulatesshamala
@incapsulatesshamala
@HarisSpahijaPon i reinstalled reaction development platform from scratch
Here are my hydra logs. do you see any issue here?
Attaching to reaction-hydra_postgres_1, reaction-hydra_hydra-migrate_1, reaction-hydra_hydra_1
postgres_1       | 2020-02-13 12:56:18.831 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
postgres_1       | 2020-02-13 12:56:18.832 UTC [1] LOG:  listening on IPv6 address "::", port 5432
postgres_1       | 2020-02-13 12:56:18.837 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
postgres_1       | 2020-02-13 12:56:18.856 UTC [23] LOG:  database system was shut down at 2020-02-13 12:55:53 UTC
postgres_1       | 2020-02-13 12:56:18.866 UTC [1] LOG:  database system is ready to accept connections
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="No tracer configured - skipping tracing setup"
hydra_1          | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | Thank you for using ORY Hydra v1.0.8+oryOS.12!
hydra_1          |
hydra_1          | Take security seriously and subscribe to the ORY Security Newsletter. Stay on top of new patches and security insights.
hydra_1          |
hydra_1          | >> Subscribe now: http://eepurl.com/di390P <<
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Software quality assurance features are enabled. Learn more at: https://www.ory.sh/docs/ecosystem/sqa"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4445"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4444"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-13T12:57:14Z" level=info msg="started handling request" method=GET remote="172.24.0.1:42420" request=/.well-known/openid-configuration
hydra_1          | time="2020-02-13T12:57:14Z" level=info msg="completed handling request" measure#hydra/public: http://localhost:4444/.latency=466100 method=GET remote="172.24.0.1:42420" request=/.well-known/openid-configuration status=200 text_status=OK took="466.1µs"
hydra-migrate_1  | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra-migrate_1  | time="2020-02-13T13:55:17Z" level=info msg="No tracer configured - skipping tracing setup"
hydra-migrate_1  | time="2020-02-13T13:55:17Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | time="2020-02-13T13:55:17Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | The following migration is planned:
hydra-migrate_1  |
hydra-migrate_1  | | DRIVER | MODULE | ID | # |        QUERY         |
hydra-migrate_1  | |--------|--------|----|---|----------------------|
hydra-migrate_1  | |--------|--------|----|---|----------------------|
hydra-migrate_1  | Successfully applied 0 SQL migrations!
reaction-hydra_hydra-migrate_1 exited with code 0
HarisSpahijaPon
@HarisSpahijaPon
it should run now no?
HarisSpahijaPon
@HarisSpahijaPon
Did you actually ever create a store though @incapsulatesshamala ?
Sebastian Franco
@jhonsfran1165
Hello everybody, I'm working in a new npm package locally, I'm follow this doc https://docs.reactioncommerce.com/docs/devs-update-custom-plugin#how-to-link-in-a-local-npm-package-for-a-plugin-while-working-on-it about how to work on npm package locally but when I start the API the dependencies in node_modules directory of my package is missing and the API can't start because it doesn't find dependencies of that package. Before start the API I run npm install in my package directory. Any suggestion?
Erik Kieckhafer
@kieckhafer
@jhonsfran1165 have you run npm link in the package you are trying to link, and then `npm link {package-name} inside the API first? do that, then npm install, then try again
incapsulatesshamala
@incapsulatesshamala
@HarisSpahijaPon yes, this is done...i am still not able to open reaction-identity app and create a product in reaction-admin
Erik Kieckhafer
@kieckhafer
go to localhost:3000/graphql and run the query {primaryShopId}
incapsulatesshamala
@incapsulatesshamala
yes, i got this
{
  "data": {
    "primaryShopId": "cmVhY3Rpb24vc2hvcDpjbnJyTW5yd2RjN2ZDRlR1Zw=="
  }
}
Erik Kieckhafer
@kieckhafer
ok, good to know you have a shop. is this a new 3.0 shop, or are you tryign to use 2.x data? we have migrations which must be run to get the correct user permissions if it's an older shop
incapsulatesshamala
@incapsulatesshamala
i am using brand new codebase of 3.0

This is my identity app

alt

incapsulatesshamala
@incapsulatesshamala

This is my hydra

alt

This is my admin, the spinner keeps rotating indefinetly when i try to create a product

alt

Above 3 are my issues, API and storefront are working fine
Erik Kieckhafer
@kieckhafer
i don't think you'd expect to see anything for hydra or identity if you're already logged in, i'm less concerned with that
nothing int he console or server logs aside from the access denied?
incapsulatesshamala
@incapsulatesshamala
yeah, no console issues and server logs
incapsulatesshamala
@incapsulatesshamala

I just completed installing "reaction-development-platform" in my friends laptop, same problem. looks like these is an issue in version 3

can anyone help me? i am struck badly :(

lk
@khoathanglong
I got the same issues using reaction development platform. Cannot change anything in "Shop Localization" due to access-denied (this expected to display for the user though). Same bug when creating product as above.
image.png
Erik Kieckhafer
@kieckhafer
if you continue to see this issue, can you please create a ticket in the reaction-admin repo for us to investigate?
as many logs (server and console) that you can provice would be helpful, as long as whatever actions you do to lead up to this
Erik Kieckhafer
@kieckhafer
also please keep in mind that our Reaction Admin is in beta. While we do try to keep it up to date with the latest API features, it's not always going to work 100%. If you're not able to complete this mutations and queires directly via the GraphQL API, then it's a separate API issue which we'd generally tackle more quickly than an issue solely in Reaction Admin
lk
@khoathanglong
@kieckhafer does reaction admin current depend on meteor? If true, do you have a plan to remake it to get rid of meteor? I would love to contribute to if you plan to make new version of reacction-admin
HarisSpahijaPon
@HarisSpahijaPon
Does anyone know a way to modify the addressToString function from component library?
So far the only solution I found is to pull all component that make use of the function and give it another import reference
erisvulgaris
@erisvulgaris
image.png
getting this error
at the beging
*begining