by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 24 22:08
    focusaurus closed #6288
  • Sep 24 22:08
    focusaurus commented #6288
  • Sep 24 22:07
    focusaurus review_requested #6292
  • Sep 24 22:07
    focusaurus opened #6292
  • Sep 24 22:05

    focusaurus on node14-E

    feat: Update to node v14.11.0 … fix: Make sure node-gyp is foun… update filename extension to wo… and 1 more (compare)

  • Sep 24 19:34

    focusaurus on node14-cjs-fix

    (compare)

  • Sep 24 19:34
    focusaurus synchronize #6288
  • Sep 24 19:34

    focusaurus on node14

    update filename extension to wo… update package.json glob Signe… Merge pull request #6291 from r… (compare)

  • Sep 24 19:34
    focusaurus closed #6291
  • Sep 24 17:50
    kieckhafer synchronize #6291
  • Sep 24 17:50

    kieckhafer on node14-cjs-fix

    update package.json glob Signe… (compare)

  • Sep 24 17:09
    kieckhafer edited #6291
  • Sep 24 17:09
    kieckhafer edited #6291
  • Sep 24 17:07
    kieckhafer edited #6290
  • Sep 24 17:07
    kieckhafer commented #6289
  • Sep 24 17:07
    kieckhafer closed #6290
  • Sep 24 17:06
    kieckhafer opened #6291
  • Sep 24 17:06

    kieckhafer on node14-cjs-fix

    update filename extension to wo… (compare)

  • Sep 24 17:05
    kieckhafer edited #6290
  • Sep 24 17:04
    kieckhafer opened #6290
incapsulatesshamala
@incapsulatesshamala

@HarisSpahijaPon looks like issue is in hydra
Could this help?

time="2020-02-12T17:47:05Z" level=error msg="Unable to connect to database, retrying..." error="could not ping SQL connection: dial tcp: lookup postgres.reaction.localhost on 127.0.0.11:53: no such host" hydra_1 | time="2020-02-12T17:47:05Z" level=info msg="Retrying in 0.800000 seconds..." hydra_1 | time="2020-02-12T17:47:06Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable" hydra_1 | time="2020-02-12T17:47:06Z" level=error msg="Unable to ping SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable" error="dial tcp: lookup postgres.reaction.localhost on 127.0.0.11:53: no such host"

HarisSpahijaPon
@HarisSpahijaPon
your hydra is not running though
it cannot find its backend
you can reboot hydra, maybe that will help?
incapsulatesshamala
@incapsulatesshamala
ok, can you help me how to reboot?
HarisSpahijaPon
@HarisSpahijaPon
docker-compose down and then docker-compose up --build -d
if that doesnt work you should try to remove the container aswell
incapsulatesshamala
@incapsulatesshamala
Here is the new stack trace
Attaching to reaction-hydra_postgres_1, reaction-hydra_hydra-migrate_1, reaction-hydra_hydra_1
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="No tracer configured - skipping tracing setup"
hydra_1          | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | Thank you for using ORY Hydra v1.0.8+oryOS.12!
hydra_1          |
hydra_1          | Take security seriously and subscribe to the ORY Security Newsletter. Stay on top of new patches and security insights.
hydra_1          |
hydra_1          | >> Subscribe now: http://eepurl.com/di390P <<
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Software quality assurance features are enabled. Learn more at: https://www.ory.sh/docs/ecosystem/sqa"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4445"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4444"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
postgres_1       | 2020-02-13 12:56:18.831 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
postgres_1       | 2020-02-13 12:56:18.832 UTC [1] LOG:  listening on IPv6 address "::", port 5432
postgres_1       | 2020-02-13 12:56:18.837 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
postgres_1       | 2020-02-13 12:56:18.856 UTC [23] LOG:  database system was shut down at 2020-02-13 12:55:53 UTC
postgres_1       | 2020-02-13 12:56:18.866 UTC [1] LOG:  database system is ready to accept connections
hydra-migrate_1  | time="2020-02-13T12:57:01Z" level=info msg="No tracer configured - skipping tracing setup"
hydra-migrate_1  | time="2020-02-13T12:57:01Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra-migrate_1  | time="2020-02-13T12:57:01Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
HarisSpahijaPon
@HarisSpahijaPon
And if you try again now?
incapsulatesshamala
@incapsulatesshamala
@HarisSpahijaPon i reinstalled reaction development platform from scratch
Here are my hydra logs. do you see any issue here?
Attaching to reaction-hydra_postgres_1, reaction-hydra_hydra-migrate_1, reaction-hydra_hydra_1
postgres_1       | 2020-02-13 12:56:18.831 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
postgres_1       | 2020-02-13 12:56:18.832 UTC [1] LOG:  listening on IPv6 address "::", port 5432
postgres_1       | 2020-02-13 12:56:18.837 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
postgres_1       | 2020-02-13 12:56:18.856 UTC [23] LOG:  database system was shut down at 2020-02-13 12:55:53 UTC
postgres_1       | 2020-02-13 12:56:18.866 UTC [1] LOG:  database system is ready to accept connections
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="No tracer configured - skipping tracing setup"
hydra_1          | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | Thank you for using ORY Hydra v1.0.8+oryOS.12!
hydra_1          |
hydra_1          | Take security seriously and subscribe to the ORY Security Newsletter. Stay on top of new patches and security insights.
hydra_1          |
hydra_1          | >> Subscribe now: http://eepurl.com/di390P <<
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Software quality assurance features are enabled. Learn more at: https://www.ory.sh/docs/ecosystem/sqa"
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4445"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-13T12:56:20Z" level=info msg="Setting up http server on :4444"
hydra_1          | time="2020-02-13T12:56:20Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-13T12:57:14Z" level=info msg="started handling request" method=GET remote="172.24.0.1:42420" request=/.well-known/openid-configuration
hydra_1          | time="2020-02-13T12:57:14Z" level=info msg="completed handling request" measure#hydra/public: http://localhost:4444/.latency=466100 method=GET remote="172.24.0.1:42420" request=/.well-known/openid-configuration status=200 text_status=OK took="466.1µs"
hydra-migrate_1  | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra-migrate_1  | time="2020-02-13T13:55:17Z" level=info msg="No tracer configured - skipping tracing setup"
hydra-migrate_1  | time="2020-02-13T13:55:17Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | time="2020-02-13T13:55:17Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | The following migration is planned:
hydra-migrate_1  |
hydra-migrate_1  | | DRIVER | MODULE | ID | # |        QUERY         |
hydra-migrate_1  | |--------|--------|----|---|----------------------|
hydra-migrate_1  | |--------|--------|----|---|----------------------|
hydra-migrate_1  | Successfully applied 0 SQL migrations!
reaction-hydra_hydra-migrate_1 exited with code 0
HarisSpahijaPon
@HarisSpahijaPon
it should run now no?
HarisSpahijaPon
@HarisSpahijaPon
Did you actually ever create a store though @incapsulatesshamala ?
Sebastian Franco
@jhonsfran1165
Hello everybody, I'm working in a new npm package locally, I'm follow this doc https://docs.reactioncommerce.com/docs/devs-update-custom-plugin#how-to-link-in-a-local-npm-package-for-a-plugin-while-working-on-it about how to work on npm package locally but when I start the API the dependencies in node_modules directory of my package is missing and the API can't start because it doesn't find dependencies of that package. Before start the API I run npm install in my package directory. Any suggestion?
Erik Kieckhafer
@kieckhafer
@jhonsfran1165 have you run npm link in the package you are trying to link, and then `npm link {package-name} inside the API first? do that, then npm install, then try again
incapsulatesshamala
@incapsulatesshamala
@HarisSpahijaPon yes, this is done...i am still not able to open reaction-identity app and create a product in reaction-admin
Erik Kieckhafer
@kieckhafer
go to localhost:3000/graphql and run the query {primaryShopId}
incapsulatesshamala
@incapsulatesshamala
yes, i got this
{
  "data": {
    "primaryShopId": "cmVhY3Rpb24vc2hvcDpjbnJyTW5yd2RjN2ZDRlR1Zw=="
  }
}
Erik Kieckhafer
@kieckhafer
ok, good to know you have a shop. is this a new 3.0 shop, or are you tryign to use 2.x data? we have migrations which must be run to get the correct user permissions if it's an older shop
incapsulatesshamala
@incapsulatesshamala
i am using brand new codebase of 3.0

This is my identity app

alt

incapsulatesshamala
@incapsulatesshamala

This is my hydra

alt

This is my admin, the spinner keeps rotating indefinetly when i try to create a product

alt

Above 3 are my issues, API and storefront are working fine
Erik Kieckhafer
@kieckhafer
i don't think you'd expect to see anything for hydra or identity if you're already logged in, i'm less concerned with that
nothing int he console or server logs aside from the access denied?
incapsulatesshamala
@incapsulatesshamala
yeah, no console issues and server logs
incapsulatesshamala
@incapsulatesshamala

I just completed installing "reaction-development-platform" in my friends laptop, same problem. looks like these is an issue in version 3

can anyone help me? i am struck badly :(

lk
@khoathanglong
I got the same issues using reaction development platform. Cannot change anything in "Shop Localization" due to access-denied (this expected to display for the user though). Same bug when creating product as above.
image.png
Erik Kieckhafer
@kieckhafer
if you continue to see this issue, can you please create a ticket in the reaction-admin repo for us to investigate?
as many logs (server and console) that you can provice would be helpful, as long as whatever actions you do to lead up to this
Erik Kieckhafer
@kieckhafer
also please keep in mind that our Reaction Admin is in beta. While we do try to keep it up to date with the latest API features, it's not always going to work 100%. If you're not able to complete this mutations and queires directly via the GraphQL API, then it's a separate API issue which we'd generally tackle more quickly than an issue solely in Reaction Admin
lk
@khoathanglong
@kieckhafer does reaction admin current depend on meteor? If true, do you have a plan to remake it to get rid of meteor? I would love to contribute to if you plan to make new version of reacction-admin
HarisSpahijaPon
@HarisSpahijaPon
Does anyone know a way to modify the addressToString function from component library?
So far the only solution I found is to pull all component that make use of the function and give it another import reference
erisvulgaris
@erisvulgaris
image.png
getting this error
at the beging
*begining
HarisSpahijaPon
@HarisSpahijaPon
You need to use docker to run reaction
erisvulgaris
@erisvulgaris
ok
HarisSpahijaPon
@HarisSpahijaPon
docker-compose up --build
erisvulgaris
@erisvulgaris
thanks for the help
HarisSpahijaPon
@HarisSpahijaPon
windows might be tricky
Vladimir Puz
@redscare
i have the same issues with 3.x update failed: Access denied. No allow validators set on restricted collection for method 'update'. git@github.com:/reactioncommerce/reaction-admin.git,reaction-admin,v3.0.0-beta.5
running on windows
Fakhriddin
@softerboy
Hi everyone. I installed reaction platform using reaction-development-platform. I have all done and works well, but I can't to login admin dashboard. So my question is what's the default email and password of admin user or how can I create new? I tried admin@localhost and r3@cti0n
Vladimir Puz
@redscare
@softerboy just register a new user on http://localhost:4080/
Fakhriddin
@softerboy
@redscare Thanks bro. En error occurs during registration. Error message: "The+request+is+missing+a+required+parameter,+includes+an+invalid+parameter+value,+includes+a+parameter+more+than+once,+or+is+otherwise+malformed"