Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Apr 04 17:39
    jinhojang6 edited #6187
  • Apr 04 17:38
    jinhojang6 labeled #6187
  • Apr 04 17:38
    jinhojang6 opened #6187
  • Apr 04 17:38
    jinhojang6 labeled #6187
  • Apr 04 05:51
    kieckhafer edited #6186
  • Apr 04 05:51
    kieckhafer edited #6161
  • Apr 04 05:45
    kieckhafer review_requested #6186
  • Apr 04 05:44
    kieckhafer assigned #6167
  • Apr 04 05:44
    kieckhafer edited #6107
  • Apr 04 05:09
    kieckhafer synchronize #6186
  • Apr 04 05:09

    kieckhafer on refactor-kieckhafer-moveAddressValidationPlugin

    chore: organize plugins Signed… (compare)

  • Apr 04 00:48
    kieckhafer edited #6186
  • Apr 04 00:48
    kieckhafer edited #6186
  • Apr 04 00:46
    kieckhafer edited #6186
  • Apr 04 00:33
    kieckhafer synchronize #6186
  • Apr 04 00:33

    kieckhafer on refactor-kieckhafer-moveAddressValidationPlugin

    chore: add plugins to jest conf… (compare)

  • Apr 04 00:32
    kieckhafer synchronize #6186
  • Apr 04 00:32

    kieckhafer on refactor-kieckhafer-moveAddressValidationPlugin

    refactor: move address-validati… (compare)

  • Apr 03 21:59
    kieckhafer edited #6107
  • Apr 03 21:58
    kieckhafer opened #6186
samkonix
@samkonix
it would be greatly appreciated. Nothing works for me, blank page for admin and Identity, error 404 for hydra
Alefe Mafra
@alefemafra
Hello, I was testing the integration tests (v 2.9), and is giving this error: "TypeError: _simplSchema.default.extendOptions is not a function", could someone help me?
In case this error is coming from the data-factory, when it imports "createFactoryForSchema"
Dmitry Motyl
@nectar1
@loan-laux thank for answer!
How to debug in this way
Loan Laux
@loan-laux
@samkonix @vigyano We (out:grow) are also working on updating our AWS ECS tutorial for 3.0… Stay tuned.
@alefemafra I’m wondering if your simpl-schema is at the right version… Can you try and reinstall your NPM packages?
@nectar1 Once you’ve done what I said, just connect whatever debugger you want (VS Code’s for example) to localhost:9229. It should work without any issue.
samkonix
@samkonix

Thanks @loan-laux .
I'm still testing.
I have not been able to run the development platform on a remote server, even by modifying the .env files
I am trying to get it to work on my windows laptop, but I get this error message:

sam@DESKTOP-UC7SSM5:~/reaction-development-platform$ make
Error response from daemon: network with name reaction.localhost already exists
Removed docker.exe development symlink for reaction-hydra
Running pre-build hook script for reaction-hydra.
reaction-hydra post-project-start script invoked.
ERROR:
        Can't find a suitable configuration file in this directory or any
        parent. Are you in the right directory?

        Supported filenames: docker-compose.yml, docker-compose.yaml

make: *** [Makefile:209: build-reaction-hydra] Error 1

I'm trying to see why. The docker-compose.yml file exists. It is not easy I am not familiar with node and docker. I learn :)

samkonix
@samkonix
just for information, I have installed node for windows and follow this tutorial for the docker installation and it works :
https://nickjanetakis.com/blog/setting-up-docker-for-windows-and-wsl-to-work-flawlessly
John Tronolone
@johntronolone
Hello. I'm following this guide https://github.com/reactioncommerce/proxy-traefik/blob/master/docs/SimpleDeploymentGuide.md and I have the example-storefront up and running. When I try to create an account, it just displays Cannot GET /. I'm new to docker and reactioncommerce so I'm not entirely sure where the issue is but I believe it has something to do with hydra. Would someone be able to take a look at these logs from the hydra startup and confirm whether or not this issue is indeed with hydra?
john@ubuntu-s-2vcpu-4gb-nyc3-01:~/reaction-platform/reaction-hydra$ docker-compose up
Starting reaction-hydra_postgres_1 ... done
Starting reaction-hydra_hydra-migrate_1 ... done
Starting reaction-hydra_hydra_1         ... done
Attaching to reaction-hydra_postgres_1, reaction-hydra_hydra-migrate_1, reaction-hydra_hydra_1
hydra-migrate_1  | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra-migrate_1  | time="2020-02-19T19:53:13Z" level=info msg="No tracer configured - skipping tracing setup"
hydra-migrate_1  | time="2020-02-19T19:53:13Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | time="2020-02-19T19:53:13Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra-migrate_1  | The following migration is planned:
hydra-migrate_1  | 
hydra-migrate_1  | | DRIVER | MODULE | ID | # |        QUERY         |
hydra-migrate_1  | |--------|--------|----|---|----------------------|
hydra-migrate_1  | |--------|--------|----|---|----------------------|
hydra-migrate_1  | Successfully applied 0 SQL migrations!
postgres_1       | 2020-02-19 19:53:12.001 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
postgres_1       | 2020-02-19 19:53:12.001 UTC [1] LOG:  listening on IPv6 address "::", port 5432
postgres_1       | 2020-02-19 19:53:12.011 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
postgres_1       | 2020-02-19 19:53:12.041 UTC [24] LOG:  database system was shut down at 2020-02-19 19:51:49 UTC
postgres_1       | 2020-02-19 19:53:12.050 UTC [1] LOG:  database system is ready to accept connections
reaction-hydra_hydra-migrate_1 exited with code 0
hydra_1          | Config file not found because "Config File ".hydra" Not Found in "[/]""
hydra_1          | time="2020-02-19T19:53:14Z" level=info msg="No tracer configured - skipping tracing setup"
hydra_1          | time="2020-02-19T19:53:14Z" level=info msg="Establishing connection with SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | time="2020-02-19T19:53:14Z" level=info msg="Successfully connected to SQL database backend" dsn="postgres://*:*@postgres.reaction.localhost:5432/hydra?sslmode=disable"
hydra_1          | Thank you for using ORY Hydra v1.0.8+oryOS.12!
hydra_1          | 
hydra_1          | Take security seriously and subscribe to the ORY Security Newsletter. Stay on top of new patches and security insights.                                                                                                
hydra_1          | 
hydra_1          | >> Subscribe now: http://eepurl.com/di390P <<
hydra_1          | time="2020-02-19T19:53:14Z" level=info msg="Software quality assurance features are enabled. Learn more at: https://www.ory.sh/docs/ecosystem/sqa"
hydra_1          | time="2020-02-19T19:53:14Z" level=info msg="Setting up http server on :4445"
hydra_1          | time="2020-02-19T19:53:14Z" level=warning msg="HTTPS disabled. Never do this in production."
hydra_1          | time="2020-02-19T19:53:14Z" level=info msg="Setting up http server on :4444"
hydra_1          | time="2020-02-19T19:53:14Z" level=warning msg="HTTPS disabled. Never do this in production."
These are the hydra logs for when I click create account from the example-storefront:
hydra_1          | time="2020-02-19T19:54:35Z" level=info msg="started handling request" method=GET remote=173.54.55.65 request="/oauth2/auth?loginAction=signup&response_type=code&redirect_uri=https%3A%2F%2Fstorefront.patchamp-store.com%2Fcallback&scope=offline%20openid&state=xNuqnfxrB1FI9Xytuegj8reE&client_id=example-storefront"
hydra_1          | time="2020-02-19T19:54:35Z" level=info msg="completed handling request" measure#hydra/public: https://hydra.patchamp-store.com/.latency=12263330 method=GET remote=173.54.55.65 request="/oauth2/auth?loginAction=signup&response_type=code&redirect_uri=https%3A%2F%2Fstorefront.patchamp-store.com%2Fcallback&scope=offline%20openid&state=xNuqnfxrB1FI9Xytuegj8reE&client_id=example-storefront" status=302 text_status=Found took=12.26333ms
Spencer Norman
@spencern
@johntronolone that guide was written for version 2.x of Reaction and has not yet been updated for v3.0
Will Lopez
@willopez
@johntronolone As Spencer mentioned, that guide is outdated. Planning on updating soon, stay tuned.
Karbal
@karbal
Hello, i am ask if the last version v3.0.0 support the multiplestore . Thanks
John Tronolone
@johntronolone
I was able to get it deployed on v3.0 by
  1. setting the appropriate environment variables on these pages: https://docs.reactioncommerce.com/docs/next/upgrading and https://docs.reactioncommerce.com/docs/next/environment-variables
  2. creating docker-compose.override.yml files for reaction-identity and reaction-admin
  3. adding the necessary A DNS records for admin and identity
Vladimir Puz
@redscare
Has anyone found a way to fix error "update failed: Access denied. No allow validators set on restricted collection for method 'update'"
Loan Laux
@loan-laux
@redscare When does that happen and are you using the latest version?
Vladimir Puz
@redscare
@loan-laux it is happening when i am trying to change any value in Shop Localization
i am using latest reaction-development-platform (trunk).
reaction-admin is beta5
and Reaction is in dev mode (tried default also)
Loan Laux
@loan-laux
@redscare Sorry about that, reaction-admin is the last bit of RC 3 that’s still in beta. It’s about to hit stable very soon. One of the very last things that are still WIP is to update the shop settings to use the GraphQL API. They won’t work until this PR is merged. reactioncommerce/reaction-admin#206
Same for the product editor with this PR: reactioncommerce/reaction-admin#188. No official ETA but looking at the commits I’m fairly sure that it’ll be just a few days.
Vladimir Puz
@redscare
Thanks for information... Can i also ask you if you have any plans to update Stripe plugin to support Strong Customer Authentication? I saw it somewhere on roadmap few month ago
Loan Laux
@loan-laux
Definitely on the table, but AFAIK no work has begun towards that. Maybe @spencern can chime in here? It’s the weekend though so expect a response on Monday, most probably.
Vladimir Puz
@redscare
well actually i did it myself for 2 version, so it there a sense to migrate it..
ok, i got it... thanks for info
Loan Laux
@loan-laux
If you’ve got it working on your own, then please definitely make a PR for the whole community to benefit. I know lots of improvements on many projects never get open-sourced by lack of time, so it would be greatly appreciated if you could contribute. :)
Vladimir Puz
@redscare
i will do it for sure, but have to migrate it to 3 version. And i still have to implement multi language support first
Loan Laux
@loan-laux
For i18n implementation, I know that @HarisSpahijaPon and @janus-reith are working on it, so you may want to sync with them… Just a thought.
Vladimir Puz
@redscare
well, it is not i18n only, i also need to translate product details and prices
Loan Laux
@loan-laux
Ah yes, very important feature too
Fakhriddin
@softerboy
Can't display image thumbnails in admin page. Browser console says: Content Security Policy: The page’s settings blocked the loading of a resource at http://my.domain.com:3000/assets/files/Media/xiFuKrkFE2RS5QCrZ/…humbnail/53238346_1016997965156219_8030264798986126558_n.png (“img-src”).
Any solution?
HarisSpahijaPon
@HarisSpahijaPon
Moin, thanks for tagging me @loan-laux . I currently have a working version of i18n including multilanguage support for product details. Afaik the product details should already be included in the product metafields. Did you check those out @redscare ? For pricing there was a HOC I think called withLocales, but I could be wrong on that one. I can check with the team tomorrow to see how we are solving this issue.
HarisSpahijaPon
@HarisSpahijaPon
Also I have been trying to optimize the NextJS part of our frontend a bit. The amount of static rendering I was able to do is crazy for performance. Especially build times and testing times was able to be reduced with something like 40-50%
image (2).png
Loan Laux
@loan-laux
Super excited about your optimizations, @HarisSpahijaPon!
Erik Kieckhafer
@kieckhafer

We have a batch of three PR's in review right now to fix some of the permissions issues that have been brought up here. It's our understanding that if you are creating a shop from scratch, everything seems to be working as it should, however some issues are occuring when migrating from 2.9 -> 3.0. Hopefully these issue PR's fix the issues you've been seeing:
reactioncommerce/plugin-simple-authorization#7
reactioncommerce/api-migrations#5
reactioncommerce/reaction#6110

Also please note that these fixes are strictly for the API, and might not affect what is being seen in Reaction Admin. Admin is still in Beta, if you are experiencing issues there please make an issue in the Reaction Admin repository.

Once these PR's have been merged, running migrations from the API should the issues that were addressed in these PRs.

manishpatell
@manishpatell
Can anyone suggest Where can I find RC developer ?
Gabriele Leotta
@gabry12
Hello everybody, here Gabriele from Italy. I am new to Reaction and I'm loving it (thank you!). Actually I just wanted to add my experience, as I am having the same issues already mentioned on the admin panel (impossible to insert products and shop info) even if I have installed (twice) Reaction from scratch and from the latest version of the dev. platform. I am about to start my first eCommerce client project with Reaction so I hope and wait for the the stable version of the Admin to solve these issues, and of course any further updates on its roadmap would help for planning on my side. Thanks again!
HarisSpahijaPon
@HarisSpahijaPon
@manishpatell @loan-laux is very active in consulting trough https://outgrow.io/
@gabry12 What are you exactly running into? Maybe we can help?
Gabriele Leotta
@gabry12
Group 3.png
Group.png
Group 2.png
Thanks @HarisSpahijaPon for the feedback, here I have pasted 3 screeshots with the description of the bugs, hope this helps, I think these were already mentioned. Again, I am working on the dev platform, built from scratch a couple of days ago, thus it's last version
HarisSpahijaPon
@HarisSpahijaPon
What does your console say?
CmdShiftJ (on Windows) or CmdOptionJ (on Mac)
and also this warning:
WebSocket connection to 'ws://localhost:3000/graphql' failed: WebSocket is closed before the connection is established.
SubscriptionClient.close @ modules.js?hash=58d4c8c3ffe31c79151497346411f04d2731eb29:320718