These are chat archives for redaxmedia/redaxscript

15th
Nov 2015
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:21
Hi, It's Sean aka Capt_zeanie
Henry Ruhs
@redaxmedia
Nov 15 2015 14:22
hello sean
are you developing online or local?
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:23
Currently local using Bitnami WAMP on Win7
Henry Ruhs
@redaxmedia
Nov 15 2015 14:23
all right, so what is your actual code inside the article?
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:24
at the moment I just have gone back to...
<function>
{
"gallery":
{
"directory": "images",
"options":
{
"quality": 80,
"height": 100
}
}
}
</function>
that is all the article content
this generate the thumbs in root/images
however I just get the article title and then blank when viewing the article.
Henry Ruhs
@redaxmedia
Nov 15 2015 14:26
all right, the code does look correct
your images like png or jpg are located inside /images ?
or inside a sub-folder?
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:28
Currently inside root/images I have one jpg plus a directory of thumbs with one thumb of the jpg
Henry Ruhs
@redaxmedia
Nov 15 2015 14:29
ok, and the jpg inside the thumbs folder is not broken and does have a file size?
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:30
the images is fine and has a valid file size. I I put the image in as a img src then it shows fine in a normal page.
Henry Ruhs
@redaxmedia
Nov 15 2015 14:31
ok... please browse the article now and tell me what code is generated
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:31
The one thing is if I have the code above in the function the article page only shows the article title, and the page source stops at
Henry Ruhs
@redaxmedia
Nov 15 2015 14:31
do you know how to browse html code? it should be a <ul> list with one <li>
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:31
    <div class="wrapper clearfix">
<article id="content" class="content grid_space s5o7">
Henry Ruhs
@redaxmedia
Nov 15 2015 14:32
well, you never told this in the thread
however, looks like are parse error or html error
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:33
I my thread I said I either get a page with the Article title followed by the "Unpublish,edit,delete bar" or I just get the Article title with no content.
Henry Ruhs
@redaxmedia
Nov 15 2015 14:33
please open the index.php and enable the error_reporting( ... write a -1 here )
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:33
What should I be looking for in the html to check for a the parse error
Henry Ruhs
@redaxmedia
Nov 15 2015 14:33
then refresh the page and search for "parse" error
or "fatal" error... something like that
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:35
Fatal error: Call to undefined function exif_read_data() in C:\Users\Sean\Documents\wampstack\apps\test1\htdocs\modules\gallery\index.php on line 105
Henry Ruhs
@redaxmedia
Nov 15 2015 14:36
here we go :D
enable the extention inside you php.ini
extension=php_mbstring.dll
extension=php_exif.dll
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:38
OK, just restarting the services
Henry Ruhs
@redaxmedia
Nov 15 2015 14:39
i will put a "if (function_exists('exif_read_data'))" to Redaxscript 2.6.0
this function usually is enabled
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:40
Yep, gallery is showing
:-)
Henry Ruhs
@redaxmedia
Nov 15 2015 14:40
great!
you can now give redaxscript a star on github :-P
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:41
sure will.
I do have to say though I do like the interface you have developed.
Henry Ruhs
@redaxmedia
Nov 15 2015 14:42
thank you very much, I will tell my lead designer
Today I will release 2.6.0
Capt Zeanie
@Capt-Zeanie
Nov 15 2015 14:43
Much easier to workwith that what I was using which was my own simple CMS I had written a few years back, I just went looking a week ago for a more RESPONSIVE CMS and tried several but they were not good and then came across yours.
I had already tried the beta yesterday to see if that make a differencebut in the end down to exif functions
thanks again, take care
Henry Ruhs
@redaxmedia
Nov 15 2015 14:44
so it worked for you?
i mean the beta
take care, glad I could help