Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 20 07:29
    nareshabbanapuri commented #198
  • Jan 19 09:54
    nareshabbanapuri commented #198
  • Jan 19 09:38
    nareshabbanapuri commented #198
  • Jan 19 08:32
    nareshabbanapuri commented #198
  • Jan 19 08:31
    nareshabbanapuri opened #198
  • Jan 15 09:41
    mburns unassigned #2
  • Jan 07 14:36
    jeffbyrnes commented #195
  • Dec 21 2018 03:16
  • Dec 06 2018 02:27
    ronny-macmaster starred redguide/nodejs
  • Nov 29 2018 20:08
  • Nov 27 2018 04:27
    Munsen starred redguide/nodejs
  • Nov 15 2018 15:06
    edgamen starred redguide/nodejs
  • Nov 13 2018 17:00
  • Oct 31 2018 22:28
    twalker starred redguide/nodejs
  • Oct 26 2018 11:48
    mmarod closed #157
  • Oct 24 2018 15:16
    anhtuannguyentran starred redguide/nodejs
  • Oct 12 2018 16:00
    jeffbyrnes commented #195
  • Oct 12 2018 15:30
    jeffbyrnes synchronize #196
  • Oct 12 2018 15:26
    jeffbyrnes synchronize #195
  • Oct 11 2018 17:53

    tas50 on v6.0.0

    (compare)

Graham Weldon
@predominant
Not sure what I can do about that.. but created a pull request for changing the download URL for the source install method.
Barthélemy Vessemont
@BarthV
hi
My dev team is also hitting https issue this morning
We probably need to fix some url headers somewhere
but I didn't have tested this so far
Graham Weldon
@predominant
redguide/nodejs#98
@BarthV : ^
Barthélemy Vessemont
@BarthV
ok
quite obvious fix
:)
merged
Graham Weldon
@predominant
That fixes basic install.
Packages referenced for package install have an issue though
Barthélemy Vessemont
@BarthV
bundle exec kitchen converge package-ubuntu-1404 is ok for me
vagrant@package-ubuntu-1404:~$ node -v
v0.10.40
vagrant@package-ubuntu-1404:~$ npm -v
1.4.28
vagrant@package-ubuntu-1404:~$ dpkg -l |egrep -i "node|npm"
ii  nodejs                              0.10.40-1nodesource1~trusty1     amd64        Node.js event-based server-side javascript engine
what is missing for you ? (on which platform ?)
Graham Weldon
@predominant
Oh, when you NPM install something with build dependencies.
Like iconv or something
The build requires download of the nodejs source, which references http://nodejs.org/dist/....
So the npm download of the source pulls down the result of the 301 redirect now in place on the site.
And fails install.
gyp verb ensuring nodedir is created /opt/mimo/node_modules/xml2json/node_modules/node-expat/node_modules/iconv/.node-gyp/0.10.40
gyp verb created nodedir /opt/mimo/node_modules/xml2json/node_modules/node-expat/node_modules/iconv/.node-gyp
gyp http GET http://nodejs.org/dist/v0.10.40/node-v0.10.40.tar.gz
gyp http 200 http://nodejs.org/dist/v0.10.40/node-v0.10.40.tar.gz
gyp WARN install got an error, rolling back install
gyp verb command remove [ '0.10.40' ]
...
Note the middle 2 http calls.
Try it yourself with curl, or in your browser.
Barthélemy Vessemont
@BarthV
I see that
Graham Weldon
@predominant
:)
Barthélemy Vessemont
@BarthV
but is it really a nodejs cookbook issue rather than a npm one ?
this is a npm install log output
maybe this npm version was not "https" patched yet ><
I will try to reproduce & find out what's really happening
Graham Weldon
@predominant
Its more of an "FYI" - If you're going to use those packages, they're going to fail.
Barthélemy Vessemont
@BarthV
okok :)
Graham Weldon
@predominant
:P
Barthélemy Vessemont
@BarthV
thank for this information anyway :)
Graham Weldon
@predominant
Yeah, not sure if its helpful.. but useful to know eh?
Selvam Palanimalai
@chartotu19
hey guys, I am trying to use this cookbook in AWS opswork. I constantly run into "No such cookbook: yum-epel" . I am using an ubuntu 14.04 machine.
Selvam Palanimalai
@chartotu19
figured it , Berkfile option was turned off on the opswork stack :-/
Chris W
@cp5w
Hey guys, I'm having some issues installing npm packages globally, where they install, but oddly it doesn't create an executable in any of the default paths. As a result, local installations fail because bash says command not found. Has anyone come across this? For now I'm having to manually create symlinks to fix it - but this doesnt seem right for a self-contained cookbook
Barthélemy Vessemont
@BarthV
hi @cp5w . I saw your issue on GH. I'll take 5 min (but no more today ;o .. it's sunday) to test that and reply to you
Chris W
@cp5w
Haha thanks @BarthV no I don't expect everyone to be around on Sunday!
Chris W
@cp5w
@BarthV that wasn't 5 min! Much appreciated. I've posted my current workaround if others come across this issue.
Barthélemy Vessemont
@BarthV
I was busy @home :)
We'll discuss again for managing this kind of "generic" symlink
but it seems really specific to each app/ needs
Chris W
@cp5w
For sure
I'll refactor my work around at some point to try and be more generic
Andreas Lappe
@alappe

Hey,

when using the cookbook with chef 12.5.1, it explodes into my face with undefined methodlog_deprecation' for class Class' (more: https://gist.github.com/alappe/84ed444400e741c70877)

Barthélemy Vessemont
@BarthV
12.5 brings many changes in custom resources management and internal API
I had to delay the migration in my company
I will take a look into that issue