Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Hiroaki SAWANO
    @hsawano
    @takahi-i MAMPではなく,Macで Apacheを起動したら動きました.これから検証します.
    Hiroaki SAWANO
    @hsawano
    @takahi-i やはりエラーがありました.
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test (default-test) on project redpen-server: There are test failures.
    そしてredpen-serverを起動しましたら,右側のコンテンツが表示されませんでした...
    capture.png
    @takahi-i 先ほどの動いたというのは,インストール中のテストの時にlocalhost:8080にアクセスしたら開いたのですが,redpen-server startすると,上のような画像になりました...
    Hiroaki SAWANO
    @hsawano
    どうやら,私の環境のphantomjsがおかしそうです.また共有します.
    Takahiko Ito
    @takahi-i
    ありがとうございます。
    RedPen サーバですが1分ほどサーバの起動に時間がかかります。
    Hiroaki SAWANO
    @hsawano
    @takahi-i インストール時に
    [INFO] redpen-server ...................................... FAILURE [ 21.527 s]
    とあるのですが,失敗しているんですよね...
    Takahiko Ito
    @takahi-i
    @hsawano ビルドの問題は置いておいて、 fix が機能するのか確かめたいと考えています。
    ↑に新しいリリース候補を作りました。ここにビルドがすんだ tar.gz ファイルがあります。こちらで動作を確認していただけますか。
    Hiroaki SAWANO
    @hsawano
    @takahi-i 対応,ありがとうございます.コマンドファイルで,
    REDPEN_CONF_FILEを変更して,
    starting RedPen server specifying a configuration file ファイル名
    で読み込めたのですが,反映がされませんでした.
    JapaneseNumberExpressionをvalue=kansuji
    にしたのですが,起動時にはnumericのままでした.
    Takahiko Ito
    @takahi-i
    @hsawano 設定ファイルをこちらに添付していただけますか?
    Hiroaki SAWANO
    @hsawano
    @takahi-i ひょっとして,読み込んで入るけれど,redpen-serverの右側には反映されないということでしょうか
    Takahiko Ito
    @takahi-i
    Screen Shot 2018-02-14 at 21.58.14.png
    @hsawano ↑頂いた設定ファイルを自分の環境で動作させました。設定ファイルでValidatorに指定しているパラメタ値が表示されおりファイルは読み込まれているようです。
    Screen Shot 2018-02-14 at 22.03.15.png
    Takahiko Ito
    @takahi-i
    ちなみに localhost:8080 で表示されるのは英語の設定なんで、指定した設定ファイルが日本語であれば、VALIDATORリストから日本語のもの(↑の画像では日本語のMarkdownを指定している)をやらないと右側に設定は機能設定は表示されません。
    表示されないのはこれが原因な気がしています。
    Hiroaki SAWANO
    @hsawano
    kansuji.png
    @takahi-i VALIDATORで日本語選択したのですが,右下の”JapaneseNumberExpression”の初期値が更新されていないです...
    Takahiko Ito
    @takahi-i
    不思議ですね。。自分の環境では頂いた設定で kansuji になっています。
    Screen Shot 2018-02-15 at 0.41.04.png
    @hsawano redpen-server の中で設定ファイルを指定している行、REDPEN_CONF_FILE=xxx を貼っていただけますか? 
    Takahiko Ito
    @takahi-i
    あと、実験環境について教えてもらえますか。OS及びバージョンなど。
    Hiroaki SAWANO
    @hsawano
    serverfile.png
    macOS High Sierra Ver. 10.13.3です.
    Takahiko Ito
    @takahi-i
    なるほど。ちゃんとREDPEN_HOME以下に設定ファイルが存在しますね。
    Hiroaki SAWANO
    @hsawano
    @takahi-i ファイルもconfの中に入れてます
    Takahiko Ito
    @takahi-i
    なるほど、REDPEN_LANGUAGE も修正されているんですね。
    これは関係なさそう。自分の環境で REDPEN_LANGUAGE を修正しましたが、 kansuji 設定はちゃんと出ています。
    Hiroaki SAWANO
    @hsawano
    @takahi-i 伊藤さんの環境では再現不可ということですね...
    Takahiko Ito
    @takahi-i
    そうですね。ログファイル(redpen.log)を貼ってもらえますか?
    Hiroaki SAWANO
    @hsawano
    @takahi-i こちらです
    Takahiko Ito
    @takahi-i
    port is taken
    これは、、?
    ポート番号が既に利用されている。。?
    Hiroaki SAWANO
    @hsawano
    %lsof -i :8080
    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    java 24951 sawano 70u IPv6 0xdb41312cec5af0ab 0t0 TCP *:http-alt (LISTEN)
    Takahiko Ito
    @takahi-i
    気になっているのはサーバが生きているときに再び起動してしまったのではないかという点です。
    Hiroaki SAWANO
    @hsawano
    redpen-server 落としたら,このportは利用されていないですね
    logを決して,もう一回実施します
    Takahiko Ito
    @takahi-i
    ありがとうございますmm
    Hiroaki SAWANO
    @hsawano
    Takahiko Ito
    @takahi-i
    port is taken は無いですね。
    starting RedPen server with stop key... starting RedPen server specifying a configuration file conf/redpen-conf_sawanolab.xml ...
    がターミナルに出ていれば
    ロードされていることにはなります。
    Hiroaki SAWANO
    @hsawano
    %./redpen-server start
    starting RedPen server with stop key...
    starting RedPen server specifying a configuration file conf/redpen-conf_sawanolab.xml ...
    出てます