Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 17 20:13
    wolfy01 commented #181
  • Nov 15 09:09
    fvincenti54 commented #187
  • Nov 15 08:58
    fvincenti54 commented #187
  • Nov 12 09:14
    alwo-io opened #208
  • Nov 06 20:21
    remie commented #176
  • Oct 23 07:47
    WanpengQian commented #198
  • Oct 18 16:58
    alanlitster commented #176
  • Oct 18 16:55
    alanlitster commented #180
  • Oct 18 13:56
    alanlitster commented #205
  • Oct 18 13:55
    alanlitster commented #180
  • Oct 18 13:54
    alanlitster commented #176
  • Oct 18 11:52
    ebeng commented #205
  • Oct 15 12:59
    hilite24 commented #187
  • Jun 13 19:43
    Travis YouTransfer/YouTransfer (master) canceled (235)
  • Jun 13 19:43

    remie on master

    Make example docker command cop… Merge pull request #195 from ph… (compare)

  • Jun 13 19:43
    remie closed #195
  • Jun 13 19:42

    remie on master

    Catch Error on file deletion Merge pull request #207 from en… (compare)

  • Jun 13 19:42
    remie closed #207
  • Jun 10 11:45
    enyosolutions opened #207
  • May 30 16:01
    akotlyar opened #206
Khionu Sybiern
@khionu
Hello o.o
Remie Bolte
@remie
Hi!
@khionu: My apologies, I wasn’t available last week
But I’m here now :)
Khionu Sybiern
@khionu
And I just woke up xD Chat-tag, it seems
I have to say, I've only found one other web app that fits the needs you're filling with YouTransfer, and.... yours is definitely a LOT more elegant.
afdevries
@afdevries
Hi all.
I had youtransfer up and running previously through the docker pull and run.
And we did some updates to our VMs so I had to restart the docker host. All fine and well. Did a docker run like before. But afterwards the smtp mail sending seems to fail no matter what I try.
I just use the smtp provided by our ISP. with empty username and password. But it still gives "An error occurred while sending your message
Invalid login"
I see there is an issue requesting for enhancement to check if authorisation is required for the SMTP config. But previously this worked for us. So anyone have any pointers on how to fix it as it is now? (remie/YouTransfer#125)
Remie Bolte
@remie
Hi @afdevries
I think #125 should be relatively easy to fix, but I'm a bit curious as to what has changed that it stopped working
It seems weird to me that your instance of YouTransfer was working correctly with your SMTP settings, and that you are now experiencing invalid login issues?
afdevries
@afdevries
@remie Yes I find this weird also. Not sure what changed either. Do you know of a way for me to test if it is regarding the credentials being passed in yes / no?
afdevries
@afdevries
I just tested it with some of your code.
the moment I add secure and auth to createTransport it fails.
⇒ node test.js { [Error: Invalid login: 535 Incorrect authentication data] code: 'EAUTH', response: '535 Incorrect authentication data', responseCode: 535 }
when I leave it out
⇒ node test.js Message sent: 250 OK id=1aaQ3X-0002vk-SX
Remie Bolte
@remie
OK, so it is related to #125
You want to use a secure connection, but you don't need authentication
afdevries
@afdevries
No it has not to do with secure connection. Im not behind my laptop atm secure was a reference to the "createTransport" code.
its just smtp.something.nl at port 25
But it sends AUTH information even when it is not needed. And since I leave the fields emtpy, it sends emtpy string in the AUTH request to the SMTP Server.
ps. Thanks for taking your time to listen to me.
Remie Bolte
@remie
Ok, I'm going to check if I can reproduce this and see if I can commit a fix!
I think I have enough info now on how to trigger this error
Paul Dach
@PaulDach
Hey