Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Mar 06 12:55
    dennorske commented #192
  • Feb 09 04:46
    frakman1 opened #233
  • Jan 20 19:40
    boukar10 commented #232
  • Jan 20 19:39
    boukar10 commented #232
  • Jan 20 19:39
    boukar10 closed #232
  • Jan 20 19:39
    boukar10 commented #232
  • Jan 05 19:29
    delannoy commented #188
  • Jan 03 03:05
    boukar10 opened #232
  • Dec 22 2020 07:54
    CrazyOptimist commented #200
  • Dec 21 2020 04:14
    dockerlead commented #213
  • Dec 18 2020 08:54
    atxbyea opened #231
  • Nov 25 2020 21:46
    SystemFiles commented #226
  • Nov 21 2020 20:32
  • Nov 21 2020 20:17
    piwaniuk opened #230
  • Nov 21 2020 20:12
    piwaniuk opened #229
  • Sep 22 2020 19:04
    wschlotter opened #228
  • Aug 26 2020 20:12
    christf opened #227
  • Aug 23 2020 19:20
    SNRSE edited #226
  • Aug 23 2020 19:20
    SNRSE edited #226
  • Aug 23 2020 19:20
    SNRSE opened #226
Khionu Sybiern
@khionu
Hello o.o
Remie Bolte
@remie
Hi!
@khionu: My apologies, I wasn’t available last week
But I’m here now :)
Khionu Sybiern
@khionu
And I just woke up xD Chat-tag, it seems
I have to say, I've only found one other web app that fits the needs you're filling with YouTransfer, and.... yours is definitely a LOT more elegant.
afdevries
@afdevries
Hi all.
I had youtransfer up and running previously through the docker pull and run.
And we did some updates to our VMs so I had to restart the docker host. All fine and well. Did a docker run like before. But afterwards the smtp mail sending seems to fail no matter what I try.
I just use the smtp provided by our ISP. with empty username and password. But it still gives "An error occurred while sending your message
Invalid login"
I see there is an issue requesting for enhancement to check if authorisation is required for the SMTP config. But previously this worked for us. So anyone have any pointers on how to fix it as it is now? (remie/YouTransfer#125)
Remie Bolte
@remie
Hi @afdevries
I think #125 should be relatively easy to fix, but I'm a bit curious as to what has changed that it stopped working
It seems weird to me that your instance of YouTransfer was working correctly with your SMTP settings, and that you are now experiencing invalid login issues?
afdevries
@afdevries
@remie Yes I find this weird also. Not sure what changed either. Do you know of a way for me to test if it is regarding the credentials being passed in yes / no?
afdevries
@afdevries
I just tested it with some of your code.
the moment I add secure and auth to createTransport it fails.
⇒ node test.js { [Error: Invalid login: 535 Incorrect authentication data] code: 'EAUTH', response: '535 Incorrect authentication data', responseCode: 535 }
when I leave it out
⇒ node test.js Message sent: 250 OK id=1aaQ3X-0002vk-SX
Remie Bolte
@remie
OK, so it is related to #125
You want to use a secure connection, but you don't need authentication
afdevries
@afdevries
No it has not to do with secure connection. Im not behind my laptop atm secure was a reference to the "createTransport" code.
its just smtp.something.nl at port 25
But it sends AUTH information even when it is not needed. And since I leave the fields emtpy, it sends emtpy string in the AUTH request to the SMTP Server.
ps. Thanks for taking your time to listen to me.
Remie Bolte
@remie
Ok, I'm going to check if I can reproduce this and see if I can commit a fix!
I think I have enough info now on how to trigger this error
Paul Dach
@PaulDach
Hey
Reda MALI
@RedaMALI
Hello everyone !
This channel is still alive ? :)