Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    John Dammeyer
    @jcdammeyer
    As I've said in a separate thread. I know that. Which is why I created a Pi3 image and compiled and programmed my 3 STMBLs with that. And this forum isn't or shouldn't be about Linux/Windows wars. The reality is if you want to easily program a STMBL you need Linux and a Pi3 is so cheap. If someone can't afford that then perhaps a DIY STMBL is also not a good idea.
    Updating STMBL Firmware-0_2.pdf
    I've pasted in the doc I wrote back in 2018 to use a Pi3 for programming a STMBL.
    DMS-Sci
    @DMS-Sci
    I used a RasPi 4 to flash the firmware to the boards, then a Windows 10 laptop to run Servoterm and successfully test the motor. If your F3 board isn't showing up as a connected USB device then maybe the board is messed up.
    WolframMalukker
    @WolframMalukker
    Ok gents
    For the 100th time, the board shows up exactly how it should on windows 10.
    I can load the firmware, and verify with ST's tools that it writes properly
    I do not think that the F3.dfu firmware that is included with the STMBL archive is any good-that's what I'm getting at.
    I think that when it's compiled from source, it works fine-otherwise too many people would be having issues.
    But it appears I'm the only person who has used the ST tools to do a DFU style upload.
    WolframMalukker
    @WolframMalukker
    That's what started the whole request for someone who could readily compile the firmware on a known working toolchain, and send over the .hex or .s19 output, which is easily converted to .dfu and uploaded.
    Seppo Pietarinen
    @spietari
    Please download a zip containing my whole STMBL folder, including my latest known working binaries. Commit 713e464, compiled on Aug 18th. https://www.dropbox.com/s/rczuvvafy74t04a/stmbl.zip?dl=0
    I posted notes on how I set up the env, compiled and uploaded on Sep 25th.
    WolframMalukker
    @WolframMalukker
    Thanks, Seppo. I'll let you know if the problem persists.
    kubabuda
    @kubabuda
    JLCPCB.com extended their $2/5 pcs prototyping pricing on aluminium boards
    Marian Omnibus
    @rabrabar
    Hey, should we get Mesa 7I94 for stmbl, is that as plug and play as it looks?
    issyvarsano
    @issyvarsano
    @rabrabar it is.
    andypugh
    @andypugh
    On the LinuxCNC side, yes.
    It should all auto-detect.
    Marian Omnibus
    @rabrabar
    Great!
    boerderpatrol
    @boerderpatrol
    Once more what is the command to enable step/dir command? Which part of the git outlines step/dir details?
    issyvarsano
    @issyvarsano
    read the integrator manual
    boerderpatrol
    @boerderpatrol
    Located in which folder?
    Nico Stute
    @crinq
    step/dir:
    link enc_cmd
    enc_cmd0.mode = 1
    Paule2002
    @Paule2002
    I would like to flash my completly new soldered stmbl.
    But the Board only pops up as STM32 BOOTLOADER and not as stm in dfu mode
    Can someone give me a hint?
    WolframMalukker
    @WolframMalukker
    what OS are you flashing from?
    If Windows, yo MUST use the bootloader jumper to get it in DFU mode. To do this, you must un-power both boards, short the boot jumper, power whichever board you're programming and then unshort the boot jumper. THEN it will appear as a DFU device
    Nico Stute
    @crinq
    if it shows up as STM32 BOOTLOADER it is in dfu mode
    Marian Omnibus
    @rabrabar
    @issyvarsano which integrator manual?
    issyvarsano
    @issyvarsano
    @rabrabar if you want to use it with linuxcnc , then you need to read the manualfrom the linuxcnc web
    Paule2002
    @Paule2002
    My OS is Windows. I tried to follow https://github.com/nneil/stmbl-notes/blob/master/firmware-flashing-dfu-windows.md But STMBL is recognized as STM32 BOOTLOADER in windows device manager and not as described in the manual as STM Device in DFU Mode.
    So therefore it is not recognized from DfuSeDemo and I am not able to flash it.
    I will try it again otherwise i think I have to flash it via SWD.
    andypugh
    @andypugh
    @Paule2002 The manual was written by a Mac user. It is possible that the reported status for DFU mode is different in Windows.
    If Nico says that "STM32 BOOTLOADER" == DFU mode then I would proceed on the basis that he is correct.
    @Paule2002 Addendum: The docs here (https://github.com/rene-dev/stmbl/blob/master/docs/src/Getting%20Started.adoc ) were written by a Mac user. The nneil repository is new to me, and might be more up to date.
    Paule2002
    @Paule2002
    I managed to flash the .bin´s with the new STM32CubeProgrammer which was super easy. Thank you for your support.
    Marian Omnibus
    @rabrabar
    @issyvarsano ok
    andypugh
    @andypugh
    John Dammeyer
    @jcdammeyer
    @andypugh As the comments say. It's just a commercial product designed for a specific need but maybe overkill for 99% of the applications?
    wiesi-94
    @wiesi-94

    Hello,
    I have a problem with the configuration of a DC motor. When i use the haas.txt configuration the motor jumps on the table.

    I have played with all parameters but i couldn't found a working configuration.

    This is my setup:
    Input: 320V rectified mains
    Motor connected to U & W
    The motor was originally operated with a maximum of 190V and 16A. And has an armature resistance of 0.8Ω.
    I mounted the optical encoder directly on the motor shaft.

    Which parameters do I have to adjust so that the motor runs smoothly?

    Nico Stute
    @crinq
    which parameters did you change?
    wiesi-94
    @wiesi-94
    I have increased and decreased the following parameters: conf0.r, conf0.l, conf0.j, conf0.psi, conf0.cur_p.
    The max_ac_cur is set to 10.
    But i always ended up with the parameters form the haas.txt file. They work best but still very bad.
    image.png
    After a few seconds I get a Fault 6: saturation error
    Nico Stute
    @crinq
    playing with parameters will not work, you need to measure them or find a datasheet
    if you can compile and flash new firmware you can try the autotuning in the sys_id branch (needs new HV and LV firmware) https://github.com/rene-dev/stmbl/blob/sys_id/docs/src/tuning.adoc#auto-tuning
    sys_id is experimental and might not work
    John Dammeyer
    @jcdammeyer
    This is what I used with my DC Servos but it never really worked very well.
    '''# KL-34-180-90 DC Servo Motor - Haas Clone
    link pid
    link dc
    link enc_fb0
    link enc_cmd
    link misc
    conf0.r = 0.925
    conf0.l = 0.0025
    conf0.j = 0.00034
    conf0.psi = 0.3
    conf0.max_force = 8
    conf0.max_ac_cur = 20
    conf0.mot_fb_res = 1000
    conf0.cmd_res = 2000
    conf0.high_dc_volt = 120
    conf0.max_dc_volt = 150
    conf0.max_vel = 344
    conf0.cur_p = 0.7
    linrev0.scale = 6
    enc_cmd0.mode = 1'''
    '''# Now enable drive if external signal there
    fault0.en=io0.C78'''
    Nico Stute
    @crinq
    haas.txt is a very old config for our vf0
    it's not suitable for a motor without a machine